F2 restoration project and wine

Discussion in 'Fallout General Modding' started by bortef, Sep 21, 2010.

  1. bortef

    bortef First time out of the vault

    Sep 21, 2010
    Hi,

    I just installed F2 & the F2RP on wine (ubuntu). Installers didnt give any errors, but when I start the game, after the short loading screen I get an error:

    wmAreaInit::Error loading Cities!

    Is this a wine-related error or did I just install wrong?

    Anybody had experience with F2RP on wine?

    Cheers! :)
     
  2. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    That's sfall complaining. You'll need to work some magic with the .dll to get it to work under WINE. There are already instructions here.
     
  3. Jotisz

    Jotisz Mildly Dipped

    Aug 28, 2007
    Well I tried to run Fallout 2 in wine it worked but I had installed it on windows and not whit the RP but the unofficial patch so I can't really give you a straight answer but from the thing you said/wrote it could be with the city limit so I would try to use this

    Edit
    deleted the link since it wasn't the solution\
    didn't seen your reply Killap I just wrote mine and didn't wait to reload the page then went to the next tread
     
  4. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    No, don't apply that file. Just follow the instructions in the link I gave to get the .dll working under WINE.
     
  5. bortef

    bortef First time out of the vault

    Sep 21, 2010
    cool, thank you! I´ll give it a try.
     
  6. Johno1605

    Johno1605 First time out of the vault

    Jan 28, 2017
    This post is 6 years old but I'll give it a go!

    So I'm at the same point as bortef and keep getting the error loading cities. I'm not the most computer literate and it's taken me the best part of 3/4 hours to get this far.

    I don't understand how to get Wine to use the native version of ddraw. Have tried typing "ddraw.dll=n" DLL but it's not changing anything.

    Any help will be greatly appreciated! Been wanting to play this game for years!
     
  7. PlanHex

    PlanHex Useless layabout oTO Moderator Orderite

    Nov 4, 2007
    I think the wikia stuff means you have to launch the game from a terminal with the command
    WINEDLLOVERRIDES="ddraw.dll=n" wine FALLOUT2.EXE
    after you have cd'ed to the fallout2 directory in the terminal of course. Not entirely sure though, I never used wine. I only really use ubuntu/linux for coding and such, not gaming...
     
  8. Johno1605

    Johno1605 First time out of the vault

    Jan 28, 2017
    Literally just type that into a terminal? Just tried that and it said command not found
     
  9. PlanHex

    PlanHex Useless layabout oTO Moderator Orderite

    Nov 4, 2007
    Oh well, was just a guess. You probably have to look up how winecfg works then, specifically the part about "setting overrides in winecfg for fallout2.exe". I can't really help you there.
     
  10. Johno1605

    Johno1605 First time out of the vault

    Jan 28, 2017
    Thanks, I've tried and been looking all day. Just searched again and still not getting it or getting it fixed.

    Looks like my only options are play the game with a sh** ton of lag and jerky movements or don't play at all!
     
  11. burn

    burn Look, Ma! Two Heads!
    Modder

    Apr 22, 2012
    if it says not found, that means you don't have wine in path
     
  12. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Playing RP without sfall is a bad idea, some scripting won't work as intended.
     
  13. HIGH_HEAT

    HIGH_HEAT First time out of the vault

    Nov 3, 2017
    I hadn't tried playing this game in years until this past month. I had it working on an older windows laptop but now I have a Mac. I ran into a lot of issues getting wine to work and the updates but finally got it all working to include this restoration project.

    I ran into the exact same issue you had. I can't ever get wine to load anything correctly thru terminal. Instead I recreated a wineskin from wineskin winery and deleted the one I had been using that kept giving me errors. Using the fresh wineskin I was able to open the 'advanced' section, then 'tools' and then on the left column select the 'config utility' (winecfg) button. From there you find the 'Libraries' tab and type in 'ddraw.dll'. Click add and it should appear below and say 'ddraw (native, builtin)'. That should solve that problem.

    I ran into the same save game issues as listed on the other page. I found that locking the individual files instead of the folders resolved that. I think the newest version of wine is different and all the newest updates on Mac are constantly working against you when trying to do things like run an old windows game. Every time I get an update on OS Sierra I have had to re-do my wineskins for this game.
     
  14. akaine

    akaine First time out of the vault

    Jun 28, 2018
    Here goes me, resurrecting a zombie...

    The dll overrides do work. Still the game is slow like hell. I have no problems running Fallout1 Fixed Edition 3.0 (includes sfall 1.8), but F2 is almost unplayable. I've tried to play with sfall and HiRes patch configs with no avail: in almost all cases the game crashes or does not load at all. The only workable config I found is to have Mode=0 in ddraw.ini while having GRAPHICS_MODE=2 in f2_res.ini. Also, changing GPUBlt in ddraw.ini (suggested by some sources) does nothing for me.

    Now, the main difference I saw was by switching to older wine versions. Running under the latest versions 3.6+ (the one I run F1 with) the game gives like 1/2 fps in the main menu and even less ingame. Switching to wine v1.6 helped: F2 became "almost" playable giving like 10-15 fps ingame.

    Still I do not understand what is the difference between my F1 and F2 installations if they both use the same version of sfall, which, as far as I understand, is the main reason of this pain. Using Ubuntu 18.04 with Intel HD Graphics 620 (Mesa drivers).

    Any suggestions?
     
  15. burn

    burn Look, Ma! Two Heads!
    Modder

    Apr 22, 2012
    I'm not sure what do you mean by same sfall, sfall is different for F1 and F2.
    I have pretty much the same environment, (U18.04, wine 3.0, intel HD), F2 runs perfectly.
    Configs attached.
     

    Attached Files:

    • cfg.zip
      File size:
      9.7 KB
      Views:
      24
    • [Rad] [Rad] x 1
  16. dozen

    dozen First time out of the vault

    Jul 22, 2011
    Seems like it's a general wine/sfall compatibility problem with the latest wine versions. Have tested it with wine-3.9-staging and wine-3.11-staging; sfall-4.0.6 and sfall2 v1.8 by Crafty. The same exact problem akaine had described, meaning everything is slow as hell. But with wine-3.0.1 sfall works just fine.
     
    • [Like] [Like] x 1
  17. akaine

    akaine First time out of the vault

    Jun 28, 2018
    Thanks. Didn't know this.

    Yes. It seems it's a wine version related problem. Using v1.7.x works like a charm though. Haven't tested with v3.0.1 yet.