Fallout 2 mod Fallout 2 Restoration Project 2.3.3 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 5, 2014.

  1. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    I load your save, go to the next floor, open the first door to the right, punch a soldier in APA in her leg to knock her down, and I can still attack her laying on the ground.
    Have you tried moving one or two hexes closer to your "unreachable" enemy laying on the ground?
  2. StrikeFIN

    StrikeFIN First time out of the vault

    Jul 25, 2017
    Good you mentioned that, because I forgot one more thing about this bug.

    You need move so, that enemy is on the door and then knock down / out, by critical hit legs / eyes (so that they won't be able to move for some turns)

    It's not possible to move closer to enemy on this situation.

    I would take a screenshot, but for some reason on my screenshots colors are a mess :/
  3. CPL

    CPL Still Mildly Glowing

    Mar 16, 2013
    That's an old issue, maybe even going back to the vanilla game. I think it has something to with something in the map blocking your shot, or something like that. I've had that happen to me a bunch of times. I'm not sure if there really is a fix for that or not, though. Maybe someone around here does know about that.
  4. Pwener

    Pwener Tunnelers? They Don't Sound That Tough...

    Aug 15, 2017
    Quick Question; Is it possible to install EPA as a standalone addition to Fallout 2 by extracting the necessary files and moving then to the Fallout 2 directory? The EPA Readme that comes with the latest manual installation of the RP says "to install EPA move these files..." or something along those line but then nothing, it doesn't say what files, if any.

    I can't run the RP on my android using Exagear RPG as it lags to hell and back and the loading times are the worst I've seen. It runs fine on the PC but I prefer playing on my tablet because it's faster and easier to use the UI.

    EPA is the only thing that really interests me out of all the things in the RP so if my request is possible I'd appreciate the instructions that the Readme file lacks.
  5. gustarballs1983

    gustarballs1983 -Level 99 in Fallout Fixt-

    Oct 28, 2009
    As i recall playing Fallout on Android is meh because You can't have a decent sfall version to run it with. Dosbox turbo is natively dos so no .dll files support. Dosbox with win98 installed and booted is still meh as it does not support the latest sfall only some very old versions, not to mention it chews through Your flash memory like a hot knife through butter due to swapfile made in the drive imagefile. Exagear is meh too since it does not support sfall *at all* as it only emulates some windows libraries just like winulator app wich it's based upon.

    The best and only viable option to play on a tablet, is to get intel atom based tablet with win 8.1/10.

    On a side note.. Fallout 2 *with RP & Sfall* does slowdown even on a modern desktop pc if You turn off the internet connection. Besides, EPA slows down to a crawl anyway, when on the ground level. It's due to massive amount of animations on that map. There is a no more existing animation on that map (globe was sepose to turn) it was shut down because of performance issues, however it did not help. it still slows down to a crawl ocasionally.

    the reason behind it is that Fallout 1/2 engine has limited graphical memory allocated to perform graphics (it *is* a really old game)
  6. burn

    burn Look, Ma! Two Heads!

    Apr 22, 2012
    EPA is meh anyway, so you're not missing much. I don't even go there anymore.
  7. Pwener

    Pwener Tunnelers? They Don't Sound That Tough...

    Aug 15, 2017
    Sfall doesn't run on Exagear? That's funny considering it does for me. Is it one of those "as long as you don't know it doesn't work it'll work" kind of things? Like seriously, Sfall works for me on my Android tablet using Exagear and it is only around 20% slower than on the PC which I like because both games run crazy fast (even with RP installed) on the PC and it's honestly faster than I would want it. The character runs like The Flash on a sugar rush. And that's with combat slowed down in the Screen Settings for crying out loud too.

    Okay, I admit it, to run Fallout 2 with Killap's patch I needed to download an older version of Sfall along with a pre-modified file for hi-res settings and some other junk. But it worked and I run the latest version of the patch so there's no problem there. Although curiously enough setting a different level cap in the ddraw.ini file in Fallout 1 does not work in the tablet. It works in the PC but not in the Android device. Kinda baffling. Setting a custom exp table in Fallout 2 though works with the older Sfall (not the new one) so I was able to reduce the level cap to 20.

    Honestly all you stated is completaly inaccurate and goes against my personal experience running Fallout 1/2 on my Android device (which doesn't have that powerful of a processor to begin with).

    Also I had some issues with some cities being black screens with the RP. I was able to fix The Den but then Vault City and San Francisco had the same issue so I said "screw it." So now I only have Killap's unofficial patch and the car retexture mod. It runs quick and no black screens.

    But I would still like to experience EPA at least once so if anyone can tell me which files I need to take from the manual installation and where to put them I'd appreciate it.
    Last edited: Aug 16, 2017
  8. blackwayv

    blackwayv First time out of the vault

    Aug 16, 2017
    I killed the submarine guard and can't find a way to steal the boat to the submarine. I click on the Mooring Posts and nothing happens; clicking anywhere else is just binoculars. I can't finish the game on a character I've played hours and hours on. Please help :(
  9. gustarballs1983

    gustarballs1983 -Level 99 in Fallout Fixt-

    Oct 28, 2009
    As I've stayted before Exagear only emulates some windows libraries (it's probably the same case as with win98 on dosbox turbo) You need sfall made by visual studio 2005. any later versions don't support win 98 (both exagear and win 98 in db turbo) the sfall for Fo2 You use, must be very old one like v 1.xx. Present sfall does not work. For Fo1 there is no sfall that works under exagear. (maybe besides 1.18e wich was actually Fo2 sfall that wotked with Fo1) (shortest way to check wether it works in Fo1 is to start a game and loot the skeleton [ed - ed is dead] and check wether interface has take all/leave all hand icons. If it does sfall is supported, if it does not than it's a bummer)
    besides last time I've checked Hi-res patch did not work neigther. What version of Hi res patch did You use?

    And another thing How big is Your internal memory on Your device? As recently (since like over 2 years) ExagearRPG stopped supporting running apps from external sd card (a.k.a microsd card) so how do You manage to fit the game inside, You'd must have at least like 32GB of internal storage.. Most of the Android devices do not come with such big internal memory. I have A Samsung Galaxy A5 (2015) (16GB- 11GB with partitions in place and minus operating system 9GB left). Even with forced 2D gpu rendering i don't recall neigther Fallout to run *insanely* fast. the speed was barely fine (and that's without sfall) besides i had to flush almost everything from my internal storage to fit Fallout 2 in it's around 5GB iin size.
  10. StrikeFIN

    StrikeFIN First time out of the vault

    Jul 25, 2017
    Fallout 2 best played Exagear on RPi 3.
  11. Pwener

    Pwener Tunnelers? They Don't Sound That Tough...

    Aug 15, 2017
    Exagaer does run with an sd card, but you need to make the "ExaGear" folder yourself in the card because the app won't make it for you automatically like it does with internal memory. My tablet isn't even high-end, it's a flimsy model but I love how user friendly and quick to load it is. It has 9.16GB and currently using 6.25 with lots of apps and Fallout 1 (Fixt) and Fallout 2 (Killap Patch) in memory. When I had the RP it still had GBs to spare.

    Also I have the Hi-Res mod running fine in Fallout 1 and have the latest version from Fixt installed. Are you sure it's not Fallout 2 you're referring to? Because I had to put some specialized files in the Fallout 2 directory to make ExaGear run Fallout 2 with it installed. Files I downloaded from here in NMA that an enterprising soul made especially to run Fallout 2 RP on ExaGear. Without these files Fallout 2 does not run with neither the Killap Patch or the RP on ExaGear. Again, the Hi-Res Mod for Fallout 2 has issues running on ExaGear.

    And no, I don't have the "take all" thing from Fallout 2 on Fallout 1 and I'm running the latest Sfall that comes with Fixt. You're right on that, Sfall does not run on ExaGear. Don''t mind not having it's mechanics though, Sfall for Fallout 2 is the essential one.

    Your comments about the memory of my device are strange. Fallout 1 + Fallout 2 only take like 3 or 4 GBs of memory for me. The RP took maybe an extra GB and a half or so.

    Also would you know of a way to speed up Fallout 1? I have an issue where the Overseer dialogue doesn't trigger in the end where he speaks to you in the cave and kicks you out. I suspect it's caused by the speed of the game being too slow strangely enough. It triggers sometimes but very rarely. On PC it works fine so it must be a speed thing. Perhaps some script can be altered to force-trigger the dialogue regardless of the speed the game is running on?

    I'd appreciate some clarity on this issue.
    Last edited: Aug 17, 2017
  12. burn

    burn Look, Ma! Two Heads!

    Apr 22, 2012
    See [Speed] section in ddraw.ini.
  13. Pwener

    Pwener Tunnelers? They Don't Sound That Tough...

    Aug 15, 2017
    That's the issue, Sfall does not run with Fallout 1 on ExaGear RPG. I would need another way to increase the speed of the game.
  14. gustarballs1983

    gustarballs1983 -Level 99 in Fallout Fixt-

    Oct 28, 2009
    As For the ExaGear folder it is strange I have it in my microsd card and full fallout fixt and it still does not detect any game installed. My Fallout Fixt installation took over 5GB, at least that's the amount of memory that was shown during copying over files. (might be because I've changed filesystem on my microsdcard to NTFS for 4GB file size support)

    Anyway Fixt had it's endgame tweaked a bit, in order to enable playing after the end.
    I'm not sure it's possible to finish the game without sfall anymore, I don't nessecarily think it's a engine speed issue (although not 100% sure since You've said it runs super fast) However the the way it is done by default in Fixt screws up endings cutting spoken monologue at the end on each of the slides so I always revert to 100% original speed instead of Fixt default 110%.

    The way I speedup my gaming is to choose faster animations for critters and choose speedy player and NPC's in power armor animations. Also the bend down pickup instead of magic hands for looting and additionally an option to cut weapon hide animation when doing anything with weapon equipped (that last option however is not present with Fixt's default sfall so i use the latest 1.7.6 for Fo1 by Crafty)

    As for Your question to speed up Fallout 1 on exagear *without* sfall, well I'm pretty sure it's possible byt switching to x86/x64 windows based machine with at least windows xp in order for sfall to run.
  15. PrimmSlim

    PrimmSlim First time out of the vault

    Aug 24, 2017
    Forgive me if this is the wrong thread, but I'm having a crash with the resto patch installed:

    "The instruction at 0004c5d09 referenced memory at 0a789df8
    The memory could not be read from"

    This happens when trying to take the elevator to the fourth floor of the Sierra Army Depot. Similar things happen if I try to leave the base from this save (as in walking onto the exit grid that leads outside) or on recent saves, or if I do something like use several stimpaks. I haven't had crashes like this outside of Sierra at all, but I'm worried these might continue and stop me from finishing the game. It seems like the whole base is buggy. Is it possible I did something after entering that messed things up in there?

    EDIT : Figured out through loading a clean, further back save and re-entering the base that it was the save that was problem, not the area. Should have tried that first. Feel free to move or delete this post, but maybe my solution will help someone else who also has this issue. Thanks in case anyone looked into it.
    Last edited: Aug 24, 2017
  16. Wiggles

    Wiggles First time out of the vault

    Aug 24, 2017
    So I got an itch to play FO2 again, and I've never tried out the restoration project.

    But I cant seem to get it to install with the nifty window installer.
    I'm on Windows10 and this is the GoG Fallout 2.

    When I try to install the Restoration thing. I get this:
    Fallout 2 appears to have been installed in the C:\Program File\directory. Installing in this directory under the version of Winsows detected on your system can cause many unexpected problems. Please reinstall the in a different directory (e.g. C:\Games) and run the Restoration Project installer again.

    And I get that unless I try to install it into C:\ and there it tells me that I need to install it where Fallout 2 exe is.
  17. valcik

    valcik Sonny, I Watched the Vault Bein' Built!

    Dec 20, 2008
    You have to reinstall whole Fallout 2, do not put it in UAC protected Program Files directory.
  18. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Replaying RP 2.3.3 for testing sfall 4.0, I noticed a couple of bugs about planting experimental/corn seeds in EPA green level and Arroyo village:

    1. epai33.ssl: Two of if (cur_map_index == MAP_EPA_SUBLEVELS) are wrong, so your plant never shows up in the green level. It should be if (cur_map_index == MAP_EPA_SUBLEVELS_1). Also for Arroyo village the plant/corn gets placed in wrong elevation.

    2. epas9.ssl: It checks a non-exist global variable (GVAR_EPA_SEEDS) for message 200, so player never says that floating message.

    EDIT: ok, I fixed these two scripts. The fix only works if you didn't return to EPA sublevel or Arroyo village maps to check planted seeds yet.

    Attached Files:

    Last edited: Sep 10, 2017
  19. Deadly_Bob

    Deadly_Bob First time out of the vault

    Sep 10, 2017
    Hello vaultdwellers,

    I've played fallout 1 & 2 when i was a kid, best games i have ever played!
    I had an nostaligic attack the other day lol, so i bought fallout 2 on Steam.
    No mutants allowed is not unknown to me, looked it up a couple of times for some cool Fallout History.
    I wanted to have the gaming experience with this restoration-mod, so i downloaded and installed the mod into the fallout 2 map.

    Unfortunately when i try to run the game, the only thing that pops up is an error which says: ''error initializing video mode 1366x768''. :-?:aiee:

    Could anyone help me out? I dont wanna play the new sell.. eh Fallout games.. :puke:

  20. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Run f2_res_Config.exe and see if 1366x768 is available in the resolution list, or check "Windowed" to make FO2 run in a windowed mode.