Fallout 1 mod Fallout Fixt - v0.90beta is being worked on! (Jan 2019)

Discussion in 'Fallout General Modding' started by Sduibek, Dec 15, 2010.

  1. Daniel "Dan" Acerbi Rocha

    Daniel "Dan" Acerbi Rocha I AM NOT A SIR! I WORK FOR A LIVING YOU MO-RON!

    Jul 11, 2018
    Thanks for the answers man.

    About answer 4: how do you do that since the line on ddraw.ini is not present?

    EDIT: Also, do you know if the Fixt fixes the burst fire being stopped by corpses bug?
    Last edited: Jul 18, 2018
  2. mandala

    mandala It Wandered In From the Wastes

    May 5, 2006
    By npcs I mean raiders, which mean I can't get to them...
  3. Foxx

    Foxx It Wandered In From the Wastes

    Oct 31, 2017
    They appear on random tiles. You need to edit the scripts.
  4. gustarballs1983

    gustarballs1983 Supreme Jerk in Fallout FIXT

    Oct 28, 2009
    about RE to answer #4:

    Perhaps U did not use proper ddraw.ini... On the contrary to Fallout2RP You should also update ddraw.ini (However be carefull as some settings need to be mimicked over to the new ddraw.ini from the old one.
    The best way to check wich ddraw.ini you have is to look-up the ddraw version in the first line of the .ini it should read ";sfall v1.8 configuration settings" without the quotes.

    as for the coprose line of fire fix and burst bullet spread fix I'm afraid they're not implemented. However if you want You may try to ask @Crafty to implement that feature, although I'm not sure when or if at all he would answer you.
  5. Bob Morane

    Bob Morane First time out of the vault

    Jul 9, 2018
    Just added some savegames to the bug report page http://falloutmods.wikia.com/wiki/Fallout_Fixt_bug_reports?action=edit&section=11 concerning the military base, which is at least extremely annoying, possibly impossible to finish (second elevator in L3 locked down), in my memory, playing around with force fields was easy in the vanilla version, it's now a nightmare.

    I think i remember being able to target the force fields generator (not just the panel) with the repair skill, now, i can't, i have to use the repair tool, still, it gives 50 XP but doesn't deactivate the forcefield, plus, destroying them with plastic just deactivate them, then, they come back online indestructible.

    Save https://workupload.com/file/KYRzfYZ (same as in the wiki) - Win 8 x64 GOG version.

    I restarted the military base 3 times and i'm not through yet (tried without the radio call, with the 2 different options, the fall and asking for reinforcements ... )
  6. dozen

    dozen First time out of the vault

    Jul 22, 2011
    Been translating Fixt into Russian, found some typos/mistakes (some might be intentional):

    They call us Fools, but you's just stupid for showing up here.

    This disk is in bad shape. It has no proper label but has "overide" scratched onto the side.

    See. So, you better find anoter place to go. It isn't safe here.

    Okay, I'll take your there. Anything for a hunky costumer, anything! Follow me. [accepts 400 caps]

    You see a businessman. You are unsure the nature of his business.
    • [Rad] [Rad] x 1
  7. azat11

    azat11 First time out of the vault

    Jun 16, 2017
    Hi all.
    Just returned to my Fallout 1 playthrough, and I have a question.

    In the Fallout wiki it's written that the endings for the super mutants are flipped:

    Is this still true for Fallout Fixt??
    Grateful for any help.

    EDIT: Also, is there any difference/consequence in doing these things in a different order, or is it just a difference in an ending slide?
  8. FDO

    FDO First time out of the vault

    Jul 4, 2018
    I had a doubt but I just finished the game with Fixt and yes, the cathedral/military base order are still flipped in the mutants ending.
    It's basically the same ending anyway. As far as I know, there is no difference in doing the order you prefer, just a few dialogs of secondary npc like Rutger, if you even stop to speak to them at that point.
  9. azat11

    azat11 First time out of the vault

    Jun 16, 2017
  10. naossano

    naossano Sonny, I Watched the Vault Bein' Built!

    Oct 19, 2006
    It seems that if you go to the military base first, you can spy a conversation between the Lieutenant and the Master, through some envoy. Also, you can gather some items that can help you agains't the Master.

    On the other hand, if you go for the Master first and mention the sterility issue, he can send a call to his scientists at the military base to confirm if it is true and they will deny it (they know and lie to him).

    But those are minor dialogs. It doesn't change the shape of the wasteland.
    Last edited: Aug 22, 2018
    • [Like] [Like] x 2
  11. azat11

    azat11 First time out of the vault

    Jun 16, 2017
    So I have a different question. Can I convince the Master of mutant sterility if the base is already destroyed? Does that even make sense? Any effects there?
  12. naossano

    naossano Sonny, I Watched the Vault Bein' Built!

    Oct 19, 2006
    That doesn't seem to make a difference. You need vree's holodisk and some character stats.
  13. azat11

    azat11 First time out of the vault

    Jun 16, 2017
    Cool, thank you : )
  14. Daniel "Dan" Acerbi Rocha

    Daniel "Dan" Acerbi Rocha I AM NOT A SIR! I WORK FOR A LIVING YOU MO-RON!

    Jul 11, 2018
    So I know I've asked this before but it's still driving me nuts...
    Does the fixt implement some kind of frame buffer or vsync?
    I swear the mouse movement after you apply the patch feels sluggish (exactly like it does with vsync on on many other games) but only in-game (not on the menus/options/character creation).
    If it does, can it be disabled?

    Disabling the variable FLICKERING_SCREEN_FIX in f1_res.ini did the trick.

    Now if I can just increase the number of simultaneous sound channels I'll be set...
    Last edited: Aug 28, 2018
  15. Fizzycswag

    Fizzycswag First time out of the vault

    Jul 15, 2018
    VirusTotal said this had malware???
  16. naossano

    naossano Sonny, I Watched the Vault Bein' Built!

    Oct 19, 2006
    I checked on Drobovic's database and the Fallout mods wikia.

    They mention two other mods that seemingly have the same goal as FIXT.

    The Update Mod restores cut content. The Restoration Mod seems to be a continuation of the Update mod. And the FIXT is said to integrate some, but not ALL the content of Restoration Mod. But it seems that everything mentioned in Update Mod and Restoration Mod are in the FIXT.

    What is the situation now. Does FIXT makes the other two obsoletes ? Or do they have contents that the FIXT does not have ? Wondering if there is any point to advertize the other two...

    Here are the wikia links :

  17. GuyManBot

    GuyManBot First time out of the vault

    Nov 26, 2017
    Just dropped in to say I am glad the mod is not dead, same with Sduibek. I thought I heard a rumor that he died in a car crash while moving. Hope to see an update to this soon.
    • [Rad] [Rad] x 1
  18. Systolic Motivator

    Systolic Motivator First time out of the vault

    Sep 6, 2018
    Thanks to everyone who worked on this mod. I completed the game with a few bugs:

    Inventory button kept turning into a black square, and trying to save resulted in a corrupted save file.
    Followers sometimes disappear, and some of my save files had images where you could see a follower, but they were not there when loading.
    Dynamite and C4 somtimes cause the game to crash with an uncaught memory exception, likely a NULL pointer dereference.
    Background music repeat is bugged which causes looping at the wrong offset.

    I had to keep multiple saves and backups, and restart occasionally however it was worth it for what this mod brings to FO1 having only ever experienced vanilla with engine fixes.

    Hopefully this mod will be updated to fix some of the bugs one day. Thanks.
    • [Rad] [Rad] x 1
  19. TheWickedGamer

    TheWickedGamer First time out of the vault

    Sep 9, 2018
    I have an issue, I am using 0.81 Alpha - Full Version, running Windows 10, 64 bit and I have no savegame file yet because my issue is on the main menu. I have tested this a few times via deleting all game files, copying the backup, then verifying files on Steam to make sure vanilla is restored completely, then rerunning Fixt again to reinstall.

    My issue is with the Colors I think, default is 16 Bit, and when I change to 32 Bit, when I go to the main menu I am stuck on the main menu. I am able to click on all the options (Intro, New Game, Load Game, Options, Credits, and Exit) but only Credits and Exit are responsive. I can click on Options and get Game Preferences and Screen Settings, but they do nothing. When I click on New/Load Game, it acts as if it wants to do something, but after a short black screen that fades to a white screen it just goes directly back to the Main Menu.

    I tried messing with the F1 res Config exe and both of the ini's (F1 and High Def) but nothing was responsive. I have no clue if anyone is even working on this mod anymore, but being there's a forum I figured I would post this. I truly appreciate all the hard work modders do to this (and all) games and post it for free for us to enjoy.

    After closing game, then restarting I get this same issue again without touching Colors. All I changed was to make it Windowed and 2x to make it bigger as I have bad eyesight. I also changed some game settings but I think my issue is with screen settings.

    2nd EDIT:
    It appears that the game plays fine as long as I play after reinstalling the mod - which means I have to delete/verify/reinstall before every time I play - I wish the save file was located somewhere else than in the main folder. I really wish I knew how to fix this issue because it is a pain in the ass. I have to play in windowed mode because I am always using my 2nd monitor for something, I assume full screen works correctly.
    Last edited: Sep 9, 2018
  20. Systolic Motivator

    Systolic Motivator First time out of the vault

    Sep 6, 2018
    I just checked and confirmed both 800x600 16-bit DirectDraw 7 and 1920x1080 32-bit 60 Hz DirectX 9 modes selected with f1_res_config.exe work for me without any colour corruption, however I have experienced the same issue you have detailed with Killap's RP and it was caused by one of the video rendering modes in Sfall. I don't have this problem anymore so it was either fixed in a newer version of Sfall (there is a much newer version available ie 4.0.7 on GitHub) or it was fixed in the GPU driver by NVIDIA. Are you using AMD?

    Looking at the ddraw.ini for Sfall there is a comment the Graphics section which states "IT IS NOT RECOMMENDED TO CHANGE "MODE" FROM 0 (8 bit), USE F1_RES INSTEAD; CHANGING MODE HERE MAY RESULT IN CRASHES IF USING F1_RES". I didn't notice any increase in visual fidelity when increasing the colour bit depth from 16-bit to 32-bit so I would keep it as 16-bit. I think the only setting you should change is the Output Mode from DirectDraw 7 to DirectX 9. Have you tried updating to the latest GPU driver cleanly, by removing the leftovers with DDU?