Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. BuxnaMan

    BuxnaMan First time out of the vault

    Mar 26, 2010
    Hey you freshened up the game a lot! Bugs will be fixed don't worry.
  2. BuxnaMan

    BuxnaMan First time out of the vault

    Mar 26, 2010
    Can you post that in a wiki? Possibly with a save file. Or at least post a save file here an I will post it there.
  3. dalponis

    dalponis First time out of the vault

    Aug 10, 2003
    Hey guys.

    So I installed Fallout2 and added the patch. I set the game to Windowed mode and I get:

    "Failure initializing input devices."

    When I run it regular fullscreen, I get the "Joesph and the Technocolour Dreamcoat version" - I'd really like it in a windowed mode.

    I just installed the patch over a clean copy of Fallout2, and this time it worked, for one launch. Now it doesn't work again...

    I installed the FULL version with all options on. I have the regular USA version.

    Second question:

    Is there any way for me to move that Fallout2 window out from the top left corner of my screen?
  4. drizzt561

    drizzt561 First time out of the vault

    Mar 30, 2010
    open ddraw.ini and set these to 1

    ;Set these to 1 if you want fallout to access the keyboard or mouse in background mode
    ;Try these if you get the 'Failure initializing input devices' error

    I'm not sure about the color issue, are you using win 7? I'm sure the fix is earlier in this thread though.

    also in ddraw.ini

    ;A key to hold down to move the window around when using graphics mode 5
    ;Set to 0 if you don't want to use a modifier key, or a DX scancode otherwise
    ;Set to -1 for either ctrl key, -2 for either alt key or -3 for either shift key

    If you want to use a key other than the ctrl, alt, or shift key, you can find the code at this website. http://www.gamespp.com/directx/directInputKeyboardScanCodes.html
  5. dalponis

    dalponis First time out of the vault

    Aug 10, 2003
    Thanks drizzt561. Works well. Sucks that now my Fallout 2 gameplay could do some nasty things, given that my mouse is not bound to the game...
  6. Dummie

    Dummie First time out of the vault

    Apr 4, 2010
    Dummie character and Kaga


    My first post to forum :)
    Sorry about my bad english.

    I´m playing dummie character (intelligence=3) and i always got stuck with dialogue with Kaga. This is the first encounter with Kaga and there are also some angry bandits with at same time.

    First encounter happens somewhere between Vault city and Den. Travelling from Vault city to Den for the First time.
  7. Endocore

    Endocore Look, Ma! Two Heads!

    Mar 14, 2010
    For the folks who want more random encounters:

    This may sound trivial or even silly, but zigzag across the grid squares of the world map. If you always travel in lines that are either parallel or perpendicular to the grid lines, you won't get very many random encounters.

    This is a general FO2 issue I noticed long ago, and doesn't have much to do with killap's work (which isn't to say anyone isn't actually having a problem).

    Anyway, try zig-zagging.
  8. CLaX

    CLaX First time out of the vault

    Apr 4, 2010
    Hello, everybody.
    First up, many thanks to Killap and everyone else, who worked on this. A damn good reason to revisit an old favorite.

    But there's a slight issue I'm having (and I'm not even sure if it's a bug or a feature):
    I made it to Vault 15 entrance, but I can't get inside the Vault. The vault door is there, intact, and no interaction with the computer helps (science, repair). Lockpicking the vault door doesn't work either (DURR).

    I know that in vanilla Fallout 2 the door was not an issue, as it was laying down in pieces (see screenshot).

    Any help on that? Didn't find any help from the walkthroughs.

    EDIT: bug submitted to technical wiki.

  9. Dravean

    Dravean Where'd That 6th Toe Come From?

    Mar 6, 2005
    That door shouldn't be there... ::points accusatory finger at Pixote:: :)

    Did we just find another game breaking bug?
  10. SPC

    SPC First time out of the vault

    Jan 20, 2007
    I like em. They really tie the rooms together, man.
  11. Not Lost Hope

    Not Lost Hope First time out of the vault

    Mar 26, 2010
    I noticed in Arroyo you put small pots in front of a few shelves blocking access to them. Will this be an ongoing theme later on in the game? I think I missed a xander root from the bottom left tent because of that, maybe a knife in some other hut, can't remember the starting items that good, it's been a while the last time I played either Fallout. Nothing major but for a guy with minor OCD it's annoying not having access to something that has the hand icon on it :lol:

    I haven't made it far so far, only Klamath, but I think your stuff is looking pretty good so far. The last RPG I played waiting for RP2.0 was V:TM Bloodlines and your work satisfies the graphics whore that game made me, so good job :clap:

    Thanks for all you guys working on the RP, new graphix, animations, high res mods, sfall for breathing new life into an old favourite game!
  12. TJ07

    TJ07 First time out of the vault

    Apr 25, 2006
    I got in the vault by starting combat with the raiders and they opened the door from the inside.
  13. CLaX

    CLaX First time out of the vault

    Apr 4, 2010
    But they have guns... that shoot! Bullets!! AT YOU!!!

    But srsly, I'm playing diplomatically this time. Besides, this still does not resolve the actual bug.
  14. Mordegar

    Mordegar First time out of the vault

    Dec 23, 2007
    The reworked slaver camp was one of the things that was badly needed because of general game balance. I've played through it yesterday and all i can say is well done!.
    It felt far more balanced than the previous version of it.

    Btw, Kaga won't run away in my encounters with him, i can beat him to death while he won't leave the map.
    By the way, i think his second encounter is bit too soon, because you can get a combat shotgun from one of his minions before you even finish Vault City.
  15. .Pixote.

    .Pixote. Antediluvian as Feck

    Sep 14, 2009
    Relax - you find the bugs and they will be fixed. Be on the lookout for the usual inconsistencies; objects and walls that the player can walk through, lighting problems, etc, no bug is considered too small, but understand that certain technical issues cannot be overcome with the Fallout 2 mapper, because they might be game engine and not mapper related.

    As for the new doors at Vault 15 - well the guys there repaired it - but understand I only enhanced the maps (with new artwork, etc), I never scripted or debugged them ::points accusatory finger at Dravean:: :roll: The door should open with the computer, but I’m yet to downloaded RP 2.0, so I haven’t actually played it - (I need to wait 4 more days). All bugs will be squashed (keep reporting them), it just takes time. :wink:
  16. TJ07

    TJ07 First time out of the vault

    Apr 25, 2006
    Well you can't be diplomatic on level 3, Darion will just burn you down. :P

    However I'm sure they'll fix the door soon.
  17. joochian

    joochian It Wandered In From the Wastes

    Apr 1, 2010
    i also got this.. u just need to start kill guards.. and the guards inside the vault we come ruishing out and when they do, they open the vault 15 door for u
  18. joochian

    joochian It Wandered In From the Wastes

    Apr 1, 2010
    Haha, Don't make me pee on your rug!!!
    "That rug really tied the room together. " -The Dude & others..
    reference for The Big Lebowski..
  19. Travesty

    Travesty First time out of the vault

    Apr 18, 2005
    BUG: When leaving the second vault-city area to the first one (courtyard?) with lenny, the screen goes black and crashes, but when leaving alone everything is okay. http://www.mediafire.com/?m2zntnjzzmd

    Submitted to wikia
  20. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I have tried both your saves and can find nothing wrong with them.
    I did what you said you did and could not get any crashes whatsoever.
    Did you try to restart the game and test it again?
    And could someone else maybe give it a try?

    On another note:
    Having sex At the Cat's Paw in New Reno crashes the game due to a silly mistake I made. So sorry guys, do try to keep your hormones in check. :P

    Except you would need two new scripts for that - one for the computer and one for the door - plus an export variable in the map scrip.
    Not that I would particularly mind a working door, but the original door do say that it's beyond repair. So how did they manage that then? :P
Thread Status:
Not open for further replies.