Fallout 2 mod Fallout et tu - Release v1.7

Discussion in 'Fallout General Modding' started by Lexx, Aug 23, 2019.

  1. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Not that I am aware of. Never heard or seen that mentioned bug either. Hero appearance mod works pretty much perfect for me for years now.
  2. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Lexx what happenned to the development of Fo:et tu? i've seen recently updates stopped on github...

    Is it due to xmas break or development ceased altogether?

    I know I haven't reported in a while, it's because I've got to take care of shit in my personall life which has been pestering me for over a month now and keeps rolling forward. However if I stratch up some time, I'm sure to make another checkup-playthrough, and report what i find, just can't do it now.
  3. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    It's just two days without update. :aiee:

    I won't be at home for the next week or so and generally less frequent updates can be expected. Also christmas time. There will be a new beta release in probably 3 or 4 days, but don't expect the world.
  4. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Christmas update. \o/

    The new release can be found here, as usual.

    • Added: Upscaled graphics:
      TownWorld, Ending Slides, Splash Screens, Death Screen, and Help Screen (Optional).
    • Added: V13 vault suit item!
      Can be found in the V13 storage room and is equippable by party members. (Optional)
      NOTE: Doesn't work right now for party members! Will be fixed with next release.
    • Added: Correct disguise-check to the scientists and technicians in the Master's Lair.
    • Added: Party members are now included in the guard disguise-check (makes infiltration with party members possible. Optional behavior, see fo1_settings.ini).
    • Added: Correct spawn hex when being teleported to the LA Library via invasion super mutant.
    • Added: Using an electronic lockpick on the atom bomb terminal in the Master's Lair now calls the bomb arming right away. No need to follow it up with using the lockpick skill on the terminal.
    • Added: Missing Brotherhood of Steel "Invaded" ending slide.
    • Added: Missing music for the Master's Lair.
    • Added: Pulse Pistol to Mariposa, but tweaked the stats to make it not be super overpowered.
    • Added: Solar Scorcher to Guardian of Forever special encounter. Removed the Zip-Pistol and increased level requirement to >10 for game balance reasons.
    • Added: Removed the Fixt-option and made reporting Bob a default feature.
    • Added: It's possible to fail reporting Iguana Bob to the sheriff (speech & charisma check).
    • Fixed: The Master's Lair bomb disarming code works a bit better now.
    • Fixed: Can't arm the bomb in the Master's Lair over and over again.
    • Fixed: Added a short delay to the endgame sequence so that the vault door will open after the endgame slides and not before.
    • Fixed: Dog barking sfx in the Cathedral tower maps.
    • Fixed: Game is using the correct font for the main menu now.
    • Fixed: Gizmo's ending slide has precedence over Killian.
    • Fixed: Ian duplicated "decline to join"-dialog.
    • Fixed: It was possible to interrupt the Adytum fight between Blades and Regulators who then wouldn't attack each other anymore.
    • Fixed: Izo, Gizmo's bodyguard, will return to his home tile on map_enter now.
    • Fixed: Junktown casino guards would float warnings on every game tick.
    • Fixed: Killian's safe would keep spawning items on map_enter.
    • Fixed: Mantis in Lance-encounter will be aggressive and not completely ignore him anymore if the player wasn't spotted yet.
    • Fixed: Player spawning on the wrong hex when joining the fight against Gizmo.
    • Fixed: Town/World entry points for Junktown moved to more represent the actual map positions.
    • Fixed: Visible "transparent" pixel in the corners of the town/world map graphics.
    • Tweaked: Main Menu button background is baked into the HR_MAINMENU.FRM file now, because the Hi-Res patch interface lacks shadow.
      Also reduced the height to 720px (from 920px), because engine resizing gives bad results.
      This is experimental - might be reverted back at some point. The original file can still be found in /art/intrface/
    • Tweaked: Some more pixel pushing on the main menu has been done. Fixed some shitty areas and brought back the colors more closer to the original again.
    • Tweaked: Removed tribal references from the character style text (Character Appearance mod).
    • Removed: Fixt-function, lockers getting destroyed by explosions. It was barely used.
    • Removed: Fixt-setting for painfields, because it is questionable game design.
    • Removed: Initial map_enter message for V13 caves.
    • Removed: V13 door computer can't be destroyed anymore (just leads to additional problems).

    Once more we got lots of improvements into the build. Mostly fixing some of Fo1's code and inconsisten design. Also removed some obsolet Fixt-settings, and added in a bit new, optional, content. It's getting harder to find stuff to fix, but there's always something to stumble over when randomly digging through the code. Yay, I guess.

    The upscale-mod is compatible not just with et Tu, but also vanilla Fallout 2 (and Restoration Project). Just copy&paste the mod folder, enable it in the ddraw.ini (see readme.md for details) and that's it. However, it will be necessary to manually copy&paste the Fallout 2 files for the death screen and the splash screens into the correct folder, as these are different in Fo2.

    Here are a couple comparison screenshots:

    Vault 13: Old | New
    Boneyard: Old | New
    Arroyo: Old | New
    Klamath: Old | New
    Death Screen Fo1: Old | New

    As can be seen, the difference is quite big and personally I won't be playing without it anymore.
    Last edited: Dec 29, 2019
    • [Rad] [Rad] x 5
  5. motiejus

    motiejus First time out of the vault

    Nov 3, 2019
    Great work dude! I was thinking about first Fallout playthrough and on the improved engine this will be so much nicer and something new for me (again, by mean how old is this game and how fun still is it).
  6. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009

    Got a couple of bugs:

    -when attempting to steal from Mysterious Stranger white interface button appears on the left when clicked whole player inventory gets transfered to mysterious stranger.

    -Robodog companion still uses Dogmeat protos so no advanced laser protection plus robodog starts with 47HP and after entering his char sheet he automagically get's buffed to max 50HP (3 current hp has to be healed though,a s he still has 47 current HP after the char sheet buff).

    - dice casino girls at Gizmo's casino don't unblock themselves after switching dice and winning too much money from them. ( they say table is temporarily closed for like 10 days in a row -i did not have patience to test more)

    - there are still NPCs that get filled with bottle caps on save load (tip. check the boxing ring guards and guy taking bets at Junktown Casino map).

    - it is literally impossible to steal Neal's Wife urn from bar-table. I've got 75% steal and 200% sneak (sneak is enabled) and I failed every time. Tried like 50 times and still no success. I remember that in Fo1 it was far easier even with 50% steal skill. (tip. ever since You've changed the skill check back from (was it) science or repair to steal, it doesnt want to work. Now the only option is to convince sherry to confess as joining skullz trick for vinnie to spill their secret is a dead end.

    above is a proof for weird mysterious stranger behaviour I've talked about
  7. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Pretty sure this is an issue with the Hero Appearance mod. Nothing I can do or would know how to fix.

    PS: What's up with that button on the loot interface.

    The robodog is just a reskin. It doesn't change any stats.

    Well, players have to report them. I don't know everything magically.

    I just took it at daytime without issues.
    Looks like the "use stealing on scenery"-feature is the problem, because the skill check goes by source_obj, but the way it works means source_obj is not the player. I'll fix it later. For now... just take it at daytime.
    Last edited: Dec 25, 2019
  8. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Noticed some inconsistent behaviour with robodog new lighting function.

    it get's really bright when robodog is around the player (as if the player is the source of the light, however as soon as player mooves away from robodog the light get's dim. i find it awkward, as robodog is the source of the light, so it should be bright around it not around the player.

    I thought it's sepose to serve as sort of a flare. dogmeat beeing source of the light and a hth character runs up towards enemies and iluminating them making them easier to hit. Was this the intention of this function? or was it charging of solar scorcher?

    nah just checked it does not charge the solar scorcher
  9. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Script is setting dogmeats light level, nothing more. If there is anything weird with it (which I haven't seen for myself), then it's an engine-level issue or a different mod conflicting.

    /Edit: Just tried it again, everything works as it should. I've set him to wait and walked away -> business as usual. Anything else would have surprised me tbh, because the same stuff is used for every light object in the game.

    I just tested this. Works fine for me. Planted dices, removed dices, had to wait a day and all was fine again. Winning lots of money and having the house close the table was also resolved after waiting a day.
    However, I noticed you can easily barter with them, which is disabled now.
    Last edited: Dec 25, 2019
  10. motiejus

    motiejus First time out of the vault

    Nov 3, 2019
    Question here, can I have installed a RP and this mod at the same time? Does it have the separate launcher?

    Sorry for bother you, but I’m still in the hospital and I haven’t checked it yet, although I’m interested in this fact.
    Last edited: Dec 29, 2019
  11. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    This mod is using its own mod folder. You just extract that into your Fallout 2 folder and done. Nothing gets overwritten.
    • [Rad] [Rad] x 1
  12. motiejus

    motiejus First time out of the vault

    Nov 3, 2019
    Just got it installed and played for some while. I have found one bug - in Junktown, after talking to Doc Morbid, he instantly teleports to the near table. Then, when I talk to him again, he teleports back to the old position.
  13. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    I need more details. What did you say to him? What daytime? Where was he when you first talked to him? Etc.
    Just checked him out, talked to him and nothing happened.
  14. motiejus

    motiejus First time out of the vault

    Nov 3, 2019
    Just asked him about who is he, what he does here and I remember that at the end I gave him some caps for medical assistance. Daytime was afternoon. He stayed near the manhole at the first time.
  15. motiejus

    motiejus First time out of the vault

    Nov 3, 2019
    Also what I noticed is that while running is set to "always", it's impossible to sneak - it's just switching off. I have to set it into "normal" mode, and then it works.
  16. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    If you got healed by him, you likely advanced the time forward so much that his sleep routine got triggered. It's not exactly a bug.
    Morbid is in the underground map from 17:00 to 23:30 o clock and the clinic is closed.

    About the sneaking, you of course have to hold shift while clicking, to force the player to walk. That's normal.
    Alternatively you can set DontTurnOffSneakIfYouRun to 1 in the ddraw.ini file.
  17. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Are You ok with FIXT changes to alcoholic beverages/drugs in Fo:et tu?

    Namely Sduibek changed beer to also add + "x" CH besides PE drop, and booze besides PE drop also adds +5% damage resistance. this causes fight with Garl hilarious even with completely no points invested in unarrmed:
    Savescum "possibly" required.
    before fight: equip leather jacket +20% DR , pickpocket garl from psycho and use on self +50% DR, pickpocket other raiders for Booze (4-5 total, required only 4 bottles for missing 20% DR).

    So: Leather Jacket 20% + Psycho 50% + Booze (4x5%) =90% Damage Resistance for fight with Garl.

    This causes us to take next no damage from Garl's hits, so it would be just a matter of beating him up to death which can be done even with measily unarmed skill.
    After the fight You get: kill exp. for Garl, Garl's stuff from his body (everything except armor), Desert Eagle + .44 Magnum JHP ammo, *before* fighting rest of the raiders, plus 450 exp for freeing Tandi. ( peacefull way yealds 500exp. points however we don't get kill exp. for Garl that way yet.) So taking Garl one-on-one is the most beneficial way of proceeding with rescue tandi quest.

    So the question is: Are You certain booze should have +5% DR on it?
  18. McRae

    McRae For sale: clown shoes, never worn Orderite

    Dec 9, 2007
    Ok first, let me tell you I can't wait to play with this beauty! You guys really put a fresh coat of paint on fo1.

    That being said, I have a resolution problem. I tried various combinations with the ddraw.ini & the f2_res.ini, and for the life of me can't make the game work with the scaling x2 with res 1920x1080. Basically, everytime I use the scaling, I have a red floating text above my character's head that says : "Warning! screen resolution too low!". This only way it works is with zero scaling and no less than 1024x768... but very often I have this "memory could not be written" bug. Argh!

    Things you should know :
    I downloaded the latest version : v0.1372
    Everything is updated on my computer and my screen resolution is 1920x1080.
    No mistakes occured during the installation of the mod so all the files are in their right place.

    As a test, I tried the exact same resolution and scaling with Fallout 2 and the RP installed, and it works perfectly. So, what am I missing? I'm running out of drinking water here. Thanks in advance.

    Some screenshots :
    Error.JPG scr00000.jpg scr00002.jpg
  19. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Delete \Fallout1in2\mods\InterfaceUpscaled\scripts\gl_iu_warning.int and check if the crash disappears.

    Did you try the RP with ExpandWorldMap=1 set in the ddraw.ini file + latest ddraw.dll? A while ago a "bigger worldmap interface"-feature was added to Sfall, which requires a specific game resolution (big enough to show the new interface graphics). If this isn't matched, the game will crash on the worldmap.

    Also you can try to remove the line "PatchFile1=mods\InterfaceUpscaled" from the ddraw.ini as that is loading new upscaled graphic files (also requires the bigger worldmap interface to work correctly). In worst case, this should solve your problem.
    Last edited: Jan 6, 2020
  20. McRae

    McRae For sale: clown shoes, never worn Orderite

    Dec 9, 2007
    I could finally get around to try your solutions. Here are my findings.

    So, deleting "gl_iu_warning.int" did remove the floating warning text, but exiting a map would still lead to a crash, sometimes it would
    work for a time and then crash some more. Especially if, let's say I'm exiting the cave entrance in vault 13, find myself on world map,
    and from there decide to immediately go back to the cave; it would always trigger the "memory" bug.

    Then I removed the "PatchFile1=mods\InterfaceUpscaled" and... you did it! No more crashes, it works flawlessly now.

    You just saved someone's playthrough. Much appreciated!