Fallout 2 mod Last Hope mod v1.083

Discussion in 'Fallout General Modding' started by Forgotten Knight, Apr 30, 2021.

  1. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    While working on the new update i deleted the old thread full of outdated info. Also there's a lot of changes since v1.082 so i recommend waiting for the new update. New version will not require vanilla game files and won't be compatible with the v1.082. While most of the quests are complete and pretty much the same between 1.082-1.083, new version changes some scripting and will cause errors if used with the old save game files.

    This post will be updated when the new version becomes available. In the meantime we can do FAQ and DEBUGGING based on the v1.082 and 1.083(Shortly available for testing purposes while the link was up).
    • [Rad] [Rad] x 7
  2. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    So I've sent you a PM Like You've asked,
    but since You've decided to start this thread we might continue that discussion in public.
    Just copy-paste my PM in a spoiler tag, and You could start Q&A from there.
    BTW I wasn't lucky enaugh to get v1.083 I'm still on v1.082
  3. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    The key is to visit these locations:
    - Miners Town
    - Farmers Town
    - UMB
    - Golden Valley
    - Duntown
    - Philton
    - Abandoned Base
    - Silting
    - Canville
    After that, person in the tent(south of the main entrance) will give you more clues.
    Thanks, i worked on Noel's appearance and proto editing for stage 2 and 3 but did not change the default proto script. Added to my "to do" list.

    I added the spoiler there and the following :) In v1.082 this was certain death.
    Later i changed that where you can actually escape through a small hole in the wall. What's the catch? You'll just need a dynamite or plastic explosive.

    I'm glad you asked since i need to continue working on my walkthrough:
    Leonard from Duntown can sell you some uranium ore. He will actually request a meeting with Aston and give you a request form, i hope this is enough.

    There's a guy located just outside the Bulls building, in his secret stash, hidden down the manhole. Wooden shelf in his little shack has some interesting items.

    I'll post the rest soon... "Ought to take a little nap, talk to Grampy Bone." :)
    • [Rad] [Rad] x 1
  4. QuantumApprentice

    QuantumApprentice Look, Ma! Two Heads!

    Feb 9, 2018
    I'll try and answer in the order asked :P

    Nah not yet. I figured the mod might be incomplete, so I played it until I got stuck in a cave unable to escape after causing a cave-in at the end of a 4 hour stream. I thought it was a funny way to provide an interesting ending to my first playthrough (plus I didn't want to have to replay the entire 4 hours again :P)

    no clue, I just figured I'd replay the mod on the next release so I'd have something fun to stream :)
    I wasn't able to find the main quest guys either, just wandered from town to town doing the side quests I could figure out.

    lol I was able to come up with
    2x metal armor at the same time due to a bug which I hope won't get fixed anytime soon as it was hilarious to find out :P

    why hide info about the steal skill? new people playing this mod should know the steal skill is also heavily modified from the original, with new effects including not being able to look in the inventory of people with perception?/steal skill? that is too high for your skill level.

    There's an easier and more consistent way to get the high level stuff...
    Click that spoiler button if you want to know more :P
    Take 150% unarmed and knock out any of the WP Patrol on top of a lootable corpse. The game makes their weapons available to loot while they're knocked out! XD

    sadly...that's all the questions I can answer, as I didn't try another version of sfall...also what's sfall-Extended?
    and I didn't take Mysterious Stranger perk, and I have no idea why you're asking me what to do next :P

    good point about dobrovik's archive, but how do I find "_Pyran_'s signature"?

    No clue, didn't look that closely at the mod. If you want to share the script name I can take a look at it, but I'm not promising anything :P
  5. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009

    yeah that bug was hilarious however i thought you'll not have enaugh steal skill to find out for yourself :p

    I hid it out of convinence, i don't want to spoil stuff for ppl that want to discover the stuff for themselfs.

    yeah but tackling those guys while undergeared seemes like a suicide anyways and taking into accout that saving during combat is a generally a bad idea i would recommend My way of proceeding with this.

    sfall-extended is a fork of the sfall branch developed simultaneusly with original sfall. By our forum Member "Mr.Stalin"
    it has few advantages to original sfall the best one i use is the no-knockback punch, but thre is more stuff to it like iprooved enemy AI options etc.

    _Pyran_ is also NMA forum member. The link to his archive is in his signature ( visible in any of his posts actually ) signature is revealed only after login btw.

    Nah Snce "The Man" Himself chimmied in i think I'll ask Him :D .

    I visited the whole worldmap but still haven't managed to reach Duntown; Silting; and possibly Abandoned Base (or is that MRC)?
    So how do i ge to them?

    I'm not sure You got what i was talking about.. party.txt states one base proto for Noel and three level ups so in total Noel should have 4 proto files however He's got 3 Base the ne named stage2 and the one named stage3. however it should be:
    bas one named Noel, than "Noel Stage1" than "Noel stage2" and "Noel stage3". now judging by proto ID number from party.txt i came to conclusion that it's Noel stage3 that is mising and not Noel stage1 so i renamed them and added Noel stage3. also the ones that existed so far [stage2 (should be 1) ] and [stage3 (should be 2) ] had armor threshods and resistances of leather armor imprinted into them. (i did not meant appearnce) I assume this was due to Noel actually wearing Leather armor in "SLOT X" when first visiting the map. thre's a certain engine bug asiciated with wearing armor on first map entrance that npc gets his stats reseted to 0/0% and when removing the armor npc get's negative stats equal to armor worn (although still displays as 0/0%) but this bug is only tied to his base proto on stage1 (currently called 2) stage2 (currently called 3) and stage 3 the issue does not persist. Hence why the resistance stats adjustments are only needed for base proto. Should be removed from the rest.
    Also Base proto had no armor bonus given. so this way Noel would be a guaranteed hit if he removes the armor.

    does that mean it's unfinishable now?

    as I said b4 i couldn't reach Duntown, it was not on the map, and I couldn't find anyone to give me the location if it's revealed.

    I actually talked to him first after i've found 3 robes in a footlocker and asked him about it. but i can't access the shelf it's behind a door that requires key. couldn't lockpick it couldn't destroy the door...

    Ok goodnight.
  6. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    Thanks, that's all the info i need. No problem, i will take care of this.
    Recruiting Noel can happen only after finishing the quest Jerry gives you.

    This location is not visible from the start. In Philton, Donson's assistant Eddie will give you a job to deliver the data holodisk to Leonard in Duntown so that's how you find out about it.
    No visible from the start. Jonathan, "servants" trader in Philton can give you a this quest if you choose to join his organization.
    Abandoned Base, it's MRC.

    Entering the cave was meant to be the bad ending, as always, i just added other possible solution to this quest. You can choose not to go hunting, right? :)

    Ok, you can try the solution i mentioned just above.

    Currently, this door can be damaged by explosives (dynamite and plastic) i didn't change this.

    Yellow access key which you can steal from safe in the main building, should unlock door on the left from the entrance. From there you can go deeper into the base.

    Later i added one extra level where you have to activate defense systems in order to access this level. It should be fun.

    This door opens only with the specific key found downstairs which means there is another hidden manhole in the area before ie. Outskirts. Just north before the east exit grid there's a manhole which can be activated once you talk to a local drug dealer. But before all that, quest (Find out who killed two Philton citizens) from Donson has to be active, then talk to Sebastian to get another clue for solving this quest
    Killing Matthew doesn't serve you well for this particular quest. Pulse detonator is fixed now, no more crashing hopefully.

    I changed how stealing works in LH mod, v1.083. Failed attempt to steal won't trigger hostility, inventory still remains hidden, it displays a chance (%) for success. I adjusted difficulty but steal remains one of the important skills.
  7. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    I already did his first quest regarding noel's farm as you've stated Jerry's second currently involves suicide, however Noel still doesn't talk to me

    he does not give such job he only yells at me to get the fuck out of his apartament wtf?

    i did talk to slavemaster and he doesn't have the option to join only asking for work where he scoffs at me

    Good to know

    I did refuse however sheriff Jerry went missing and I still can't talk to Noel

    Thanks although I wasted my last dynamite pack on this

    did as you've told me one pc was responsive inside so i've activated the self defense and later blew up the generator and disabled power in comuter. looted the other level. is there any way to get to that third room elevator seemes behind rocks and dinamite didn't work. Now I'm out of dynamite anyways so I can't check it and shops stopped restocking since i ceased time from passing 4months seems short as fuck to complete the task

    I assume "Later" means 1.083?

    I've got the quest active however Sebastian doesn't talk anything on this topic and drug dealer says he doesn't deal with locals although I've cleaned his stock out once matthew is alive started from an earlier save

    fine with me. although the way it is in 1.082 did not bother me either.

    Sorry it took so long to respond however the way car is implemented in game doesn't speed things up in terms of travel,and the encounters are popping like crazy.

    I've tried your approch in order to take stuff from wp patrol when they are knocked out ontop of a dead lootable critter, however they don't have the guns that way only gold.

    So I might as well try agin with my approch. last time I did this I was amost succesfull as plasma rifle guy went out of ammo and has put his gun into inventory, however in next fucking turn WP Partolman had a oopsie miss and hit me instead of a robber so they began attacking me after I've wasted the robbers, and whole work went down the drain, but chill I'm going to make it sooner or later I've got like 850 stimpacks.

    Also @Forgotten Knight
    is the encounter trader with guards sepose to have 3x Alien Blasters in it? or did you've ment to set the encounter to be "A caravan with guards"? the encounter is quite rare and most of the time it's just rippers in it, but it seemes quite off especially given how limited Small Energy Cells ammo is
    Last edited: Apr 30, 2021
  8. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    Save game might help me to find out what's causing Noel to stay silent.

    Yeah, he gets upset if disturbed. However,
    if the group responsible for plotting to kill Donson gets exposed (another quest), Eddie will be willing to talk.

    This quest requires higher town reputation.
    "Solving" Matthew's situation for Donson has a negative effect on town reputation, just a heads up. Also, solving Jonathan's quest reduces town reputation. Anyway, finishing quests for Donson and Eddie alone should be enough.

    If you mean that elevator with the red door frame, no worries, it can't be accessed.
    While at it, four months timer gets reset every time you report back to Administrator. He will spank you a bit.

    That's right, it should be interesting.

    Sebastian should give you some info about the active quest. Check if anything happens when you talk to him again and Drug dealer after that.

    Nice to hear that, which means i'm still doing a good job :)

    Car works different atm, like a shopping cart following you around. I can work on it. World map encounters is something i'm currently working on as well.

    Holy hand grenade! That's something unexpected as NCC-1701 almost crashing into a space phone booth :) I'll look into it.
    Last edited: May 1, 2021
  9. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Save attached, although you may want to adjust some settings in Sfall to be able to moove, or throw some sh!t out of the inventory. In order to moove i use InvSize=5 InvSizeLimit=2000000000 so that i'm not bugged by inventory weight and size limits

    Yeah i can't proceed with that quest either.

    Well i did most of the quests in town besies maybe 2 or 3

    I mean the only elevator(s) in UMB underground one is behind rocks and another is in a different room with a computer. the rest are actually stairs.

    About the administrator maybe it should be reprased somehow since from what I understood from what he's saying/ yelling at me is that he once gave me 4 months and that I should keep his schedule ( I actually couldn't figure out from what he's sayng that he gave me 4 moths extra time after i came back to report. ( the wording should be a bit different so that player actually realizes he get's another 4 months to do the job and not "4 monts time no more" what actually could mean that we're ought to finish our task in the original 4 months time limit.

    scr00000.jpg scr00001.jpg scr00003.jpg
    so which options should i choose?

    Yeah I've noticed..
    is there anything special about the vehicles, i mean the seller mubmles something about that bus beeing able to be retrofited with autonomus weapons systems and the highwayman with trailer but that guy in Philton despite beeing a car mechanic doesn't do sh!t only gives 2 fetch quests. Also the guy selling fuel cel controller and fuel cell regularor doesn't do jack to my car, do theese items actually serve a purpose?!

    As I said You've probably mistook 2 diffrent encounters and picked the wrong one to be placed in game..
    the trader adnd guards is a Fo2 rare random (semi special) encounter happening only few squares above modoc where you meet a trader fall asleep when he's promoting his stuff and get awoken to buy it. and you have to decide whether you buy or not.
    long story short: you've set this encounter:

    instead of any normal caravan/merchant encounter which are called "Caravan" or "Merchant and guards", which are multitude of variations with different stock (I'd recommend some books, ammo, and possibly better armors as stock).

    Attached Files:

  10. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    Yeah, you're using the full potential of inventory management :) Back to the case.
    It's actually the second quest Jerry gives you, i forgot to mention that. From your save i see you can report to Jerry after a couple of days and choose to stay behind. Wait for him to go hunting on nearby "Mountain Cave" location on the world map. When you enter the location, don't enter the cave, blow up the support beam. Don't mind Jerry, he's getting tanned :) Return to Canville.

    We can do something about this. This is a tough one.
    Talk to Sebastian, Jonathan, Samuel in any particular order but you have to be in good terms with them. After that talk to graveyard worker, positive karma is required to get the information. Report back to Donson and head over to docks to eliminate the Mad Scorpions. Back to Donson and voila.

    Administrator's response:
    Solving missing citizens quest when it's active and gain access to the underground area:
    Ask Sebastian: Two citizens were killed recently. Do you have any information that could help?
    Ask the drug dealer: Do you know who runs the business up in the town?

    They are just random car parts. Currently, vehicles only give you more space to store items.
    You can install turbocharger, adds more horsepower but travel time stays the same because of the harsh terrain.
  11. Muttie

    Muttie Still Mildly Glowing

    Oct 9, 2017
    Maybe this helps. The following are excerpts from my quick guide notes. [Note that this is mixture of 1.082, 1.083 and development, so it may include errors.]

    This is how Canville works (recruiting Noel) [Quest names are added (may be a bit off if using 1.082); scan for those and try to avoid reading anything else.]
    (Revealed by Ron (Philton) or (new) outskirts bartender (Philton). Or travel south-east from Philton, or south-west from Golden Valley.)
    • You can repair the broken valve of the water tank above the hospital (60% repair). And then tell Doc Travis about it.
    • There's billboard with a car-advert. In the building above it, you can purchase a car, requires up to $5000 (you may wait until you're ready to purchase as “window-shopping” costs $1000 each). A car does not give you a speed boost, but the trunk [aka additional inventory space] may help with transporting some of the heavier stuff like the 10 tires, 5 barrels, 10 fuel etc. To get the car following you, you need to turn on the engine with the ignition key. [Later you can purchase a turbo loader and install it, however, this is WIP and doesn't do anything atm.] [Regarding Rob's basement door: You can have some fun with it. Use hand-icon, lockpick (which doesn't work, even if sneaking), science or traps (twice, but save first). Alternatively, you can also just blow it up with dynamite. However, the end-result is always the same, combat with Rob and the town of Canville.]
    {1300}{}{Solve the brahmin problem at the ranch.}
    {1301}{}{Prevent deathclaws from overrunning the city.}
    • Before you can proceed with anything else you'll need to talk to sheriff Jerry. He'll ask you to investigate the problem at the ranch (south-east). At night you'll find a small deathclaw. Kill it. Report back and Jerry will ask you to clean out their nest before they overrun the city. You need to wait 24 hours before you can make your choice with Jerry. [This may have developed but...] In 1.082 the only solution was to say no, let Jerry go alone and then follow him to the Mountain Cave. There you'll find a dying Jerry asking you to destroy the cave entrance. Do so by using dynamite (from inventory) on the support beam. [Don't set the timer, just “use object on beam”.] In 1.083 fighting the deathclaws, and finding the survivor with dynamite, may be an option, but I can't confirm that yet...
    • Note: In the east is a restricted area with several deathclaws. If you manage to reach the ranger, you can talk to him.
    • After you took care of the deathclaw cave for sheriff Jerry, Noel (south-east ranch), can be hired as a companion. He's a bit susceptible to getting hurt [insert: in 1.083 he can now wear armour which may help...?], but can handle small guns fairly well and has the melee damage to be a force in unarmed/melee. [Note: may not work properly; WIP.]
    {1302}{}{Larry needs a replacement part to fix the ore processing machine.}
    {1303}{}{Optimize the ore processing machine.}
    • The second unlock (for solving the deathclaw problem; quest {1301}) is the quest by Larry (mine owner) to find a replacement part for his ore processor. You need to use science (50%) on the machine in the factory hall to learn what part is damaged (control unit). Then travel to Philton and approach Owen. He'll sell you the part (but it's no-good). However, as part of the purchase he mentions that the water station uses the same type of unit. You may now go there and remove it from the terminal (70% science, this will sabotage the water station) [bugged in 1.082, after removing the unit and finding the table in your inventory, open F12se and give yourself the correct item (ID 582)]. Return to Larry. If you only got Owen's part Larry will tell you that it's of no use. You may ignore him and try to fix the machine anyway (“that'll show him”). Or if you got the proper replacement part you can offer to optimize the machine yourself. Do so by using the “correct” part (from the Philton water system), or not... up to you (save first). :)
    {815}{}{Get a doctor's bag and help Aston's imprisoned man.} #Golden Valley section
    • WIP: (1.083 only) If you have solved Aston's uranium ore quest (see Golden Valley; quest {810} & Duntown section), a man will appear at the Canville entrance. Talk to him, then travel to Aston. He'll ask you to help his man in the Wasteland Forest Prison. Travel their and inspect the top right cell in the southern cell-complex [a successful repair roll with -60, can lower the cell force field]. [If you did not help Nill, you need to inspect the bottom right cell instead.] Either way, you'll find a sick man you need to treat. Originally this required a Doctor's Bag (still does), either way the item can be purchased from a doctor in Farmers Town and Canville. Upon your return, Aston hands you a H&K G11 as reward.
    • Traders: You can also gear up in Canville. The two traders offer Metal Armor, .44 Magnum, P90c, Rocket Launcher, Ripper and Power Fist.
    • Eventually, you'll trigger the end-game here. This requires to have visited most major places of the game (Miners Town, Farmers Town, Golden Valley, Philton, Canville, Duntown, UMB, MRC (bug in 1.082; each new start sets this to “unvisited” so you need to make sure to revisit the MRC after each new start) and Silting). After you've done that a pauper will appear in the tent that is in the south of the residential area. Talk to him and give him money. When you wake up you are at the Shelter (see that section).

    This is how Philton works [Quest names are added (may be a bit off if using 1.082); scan for those and try to avoid reading anything else.]
    (Revealed by (new) guardian, aka contact (Miners Town) or Leny (Canville). Or travel south from Miners Town.)
    • The gate guard (Gordon) checks for Psycho, Jet, Buffout, Mentats, Mutagen & Poison.
    {1101}{}{Find twenty empty bottles and deliver them to Mary.}
    • On Main Street is Mary's bar. She'll ask for 20 empty bottles for her whisky production. If you threw some away already, don't fret there are plenty spread around the world (must be about 35).
    {1106}{}{Collect Eric's money from Norman, the butcher.}
    {1107}{}{Pass the cage fight test.}
    {1108}{}{Return Red's payoff to Eric without any incident.}
    • In the east part of Main Street is Eric's underground bar, including fight-cage. He has three quests you need to solve in order. First: Collect money from Norman, the butcher (you need to manoeuvrer the dialogue correctly and agree to pay yourself; $2000). Secondly: win a cage fight (either against Jacob Bone-crusher, or, if lost, Eric himself). And last to collect the money from Red (this requires to do Red's letter quest first; quest {1104}). Talk to Red agree to either payment method, wait for the week he asks for, then collect the cash.
    {1102}{}{Get ten car tires for Nick, the local mechanic.}
    {1117}{}{Get a screwdriver and adjustable wrench for Nick.}
    • On the city council map is the workshop of Nick the mechanic. He'll ask you to bring him some tires (“because he suspects the next wave of customers to roll in at any moment”). There are some spread around the world, but not enough to solve this quest, so you'll have to travel to Farmers Town and ask Joe about it (and purchase his storage key for $2000). After this, Nick asks for tools, which are again found in Farmers Town. [At this point it becomes a bit of a habit to circle around the world in trips of four months duration each. “Don't forget to report to your parole officer!”]
    {1103}{}{Get 10 iron ore pieces and deliver them to Greg in Canville. Return the product to Ron.}
    • South of the old city council is old Ron who'll ask you to buy 20 iron ore and bring it to Canville for processing. Do so (purchase it from Jack at the docks in Philton (overpriced, fixed in next version), talk to Greg the smelter and have him turn the ore into five barrels (takes one or two days), which you bring back to Ron.
    {1115}{}{Get information about the slavers base in Silting for Jonathan.}
    • On the old council map is the slaver camp of Jonathan. He'll send you to Silting, but it requires a town rep of 15 (Liked), reduced to 10 (Accepted) when Basil has been busted, before he'll trust you with it. See Silting section for the quest.
    {1104}{}{Check on Jackie, the bartender, for Red.}
    • In the west are the docks and Red's bar. Talk to him and he'll send you to check up on Jackie. Her house is the first on the right when entering the City Council map. The house is empty but there is a letter on the shelf. Bring it to Red and don't get in his face.
    {1105}{}{Deliver ten fuel cans to Frank.}
    • North of the docks is the water station. Talk to Frank and agree to bring him 10 fuel to keep the water supply of Philton running. Locations of fuel are: 2 (Gang Base), 4 (Farmers Town sold by Joe, barter for car parts), 4 (Joe's storage, requires Nick's tire quest), 4 (Canville, storage, requires to break in), 1 (Greg the smelter, Canville), 2 (water station itself) and 1 (Silting, storage; but moved to Duntown, survival shelter in 1.083, I think, requires to break in). [If you sabotage the water station (see Canville section) this quest may become unsolvable.]
    • Note: you can repair the robot on the water station map.
    {1100}{}{Find out who's planning the mayor's assassination.}
    {1111}{}{Donson needs five circuit boards for his man Owen.}
    {1112}{}{Find out who killed the two Philton citizens and bring those responsible to justice.}
    {1116}{}{Investigate the defiling of graves.}
    • Donson's quests: Find the old man on Main Street, agree to help and get access to Donson. Interrogate the three suspects (Jonathan (slaver), Sebastian (old council building) and Samuel (weapon store)). After this it unlocks an option with the undertaker on the outskirts of town. This prompts you to investigate the shore at the docks. Defeat the Mad Scorpions (may need armour better than Leather Jacket), then report to Donson. Second quest: Wait a week and get tasked to collect 5 circuit-boards. Locations: 1 (Duntown, locker, reactor level 2), 1 (Matthew's shack, opened by traps skill (no disarm message) or setting off the trap), 2 (Military Base, GV), 1 (MRC), 1 (Greg the smelter, Canville), 1 (UMB, underground north, same as Bio Med Gel), 2 (Silting, storage behind trader). Do so, report back, wait a week. Third quest: The next quest is to investigate the murder. Talk to Sebastian (old city council), then the Drug Dealer on the outskirts. This unlocks the manhole on the outskirts map. Take care of the smugglers and investigate the freezer in the small cave under the smuggler tunnels. Report to Donson (bugged in 1.082, you need a save editor and adjust the gvar 540 by one more (edit: BEFORE) you killed them all, needs to be 17 in the end, but there are only 16 to kill, so kill all (edit: BUT ONE) go in save editor, and increase gvar 540 by 1, so that killing the last smuggler ends at a total of 17, then continue as normal). Fourth quest: Wait a week, and get tasked to investigate the body theft. Talk to the bartender in the outskirts bar (if still on speaking terms) and promise to help Paul. Then find the witness hiding at the docks (opposite Red's bar) and threaten him with Donson. Report to Donson [he'll give you a FN FAL (Night Sight)], and visit the graveyard (on the outskirts) at night. Stop the cultists/robbers. [Be careful, this fight can be tough.]
    {1110}{}{Deliver the data disc to Leonard to provide Philton with more power.}
    {1109}{}{Copy the GV weapon plans and deliver them to Eddie.}
    • Eddie quests: After you took care of the Mad Scorpions, Eddie will give you quests. First he'll send you to Duntown to get more power for the city. This requires various jobs in Duntown (see Duntown section; quest {1007}) and may take a while. After you've managed the task, Eddie will send you to Golden Valley to steal the weapon plans. To do this you need to buy the replicator from Hank (tent on Philton Main Street, c.$15.000). Get access to the military base (see Darren in the Golden Valley section; quest {814}). Open the locker in Dr.Fred's lab, take the plans, copy them, put the original back and return to Eddie.
    {1113}{}{Kill Eddie for Matthew.}
    {1118}{}{Solve the Matthew "situation".}
    • On the outskirts map is a rude man in the east (Matthew). He will not talk to you until your town rep is 15 (Liked). Then he'll ask you to kill Eddie. Either do so (with the poison needle), and then bury him in the grave with the wooden cross (a shovel can be stolen from the gravedigger). Alternatively, tell Donson about it and kill Matthew. This will cause combat with Matthew and hostility with the outskirts (a citizen should come running and investigate, then tell the bar about it), however, you can kill Matthew and then flee into the forest to the east. This “retreat into the night” will be sufficient to clean the hostile state (as long as you didn't damage anyone, other than Matthew, naturally, and have not been seen by anyone, other than the one citizen that saw you inside Matthew's house). [Sounds a bit complicated, but the game will set a temporary condition that has everyone attack you on sight, but leaving the map will wipe it. However, anyone triggered before wiping that temporary condition will remember you and continue attacking. In that case you can only “silence” that one, then flee the map again to reset the others.] Donson will give you a Sniper Rifle as a reward. You can then plunder the shack behind Matthew's house [the door is bugged in 1.082] where you'll find among other things a Combat Armor.
    {1114}{}{Bring some flares and ropes (5 each) to Gregory.}
    • WIP: Gregory in Red's bar needs 5 ropes and 5 flares. Organize them from Jake's Mining Emporium or from Canville.
    • WIP: On the outskirts is a hunter called Martin (currently not implemented/invisible). If you want you can go mole-rat hunting with him.
    • Gimmick: Draw your gun at Red's place and watch them freak out (no consequence). They also won't calm down until you holster :). It's just funny to me watching them screaming their heads off.
    • Town Rep (this should be correct in 1.082, I think): Mad Scorpions +12, circuit board +1, killing smugglers +(a lot), murder quest +5, stolen bodies +5, killing Matthew +5, tires +1, tools +1, barrels +1, Jackie letter +1, fuel +5, power +10, weapon plans +5.
    Last edited: Jun 2, 2021
  12. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    huh quite a detailed walkthrough.. Mind add one thing..

    Matthew can be killed quietly another way (over the course of the game i found 15 super stimpacks) simply save before killing Matthew and take a note which one of the peasants runs towards you when you kill him. Reload ans superstimp him ( 7 will do just fine) next wait 10 minutes. later on you may kill matthew provided you have sneak on, and nobody should notice :D
    at least they didn't last time i killed him.
  13. Arathos

    Arathos It Wandered In From the Wastes

    Feb 2, 2017
    Hmmm, if I might ask any estimate as to when it might get released?

    No pressure! I just wonder if I should wait a bit more before playing or maybe give it a try already and perhaps inform about any bugs (if I happen to run into any) in the meantime.

    So if the mod is only like days or 1-2 weeks away from release then maybe I should wait but if its more than that then perhaps I could give the current versions a try already.
  14. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Are your guides to mods present somwhere online? as I don't seem to find neither yours or any other for this particular mod.
    if You did put out a guide could you provide a link? this is especialy helpful for the bugged areas where one is literally forced to edit a savegame in order to progress..

    @Forgotten Knight
    First mayor quest was kind of misleading.
    there were no additional dialogue lines with Sebastian Jonathan and the Gunshop owner, although talking to them enabled dialogue option with the gravekeeper.

    I seem to have a problem getting Jonathan's quest done. he uncovered silting on the map. I went there looted and purchased to my heart's content, and stole the silting slavers account book, However Jonathan still doesn't seem to recognize that i bring him the Silting account book

    I was quite suprised when i realised that Eddie gives quests in reverse order than what You and muttie stated... I first got the quest to Golden Valey military base weapon plans theft,and Holodisk to Dunton was the second quest.

    Could You upload fixed script to Matthew shack's door? I know there's a second combat armor from what Muttie already told, yet i'm constantly crashing when trying to tackle this door. You mentioned you already fixed them, so can you please upload the fixed script?
  15. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    It can be difficult to figure out what to do here.
    Players get bits of general information about all the groups and their "relationship" with the mayor. And then, that one guy drops the bomb. Yeah, i can put a display message after the player gets a clue, better than a red arrow pointing to the quest objective.

    Of course, uploaded.

    About Philton Slavemaster quest
    You are using the old version where he only accepts a copy of the book.There's a replicator item you can use to copy this book, Hank in Philton sells it. In v1.083 both copy and the original can be used to complete the quest

    If bugged areas need fixing, i got the tools, just point at it. Sadly, my walkthrough went down with the website, few years back. I'm working on updated walkthrough as more "details" were added to the mod.

    Attached Files:

  16. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Thanks for the script. I hope I won't have to start over from the beginning for the third time...

    as for bugs:

    I'm using 1.082 but if you have anything newer upload it somwhere for the purpose of testing (if you're afraid putting it public yet then send link via PM.

    Anyways as Muttie pointed out
    that Canville machinepart quest:Philton-waterstation-part-harvesting yealds invisible item worktable instead (what i assume was sepose to be machine-part-type(A) in the inventory. Muttie says one needs to change the part in the editor.

    Mayor Dunton/Donson 3rd quest finding missing people and killing smuglers can't be turned in... killed all 16 of them and the guy on the surface near the shack went down and ffound the MiA/KiA people in the fridge with rats around tried to fiddle with GVAR 540 as muttie suggested change from 16 to 17 but it didn't do sh!t, can't turn it in either way


    hint request
    in Dunton. Are they reparable or are they just for lulz and player wet dreams? if they are to be fixed what do i need. Science skill use says variour parts are missing and highly doubtfull it can be fixed (Science&Repair 300% each)
    Last edited: May 9, 2021
  17. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    I'm currently sorting out files to reduce the archive size to something normal, closer to what 1.082 used to be, not couple of hundreds of megs yikes! ... with all the goodies of course :)

    I fixed this in november 2019 but after 1.082 was released, this will work correctly in 1.083. I can check your savegame file if you want.

    Armor parts...
    Currently there's no Power armor, it would be op as hell. It's all about special weapons and tactics.

    I will update my answers, writing this in a hurry... [to be continued...]
  18. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    It's 2021 so hundred megabytes more or hundred megabytes less doesn't make that *huge* of a differenc right? I mean come on 90% of the world is on an optic fiber connection right no, so unless one uses some sort of mobile internet or perhaps satellite intenet, one is not going to be charged extra for data transmission. So i don't think it's all that nessecary, unless ofcourse You're like Killap who wanted to have a full experience without any additional downloads, for people living under a rock, with no internet access.

    I'll check if Muttie's tips work for that one first. If they don't, I'm gonna take your offer into consideration.

    No problemo, I actually think the same. although I've noticed the PA parts laying on the table and was thinking what was the intention for them.. are those parts fixable and PA obtainable or was it just a funny joke, mocking at all those weaksauce pussie players running around with sniper rifle and getting owned by bandits, saying prayers and counting there's actually a PA ingame.

    Actually this low tech setting suits me just fine.
    Actually for me you could also consider blocking theft from mysterious stranger, as this puts the game out of balance too much imho. the amount of ammo one can get from mysterious stranger is enormus. especially that he/she can spawn even when clicking on the stopped icon anywhere in the wasteland. unlimited amounts of time. this provides unlimited amouts of stimpacks and various ammo depending on player level (provided one takes mysterious stranger perk).

    as for the stunts I managed to pull off:
    One encounter WP Patrol fighting (some) robbers, which spawns with 3 tents and a car-wagoon, spawns two unarmed fighters next to WP plasma rifle man. one time they knocked him out in first turn, so i ran in and stole his stuff while he was unconcius (including the plasma rifle), it didn't matter however as the robbers managd to finish him off while he was still uconcious. When hard hitter was out of the way i managed to stim-up to full few of the robbers that were constantly attacked by the rest of WP patrol, until the patrolmen went out of ammo, and after a reload try, put their weapons into backpack. After that I finished off the robbers, and stole the empty weapons from WP patrolmens's backpacks. 1 sniper rifle,1 laser pistol,1 mageto laser pistol,1 plasma pistol (which a "Military Base in GV" bug stole from me), and 1 Plasma Rifle.

    the bugs:
    1. entering Military Base with any amount Plasma Pistols you have to leave all of them inside the base or you'll be ransacked by the gate guard and your security pass revoked( despite the fact that original Plasma Pistol [ the one originally in the base was left by me in the base together with those weapon plans]) it goes for any extra plasma pistol player might have. although i haven't tried givig them to Noel yet, it does seem to work for the drug inspection in Philton XD
    2. Had this bug in couple of other Fo2 engine games. So i guess it's sfall's fault (or maybe some mod like the inventory filter mod) after extended periods of play when dropping weapon from weapon slot into inventory the weapon suddenly dissapears (doesn't show up in inventory) and is gone forever afterwards. the only cure is to load a previous savegame, I didn't as the progress from last savegame was a bit too big, that's how i lost my Laser Rifle from Silting.

    Anyways I'm sorry I haven't responded faster but this sunday I had sort of family-reunion-grill-meeting and it took whole damn day, so I haven't managed to get to my pc to answer.

    Anyways I'll wait for the update
  19. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    Longer than weeks. Most of the errors from 1.082 were taken care of some time ago and visually there are lots of small map changes. So version 1.082 is, to put it mildly, Obsolete :)

    The devil is in the details :)

    Interesting, i can look into it.

    1. I can work out something, just to make sure that particular weapon doesn't get stolen. Quick workaround would be to use Noel. I can put a check on Noel's inventory as well but JK, it's an overkill :) I want to stay consistent with the original (Vault city's gate check for example).
    2. (un)Lucky me, my weapons mostly critically exploded and nothing much else. My engine purrs like a kitten.

    This works ok with 1.083, i can check savegame as well and take out two flies with one strike.
  20. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    @Forgotten Knight
    1.Matthew's shack has a desk that can't be looted, because there's a chair blocking access to it
    2.Canville on the map with Greg the smelter there's a guard in one of the buildings (covered by a wall actually so it's easy to miss him). this guard gas literally 99999 stimpacks and lots of other stuff in large amounts in his steal inventory. That's a bit of an overkill.

    3. can I get a rundown on Duntown's quests? I went there did some of them, but i stumbled on a green shirt guy quest when i finish talking to him he runs off to level2 of the reactor. When i enter level 2 he runs towards a locked door, opens it, turns a valve and explodes, i tried to shut the valve but guards attack me.. any way to proceed with this quest? ( i loaded an earlier save, and kept playig fom there, cause i think i've messed up)
    Last edited: May 12, 2021