Fallout 2 mod Last Hope mod v1.083

Discussion in 'Fallout General Modding' started by Forgotten Knight, Apr 30, 2021.

  1. gustarballs1983

    gustarballs1983 Vault Senior Citizen
    Modder

    Oct 28, 2009
    Well have You managed to pinpoint the bug that is preventing majority of the players from finishing the game?
    Some of us are having hard time to spawn the pesant in that tent Canvile. no problems with unvisited towns though worldmap doesn't show anything wrong. judging by .msg files most quests have been done except
    Garol's letter to his family, hunt molerats, find ropes and flares, and kill eddie for matthew,
    as explained somwhere in a post above.

    played 1.082 *and* 1.082.2 whatever this second version is. in 1.082.2 i also couldn't spawn Aston's man in canville that triggers the beginning of final quest for Aston. However despite visiting every damn location from the spoiler list and doing like 95% of the quests still no freaking luck in spawning that pesant... I still have no idea what do es @Muttie mean by certain locations becoming unvisited.. i haven't encountered that. besides:
    i couldn't repair the ventilation system. Could only bio sensors, no idea where to repair ventilation. Besides fixing network uplink with nav com parts and activating the defense systems doesn't enable lvl 5 access, despite You saying so. Strange since in both 1.082 and 1.082.2 , level 5 seemes to be noted in the computer's .msg files. Anyways wasting the turrents doesnt do anything and i still can't access lvl5. Was MRC sepose to be something special or just a small map with couple of rats and items, and no quests?

    And finally:
    what's the deal with Player_mutate= and mutate_when= gvars? it grows only when visiting UMB and after applying that mutagen hypo from MRC, is the player seposedly turn into some kind of mutant?
    .

    Also:
    It would be neat if player could rebuild the power armor from those parts but for example by totally fucking up key quests (by not doing them to save parts for PA) that would mess up the ending slides like the PA would require those electric motors a screwdriver, pliers and some kind of nut/bolt keys plus possibly the PA could be a requested item by a those escaped convicts for an alternative ending, or perhaps it would be them who would give you the PA schematics nessecary to rebuild the armor
    .
    Even without PA this game rocks. Those 2/3 combat armors I've found are neat too..

    It would be cool tho to be able to finish this game, and quit having the weird feeling, that this game is an endless fly trap for fallout gamers, without a way to complete the game...
     
    Last edited: Aug 30, 2021
  2. Muttie

    Muttie Still Mildly Glowing

    227
    Oct 9, 2017
    If this is Brian and the waste issue, it's known and fixed. Otherwise I know nothing, except Laura who is not implemented. But that's fine.

    The plasma pistol “theft” did remove 1 & 2. Garol was bugged by sheriff [insert name when brain is back] XP bug, which is fixed.

    Need to look into 1. Gregory (flare & rope) was not implemented in 1.082, is now. Hunting was not implemented, still isn't (to my knowledge). Garol was bugged, see above, fixed.

    Yep, that should be all fixed, and then some... ;)

    As far as I know there is no bug with the peasant. And I also have no idea how that could bug out. Other than the MRC status resetting. I did spawn it in 1.082. Only had to visit the MRC once more, then travelled to Canville... no idea...
    Anyway, the method of spawning him may adjust in the next version as it was not very intuitive.

    Aston's man was bugged in 1.082. Fixed in next version.

    There is no ventilation system to repair in the MRC (as far as I know), [Duntown had one] and lvl 5 is part of the upcoming version, not part of 1.082.

    I would be strongly against fixing the Power Armour, as the mod is balanced around lower tier 1 weapons (combat armour & sniper rifle are end-tier). PA would disturb that game balance. My guess is that the PA is only there to represent lost technology.
     
  3. gustarballs1983

    gustarballs1983 Vault Senior Citizen
    Modder

    Oct 28, 2009
    Since My last post here I PM'ed with Forgotten Knight, a bit and managed to finish the game, The peasant was bugged, since Knight had to update two scritps in order for the pesant to appear.

    Good to know about the rest.

    As for PA, I don't mind, it's the way it is, however player could be teased a bit more with PA, I actually thought about Requiring to repair the PA in order to give it to a npc to proceed with MQ, can you imagine how PITA it would be to run around all the errands to fix it, and then one would have to let go of it anyways :D, well unless one would cheat, and multiply the armor, but cheaters have it easy anyways xD.

    One way or another I managed to beat the game, Unfortuneatly not without F12se,as the bugs in 1.082.2 still prevent the game from finishing, upated scripts are also a must..

    Hope the new version hits soon..

    Oh well.. Back to curing my atumn depression..
     
  4. Lorddervish212

    Lorddervish212 First time out of the vault

    6
    Jul 26, 2018
    It's already november, when is the next update coming out?
     
  5. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    116
    May 24, 2006
    I made these, on the fly, changes just to avoid frustration or being vatted :) Testing and fixing "unofficial" mod files from other sources is challenging so i made adjustments that worked just for this peculiar case. Still, feedback is always appreciated and without it i would think we're still living in the Matrix... time for my red pill...

    Dangerously close :) Plenty of "back to the drawing board" moments but managed to make a fair amount of small changes, nothing fancy. There's just some testing left to do, last minute check before [input missing-date field]
     
    • [Rad] [Rad] x 2
  6. Muttie

    Muttie Still Mildly Glowing

    227
    Oct 9, 2017
    Funny note: I asked Forgotten Knight if I could do some proofreading in the spring of 2019, and back then I thought it would take about 3 months tops... it's almost 3 years now. ;)
    But it is wrapping up, nothing big left, as far as I know. At least for this version.
    P.S.
    If interested these:
    GVAR_MUTATE :=0; // (132)
    GVAR_MUTATE_WHEN :=0; // (133)
    GVAR_HAVE_MUTATED :=0; // (192)
    GVAR_MUTATE_STAGE :=0; // (193)
    are vanilla Fo2, not LH. Seem to be connected to radiation, maybe the toe, or something else, probably WIP that never got finished like GVAR_DUDE_STOMACH :=0; // (104)... neither should be part of LH, checked the scripts.

    Edit: I did check again, and all four GVARs are for the mutated toe (triggered by KtGoo) and that script is used in LH (Lost City, I think), however, it is not possible to grow a toe, as the second part (192 & 193) is not set in the obj_dude of LH. So there is build up on GVAR 132, and it should start a timer (133) but it goes nowhere.
     
    Last edited: Nov 14, 2021
  7. gustarballs1983

    gustarballs1983 Vault Senior Citizen
    Modder

    Oct 28, 2009
    good to know...

    Anyways I did Full video playthrough of the 1.082.2 LH mod dissected into smaller clips ( haven't edited it yet for publcation, as there is no interest in it, even @QuantumApprentice haven't replied to my PMs, and He was about the only one doing YT content on that mod. Perhaps things will change when 1.083 comes out.
     
    • [Rad] [Rad] x 1
  8. Zorchar

    Zorchar Look, Ma! Two Heads!

    324
    Jun 18, 2018
    There's at least *some* interest ;)
     
  9. gustarballs1983

    gustarballs1983 Vault Senior Citizen
    Modder

    Oct 28, 2009
    So You say You're interested in reciving/downloading +/- 25GB of unedited video conttent on this mod?
    Unfortuneatly i don't have enaugh spare time to cut&edit the files into proper YT videos, besides it's not a legit playthrough, currently it's not even possible to run without save editor due to bugs, however i took some modding liberty on the mod so the gameplay is rather smooth, but it definetly ain't legit.

    You're still interested in that?
    If so please say where to upload the videos..
     
  10. Zorchar

    Zorchar Look, Ma! Two Heads!

    324
    Jun 18, 2018
    I was more interested in the edited version, honestly. Thought it could be entertaining, with the way you comment here on NMA and all.
     
  11. _Pyran_

    _Pyran_ Mildly Dipped

    503
    Jan 31, 2017
    What exactly has been done that the passage is considered "illegitimate"?
    Many people are interested in the walkthrough. Because they can't get past the main task.
    Question 1: the main quest is possible to complete? If the answer is yes, I'm interested, too.
    Question 2: The Cave with the Death Claws in Kenville. How to complete this quest?

    However, if there are many changes in the new version, the previous walkthrough will not be as relevant.
     
    Last edited: Nov 16, 2021
  12. Muttie

    Muttie Still Mildly Glowing

    227
    Oct 9, 2017
    Question 1: Yes, I did it naturally (without any modding, save editing etc. just playing), but there are some issues, and some I don't understand (still, no idea what caused the issues that gustarballs had).
    This is the spoiler I put somewhere in this threat (reworked) and it worked for me:
    Eventually, you'll trigger the end-game in Canville. This requires the {207} quest (Miners Town) and to have visited most major places of the game (Miners Town, Farmers Town, Golden Valley, Philton, Canville, Duntown, UMB, MRC (bug in 1.082; each new start sets this to “unvisited” so you need to make sure to revisit the MRC after each new start [& load, I think]) and Silting). After you've done that a pauper will appear in the tent that is in the south of the residential area [of Canville]. Talk to him and give him money. When you wake up you are at the Shelter (see that section).
    So I visited most places, reset the MRC (i.e. visited it again) then went straight to Canville. Worked for me.
    Question 2: By not going with the sheriff, let him go alone, then follow him after he is gone.

    But as far as I know, a 1.082 walkthrough won't be as relevant anymore. Both these points should be changed in 1.083.
     
    Last edited: Nov 17, 2021
    • [Rad] [Rad] x 1
  13. gustarballs1983

    gustarballs1983 Vault Senior Citizen
    Modder

    Oct 28, 2009
    WTH?! One ,virtually unknown, Russian quotes one of my more Cringy posts in Fo:Yesterday thread, touching upon my PoV on Fallout Games in general, within a video rewiev on Olympus2207.. and suddenly i became a local celebrity?!

    otherwise what's the deal about:

    in general besides the mods like stealcheat.int and fo2tweaks, i fuckfisted certain sfall functions abusing them to the max, mainly carry weight, item size, burst calculations, Fast shot fix ( which is changed once or twice during the playthrough, since with a decked out character it is extremely hard to do a certain scripted ring fight scene without killing the opponent ( which yealds bad quest ending) literally the oponent dies wthin 2 shots on a decked out melee char, and the key is to try on a lucky low damage roll twice in a row on a targeted attack to one of the legs, if succesfull the oponent ends the fight with like 1 or 2 hp and gives up.
    Additionally i did a custom hex edited character file which i loaded at the start of my playthrough 10 all stats 300% in all skills except steal ( to farm xp from stealing early on). than i test the steal on an early npc that des not have a initial steal check, and load a decked out char with all perks taken ( with nirran's modified RapidPerks HereAndNowPerks) and on lvl 24.
    I generally stock up on mysterious stranger *a lot* by knocking him out and robbing him. ( the only way to peacfully aquire decent gun for the only party npc ingame).

    the game is beeing intrupted and paused whenever something disturbed the Recording Me causing Me to return to real life ( no mic used so it's only a pause issue) but it happens a lot. any of the repeated attemtps at stuff are not edited out, and due to the fact that My PC is a potato it is unlikely that I'll have a enaugh time to edit all of the videos anytime soon ( the cut and merge edits to large videos take significant amounts of time and I just don't have that).

    ad#1 what @Muttie said is on the topic of 1.082 however pure 1.082 is nowwhere to be found anymore. _Pyran_'s archive has the modified 1.082.2 which has a more recent sfall and an exteded forked version at that, so it behaves a lot different than 1.082. namely the MRC and Canville locations don't get grayed out, and i haven't foud the way to complete without applying a patch from Forgotten Knight that he made specifically for me. If He agrees I'll upload the fixed files plus some of my fixes to the game as well.
    It causes the game to always spawn a certain npc at certain place without any prerequisities, so it's possible to trigger endgame in any given point ( which isn't optimal for some players) although i did all of the quests, some of the sidequests like @Muttie mentiones in this thread require to edit the savegame with a save editor, because due to bugs they're unable to be finished. (I've counted two of theese) and I don't specifically mark the moment where i edited the save file just exited the game, paused the recording, and resumed recording when the edit was done ( wouldn't matter anyways as the screen in the desktop is black anyways, beats me why).

    ad#2 As @Muttie stated in his post. I'll just elaborate more on that:
    You're sepose to *deny* Your part in the deathclaw hunt in 1.082. and it is glithy as fuck. first off before you talk to jerry on a second quest make sure it's past 8:00AM but not too late. if you pick a wrong time the game won't acknowledge the waiting time you're sepose to take for Jerry's team to gather up, the conversation will end and nithing will happen. your best bet is to wait till 8:10AM and wait a several seconds idly and talk to Jerry say you don't agree, jerry will mumble something about waiting till tommorow. this is important don't wait 4x 6hrs just wait till 8:00 AM and attempt to speak with Jerry if it doesn't trigger wait to 8:10AM and quickly talk to jerry. this is glitched that if you don't wait several seconds on the day before, jerry will actually be gone, it must be almost 24hrs spent not exactly 24hrs and definetly *not more* than 24hrs. if this is done correctly jerry will say he and his team are ready to go. You say that You'll wait here. after that jerry leavees the map to north west. Don't go there. instead exit the town to world map. and go to a new area "Small Cave" or something like that. and talk to Jerry when conversation is over, approch the cave entrance beam support ( don't enter the cave) and save the game. next this is very important *load* that last savegame. I don't know why but if i start from a savegame from beyond this map the game crashes to desktop (glitchy as fuck aint it) so after You have loaded that save I told you to make, apply a dynamite to the support beam. (don't worry if you didn't had any when You arrived. Jerry gives you one. After that the quest is done, and there is a party NPC in town waiting to be recruited. I think the dialogue to recruit him is pretty cheap excuse to just have a mule to follow you around, (there's little of sense in it but who cares right?). anyways that'it

    Before You recruit the new party npc know that 1.082 and 1.082.2 have a bug that i fixed personally as the party npc is muissng his last stage proto which I created and added to critter'lst plus modified some proto stats so it doesn't have bizzare super op resistances and thresholds. the best armor You get is probably still enaugh for him to survive most encounters. at least I didn't had any problems with keeping him alive(but i cheated so...).
    One note tho. just like Fo1 vanilla party npcs he doesn't have the "push" option, so take that in mind while he follows you around. I mean it's hard for one npc to corner you but it *can* happen, in certain places, and then it's just the savegame reload.
     
    Last edited: Nov 17, 2021
    • [Rad] [Rad] x 1
  14. _Pyran_

    _Pyran_ Mildly Dipped

    503
    Jan 31, 2017
    There are a minimum of changes in my version (the main ones are: added video (intro), added exit from the cave in Kenville, added additional animations (tribal with knife) - that's all. No fixes were applied to the locations or etc).

    #ad2 - In the cave, in addition to Death Claws, there is a person... who is it?
     
  15. Zorchar

    Zorchar Look, Ma! Two Heads!

    324
    Jun 18, 2018
    Which video and quote? I'm curious.

    I misread. I thought you wanted to make a playthrough with commentary, QuantumApprentice style. This could have been entertaining, IMO.
     
  16. gustarballs1983

    gustarballs1983 Vault Senior Citizen
    Modder

    Oct 28, 2009
    It's some random dude that got trapped there, and freaks out. You can scavenge dynamite from him if you talk to him and grab it, he'll attack. But in 1.082 going into that cave is a trap set by the developer. There is sepose to be no way out. Your let's call it "so called solution" to the situation, only glitches the game further, when you return to Canville. The only way to proceed is the way I described. And yes I know this from the LH developer himself.



    Some Warlock(something) can't remember now. He did the first video review of Olympus2207. He even wasn't aware that KeyboardGecko was just finishing translation at that time.. KeyboardGecko said, that He almost shitted himself out of beeing so pissed off, after seeing the review. Anyways this Warlock(something) guy has been chewed and swallowed by the Russian machine, and now works in the Russian modder's team on discord, helping out with Olympus and Sonora english versions.( I guess propaganda folks taught him a "harsh" lesson not to crap on the efforts of his fellow countrymen). The post mentioned, was my ubercringe roar on the state of the gaming industry, that developers make dumbed down games, because majority of players are stupid.. TL:DR I said games are made stupid because soyboys ( the main gamer audience nowadays) are stupid. That triggered him, although I agree with the guy that Olympus2207 is not throughly thought out game, at least plot wise. and I wouldn't recommend classic Fallout player to play Olympus2207. It is not a fallout game only a thing of it's own on Fallout2 engine. it's like Fallout TC of another game like Neverwinternights or was it aniother game that was floating around the download section like 15 years ago. I remember that mod made me insta quit when i failed to pickpocket a shop owner and shop owner began casting faggy violet balls at me (spells), this has no place in Fo themed game, i thought, and quit playing it.

    Olympus2207 was probably made as a freeware demo on Fo2 engine to attract as much Fallout fanbase to buy Olympus2249 or however it's called, when it comes out.

    I mean who the fuck would play post apo turnbased game if not classic fallout fans? Definetly not soy eating agile monkeys with both 'attention span', and 'reading with understanding' problems. they tend to stick to FPS genere, as that is much less complex for them.
     
  17. Muttie

    Muttie Still Mildly Glowing

    227
    Oct 9, 2017
    WIP, I think. I do know that FK changed something about the cave, and I saw a script which I'm pretty sure is an exit-script for the cave, however, I wasn't part of that so I don't know how it's going to work. Maybe that dude is going to be part of it, maybe not.

    Also here is a pic of the MRC issue.
    I did load a save that is on the MRC, left to worldmap and it looked like this:
    upload_2021-11-19_3-10-45.jpeg
    I'm on the square and it is set to dark, which makes no sense (reset bug). Do note: In order to get the MRC to “visited” it is not enough to just walk now, I do need to enter and leave the MRC again. Did that, travelled to Canville and there's the corpus delicti:
    upload_2021-11-19_3-11-14.jpeg
    Technical: to fix this it would require a change to obj_dude, which is unlikely, even in 1.082.2, and Pyran didn't mention changing that. Maybe the sfall version “prevents” obj_dude resetting it, but that seems unlikely, too.

    Anyway, all this is going to be academic in 1.083 anyway.

    @gustarballs1983 you need to be a bit careful when calling LH glitchy af, you do like to use save edit and change stuff which all very well may cause corruption.
    [This is a real thing btw: For example, assigning addictions as “perks” instead of “gvars” (as is possible with F12se) will create a frm mess. Assign an item to an empty inventory and the game is likely to crash. Add too many items (which I once did during testing) and it crashed eventually (and surprisingly). And so on and so forth. F12se is great, but I only use it for testing, and rarely, if ever, do I continue playing with edited saves. I usually consider those test-saves tempered with & corrupted. And it can get extremely bizarre if messing too much. During one weird experimentation phase (messing with scripts to test [deducted]) I actually did bug out the Canville pauper and he wouldn't turn visible anymore. Another time I completely bugged the difficulty settings. Another time adding/removing Gifted resulted in a total mess. Those are consequences of messing, but I'm not blaming LH for it. Nor did I call for sfall support. Not after the amount of banging about I did.] [There were only two exceptions were I used F12se to get around bugs of 1.082 (as I posted here), but those were “fairly” save to make. And those were the only game-breaking bugs of 1.082, btw. Anything else just needed optimization.]
    So far everything you describe is something I have not experienced in my "normal" play-through. I don't know why or what happened (could be any number of reasons) but it very well may be at your end (too much tempering) and not LH's fault. That is a possibility.
    Also there had been no other reports of this as I know, only people who couldn't figure out “how to do it” but after being told, those people did not return saying it doesn't work. At least I haven't seen that yet.
    Anyway,
    You can't mess around that much and then call it glitchy. Of course, it's glitchy.
     
  18. _Pyran_

    _Pyran_ Mildly Dipped

    503
    Jan 31, 2017
    Nope. In v1.082.2, the locations and scripts did not change (except for the exit from the cave in Kenville).
     
  19. gustarballs1983

    gustarballs1983 Vault Senior Citizen
    Modder

    Oct 28, 2009
    F12se was only used to edit GVARS and edit in nessecary items in broken quests two or three edits in total. it does have signifcant change on dude himself since after initlai edit his naked appearance changes to jumpsuit, instead of hero-tribal.

    As for beeing glitchy as fuck I only ment sherriff Jerry's second quest (in canville) not the whole LH, if it did sound like that, than it's probably missing a coma or a period somwhere, as I am terrible at both grammar & spelling. I sincerely apologize if, my previous message was understood like the whole LH is seposedly bad or something, it wasn't my intention... No on the contrary I think it's a great game, and only a second to one other that starts out in a prison ( the masterpiece would be to start out as a slave in a slaver's Guild slaver camp, near a deathmatch ring or something). Anyways as I said to the 'Knight man' himslef I really had a blast playing trough the mod, although
    It could have some ending slides at the end...
    plus some bugs need to bee ironed out.

    Also I don't know about sfall fixing dude_obj, however while running v4.3.0.2, no city went shaded after reloading the game, and visiting them, going back and forth, to every city didn't change nothing, there was absolutely zero chance at spawning the pesant, Knight had to modify some scripts for me in order for the pesant to be there ( now, after applying the patch the pesant is always there. no matter what, from the moment i enter canville for the first time).

    as i said in my previous post, it creates glitches. since when you return to Canville after visit in the cave, the whole screen beginns to blink black,at first very slowly, but then faster and faster until a crash occurs. So I suggest until 1.083 let's stick to the official way of solving this quest, that is by denying sherriff Jerry, Your help in asisting to eliminate the deathclaws nest, and later going near the cave and collapse the entrance, sealing the bastard lizards in.

    For the time Beeing I can upload all the fixes I got from @Forgotten Knight if He says it's ok to do so, at least until new version comes out. plus a small proto fix to the party npc ( which You still haven't aquired since you struggle with the cave quest, and that is the last obsticale before beeing able to aquire him).
     
    Last edited: Nov 20, 2021
  20. Muttie

    Muttie Still Mildly Glowing

    227
    Oct 9, 2017
    Another thing to keep in mind is that any changes to maps or files like city.txt do require a new game. Trying to use old saves, after those been changed, will fail to work or create a mess.
    For example, there were changes to the very end-game maps & locations, and I wanted to test them, but had absolutely no time to play through the entire mod again, so I tried to shoehorn my 1.082 saves into 1.083. I did find some “real” bugs, but it also created a complete mess, with failing elevators, locations appearing where they shouldn't and so on. Was ugly.
    I wasn't that savvy back then, so I reported them (with a note that I used 1.082 saves), and FK ignored it all , which was correct as none of those were bugs but just issues of using saves with a version they were not compatible with.

    Anyway, it's not easy to pinpoint some bugs. I did though you had corrupted saves, but after you've re-phrased the Canville crash, I think, I recognize that one now.
    This does sound like the “Jerry fade”. His script had a certain condition that would start a fade, and there was nothing stopping it, so it kept going. That took a while to find actually... as it had a very specific trigger (those are the hardest to pinpoint). Fixed in 1.083 (tested). If this happens in 1.082, just exit the map (or load a previous save; if you don't want Jerry to be gone) and return at a different time. Anything between 6.00 & 18.00 is fine. It's odd like that. Also, letting Jerry go alone will cancel this.

    Btw, the Jerry thing is not glitchy, just a bit odd in the way it uses time. I looked into it (script) and here it is:
    {1300}{}{Solve the brahmin problem at the ranch.}
    {1301}{}{Prevent deathclaws from overrunning the city.}
    • Before you can proceed with anything else you'll need to talk to sheriff Jerry. He'll ask you to investigate the problem at the ranch (south-east). At night (18.00+) you'll find a small deathclaw. Kill it. Report back (200 XP), then ask for another job. Jerry will tell you that the city decided to clean out the nest before the deathclaws overrun the city. You'll get to make a choice of either joining the hunt or postponing the decision (only the latter will give you a choice later on). You then need to wait 24 hours or more. [Note: If you choose to join the hunt, then Jerry will wait until you're ready, if you postponed the choice then Jerry can disappear if you enter the map during the night (18.00 to 6.00) after 24 hours have passed (quest becomes unsolvable), if you avoid this, then Jerry can be made to wait indefinitely, in either case you must approach Jerry during the day, i.e. after 6.00 & before 18.00, else he won't talk.] After this preparation time you either go with Jerry (if you previously agreed; this was a death-trap in 1.082 but may have developed in 1.083...), or (if you postponed it) you'll get to make a decision of going with Jerry or not. In 1.082 the only solution was to say no, let Jerry go alone and then follow him to the Mountain Cave. There you'll find a dying Jerry asking you to destroy the cave entrance with dynamite he'll hand you. Do so by using the dynamite (from inventory) on the support beam. [Don't set the timer, just “use object on beam”.] Note: In 1.083, joining the hunt, fighting the deathclaws, and finding the survivor fiddling with dynamite, may be an option now (i.e. the lair can be left through a hole in the north), but I can't confirm... [either way this “hunt” is always a disaster and ends with Jerry dying; which I believe is as intended. Only change in 1.083 is that the player can become the sole survivor, I think.]
    I think this is correct now... My guess is, that the thing you got stuck/confused on is that Jerry has “business” hours (6.00 to 18.00). Other than that it should just be a 24 hours timer. Well, plus some oddities, like the dialogue folds when choosing to join and talking to Jerry at night. Could be optimized.

    Also Noel has a push option now (just checked), that got added some time ago. I think Noel is fixed...
    Actually, I think we fixed everything that has been posted in the forums over the past three years... :crazy:

    Otherwise, I'm not offended just a bit worried. I think, LH is somewhat reliant on good will. If building up too much negativity, it will become negative. Which is fine, but if you want to support LH, you need to balance it out. I also don't know how buggy 1.083 is going to be. A lot has been fixed, but there is also a lot of new stuff which may have introduced new bugs. Idk. I remember when people rated this mod 1 star, which was just stupid. I think it's a 3 out of 5 stars mod, some elements are 3+, possibly even 4 (the mayor cities are among them, I think), some are 3-, possibly even a 2. However, being “middle of the road” means you can pick your side. To me, LH is a finished total conversion mod of the size of Fo1 (17 locations) and that alone makes it all worth it, as there aren't many like that. But, I think, it also had to take a few short-cuts to get there. Alternative quest solutions are usually missing (although we added an alternative to every quest that required stealing). Contingency can be an issue, too (as long as you stay on the correct path, it all works, but if you do something the mod doesn't expect, it can't always handle it that well*). Anyway, I think the past three years made an improvement, but then it also feels that after three years there shouldn't be that many glitches anymore [although “three years” is deceptive as it had frequent downtime periods of 3 months. Not even sure what the actual total would be. Especially 2020 was slow. 2019 was good, while 2021 was OK, too, as I started scripting in the winter of 2020, which I think helped a little (i.e. rather than just randomly pointing at something, I could make actual suggestion based on facts). In general, 2021 was the development year, I'd say (added the Canville pauper redesign, worldmap overhaul, travlling trader, Gregory quest, Golden Valley arsenal development, two more main-story links hat help with progression and more. Plus, the stuff that FK did without me (maps, new systems, Canville cave). Also a lot of fundamental fixes, like map.msg, endeath and pro_item.msg got cleaned up over those years, things like that. I think LH has seen a lot of change, but then there is also a very long list of stuff that isn't optimized yet and stuff that could be done... there's easily two more years in it. But both FK and I want to come to a close, I think.]

    *I just spend the weekend going over the initial trial fight. FK told me “no more big fixes” but the bugs I ran into were bad, I mean really bad, (like getting stuck in an UI-disable, had to window-key out of there) and other. The good news is that I found a fix for all them. The bad news is, that it means more delay for 1.083 as FK will need to implement those fixes (not that difficult, though, but it took me 2 days of testing, scripting and writing it down in comprehensible English, the last always being a bit of a challenge). Then there is always follow up to it.
    Anyway, I also found the reason why the initial dialogue before the unarmed/melee phase was inconsistent. That was also on the back of my mind for the past three years. Finally, found it.

    It's getting better, but it still has issues. Wish it hadn't. It's OK, I guess.

    Anyway, I'll probably go afk again (if anyone is wondering), as I can't do both, it's too much. Also when I keep looking into stuff, like Jerry, I'll never finish.