Problems playing Fallout 2

Discussion in 'General Fallout Discussion' started by vlad98, Nov 27, 2015.

Thread Status:
Not open for further replies.
  1. vlad98

    vlad98 First time out of the vault

    4
    Nov 27, 2015
    Hey guys, i need a little help playing Fallout 2. I purchased it with its prequel a month ago on steam and Fallout was working just fine.
    Now I want to play Fallout 2, but at first after some playtime the game always crashed when I tried to enter the upper left area in Klamath (Sry if It's called diffrent in english, I just know the german name).
    After a bit googleing I found some mod called "Restoration Project" and after installing I was able to enter the place, but some of the conversation and quest texts turned just into "Error".
    After following some other guides with lots of diffrent mods and patches everything I got is
    "Error initilizing Video Mode 640x480" when starting the game.
    So I just don't know what to do anymore, after that great first ga
    me I really want to play it. Maybe the problem is that I use Win 10.
    If someone can help me with this it w
    ould be just wonderful.

     
  2. Gizmojunk

    Gizmojunk Carbon Dated and Proud

    Nov 26, 2007
    I don't have an answer for you. There are many here with first hand experience with the mods and common issues; likely even the makers of the mods themselves.

    But expect problems using Win10. Fallout was designed for Windows 95, and works at all with future versions by fortuitous chance decision during its development.
    I'm not even sure if most modern graphics cards can actually provide 640x480 sVGA resolution anymore.

    It might be possible to manually change the resolution to 800x600 or better in the mod's config files.

    Does Windows 10 have a compatibility layer for Win7 (or earlier)? If it does, then that might be an option ~if it's not a graphics card issue.
     
    Last edited: Nov 27, 2015
  3. Severite

    Severite First time out of the vault

    78
    Dec 19, 2008
    If you installed restoration project, and then played the same save, yeah, it will be borked. Try a new game ifnyou have not already
     
  4. TheRippaMan

    TheRippaMan First time out of the vault

    62
    Nov 4, 2015
    Backup your saves, and reinstall the game. Mine crashes a lot too, but that might help. Also, don't tick the box on 640x480 in backwards compatibility settings.
     
  5. vlad98

    vlad98 First time out of the vault

    4
    Nov 27, 2015
    I had to, to old save files were corruptet.
     
  6. vlad98

    vlad98 First time out of the vault

    4
    Nov 27, 2015
    I tried the compatibility mode if you mean that, don't works anyways. My graphics card is the NVIDIA GeForce GTX 960. It would be very depressing if I can't play this game cause of too new stuff. Now I'll try to change the resolution somehow.
     
  7. GlowHound

    GlowHound Look, Ma! Two Heads!

    311
    Jun 12, 2008
    If you click Options from the main menu, you can configure things related to the High Res Patch in Screen Settings, including resolution.
     
  8. vlad98

    vlad98 First time out of the vault

    4
    Nov 27, 2015
    I did it, oh my god it finally works! The only thing I needed was the Bloodpatch, nothing else. No crashes or Error bugs anymore :D
    Thanks everybody for help, i'll close this thread now
     
Thread Status:
Not open for further replies.