Fallout 2 mod Megamod version 2.46 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Jun 25, 2014.

  1. Oggrr

    Oggrr First time out of the vault

    Dec 10, 2016
    So having some problems with the BoS bunker, looked through the thread to see several having the same problem, but no answers on how to work around it.

    Same old, same old, you can enter the location and get the quest (new Siege location etc) but when you come back you cannot enter since you don't have any "points" to go too. The town world map is just blank.
     
  2. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    So... Mibb?
    What can we expect? from new release (beta)...
    I now its will be the surprise that we read on change report but...

    Some go to location Fixes,... Maybe the food system, or maybe full healing the party by feeding by meals on ins. (Like mom -Den or -Modoc)
    But the main point i want to know if the "Alveys count critical hit" bug was solved. (its has been discus a lot, but final word nothing)
    And if you do something about that random encounter around Valut City "pack of dog" Which contain 2 alien queens
    And if that dam cockroach attack animation can be cut, speed out or removed.
     
  3. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    @Oggrr
    Yes, the BoS bunker and related quests... Ugh. Those had a ton of bugs. And, unfortunately, I was never completely sure how those locations were supposed to work exactly. Did a little guesswork. I have been putting off dealing with those, knowing that it will be a headache to deal with. I guess I'll try to start tackling those fixes for 2.48.

    In the meantime, you can make this change to the city.txt file in the data/data folder:

    [Area 81]
    area_name=BoS Bunker
    world_pos=1150, 1700
    start_state=Off
    size=Medium
    townmap_art_idx=476
    townmap_label_art_idx=514
    entrance_0=On,130,150,BoS Entrance,-1,-1,0
    entrance_1=Off,-1,-1,BoS lvl12,-1,-1,0
    entrance_2=Off,-1,-1,BoS lvl34,-1,-1,0

    This should allow you to enter the bunker once you have returned from the worldmap.

    There was a sleep/food system that was being worked on a while back. I would really like to have implemented that, but it was never completed, as far as I know.
    Regarding combat, are you referring to the bug from just a few pages back? I have included a fix from @Endru1241 in the next release.
    I found the bugged encounter with the wild dogs a while back and had already fixed it.
    The cockroaches may seem a little slow, but I haven't encountered any problems with them. They work alright. I don't plan on removing them, as they are quite formidable foes. However, you can easily remove them from your game by deleting the proto files for them. Or, just move them to another folder, just in case. The files are in the data/proto/critters folder, and are 539 and 540.

    From the next readme:
    Changes/Fixes made since version 2.46 and 2.46.1:

    -Numerous dialog and grammar fixes
    -Fixes/Changes to Cassidy
    ---Corrected an issue with Cassidy's damage resistances not being calculated correctly
    ---Slightly different artwork for Cassidy in leather armor which now allows for different background animations
    ---Cassidy in leather armor now speaks
    ---Replaced artwork for pistol use (files were there before, but replaced them just in case there was something wrong with them)
    ---Cassidy now says the line about trying Jet only once after giving him heart pills or using them on him
    -Shania in Arroyo no longer speaks about the GECK if you have not been given that quest
    -Added the Abbey from the RP
    -Moved and renamed the earlier version of the "Abbey" which was in the MM
    -Fixed a crash-causing bug on certain maps that would result from NPCs looting corpses
    -Corrected issues with the Chad skimming quest
    -Can now properly get Metzger or freed slaves to talk about the slaver camp
    -Corrected situation with some critters producing multiple sets of armor when killed
    -Radscorpions in the Temple of Trials no longer count as Super Mutant kills
    -Guards inside the Hubologist base carry weapons with the correct ammunition
    -Corrected issue with Bishop which caused dialog and experience to be repeated indefinitely
    -Corrected issue with Myron's dialog options being all "Error"
    -Fixes to combat damage calculations with regards to critical rolls for armor bypass, the deathclaw weapon, miniguns, and bazookas (thanks to Endru1241)
    -Fixes to Vault 14
    ---The Vault 14 stairs now take you to the correct maps (no more getting stuck on the level with Ardenius)
    ---Cleaned up some of the code with some of the Vault 14 scripts
    ---Should now be possible to fix the generator (if you are asked to fix it)
    -Added minor enhancement regarding nomads in random encounters (addition from Endocore)
    -Harming the characters at Bunker 21 or the ghoul at the truck encounter will no longer affect your reputation Arroyo or end your game prematurely
    -Fixes to some random encounters
    ---Random encounters with children now correctly show boys and girls
    ---The homesteader's wife has missing dialog restored for fighting/fleeing
    ---Caravan guards now acknowledge if the caravan master was killed
    ---Alien queens no longer appear in wild dog encounters
    -Cleaned up the workings for the Wasteland Taxi mod
    -Changes/Fixes to the car
    ---Car will appear in Modoc if you already have it when you escort Jonny back
    ---Now appears at the Ruined City encounter

    I was going to re-add the quest for Torr and the bugmen. However, I hit a bit of a problem with trying to decompile the script for Torr. Maybe I'll be able to get it into the 2.48 release.
     
    Last edited: Jan 3, 2017
  4. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    Sorry if this will be sound a weird, bud why not counts hammers as heavy weapons?
    Just think about it.
    Not cold weapon but heavy. They are "relatively" heavy as flamers, machine guns and rockets.
    or we talk about it?

    Something else. If we talk about attributes to use weapons. They can be use by only by one skill right? Like : Electric rod is cold and energetic weapons skill do nothing in this. Right?
     
  5. downloadmyheart

    downloadmyheart First time out of the vault

    Nov 2, 2016
    hello to MegaMod Devs. can u add an enhancement to the inventory that can filter items by categories in the next update?
     
  6. Raiden

    Raiden First time out of the vault

    Jan 21, 2017
    Every mod makes gameplay like this, first half of the game you run away, onther half you chase your enemies. It would be handy to have enemy numbers rising along with your level. Even 6 yakuzas with wakizashis can stab enclaver to death(+combat sequence)

    Would love to have an opportunity to mod some armor stats, AC, and defensive properties against different types of threats(flame resistance, eneregetic, or cold wpn.)
     
  7. M0nk3m4n

    M0nk3m4n First time out of the vault

    Jan 30, 2017
    Ok, so I'm having absolutely no luck whatsoever.
    1. Installed vanilla fo2 from original cd (seems to be version 1.02 US, so it's not the original-original release)
    2. Unzip entire contents of Megamod 2.46 into BlackIsle\Fallout 2 directory
    3. Run Fallout 2.exe. If I'm not getting the "Windows 7 funky colors" problem, then I'm having crashing errors
    when I enter the temple, attempt to load a savegame (like, one i just made) or when entering the next room.
    4. I also notice there are NO ants whatsoever in the temple
    5. On my first attempt at all this, I made it to Cameron, and all he could say is Error. All of his options were Error and they never got me anywhere. They just looped me out of the conversation. So I nuked this installation & clean installed again.

    I attempted to install Megamod 2.44 (Windows Installer version) over the 2.46 version. Here's what happened:
    1. Black ants were there, along with some red ants, nice touch
    2. Weather (i guess a sandstorm?) was going on before i entered the temple
    3. Savegame issues were still there, any time I tried to load a save game after making one in the temple, it crashed
    4. Tried putting the FO2 High Res pack into the folder to see what would happen, visuals improved, but nothing else.
    5. Keep trying more files and ddraw.ini options yet nothing solves the savegame crashes or lack of ants
    unless I'm using both 2.44 and 2.46, but even so, the savegame problem & Cameron error problem is the worst.

    I tried installing 2.44 first, with another clean vanilla FO2 install and got the same results as the above.
    Installing 2.46 onto 2.44 didn't change anything, it was still just as broken as "2.46, then 2.44" installation.
    Running a Dell Latitude E6410 laptop. (i7 720qm 1.6ghz, 8GB ddr3 ram, Nvidia Quadro 3100m gpu, Win7 SP1 x64)
    This system runs Killap's Restoration Project flawlessly, as well as the Fallout 1 FIXT mod, each without any issue.
    Can someone tell me what the heck I am doing wrong here? I have been at this for hours & I'm going insane. lol
     
  8. Altair90

    Altair90 First time out of the vault

    Jun 21, 2015
    Any thoughts how to run this mod on steam version? :O
     
  9. naossano

    naossano Vault Fossil

    Oct 19, 2006
    I was intrigued by the Dominion part of megamod that supposedly bring back the maps from the first Fallout, but i am unable to find ANY information about the current state of this project. Is it finished ? Is it dead ? Or is it still going on with another name ?
     
  10. Dude101

    Dude101 Vault Fossil
    Modder

    Aug 3, 2005
    Dominion mod was a demo. I think it was Pavel working on it, but it is abandoned as far as I know. I used to lurk on fallout.ru for updates but have not seen anything on it for years.
     
  11. Declen

    Declen First time out of the vault

    Oct 31, 2012
    Good daytime.
    I currently play Megamod (2.46) through New Reno and have noticed some changes:
    1. Mason (the Salvatore's right hand man) doesn't have mirrored shades (sunglasses that give CH +1 when equipped) on him anymore.
    2. Wright children playing "metal insects" outside do not talk to me. If I try talking to them, they reply "you are a bad person..." in floating message.
    Are those changes ment to be there? Why?