Can't Access Vault City In The RPU Mod

Discussion in 'Fallout General Modding' started by AmericanSephiroth, Jun 15, 2022.

Tags:
  1. AmericanSephiroth

    AmericanSephiroth First time out of the vault

    21
    Dec 31, 2012
    First hello all it has been many years since ive been here but i need help with something i'm playing the latest patch for the restoration project and every time i try to enter vault city i get a crash to desktop no popups or anything just sudden crash and i used a save editor to try to correct the issue by just seeing if i can place myself in vault city and while the downtown area works (the area with the 2 guards that you have to get past with the sliding metal door) the starting area of vault city causes a ctd whether i enter from the map or head south from the second area i don't know what is causing this problem and i have tried to fix it several times and im sorry if im just being dumb or this issue has been addressed before but i could really use a hand if anyone would be so kind as to point me in the correct direction or offer a suggestion for a fix thanks in advance

    to add extra context if this helps at all i am using the steam version of the game and added the latest rpu patch immediately after installation and to my knowledge no other area has this issue so far
     
  2. .Pixote.

    .Pixote. Antediluvian as Feck
    Modder

    Sep 14, 2009
    Did you edit your character in any way?...try visiting the other locations and then come back to Vault City. See if that has any affect.
     
  3. AmericanSephiroth

    AmericanSephiroth First time out of the vault

    21
    Dec 31, 2012
    yeah i made adjustments after the fact to test what other areas are broken (stuff like cranking outdoorsman and just stuff to skip encounters/make them easier) and here is what i have found so far the starting area of vault city, the last area of ncr (where tandi is), and the abbey for some reason cause an immediate ctd upon arrival... and no matter how i enter vault city so far nothing works it mentions the starting line of the area in the text box in the bottom left and doesnt finish loading properly, now i did turn on debug mode and also finally got a singular pop-up as well stating it was trying to reference 77a78ffd at ffffffff or something to that tune, and my findings from debug mode is in vault city at least it seems to show a metric assload of errors like a bunch of files are missing or something (i have not made any attempts at modifying those files since i know nothing about modding fallout and im sure i'd break something) so i'm at a bit of a loss as to what to do most other areas seem to work fine-ish but it's a bit disheartening...

    this same issue has plagued several different characters and installations for me so i don't know what i could be doing that is the issue or if it is even my fault if there is any files i could send that could help point out the problem i'd gladly do so since i just want this sorted out
     
  4. .Pixote.

    .Pixote. Antediluvian as Feck
    Modder

    Sep 14, 2009
    Sound like the game is corrupted, a clean install would be my advice. Both Fallout and RPU. Try a clean game, no fixes, even in the ddraw.ini file. Just run to Vault City and see if it loads properly. Just scum save through the trip to avoid dying. If it works then start a clean game and enjoy.
     
  5. AmericanSephiroth

    AmericanSephiroth First time out of the vault

    21
    Dec 31, 2012

    well sadly i just tried that and it didn't work completely clean install of both no fiddling with anything just speedrunning through made it to the vault city button clicked it and again same thing just ctd no notification or anything to your knowledge has anyone else had this issue? for reference i'm using the steam version of fallout 2 in english and using the installer to install rpu am i just boned and need to get my hands on a different version or is there any kind of fix i could possibly do?
     
  6. lostabroad2

    lostabroad2 First time out of the vault

    77
    Apr 2, 2013
    As a modding illiterate I can only suggest trying F2 in its default state and then trying again with a different mod to determine that the fault is within RPU.v26. I recently loaded F2 from an old CD then added RPU.v26 and the only crash error I had wasn't related to the RPU mod. Good luck.

    Edit: Perhaps uploading a save-game file would allow someone to look at it. Beyond my capability i'm afraid.
     
  7. AmericanSephiroth

    AmericanSephiroth First time out of the vault

    21
    Dec 31, 2012
    yeah once i get a few minutes to myself i'll try to upload a save and see if anyone can make heads or tails of it and if not then ill see if maybe i can get another version or something maybe...
     
  8. AmericanSephiroth

    AmericanSephiroth First time out of the vault

    21
    Dec 31, 2012
    well if anyone wants to take a quick look at this save of mine and see if there is any info that can be gained from it please feel free and i will try to answer any questions i can...

    i appreciate all the help you guys have given me so far i just wish i could actually get the game to run properly

    this file is in modoc just before vault city on a completely new and clean installation with minimal interactions done and mostly just a quick sprint to vault city
     

    Attached Files:

  9. Gorgragar

    Gorgragar First time out of the vault

    11
    Feb 8, 2019
    It is the RPU having same issue.. clean install of FO2 from gog and can get into vault city. when I install the RPU it crashes at vault city. the problem is the RPU corrupting files. even the lastest version. Appreciate everyone working on the RPU. it would be nice to be able to play it though. Hope someone gets time to look into this.
     
    • [Rad] [Rad] x 1
  10. Gorgragar

    Gorgragar First time out of the vault

    11
    Feb 8, 2019
    so on main menu of the game (new game/load game etc) you can hit control +R to pull up a map test thing? well for the main valt city down town it loaded. but for the vctyctyd.map which I am assuming is the court yard/ entrance of vault city it crashed. I am thinking the maps are corrupt someplace.. its a clean install too .. I could go to vault city before I installed the RPU on a completely vanilla FO2 game. so anyone know where the maps are pulled from? and have that file so I can replace mine? or make a video going through you fallout2 foulder and showing what files and where they are in the folders and sub folders to do with maps? cause I dont think a save game is gonna help anyone...
     
  11. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    @Gorgragar
    I can enter the Vault City just fine with your save (from another thread) in the latest RPU.
     
  12. Gorgragar

    Gorgragar First time out of the vault

    11
    Feb 8, 2019
    I figured you would be able to. its something to do with map data I am assuming and for some reason it wasnt installed correctly some how or a path messed up.. Ive b een messing with it all day. question.. My sound (the music) some times like skips. but keep playing but will play the same part like 3 times then continue with whats it suppose to do it is hardly noticable but since Ive been picking it over with a fine tooth comb that came to my attention.. think that might have somthing to do with vault city not loading?... it will like almost load.. like I hear a beep the screen looks like its about to load music starts then black and crash.. its like blink of an eye fast. I reallly wanna play this RP lol

    Edit. when it crashes It goes to desktop and I here the fits 2 notes of the music and crickets chirping. and the error message is up and the music keeps doing the 2 note loop untill I close the error message
     
    Last edited: Jan 26, 2023
  13. Gorgragar

    Gorgragar First time out of the vault

    11
    Feb 8, 2019
    interesting thing. I start it up turned off all sound. went to go into vault city. it crashed unfortunately but this time no error message. but then my mouse cursor was disappearing on my screen and when task manager was opened it said fo2 was still running just not responding.. couldnt atl tab to it either. so the game was still running just not responding ands closed out. if anyone has any ideas id appreciate it

    Crash report uploaded
     

    Attached Files:

    Last edited: Jan 26, 2023
  14. Gorgragar

    Gorgragar First time out of the vault

    11
    Feb 8, 2019
    so I messed with the save editor. I made vault city "discovered" and when entering it I have the option for inner city and for the courtyard...If I go to the inner city It loads.. if I enter the courtyard thats when it crashes. so the courtyard is the issue.. I put up the report there in a previous post can anyone please help me out?