Fallout 2 CPU idle option

Discussion in 'Fallout RPG Gameplay & Tech' started by IYouI, Jun 22, 2014.

  1. IYouI

    IYouI First time out of the vault

    42
    Dec 15, 2013
    I have Fallout 2 GOG version (Windows), and I would to hear your option which is better way to fix that CPU overheating problem?

    ddraw.ini (sfall)

    Code:
    ProcessorIdle=1
    f2_res.ini (High Resolution Patch)

    Code:
    CPUfix=1
    I've tested both of them, of course I did run just one at time. But I didn't manage to see much difference, and I would like to hear your options about this. Which one do you use, and what processor type you have?
     
  2. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    I use sfall's ProcessorIdle to prevent 100% CPU usage on my AMD Phenom II X4 955 (home) & Intel Core i3 (office). The CPUfix from Hi-res patch also works for me, but I'm just used to sfall.
     
  3. Kermac

    Kermac First time out of the vault

    5
    Jun 30, 2014
    None of theese works for me. Still 100% usage on core1. Can someone help me solve that ?
     
    Last edited: Jul 9, 2014
  4. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Try setting ProcessorIdle to a greater value, like 5 or 10. Or you might try BES instead.
     
  5. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Hm, both sfall and Hi-Res patch fixes worked fine for me. Fallout 2 is sucking up ~25% CPU time on core1 of my C2D E4500 with sfall's ProcessorIdle parameter set to 1. How about other parameters, do they work as intended? Try disabling intro movies and see if that works, just to make sure you're editing the right file. Perhaps there are two or more instances of ddraw.ini hidden somewhere on your drive.
     
  6. Kermac

    Kermac First time out of the vault

    5
    Jun 30, 2014
    Setting 5 or 10 doesn't work. I tried BES before. It works but the game is very laggy. Also I'm sure that I'm editing right ddraw.ini since other settings works as they should. Still one 1st core is still on 100% (25% of whole CPU since it's quadcore). I don't thinks that's somewhat relevant but my cpu is Intel i5 3470 at stock clocks.

    edit: I tweaked BES config a bit so it better, but still game has worse framerate... Getting sfall or HD patch to work would be much better I guess.
     
    Last edited: Jul 9, 2014
  7. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    You might try valcik's suggestion to check if your edited INI really works or not. Maybe search your C: for ddraw.ini and see if there's any other one exists, especially if you're using Windows Vista or newer.
     
    Last edited: Jul 10, 2014
  8. IYouI

    IYouI First time out of the vault

    42
    Dec 15, 2013
    Now I use Sfall option for CPU idle, when there is combat CPU usage goes higher. That is normal?
     
  9. Kermac

    Kermac First time out of the vault

    5
    Jun 30, 2014
    Like I said, I'm sure that ddraw I'm editing is right one... But checked it again and found out that only ddraw.ini on my HDD is the one I'm editing.
     
  10. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    It's normal to have some CPU peaks, at least on my CPUs it can be as low as 2% and as high as 87% (peak, not constant).
     
  11. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    This is how it looks when my Chosen One is exploring Klamath. Doing some barter, dialogues, walking, running around. And finally punching poor brahmin with bare fist, for testing purposes! :look:

     
  12. Kermac

    Kermac First time out of the vault

    5
    Jun 30, 2014
    Noone knows what elese could cause it ? It's not good to have my CPU at max clock with core1 100% loaded... Especially now when it's summer and my CPU is at 45C. BTW when I set some high number for ProcessorIdle, like 999, game barely runs (like 0,5 fps) but it still eats my CPU. It really annoys me.

    edit: Solved it... sort of.
     
    Last edited: Jul 10, 2014
  13. Buxbaum666

    Buxbaum666 Heterostructured Nanorod oTO Orderite

    Dec 5, 2003
    General hint: if you solved a problem that you posted on a message board, describe what solved it so other people with the same problem can try your solution.
     
  14. Kermac

    Kermac First time out of the vault

    5
    Jun 30, 2014
    Well I was trying different values in ProcessorIdle and in the process of doing so found out that task manager is not the best thing to view CPU load in this case. My game strangely runs 100% of core1 only when I alt-tab it. Which is really strange... But actually when I'm ingame it doesn't. Still it eats more than it should but atleast it's not 100% all the time.