Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. lucas.

    lucas. Still Mildly Glowing

    253
    Jun 7, 2010
    Hey, I got a problem...


    I downloaded the 17th april fix then I...

    -Opened the fix folder.

    -Opened the Fallout 2 folder and removed everything the fix folder alredy had.

    -Ctrl C Ctrl V all the stuff in the fix folder to F2 folder.

    -Start the game.

    -Check the rock and still says it's 2.0.2d instead of 2.02e


    What I am doing wrong?
     
  2. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    @lucas.
    Hmm, not sure. Try again though doing this:

    Copy the two "files" (data folder and ddraw.dll) from the fix folder and paste them into the main directory of Fallout 2 (where fallout2.exe and ddraw.dll are). Say yes to overwrite.
     
  3. benwah

    benwah First time out of the vault

    10
    Apr 2, 2003
  4. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    You don't need the latest version of sfall to play 2.0. However, the latest version will be included in the upcoming 2.1 release.
     
  5. JaW

    JaW It Wandered In From the Wastes

    188
    Oct 1, 2006
    So you are not going to fix all reported bugs from Wiki page in the next release?
     
  6. Taleyran

    Taleyran First time out of the vault

    8
    May 13, 2008
    Talking about the planned content. I've been always puzzled with those Elvis portraits scattered throughout the game. Are they a part of some unfinished quest? Anybody knows anything abount the purpose they were intended to serve?
     
  7. Hellburn

    Hellburn First time out of the vault

    14
    Apr 14, 2010
    I guess it's just a valuable thing at early state of the game. Or an mini easter egg...
     
  8. smilodom

    smilodom Look, Ma! Two Heads!

    346
    Apr 17, 2008
    Wrong thread but anyway maybe it´s better to post it here than in the suggestions thread because at the moment "Killap" pay not so much attention..on... :lol:
     
  9. PainlessDocM

    PainlessDocM Sonny, I Watched the Vault Bein' Built!

    Feb 5, 2010
    Hello Killap, do I miss something when I don't use the latest sfall?
    I ask this because I use an older version since I almost get no encounters with the current version.

    Thanks in advance
     
  10. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    @JaW
    So, all bugs marked "CONFIRMED" are fixed for 2.1. Any entries that are marked with "UNCONFIRMED" or don't have any status to them are not being addressed. Most of the ones without a tag are map issues and those should be addressed now. The rest just seem to be bad installations, not bugs at all, or people reporting too little information for me to do anything about it. If they are truly bugs, then we'll see if they come up again in 2.1.

    @PainlessDocM
    No, you don't miss anything. To few random encounters are not the result of an old sfall version. Try messing around with the world map movement settings in ddraw.ini and seeing if that helps.

    @all
    The potential problem I mentioned earlier is not a concern. One more item off the to-do list.
     
  11. sydney_roo

    sydney_roo Still Mildly Glowing

    282
    Nov 24, 2008
    Does that mean you only have an FAQ to finish, killap?
     
  12. lucas.

    lucas. Still Mildly Glowing

    253
    Jun 7, 2010

    I see no ddraw.dll on the fix folder... just this:


    F2_Restoration_project_2.0(1,2,3) <-- there's 3 of these.

    F2_Restoration_project_2.0update (a bunch of these)

    Fallout2.nrg

    UnoficialFO2patch



    EDIT: Fail, clicked on "open folder" instead of downloading winRAR and clicking "open"... Sorry about that.
     
  13. JaW

    JaW It Wandered In From the Wastes

    188
    Oct 1, 2006
    Thanks for your answer, Killap.
    I was asking because my report from Abbey refering to epitaphs (no chhange from version RP1.2) and second Kaga encounter with bandits haven't been marked as done.
     
  14. lucas.

    lucas. Still Mildly Glowing

    253
    Jun 7, 2010
    Nvm on my edit I copy/paste the data folder and the ddllwhatever and the rock still says I'm running the 2.0.2d version...


    When will you include 2.0.2e in the full stuff? I don't have luck with extracting/updating/paste... :?



    EDIT: I fucking did it! F*ck you RAR!!!



    Anyway... From what I readed version 2e looks pretty good, I had most of the problems this version fixed.


    Thank you for you work... and patience... >.>
     
  15. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    @sydney_roo
    No, remember I said 3 things were still left to be done. We still have two more (one of which includes FAQ, documentation, etc)

    @JaW
    The kaga issue shouldn't be a problem anymore. I haven't personally confirmed this to be the case, but changes were made that should resolve the problem.

    The abbey grave issue is something I haven't spent much time looking into. It doesn't seem clear why it would happen and more reports from others regarding this would be useful.
     
  16. jewslox

    jewslox First time out of the vault

    2
    Jun 12, 2010
    Killap, what you've done is awesome so I first want to say thanks. Problem is, I haven't played any of it since my game black screen crashes after the intro movies.

    I tried fresh installing to no avail. I even tried doing the very minimum restoration install (w/o the other mods included), but the installer says they are already there even after I previously deleted the directory. I also tried starting at my lowest resolution of 800x600 at 16 bit color and still crashes.

    I have vista 64 if that helps.
     
  17. Herr Mike

    Herr Mike Look, Ma! Two Heads!

    322
    Jul 28, 2008
    Same thing happened to me after updating to 2e. I gave up and decided to wait for 2.1.
     
  18. jewslox

    jewslox First time out of the vault

    2
    Jun 12, 2010
    Ok, I am perplexed to the max.

    I was tweaking the hell out of this installation to see if anything worked. After noticing that the game remains updated to 1.2 after uninstalling the restoration pack, I tried separately intalling the hires patch after the restoration pack. Before or after the pack install, the patch didn't seem to help. So I just left it installed with the restoration pack and decided to tweak some numbers in the ddraw.ini file. Nothing worked, but I left the sfall updater to 0 instead of 1.

    As a last resort I tried running fallout in compatibility mode. None worked, but MIRACULOUSLY going back to normal worked this time. The screen stayed! WTF???? So basically fucking with things and going back to where they were originally worked.

    I'm gonna stop questioning things and just play now.
     
  19. lucas.

    lucas. Still Mildly Glowing

    253
    Jun 7, 2010
    Weird... I just noticed that after updating to 2e my FO2 don't have music anymore.
     
  20. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Some F2 versions are preset to use compatibility mode even though it's not showing in the compatibility menu. That's probably what happened to you.
     
Thread Status:
Not open for further replies.