Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. BubbaBrown

    BubbaBrown First time out of the vault

    Aug 18, 2009
    A few questions a bug or two...

    What stats does the Prizefighter Perk modify and how much?

    I think the boxing in New Reno is bugged. For some reason my Damage Threshold was raised ridiculously high during the fights and it never seemed to go down afterwards. It's nice, but I don't think it fits in the realm of the game. Without armor and with the prizefighter perk, I have a Normal DT of 12. Pretty hefty by any right.
    EDIT: Rechecked this with the latest version. I did not have a clean save before entering the fights, but rolled back the variables in the saved game to "clean the slate" in New Reno when it came to boxing. It seems that with each fight, the game adds +3 Normal DT and +1% into Normal and a few other types of DR... without removing it afterwards.

    Also, if you lose a turn, you lose the fight by "knockout". There also seems to be a glitch that when you are given another chance, the next fight instantly resolves with you losing by "knockout". There must be a global variable that isn't getting reset properly.
    EDIT: Still in the latest version.

    -Ignore - In the Abbey, I try to escort Brother Jason to Gecko and he disappears completely, not to be found in either the Abbey or Gecko.
    EDIT: The very latest version fixes this. I was operating under the update "2d" before.

    I've noticed that game cycles through all the extra NPC dialog at warp speed in the background when you are talking to Kaga at the prompt.

    EDIT: These may be old bugs, I didn't realize the installers provided weren't installing the latest version.
  2. Chancellor Kremlin

    Chancellor Kremlin Mildly Dipped

    Nov 17, 2008
    First and foremost, this probably never gets old, thanks for an awesome mod and the patience to make it. I do remember a very very long time ago in what felt like a galaxy far far away waiting for 2.0 to come out. And now that its here I am very very please and it was worth the wait.

    I have a quick question. Well, two or three quick questions. What program do you use to edit the INT and other Fallout 2 files? I want to try and mess around with a couple of scripts but have so far been unsucessful.

    Secondly, is there any unused dialogue in the game? I had a quick glance for example at dcFranki and dcBilly (The patron and owner of the Hole in the Den) at data/text/english/dialogue and there are a couple of options towards the bottom of the text which seem to suggest its possible to give Billy a refund as a female character if you are very bad at the sex, and some weird dialogue with Franki also.

    Is this an oversight, abandoned dialogue, what are the prerequisites for engaging in these particular lines?
  3. ralphrepo

    ralphrepo First time out of the vault

    May 1, 2010
    Totally tangential question about how some of the experience points for successful combat are rewarded; I noticed that on many occasions, the text will say something along the lines of "for defeating your enemies without taking a scratch you earn x number of XP..." (words to that effect). My question is then, is there a calculated bonus above the normal value for each target if you don't take any damage?

    Further, I noticed that sometimes, I would be able to dispatch the entire enemy encounter (without NPC involvement) in one turn; shouldn't there be a bonus of some sort for that too? On several occasions, I even killed all the enemies of the random encounter with one shot (all six mantis with one plasma grenade); shouldn't there be some sort of point score recognition for that too?

    I know some of the above may be "wish list" type stuff, but would it be possible even to do something like that?

    BTW, can anyone tell me the names of the dialog files for three EPA NPC's? I'm having a real hard time finding them.
  4. FallMan

    FallMan First time out of the vault

    Mar 14, 2009
    killap, any news on 2.1? How are the things going?
  5. Felipefpl

    Felipefpl Look, Ma! Two Heads!

    Jun 17, 2010
    dammit, did you read what was posted a few posts back? Let the man take his time, how much time is needed. :evil:
  6. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Interesting. The Billy stuff is just the dialog, it was either removed or never finished in his script. Frankie however is a different story. I believe what you refer to as weird dialog is the female character sleeping with him part. It's all there but can't be accessed through dialog because of a bug (or if it was intentionally disabled, it's hard to tell).
    procedure Node023
    if ((game_time > local_var(7)) and (local_var(7) != 0)) then begin
    It's that last part "(local_var(7) != 0))" that disables it. Basically, you can't have sex with him when local_var 7 is 0, and it will always be 0 before you have slept with him.
  7. gurachn

    gurachn First time out of the vault

    Jun 21, 2010
    Do you have the latest patch (2.0.2e)?
    I just finished this mission (twice actually as I was killed shortly fast travelling shortly after the first time), and didn't have this problem.
    I also had Vic and Sulik and they both performed well. Vic with a .44 killed at least two dogs and nearly got himself munched in the process, and Sulik did very well with his combat knife.
    Two brahmin were lost, but not due to my boys lack of fighting spirit.
  8. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yeah, like I said RL keeping me busy, this weekend especially. I'm still shooting for a June release, so it looks like I got until Wednesday to see if I can stay true to it. :P
  9. Felipefpl

    Felipefpl Look, Ma! Two Heads!

    Jun 17, 2010
    dont worry about dates, just take your time to make everything good as it needs to be. ;)

    btw, dont forget to update your site too. ;)
  10. Chancellor Kremlin

    Chancellor Kremlin Mildly Dipped

    Nov 17, 2008
    Thanks Darek. So is the 0 veriable not changeable then? And on that note, if these two characters have unused/unimplemented dialogue, is there any chance others do too? Is this within the scope of the Restoration Project?

    Also, a bug im sure, I've noticed a lot of ''You were hit for x ammount of damage'' just shows up as a dot, .
  11. matthewfarmery

    matthewfarmery It Wandered In From the Wastes

    Jun 26, 2010
    @gurachn I managed to do this, but the mission was still not entered in the quest log (did it show up for you?) yes Im running the latest version, 2.0.2e, I gave sulik a SMG, he did better this time, and helped kill many dogs, vic was still useless, (even though I gave hime decent armour and a shotgun) I lost one brahmin, I also think I know the reason why the AI ends up attacking the brahmin, as they can accidentally hit the brahmin instead of the dogs, turning the brahmin hostile, but anyway managed to do this, but the quest for this wasn't logged in the pipboy, surely that is a bug? I think I have a save before I accepted the mission in case its needed,

    anyway thanks for the response

    yeah take your time, if needed, I been associated with a few beta projects in my time, and know that its always a good idea not to rush things, (even if it can piss off a lot of people in the process (give us it now or we can't wait any longer, etc) so yeah, better to give it polish then to rush, :wink:
  12. Goettschwan

    Goettschwan First time out of the vault

    Jun 28, 2010
    Bug in installation of 2.02e Patch

    Hi, I am running Fallout (vanilla installation, humongous, no idea on the country version, probably US) with RP2.0 (complete install with everything checked) and the latest patch 2.02e, under OpenSuse with Wine 1.2rc5.
    Linux being case sensitive, this also applies under Wine, so the latest patch will be installed, but creates own directories,
    eg. fallout2/data/Maps after the RP install, and an additional fallout2/data/maps from the patch.
    The game will not see these files, but run, and it leads to an error while trying to save the game.
    Workaround is to copy all the files manually in their respective directories, and deleting the folders that were installed by the patch. If this would be possible to use the exact same filenames it would be very nice :)

    Also, I had no scrn button in the game preferences menu although I had checked for installing everything necessary.
    I have tried and installed vc6redistsetup_enu.exe which was supposed to install the runtime library. I do not know if this runtime exe needs to be anywhere or inside the Fallout directory, both positions have no effect on the button. I have tried and updated Sfall to 2.9c, no effect either. Since the patcher exe is not anymore there, I downloaded this mod again, and it says it is patched already. I cannot run the DirectXwebinstall thingy, it stops with some error. Due to me using wine/linux, this is not surprising.
    I have then manually changed the resolution in F2_res.ini to 800x600, and surprise surprise, the button appears. Everything inside the new menu works, only when selecting 16bit color and restarting fallout it becomes unplayably slow already in the main menu. I am now running 1024x600 (my netbooks resolution), 8bit color, and all is cool.

    I have a file called Elevation.ini in the fallout root, is this supposed to be there or elsewhere?

    Also, this may sound a bit doofus, but is there a screenshot for the stone that should show the RP version? I have tried a lot of stones, and none show a version info, only text like "you see some faces in the side of the rock" etc.
    Any help would be greatly appreciated, and thanks, killap and the others, for your efforts going into this game!
  13. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Re: Bug in installation of 2.02e Patch

    Yes, here, thanks to SPC.
  14. Goettschwan

    Goettschwan First time out of the vault

    Jun 28, 2010
    Ah thanks for that. I must have missed it while reading this thread. Also, in the meantime i found out about the very helpful left-shift feature of sfall!

    As to talking to Klint, wasn't there some kind of dialogue at one point about how killing him is not useful because we need two men to move the skull pillar? I may be confusing things.
  15. Sephis

    Sephis It Wandered In From the Wastes

    Mar 29, 2010
    whats left shift do..?
  16. Goettschwan

    Goettschwan First time out of the vault

    Jun 28, 2010
    I do not know from which version number, but Sfall now highlights all the pickable items (eg. Zander Roots, rocks, etc.) on the ground if you hit "left shift".
    Also, "tab" will display the area map.
    There may be other new functions, I only know these two.
  17. matthewfarmery

    matthewfarmery It Wandered In From the Wastes

    Jun 26, 2010
    that is utter awesome and works a treat, didn't realise that, but that is one useful and a godsend feature for this game, considering some items are a little hard to see at times, man that is awesome :D
  18. Radar E 33

    Radar E 33 First time out of the vault

    May 27, 2010
    Checked the Draw.ini file and damagecalculation is set to 0 (default). I am now also using Fallout 2: Weapons Redone along with FO2RP. I still cannot get anything higher than 50 points of damage. With criticals i can get 110 max.

    vs. Combat armor: 20-35
    vs. leather armor and jackets: 25-35
    vs. SM's: 12-30
    vs. DeathClaw's: 20-24 damage
    vs. robots: 12-19 damage

    Also... I can't find an improved flamerthrower :(
  19. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    What traits do you have? "Heavy handed" reduce effect of criticals, "Finesse" reduce overal damage (-25%).

    [spoiler:58f5c5047f]In the basement of "New Reno Arms" you'll find guy, who upgrade your basic flamer to improved one.[/spoiler:58f5c5047f]
  20. DarkCorp

    DarkCorp So Old I'm Losing Radiation Signs

    Oct 27, 2003
    Using patch 2.0e. I am stuck with the light quest at the EPA. The old way to do it is to use science on the generator in the room with the 0000 hologram. Problem is whenever I try using a skill on the top generator it says I cannot reach it. I also think the basic description when you binoc it also is changed.

    So how the heck am I supposed to fix the lights so I can get the agility serum?
Thread Status:
Not open for further replies.