FO/FO2 Map Viewer

Discussion in 'Fallout General Modding' started by Digital_Utopia, Dec 6, 2013.

  1. Digital_Utopia

    Digital_Utopia First time out of the vault
    Modder

    24
    Dec 6, 2013
    First off, I apologize for taking so long to reply - had some real life stuff that came up.

    I'm currently creating a Windows 7 VM, on which I should be able to debug the app, without having to worry about (relatively) trivial matters like visual style support - something that xp doesn't have, which may add complications to rooting out the real cause. In addition, the version of vstudio used to write this, doesn't install in xp.

    I do appreciate all the feedback, and help you guys have given me - and apologize for not testing this out fully, on other platforms, before releasing it.

    Oh well, I guess those learning experiences just keep on comin' :p

    Thanks for your patience :/

    Update: The problem with the config file generated by the program, boils down to a simple typo. In the current version, the config file it generates, contains the following line:

    Code:
    < supportedRuntime version="v4.0" sku=".NETFramework,Version=4.0" />
    <supportedruntime version="v4.0" sku=".NETFramework,Version=4.0">
    When it should read:

    Code:
    <supportedruntime version="v4.0" sku=".NETFramework,Version=<strong>v</strong>4.0">< supportedRuntime version="v4.0" sku=".NETFramework,Version=[B]v[/B]4.0" />
    <supportedruntime version="v4.0" sku=".NETFramework,Version=<strong>v</strong>4.0">
    The "v" was missing before the 4.0 in the sku attribute.

    However, that only covers the .NET error box, not the reason why the app would crash. That turned out to be nothing more than stupidly using real paths, instead of relative...which is why it worked *perfectly* on my computer...and nobody else's.

    So, that's fixed. Even tested it out on a "virgin" Win 7 box (i.e. no Vstudio installed), and loaded up fine.

    Now, it's still not working on xp - but that, is likely due to visual styling, and I'll go ahead and work on that, by making it use a "normal" window in that case.</supportedruntime></supportedruntime></supportedruntime>
     
    Last edited: Jan 10, 2014
  2. Digital_Utopia

    Digital_Utopia First time out of the vault
    Modder

    24
    Dec 6, 2013
    Alright, I figured I'd put this up since it should now be working for all of you.

    Fallout MapViewer 0.1.2 Beta

    quick rundown of what's changed:

    • Config file now properly (re)generates, without throwing that silly .NET error (remember to delete any existing ones!)
    • Most importantly: Paths have been fixed, so it should actually run now
    • A border has been added around the main window, to help separate it from the background, if Aero isn't enabled
    • Further style changes were made so that it maintained the same appearance across Windows 7, Vista and XP.
    • App will now adjust for xp's lower level of desktop graphics support, by using software rendering and skipping the drop shadow.


    As always, please let me know if you run into any issues. :)
     
    Last edited: Jan 12, 2014
  3. Sduibek

    Sduibek Creator of Fallout Fixt Moderator Modder

    Oct 27, 2010
    Still crashes for me saying it needs .NET 4.0 :'( But I'll let others chime in, maybe it's just my computer.
     
  4. Digital_Utopia

    Digital_Utopia First time out of the vault
    Modder

    24
    Dec 6, 2013

    Grab the latest one (0.1.2)

    and make sure you delete whatever exe.config file you may have in that same folder.

    The only time you'll see that .NET 4.0 thing is if the typo exists in the generated config file.

    alternatively, you can open it up in notepad, and change the line:

    supportedRuntime version="v4.0" sku=".NETFramework,Version=4.0"

    to

    supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"
     
  5. TheEart

    TheEart First time out of the vault

    15
    Nov 8, 2013
    When there will be a support .DAT files without their unpacking?
     
  6. Digital_Utopia

    Digital_Utopia First time out of the vault
    Modder

    24
    Dec 6, 2013
    At some point after I get all the Fallout 2 maps working. It's certainly, in my mind, a requirement for it being truly finished - but I want to make sure that everything is working with the unpacked files, before adding the complexity of opening files directly from the .dat file.
     
  7. Sduibek

    Sduibek Creator of Fallout Fixt Moderator Modder

    Oct 27, 2010
    Is that why it's not working for me, perhaps? I did not read anywhere that unpacked data files were required. So I need to unpack all files from master.dat AND critter.dat or just master.dat?
     
  8. Digital_Utopia

    Digital_Utopia First time out of the vault
    Modder

    24
    Dec 6, 2013
    The program will still open regardless, you'll just get errors if you attempt to open a map file. But yes, both critter and master.dat need to be extracted at this point.

    If you're seeing this error:



    the only cause is a bad config file.

    1. Delete anything with the name "Fallout MapViewer" in the folder - including the application.

    2. Download it again here.

    3. Extract the application from the .rar file, to the desired folder

    4. Run it.
     
  9. Sduibek

    Sduibek Creator of Fallout Fixt Moderator Modder

    Oct 27, 2010
    Thanks, I'll try when I get home and report back to you .
     
  10. Sduibek

    Sduibek Creator of Fallout Fixt Moderator Modder

    Oct 27, 2010
    Update: working. It was crashing due to my mistake; I was trying to run it from the desktop prior to this post. I hadn't realized it needed to be in Fallout directory, for some reason I'd just assumed it did some sort of auto-detection or could be configured what directory to search after opening. I apologize, that's my mistake for sending you on a wild goose chase.

    Suggestions:
    1) Text next to the button icons, instead of just icons. (top-right)

    2) Maybe to avoid user stupidity like mine, you could start by informing user it need to run from Fallout directory with data files unpacked (via message box) and if it doesn't find those files. (this to avoid confusiong .NET Framework crash messages)

    3) Assume DATA\MAPS subdirectory relative to Fallout directory, if run from valid location (i.e. files needed for #2 above have been located)

    Questions:
    4) Does it matter if the files are read-only? (The map files and other files your program needs to read) i'm currently running it in an setup where all extracted Fallout files (~25000) are Read-Only.

    Also not sure if bug or oversight, but if I have Windows set to not auto-hide Taskbar, mapviewer still goes to bottom of screen if maximized, i.e. it goes under taskbar and can't be seen unless I un-maximize it.

    Looks great so far :clap: Official mapper you can hit "i" key to display over objects their scripts, any chance your mapper can do that? Also I assume the X/Y coords and hex numbers is pending, I didn't find an option to enable those.
     
    Last edited: Jan 16, 2014
  11. Digital_Utopia

    Digital_Utopia First time out of the vault
    Modder

    24
    Dec 6, 2013
    It should be able to run from anywhere - although I did notice a new issue that seems to have something to do with permissions of some sort, when attempting to run it from the desktop. I'll have to look into this more. If you can, alt+print screen the error message, upload it, and share. Because I think whatever is causing that - is the root of the trouble. Also, please include the path to your fallout folder - just to see if I may have overlooked something. The closest I can get to replicating what you're working with, the better chance i have to track down this pesky little bug :p


    1. I think I see, and agree with your reasoning on that; but let me bounce this off of you. I admit that relying on tooltips, and only having certain options available on the toolbar, is bad form. To remedy this, the next release will not only have a View menu, with the filter options - complete with text; but there will also be a status bar that will display what the tooltip does now. While I don't really want to clutter things up by adding text to the toolbar area, I hope that both of these combined will fill that suggestion.

    2. This, as I mentioned above, is something I really need to get to the bottom of. Because, regardless of whether you have the files extracted, or where you run the program from, it should at least open. Believe it or not, there are several checks while it's attempting to load the map - although it is still pretty light. The point remains though, that if you're getting crashes before you even attempt to load a map - then my problem is somewhere else.

    3. That's something that it *should* do already - but only if the Data path isn't already set. However, *should* and *does* are obviously two different things. I will double check this behavior; but something tells me it's related to the other issue.

    4. Read-only shouldn't matter, as long as the config file isn't - as that's the only thing it writes to. Everything else is merely a matter of reading the various files. That being said, while it shouldn't need admin rights, there may be something to that. In fact, for whatever reason, there's certainly a permissions related issue that just showed up for me, while attempting to run from desktop. So yes, I definitely need to look into that.

    5. It's a bug and definitely not intended. I assumed that all windows would respect the taskbar, which was obviously wrong. :p This will be fixed on the next release.

    After reading your question about the scripts, I went ahead and finally got around to downloading the official map editor. And the answer is...I'm not completely sure where to get that info yet. What I'd like to do, is to parse the MSG files, to get the in-game names/descriptions for the various critters/items; but I have to do some more digging to see how everything is tied together.

    As far as the X/Y stuff for the tiles/hexes there has been some progress with that. While I'm still working on an efficient way of actually displaying the grids with numbers, the status bar has a section for both hex and tile info based on where the mouse pointer is.

    http://i.imgur.com/hCfdno1.png

    I'm happy you like it so far, and especially, that you were able to get it running. But I'd be a lot happier when I can get these bugs squashed :p
     
  12. Sduibek

    Sduibek Creator of Fallout Fixt Moderator Modder

    Oct 27, 2010
    The name of the scripts themselves is in SCRIPTS.LST, btw.
     
  13. Digital_Utopia

    Digital_Utopia First time out of the vault
    Modder

    24
    Dec 6, 2013
    Fallout MapViewer v0.2.0 Beta

    Notes
    Just some things to be aware of...
    • All files still need to be extracted from the DAT files (work on reading from DATs will continue once I'm sure the program itself is working properly for everybody)
    • Fallout 2 Maps are still not supported entirely

    Changes

    Fixes:
    • Application will now properly respect the taskbar when maximized
    • Due to possible permissions related issues, settings are now stored in a local application data/appdata folder.
    • DATA path checking/discovery has been rewritten, and will now verify the path, even if it's set in Preferences.
    • Application would crash upon opening the preferences window more than once - this has been fixed.

    Additions/Improvements:
    • A View menu has been added, containing redundant filter options with icons/text.
    • A Status Bar has been added, which will describe icons/menu choices with more detail
    • Hex/Tile information will now appear in the status bar for the location under the mouse pointer.
     
  14. JDFRG

    JDFRG First time out of the vault

    1
    Jan 1, 2020
    Hello,
    I would like to use the program, but none of the download links work any more.
     
  15. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    303
    Oct 29, 2015
    I will look in my repository, it is possible that I still have a file.
    but it’s bad that this has not been brought to release and it does not work with .dat files.
     
  16. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    303
    Oct 29, 2015

    Attached Files:

    Last edited: Jan 3, 2020