Megamod 2.44 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Ok, if the Broken Hills and Raider maps are loading when you delete the ones in the folder, then that means there is something on the maps that the game doesn't like. Could be a script I modified (unlikely). Could be an item I added/changed there (more likely). (Or, it could be something else I just can't think of at the moment.) This makes sense, if you are getting the original maps from the master.dat to work.

    By using the original maps, you won't lose much. Again, the vertibird might not land there correctly. There may be a problem with creation of the car. And, there is only a slight difference, I think, in the external Raider map.

    As for the crash when using the raider map, that might be related to the fix for the too many items bug. If I remember correctly, that map script is in the obj_dude script. But, I may have forgotten to update the item on the map, which may be the reason behind the crash.

    Still trying to get my desktop back up, so I can't test anything. Soon, hopefully...
     
  2. Vrede

    Vrede It Wandered In From the Wastes

    110
    Mar 11, 2008

    That's ok mate. If there's not much lost, I'll play like this for the time being and report back if I find anything else.
    Thanks for all the support and best wishes to you.
     
  3. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    Vista problems still?

    New laptop, running Vista 32 bit.

    Installed Fallout2, runs fine.

    Installed self-installer of 2.44 and when entering the temple get crash: The instruction at xxxxxxx referenced memory ay yyyyyy. The memory could not be read from.

    Anyone running the megamod successfuly on Vista?
     
  4. Tiek68

    Tiek68 First time out of the vault

    21
    Jun 26, 2011
    Hi MIB88, Now I have this problem...sorry. After installing the High Resolution Patch 3.0.2 I noticed that not all 2.44 maps have the corresponding new edge file (xxx.edg), so I wanted to use Mapper (properly configured to point to the directory of MegaMod and with the relatively HR Patch 3.0.2) to create them but in the launch phase of the program, this does not start with the following error: wmAreaInit:Error loading Cities! With other F2 mods Mapper loads regularly. Is there a solution? Thanks in advance!

    I have also another question: all the maps in the directory \data\ maps are used in ver. 2.44 or some are a remnant of old versions? I ask because the total number of files .map is 227, that of the edges files included in the Mega Mod (*. ini) is 213 while that of the edges files included in the High Resolution Patch 3.0.2 (*. edg) is 138.

    EDIT: Fixed. Looking in the forum I found the mapper cities patch.
     
  5. Vrede

    Vrede It Wandered In From the Wastes

    110
    Mar 11, 2008
    Re: Vista problems still?

    Did you delete patch000.dat from the installation folder?
     
  6. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    Re: Vista problems still?

    Ah, right. I had forgotten that. Deleted in. Now made it into the temple.

    Fought the two ants. Quick Saved into a new save slot, and crashed on restore. Had this same problem in 2.43 with Vista 32 and Win7 64 .... doesn't happen with with Fallout2 stand alone, nor with the 2.1.2 RP.

    Something about the megamod makes post-XP operating systems unhappy.

    Michi
     
  7. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
  8. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
  9. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    :clap: AWESOME!!!!

    I can finally play! Saved/restored a buncha times in temple after killing stuff, and picking stuff up... Yes!

    Thank you!
    :notworthy: :notworthy: :notworthy: :notworthy: :notworthy:
     
  10. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    Welcome

    Nirran
     
  11. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    What stupid thing am I doing?

    installed the MM on two different computers.

    On one of them, when I go south from where the Elder is, the map is all black... I see myself, but nothing else.. i can run around in the blackness.

    I must have done something dumb ... what was it?
     
  12. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    edit : missread your post

    Nirran
     
  13. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Re: What stupid thing am I doing?

    Could be a random corruption. But, usually this error is a result of some item being on the map that is missing from the data/proto/items folder. You made sure to make all those files read-only, right?
     
  14. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    Ok, I assume the problem was that not everything in proto was read-only after installing Nirran's mod.

    But, now I have an odd problem.

    I have two copies of Fallout2+MM244+WR2.2+Nirran's mod+Hires

    They both work fine. But I can't copy saved games between them ... they crash on loading after copying.

    I seem to recall having been able to do this in the past...

    EDIT: Fixed. Not sure how. :)
     
  15. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    Maria not working

    In Navarro, I went to to Maria after getting the Vertibird to land. She is standing in the building with the cook, in the bunk area, not doing anything.

    When I try and talk to her I get floating text telling me "Not now, Honey" or that she is on inspection. Going down a level a waiting and coming back doesn't fix this.

    Anyway to get her to talk?
     
  16. Tiek68

    Tiek68 First time out of the vault

    21
    Jun 26, 2011
    Hello guys, can you tell me if in the Mega Mod there are the new animations for Leather Armor Mk2 and/or black combat armor? If not can you please tell me how to insert them or show me a link with instructions? Thanks in advance!
     
  17. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    In the Arroyo main map, there is a reserved item placed in one of the pots. (I suspect old Hakunin to be responsible for that, hehe.)
     
  18. Voron

    Voron First time out of the vault

    24
    Jun 11, 2008
    MIB88, Are you planing to add killap's Restoration Project in your mod in the next versions?
     
  19. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Does this occur every time you enter that map? Have you spoken to other people on that map? Try talking to her after talking to the Sergeant or the doctor on the underground level. Or wait a bit on that outside level with her. She is supposed to ignore you for a while. Then she is supposed to do her rounds inspecting the base. After her rounds, you can talk to her about other things. Another thing to check: Have you already been to the Klamath vertibird map?


    I have not added those other armors yet. If you want to add them, you would need to create new critters that use the art with either Fallout Utility for Critter tinKering or the official mapper. Then the new critter would need to be placed on a map using the official. It also means updating the critter.lst file to introduce the new art. Check this forum for a tutorial on creating new critters.


    I'm guessing that there is an item that was added to a pot/container via one of Nirran's mods: random loot. An item might have been added that was not really meant to be in the game yet. The thing to check is if other people also have the same bug. If it is just you, then it may just be the result of some random item like I said. If others also have this random item in the same container on the same map, then it is likely something I messed up. I won't be able to check it til I get my main computer back up. (Yeah, it's still down.)


    Yes... someday. Most of it, anyway.
     
  20. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Thanks for info, if anybody else is willing to check this meanwhile, I have found it right there:
    [spoiler:eef1a8e640][/spoiler:eef1a8e640] Just a FO2 clean install + MM2.44, nothing else added. Item was described "Reserved item. DO NOT USE IT"
    (Playing with PE7, LCK6)
     
Thread Status:
Not open for further replies.