Megamod 2.44 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. phillon

    phillon First time out of the vault

    79
    Jul 23, 2013
    I have played the megamod once before and enjoyed it tremendously. I just want to also say thank you MIB88 for all the time and effort you have put in to make this mod and add to our experience of this masterpiece that is Fallout 2. The itch to play F2 is in me again, and I would love to give the new version a go once you release it; I will also report any bugs I find to the appropriate resource. Thanks again for still supporting and refining this mod and keep us posted on your progress.
     
    • [Like] [Like] x 1
  2. Endocore

    Endocore Look, Ma! Two Heads!
    Modder

    365
    Mar 14, 2010
    In talking to Drobovik about the trapper script I posted here earlier, I found a bug in the script (trappers weren't correctly poisoning the Chosen One). Here's an updated version (the dialogue is the same, only the script is changed). The script is fully compatible with both the Megamod 2.44 and the RP.
     
    • [Like] [Like] x 1
  3. Endocore

    Endocore Look, Ma! Two Heads!
    Modder

    365
    Mar 14, 2010
    I want to do a little work on the MM feature whereby in a random encounter with slaves, the Chosen One can tell the slaves they're free (prompting them to run away) if their slavemasters are killed. I'm having trouble with one tiny detail, though-- I can't find the script or place where the map variables are set and sums are tracked for tallying how many slavers there are and whether all the slavers are dead. Does anybody know where is this particular snippet of code (map variable usage for slaver counts) is located? I looked at the likely suspects (random encounter map scripts, merchant, slave and slaver scripts) and just can't find it. Thanks in advance.
     
  4. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    Sorry for the long delay. I've been out of the country again and not really in a position to be messing around with the mod. Ok, here is the deal: Every random encounter map has a .gam file. If there wasn't one before, I created one in order to account for the new map variable of slavers/slave masters being killed. I figured there was no need to account for all of them. You only need to kill one, since, if you killed one, most likely you killed them all, or they ran away from your party because they were too wounded to fight. (In either case, the slaves would be available for talking and possibly capturing.) The map variable is set in the critter's destroy procedure as map variable 0. The slave scripts then only check to see if the map variable is greater than 0.

    I suppose if you wanted to account for each slaver, it would be pretty easy. Maybe in the critter procedure or map enter of the slavers/Den caravan masters/etc. scripts, you could add 1 to map variable 0 and subtract 1 when the critter is destroyed. Then, though, you would have to also change the condition for the slave dialog/capture scenario to be map variable 0 instead of greater than 0 like I have now. But, you would be out of luck if a slaver ran off the screen before you could kill him...

    What are you trying to do, by the way? Good luck.
     
    Last edited: Apr 3, 2014
  5. Endocore

    Endocore Look, Ma! Two Heads!
    Modder

    365
    Mar 14, 2010
    Thanks, and I hope all is well even if life is hectic. I haven't got back to actually scripting this slaver thing yet, but in the meantime my thoughts were leaning toward a more precise system as mentioned in your second paragraph above. The mvar counter can be reset to 0 on every map exit, and then each slaver critter's script can increment it in map enter on subsequent map loads. The "ran off the visible map" problem you mentioned is important, but shouldn't be insurmountable.

    I've been developing some pretty heavyweight characters lately as part of this rather grim Den-slaves-whores-drugs subplot I think I told you about before, but not every npc has to aspire to be a literary masterpiece. For the slaves I was thinking of just doing my usual basic stuff in the scripts-- more sex, more drugs, more comic relief, etc. :monocle:.
     
    • [Like] [Like] x 1
  6. phillon

    phillon First time out of the vault

    79
    Jul 23, 2013
    Hi MIB88. Just a question. I have been experimenting with 2.44 and noticed that f2_res (high resolution mod) does not seem to be fully installed in your mod; only the ini config file is there. The dll, configuration tool (exe) and dat files are not in the folder at all and I was unable to get higher resolutions working. What worked for me was just manually installing f2_res with basic mode (so as to be compatible with sfall). I just want to ask: is this intentional on your part, did you forget it or is there something I am missing perhaps? Will 2.45 and future versions have all the f2_res files included so as to make the mod work correctly? Or does f2_res mess up Megamod somehow by altering the exe at runtime in memory to support higher res (and that is the reason you left it out)? Any feedback is appreciated. Thanks.
     
  7. MSlavko82

    MSlavko82 First time out of the vault

    77
    Sep 16, 2009
    Hello! I just started new playthrough with MM, after looong time. Awesome mod, awesome game:clap:

    I have problem with combat damage. All guns do a little too much damage (both mine and NPCs). I deleted HS_Combatdamage, and HS_Tohit and it restores damage to normal values. However, I don't seem to score critical hits anymore. Even when I return HS files to their places, I never score criticals.
    I vaguely remember that last time I played MM (maybe 2-3 years ago, I think) I had the same problem, and I solved it by changing values in damage.ini file - values for critical hit to certain body parts say 40, 60, 30, and it worked when they were set to -40, -60, -30 (like in vanilla). Then it worked, but now it don't, because I still get no criticals. I tried removing damage.ini altogether, but that didn't helper. Any idea?

    Also, nice work on Klint, congratulations:clap:
     
    • [Like] [Like] x 1
  8. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    Yes, it was intentional on my part. You didn't lose any any files or mess anything up when installing it. I know that many people really enjoy playing at higher resolutions. But me... well, I guess I am just too old school. I haven't included anything really for the higher resolutions, unless they were map fixes or other files that others have sent me because they modded the MM. I just never really tried to fully implement the high resolution mod. Drobovik has been doing a lot of bug hunting, and he sometimes encounters issues as a result of the high resolution mod. However, with all the other bugs I have yet to squash in the MM, please don't let his discoveries stop you from adding it! :wink:


    I'm sorry, I have no answer for this. I will experiment with my own version now. I am getting critical hits. Hmmm... I wonder if you might have an old file laying in your data/scripts folder. Did you install the latest version alone? Or did you install it over a previous version of the mod? I will test my latest version and see if I can reproduce this.

    As for Klint, thanks. But what are you referring to exactly? Are you referring to getting him to work right and making him less of a tank that he was? Or, are you referring to the little spark of "life" that I tried to give him? If it is the latter, expect to see more of that with the other party NPCs in the future. I am already working on adding the newest version of Miria. My plan is to have the others have more floats, more dialog options throughout the game that come up after certain quests/actions/levels, dialog options that may lead to "missions" of their own (like Sulik's quest for his sister or Goris's return to the vault), changes to inventory when you leave them for too long in one location (you don't think they are just waiting around in the town in that one location doing nothing, do you?), etc. For example, I have ideas about what the other NPCs might be doing when you decide to get one of the implants in San Francisco that takes 3 weeks. I envision them going off, and trying to return when the process is completed. Who knows, though? Maybe one or more of the party gets thrown in jail for some rowdy behavior after a night of drinking? Or maybe they have made enemies of the locals, somehow, while you were undergoing the procedure? Like I've said elsewhere: I have pages and pages of ideas I would like to implement.
     
    Last edited: Apr 11, 2014
  9. MSlavko82

    MSlavko82 First time out of the vault

    77
    Sep 16, 2009
    I did clean install of latest version, and then installed fixes from Drobovik signature. I disabled weather mod, and when noticed how much damage guns do, I disabled those two HS_*** files. After some time I noticed I never score critical hits... I will check files manually, maybe I made mistake somewhere...

    Both:grin: He is working properly, and he is not crazy overpowered any more (actually, he is, because his healing abilities, but he is not a combat monster). And he doesn't behave like a bot any more. Really good work, I always though that Klint is beyond repair (playing earlier versions), but you proved me wrong.

    As for ideas, they are great, I hope you will find time to implement them all... I am guessing (and hoping) that you will never say: that's it, I implemented everything I wanted, this is final version, don't you?:grin:


    EDIT: I found a problem with critical hits. Apparently, with HS_CombatDamage and HS_ToHit I never get any critical hits. However, when I deleted them, I deleted damage.ini also, and I still didn't have criticals. When I put damage.ini in place, but without HS_f* files, criticals are working, and damage are normal. Why it behaves like that, I have no idea. Also, values in damage.ini for critical hits of certain body parts are positive (40 for head, 60 for eyes...), and for me, it works only when values are negative (-40, -60). In file it also says this is vanilla values (-40 etc), so I don't know why by default this values are positive. Anyway, it is working now, time to enjoy!

    MINOR BUG: on some maps I cannot access exit grid. For example toxic caves, there is plenty of area outside of cave to go around, but exit grid is missing. Bypass: in f2_res.ini set IGNORE_MAP_EDGES=0 to 1, then you can scroll around a lot, and access exit grid. Just in case someone else have same problem.

    EDIT: No, it is not so minor, but it is my mistake. I installed full f2_res mod. It messes up with some maps (Toxic caves and some caves (like ones you meet random raiders)). Without hi-res mod everything works properly. With it, some maps won't work well - even though I could exit Toxic caves, on some random caves map fighting is impossible because you cannot target properly. I guess some tweaking must be done for maps to work with hi-res mod. I tried myself, and I failed miserably, of course:cry:
     
    Last edited: Apr 13, 2014
  10. Vic_Boss

    Vic_Boss First time out of the vault

    17
    Jan 22, 2014
    What version of the f2_res mod are you using with the Megamod? I managed to get it working before, but I had my hard drive wiped, teaches me to save backups.
     
  11. Almaz

    Almaz First time out of the vault

    1
    May 16, 2014
    MM 2.44 i have some bugs:

    1. When green shit kill you in a Toxic Cave game have a bug with animation - you die like a soup (Like plasma gun finished) - game crashed;

    2. Have a error with Sulik`s Sister quest:
    - I payd Sulik`s debt and add him to paty;
    - Visit his tribe and done with ghost + firewood quests + have a speak with chief and Sulik - was sent to Metzger;
    - Metzger give Slaver`s camp coordinates (speech) (If kill him no one of slaves NOT give coordinate..?);
    In a Slaver`s camp:
    1). Slaver give me a key - but open only west Fence - guards attack me;
    2) If i kill all slavers (after/before key) - i can only open a west Fence and free slaves for 200 Exp. The east hut door only give a dialog window and leave.. or in buttle it`s give error and game crashed...

    3. Collyweb:
    Not work central quest (Grizzly John`s):
    - Leila, Humphry's girfriend say that she love Josie;
    - Josie said that he hate his brother;
    But i can`t does that they still alive, in any option..
    (they attack me with others)

    I try to Say Humphry about his little secret, join in gang (Cans), all times tolking with Josie (after return book and speech about books) - he doesn`t ask about gun..
    And in any options they atack me with other gang members..


    sorry for my bad eng. language :confused:
     
    Last edited: May 20, 2014
  12. diggerzz

    diggerzz First time out of the vault

    16
    Feb 2, 2012
    When to begin wait 2.45? :mrgreen:
     
  13. Mr.Taxman

    Mr.Taxman First time out of the vault

    5
    Jun 14, 2012
    I've encountered the same problem, after acquiring the key through speech, I go to the shack where sulik's sister is held, but the door refuses to open. It enters a dialogue box and says there are too many slavers around or something like that, the door is left close, further attempts result in the same dialogue box appearing. There is a guy with a dog patrolling around the shack, but I failed to kill them silently any way I tried, all slavers go hostile and I have to kill them. It's really frustrating because it eliminates the purpose of clandestine means to complete the rescue. I have left this quest alone after my initial failure, so I don't know what happens when I kill all the slavers, though reading this above comment doesn't give me too much confidence in a favorable outcome.
     
  14. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    Thank you for the bug reports and confirmations. I think I have this figured out. I've got the keys properly working on that hut door now. I've rewritten how a variable was checked and added a new global variable. I've tweaked the script for that roving guard, too. I will test the ability to kill that guard without causing the other guards to go hostile. And, I will add in code to prevent using that door during combat in order to prevent a crash. Using the stealth option to save Sulik's sister, you should not be able to open the west pen. In Don's dialog, he specifically tells you to get slaves from the pen inside the hut to the east. I need to test things a little further, but I think I have this area working properly, now.

    Edit: The more I think about it, I don't think a stealth kill for that guard should even be required. I think if you kill him, everyone should turn hostile.

    Edit: Code has been added to the door to prevent its use (and the dialog box) during combat, thereby preventing a possible crash.

    Working on these. The one about the message from the EPA when the leader is killed has been fixed. I cannot reproduce the error with either assault rifle causing a crash.
     
    Last edited: Jun 3, 2014
  15. tomato

    tomato First time out of the vault

    1
    Jun 6, 2014
    HI

    This error might have been answered, but I cant find any real solution to the problem and Iv tried looking around the forum, but seeing how big the support thread is for all versions of MM I figured that Id either ask for help or just forget about it.

    So I get the reference error when loading my game, 00459781 referenced memory at 00000064.

    I found a old thread that said that removing the obj_dude.ini fixes this, and it did, but it appears as crafting and the like wont work anymore. In another old thread someone suggested replacing obj_dude.ini with a older version from 2.42, so I downloaded the 2.42 patch and extracted it into another folder, but it didnt contain a obj_dude.ini file. Someone else referenced to a new dude.ini file that was created after the release of 2.44, but I cant find it anywhere on the forum.

    Is there a new solution that I have missed to this reference error? Or am I gonna have to play MM without the obj_dude_ini (and thus miss out on some of the new content?)


    Thanks!
     
  16. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    @tomato

    There was a separate obj_dude.int file floating around... check under posts made by either Drobovik or Endocore. Or, give me a few more days and I will release the latest version along with 2.45. I have a few more things I want to fix before the next release. Or, if I can find a decent file sharing website, I could just upload the obj_dude script there. I will do that if I am not ready to release version 2.45.

    And, for those who are curious, below is the change log from the 2.45 readme file.

    Changes/Fixes made since version 2.44 (With many thanks to Drobovik and Endocore):

    -Fixes to Klint
    ---He no longer appears in Arroyo if he is killed when helping the player character inside the Temple
    ---He should no longer become unresponsive to the player character
    ---Corrected instances where he would sometimes not rejoin the party if asked to wait
    ---Now immediately obvious to the player (through dialog) if Klint actually heals the player character
    -Addition of a new party NPC
    -Numerous fixes to party NPCs, Vault 14, New Reno, and other scripts
    -Removed the weather mod
    -Environmental armor now provides the same protection from toxic fumes as the gas mask
    -Numerous fixes to the Brotherhood of Steel scripts
    ---characters inside can now be meaningfully interacted with
    ---Dr. Steel delivery quest can now be completed
    ---quest to Den outpost now available
    -Updates and fixes to certain doors
    -Some trappers in random encounters interact a little differently
    ---slightly different in how they trade
    ---new options with regards to the player character, Davin, and Miria
    -Numerous dialog corrections
    -Removed scripts from more items, thereby eliminating the dreaded "too many items bug" that results in the
    missing Skilldex button
    -Added conditions to be able to wear/use power armors. (Take that, cheaters! :P )
    ---Maybe a certain item will allow you to wear power armors
    ---Maybe there is a level requirement
    ---Maybe certain NPCs can help you
    -No longer start with the Idolized reputation in Scraptown
    -Updates/fixes to the Skynet NPC
    ---dialog updates/changes
    ---should no longer forget his combat AI settings when loading a saved game
    -Player is now be able to complete the mission to kill all the spore plants at the EPA
    -Added a missing music file (from F1) needed for one of the maps
    -Included Drobovik fix for Marcus's voice regarding his use of weapons and armor
    -Added a new NPC to Arroyo created by Endocore
    -Modified the random loot script to eliminate chance of finding overly powerful items on unattended shelves
    (i.e. Advanced Power Armors, Plasma guns, etc.)
    -Fixed problem with the gecko appearing in the walls of the Toxic caves (Sajag quest
    for evil characters can now be continued)
    -Fixes to the Slaver Camp
    ---Sulik's quest to save his sister can now be completed
    ---The east building with the pen can now be unlocked
    ---Using the east pen door in combat will no longer crash the game
    ---Killing the leader no longer gives a message about the EPA
    -NPC Loot Bodies mod is working once again
    -Using the EPA information terminal while in combat will no longer crash the game crashes
    -Updated Vault-Boy picture used for Vertibird Pilot trait (from Russian Global Mod)
    -Corrected the downtown Redding map, where I had previously placed a number of fruit flies and cockroaches
    for testing. Those critters have been removed.
    -Fixed Vault 23 entrance map so you can no longer run through the elevator and beyond the map borders.
    -Using Pop rocks and soda now has the proper effect on the player character
    -Refusing to carry out English Bob's mission now has the proper consequence
    -Corrections to Myron and creation of stimpacks
    ---Myron can make stimpacks once again after teaching the player character to make them
    ---Myron can make super-stimpacks once again after teaching the player character to make normal stimpacks
    ---Myron does NOT teach the player to make super-stimpacks (just for clarification, this was never intended)
    -Corrected two instances in Vault 15 of critters with incorrect ammo types for the weapons they carry
    -Changed the frequencies of being able to obtain Metal Armor, Metal Armor mk II, and Tesla Armors from
    defeated enemies (chances of getting any of those armors was approximately 33%, but now the chances are 75%,
    20%, and 5%, respectively)
     
    Last edited: Jun 12, 2014
    • [Like] [Like] x 2
  17. bombic85

    bombic85 First time out of the vault

    19
    May 22, 2010
    New release is comming? Goody, goody!:clap:
     
Thread Status:
Not open for further replies.