No cursor for Fallout 2 played in DirectX Windower

Discussion in 'Fallout General Modding' started by pjlinfield, Oct 19, 2012.

  1. pjlinfield

    pjlinfield First time out of the vault

    5
    Oct 19, 2012
    I have a fairly specific concern here regarding Fallout 2, played in DirectX Windower v1.88 on Windows 7.

    After much study I managed to get everything going perfectly (finally resolved the rainbow colour issue), but now I have no visible cursor (in-game). When I start up the game in Windower, the cursor appears for a brief moment, but then it's gone for good. I can't even manage to load a game or start a new one because I have no idea where the cursor is. Any advice? Do I need a particular setting in Windower checked off? I'm finally back in the PC world after nearly 7 years with a Mac, so my technical skills are RUSTY. Any advice for this would be really appreciated.

    Much love,
    Peter
     
  2. Darek

    Darek is currently unavailable

    Jan 7, 2008
    What happens if you start the game without that windower program?
    And why do you use it? You can play in windowed mode if you get the Fallout 2 Hi-Res Patch, in case that's the only reason.
     
  3. pjlinfield

    pjlinfield First time out of the vault

    5
    Oct 19, 2012
    If I don't use the windower program, I have a lot of rainbow-ing and colour issues. I downloaded the Fallout 2 Hi-Res Patch, but when I open it up I get an error ("Fallout 2 executable cannot be found"). I don't know why it can't be found, as it's installed already. I did have to download a version of the game since my laptop doesn't have a disk drive (so I obviously couldn't install off the original disk), but I don't see why that would be a problem. Looks like all the files are there and the game does run. So basically the windower was a fall-back plan to correct the colour issue that I couldn't fix because the hi-res patch failed.
     
  4. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Well you have two options I can think of.
    You could get killap's unofficial Fallout 2 patch. That should give you a working fallout2.exe version I would think, and it's a good idea to get all the bug fixes anyway.
    Or you could download the manual install version of it, and only replace fallout2.exe from there.

    Or wait a minute, when you say "Fallout 2 executable cannot be found", is that from using f2_res_Config.exe? If so I think you simply have to put the hi-res files into your fallout folder before you run it and it should work.
     
  5. pjlinfield

    pjlinfield First time out of the vault

    5
    Oct 19, 2012
    Ahhh, clever man! Well, after moving the patch files into the Fallout 2 folder, I still get an error - An unsupported version of Fallout 2 was detected. I know that the Fallout game is v1.00, so perhaps I just need to update it with another patch?

    EDIT: Any recommendations on what version would be supported?
     
  6. Panzerkampfwagen

    Panzerkampfwagen First time out of the vault

    65
    Feb 15, 2010
     
  7. pjlinfield

    pjlinfield First time out of the vault

    5
    Oct 19, 2012
    Okay, so I got killap's patch off his site, and installed it. This HAS corrected the error I was getting from the Hi-Res Patch Config. But now I cannot enable the Hi-Res to correct the colour issue. At the bottom of the Hi-Res Patch Config it says: "Fallout 2 US v 1.02d / The Hi-Res Patch is Disabled." I can click the Enable button, but it doesn't change anything.

    I've tried switching all of the settings of the Config, but I still can't enable it for no apparent reason. I'm leaving everything as such:Graphics mode is at DirectX 9 / Windowed / Colours 32 Bit / Refresh Rate 60 Hz. I click Enable, and nothing happens.

    Thanks so much for getting me this close - any final changes I need to make?
     
  8. Darek

    Darek is currently unavailable

    Jan 7, 2008
    pjlinfield, I'm pretty sure you're FALLOUT2.exe is set to read only, so it can't be modified (probably your downloaded version was and when you copied over the newer one it kept that attribute). Stupid windows.
    What makes it even more stupid is that sometimes files can be write protected without windows showing it.
    So remove the read-only (or if it doesn't show, set to read-only and apply, then remove it again) and you should be able to enable the hi_res patch.

    If that isn't the problem then maybe it could be something like the game being installed to the programs folder (protected windows folder, fallout shouldn't be installed there), though I haven't heard of this specific problem before.

    I would also suggest you read the included readme file for the hi-res patch on how to set it up, if you haven't. It could be useful.

    EDIT:
    I just saw this in the hi-res thread...
     
  9. pjlinfield

    pjlinfield First time out of the vault

    5
    Oct 19, 2012
    Praise Allah! Thanks to your eagle-like vision and tax lawyer-like scrutiny of texts, the day has been saved! I was having the same problem as TEM - just needed to run it as administrator to enable it. What a glorious day for me! Haven't played Fallout 2 since 2006, where I ended up missing a full-week of university classes. I am so damn ready to get back. Thank you so much! You're the best.