RP 2.3.3 Error loading cities...

Discussion in 'Fallout RPG Gameplay & Tech' started by HorrendusPT, Dec 26, 2014.

  1. HorrendusPT

    HorrendusPT First time out of the vault

    17
    Dec 15, 2014
    Ok, i´ve been searcging the entire forum to find out how to fix this, but nothing.
    Found one post with one solution that worked at start: using the mapper fix. Done it and the "error loading cities" don´t show anymore and i was able to start the game but... got stucked in the begining of Temple of trials because could not move forward once entered it.

    Searched in other web pages for this error and it looks like to be related with sfall ddraw.ini. But even there i got no solution.

    I´ve done all steps for a clean and working instalation as it was recomended averywhere:

    - installed original version of Fallout 2
    - updated to 1.02 us version
    - installed RP 2.3.3
    - updated directx

    Nothing. Still cannot play rp 2.3.3 (last played was 2.1.2b without any kind of error)

    So, Killap, enyone... what to do to avoid this error and be able to play Rp 2.3.3????????????
    Saw a lot of people asking the same and seems no one knows what to do. Any help or i´ll have to wait untill other version of RP?
    Thanks in advance for anyone who can answer this and help.
     
  2. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    That means your system failed to load sfall (ddraw.dll + ddraw.ini), and using the city limit patch WILL NOT solve the true problem.

    There are several causes you can check:
    1. Your security software blocks sfall from getting loaded.
    2. You are using Vista or newer Windows with UAC enabled and install FO2 in "C:\Program Files" or "C:\Program Files (x86)" directory, which is protected by Windows. In this case, the ddraw.ini in your FO2 folder won't get loaded because ddraw.dll is forced to check your VirtualStore folder (C:\Users\<username>AppData\Local\VirtualStore\...) for the INI. If there's no INI for ddraw.dll loading in VirtualStore folder, sfall will use its default settings, and the number of world map slots (default 17) won't match RP's number (22).

    Some more details about your system & how you install your FO2 would be helpful.
     
    Last edited: Dec 26, 2014
  3. HorrendusPT

    HorrendusPT First time out of the vault

    17
    Dec 15, 2014
    Thanks NovaRain for your reply.

    I´m using and old pc with windows xp sp3, directx 9 updated (with a 32 mb graphic card) and 1 gb of ram.
    The game is istalled on "\program files" (default folder).
    Antivirus Bitdefender, wich i disconected to prevent any interference with sfall files.
    Used both RP exe install and manual install.

    I followed sfall recomendations and installed:

    - original fallout 2 1.0 version full instal (original cd) - also tried with fallout 2 1.02 (iso file emulated with daemon tools)
    - patch 1.02 us
    - rp 2.3.3

    I played all previous rp, from 1.0 to 2.1.2b without any problem.
    Sry, searched everywhere about this and can´t figure it out how to bypass this error.
    Also tried to chek out ddraw.ini sfall file to see if there´s anything to be changed there.
    Kinda frustrating...
     
    Last edited: Dec 29, 2014
  4. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    You can try installing official FO2 + US 1.02d patch (don't install RP) and sfall (just extract ddraw.dll & ddraw.ini, no need to edit the INI) first, see if sfall works with your FO2. If sfall gets loaded correctly, there should be "SFALL 3.4a" string on the bottom right corner of main menu, and you can press shift in game to highlight items on the ground. If no, try older version or win2k version.
     
    Last edited: Dec 29, 2014
  5. HorrendusPT

    HorrendusPT First time out of the vault

    17
    Dec 15, 2014
    Done. The game loads and work normally, but on main menu just show "Fallout II 1.02".
    At first it crashed to desktop untill i turn off my anti-virus, than it keep stable amd working as it works on it´s original way.
    Already used sfall 3.4 with rp and same error.
    Gonna try instaling in different directory (programs instead of program file and see if anti virus still works on background after turning it off).
    I read somewhere to overwright ddraw.ini and keep the ddraw.dll from rp...

    Thanks for your time, much appreciated. Tomorrow i´ll try it better and tell more.
     
  6. HorrendusPT

    HorrendusPT First time out of the vault

    17
    Dec 15, 2014
    ok, tried other versions of the game, with and without patch, and instaling in diferent locations.
    Also make a clean instalation deleting the old reg files on the registry before install it.

    After several tries i figured what the problem might be... after instaling the rp the game only works in compatibility mode (something that don´t happen in previous versions of rp) and seems Sfall files don´t work with compatibility mode. So looks like the problem is the RP itself...
    Too bad we only have here rp 2.3.3 for download. Previous versions should be available also. I would like to try with rp 2.3.1...
    I let this recomendation here to keep in the download zone previous versions of rp.



    P.S.: PROBLEM FIXED!
    Indeed the problem was loading the game on compatibility mode, so i tried something - changed the fallout.exe, ddraw.ini and ddraw.dll from the RP .exe vertion for the same files on the manual install from "Windows NT-2000" folder.
    Kinda weird since i´m using windows xp sp3, but it solved the problem.
    With the files from Windows NT-2000 folder from the manual instal the RP 2.3.3 runs just fine (now it shows the RP 2.3.3 and sfall 3.4 at right corner on main menu).
    Thank you again NovaRain for your time. Hope this may help other people who have the same problem.
     
    Last edited: Dec 29, 2014
  7. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    It looks like only win2k version of sfall (ddraw.dll itself) works on your system, weird. RP doesn't need to be run on the compatibility mode.
    Could you test the newest build? See if the "normal" version works on your system (if no, try win2k version, it should work like the dll you extracted from RP 2.3.3 manual install).
     
    Last edited: Dec 29, 2014
    • [Like] [Like] x 1
  8. HorrendusPT

    HorrendusPT First time out of the vault

    17
    Dec 15, 2014
    It´s really strange ´cos all RP previous versions and original FO2 (with or without patches) work perfectly with my win Xp sp3 OS. Only the RP 2.3.3 don´t, it works only with compatibility mode (not compatible with Sfall files as i read on Sfall page).
    Only replacing the FO2 .exe file and sfall files with the windows NT-2000 version from the folder of the manual install. I believe the problem was on Fallout2.exe file instaled with the RP 2.3.3...
    I was using the sfall2k 3.4.7z but since it only worked in compatibility mode, the "error loading cities" was always there.

    Now with win NT-2000 version i´m playing it perfectly, without compatibility mode, with sfall 3.4 version. Until now, no bugs, no crashes, all goes perfectly, even with anti-virus on.

    Strange thing is that the files from folder "windows xp, vista" on the manual instal didn´t worked also - same asking for compatibility mode. Only the "Win NT-2000"

    I´ll try the latest version to see if there are any changes. But right now, as i said, it´s working perfectly :smile:
     
    Last edited: Dec 30, 2014
  9. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Actually the fallout2.exe in both NT-2000 and XP-Vista-7-8 folders are the same file, at least their CRC checksum are the same.
    Just don't set any compatibility mode for fallout2.exe in the properties.
     
    Last edited: Dec 30, 2014