Fallout 2 utility [SOLVED] FRM2GIF Colour Issues

Discussion in 'Fallout General Modding' started by Cory Macdonald, Feb 1, 2017.

  1. Cory Macdonald

    Cory Macdonald First time out of the vault

    17
    Sep 12, 2016
    Hello,

    I've been recently working on an FO2 mod, and just realised that much of my resources have colours that are off, by which I mean, brighter than the colours of the original game. After some testing, I believe I have narrowed the error down to something with my frm2gif program. I know I had solved it earlier, as I have a few resources that are coloured correctly, but I cannot remember how I did it. Any assistance in getting these colours correct is much appreciated.

    Thank you.
     
  2. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    279
    Oct 29, 2015
    use original color.pal file from fallout2. other used palette will lighten the picture.
    frm2gif.exe -p color.pal file.frm
     
  3. Cory Macdonald

    Cory Macdonald First time out of the vault

    17
    Sep 12, 2016
    Can you tell me where to locate the original file? The file that came with my copy of the tool clearly isn't right.
     
  4. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    You should be able to get it from master.dat with DAT explorer.
     
  5. Lexx

    Lexx Background Radiant
    Moderator

    Apr 24, 2005
    It's also included in the FrmAnimator, for the lazy ones.
     
  6. Cory Macdonald

    Cory Macdonald First time out of the vault

    17
    Sep 12, 2016
    Yeah, I initially thought the problem was with the palette that comes with the program. Either way, both palettes come out incorrectly.
     
  7. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    279
    Oct 29, 2015
    Download in my signature F2_ProtoManager, in archive is color.pal & frm2gif.exe this is exactly correctly converts graphics. (The program itself uses them).
     
  8. Cory Macdonald

    Cory Macdonald First time out of the vault

    17
    Sep 12, 2016
    Well, tried that too. Left to right is the original, a file sent through my frm2gif, a file sent through Mr. Stalin's, and a file sent through Mr. Stalin's with the -p color.pal. As you can also see from the doors, this wasn't a problem previously. The three wall files have been converted to gifs, then directly back to FRMs with no modification.
    https://1drv.ms/i/s!Avdn_MmHaPOuhPdeorFkUoUms8Xw3Q
     
  9. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    279
    Oct 29, 2015
    you're right, frm2gif slightly lightens the picture. then, after converting, change indexed palette in photoshop on the original (below pallete for photoshop).
    or convert to another format, or use the viewer titanium frm browser 1.3 for manual conversion to gif
     

    Attached Files:

  10. Cory Macdonald

    Cory Macdonald First time out of the vault

    17
    Sep 12, 2016
    I've just tried with Photoshop now, didn't work:
    https://1drv.ms/i/s!Avdn_MmHaPOuhPgFhmd9j5ke2iWTag
    The first door is the original, second is straight through frm2gif, third is via Photoshop with my palette from Frame Animator, and the last is with Mr. Stalin's. His palette does contain more colours (256) than mine, which has only about 226. The end wall is also Photoshop with Mr. Stalin's palette. I've also just tried Titanium, however I get the error "Failed to set data for '" and the program GUI loads, the buttons react to being pressed, but that's about it, the FRM doesn't appear. I do believe I used to be using frm2bmp, but I can't find that anymore.
     
  11. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    279
    Oct 29, 2015
    230-255 used for engine animation color.

    in help frm2gif have the option of brightness, by default it is equal to 40, need use 0
    correct use. :dance:
    frm2gif -b 0 -p color.pal file.frm
    scr00035.png
     
    Last edited: Feb 7, 2017
    • [Like] [Like] x 2
  12. Cory Macdonald

    Cory Macdonald First time out of the vault

    17
    Sep 12, 2016
    Yep, brightness set to zero has it working. Thank you very much!