Tutorial: forcing affinity on Fallout 2

Discussion in 'Fallout General Modding' started by gustarballs1983, Mar 2, 2019.

  1. gustarballs1983

    gustarballs1983 Where'd That 6th Toe Come From?

    453
    Oct 28, 2009
    Hello and welcome..

    We all know Sfall or so called ddraw.ini has a function called SingleCore=1 which forces Fallout 1 or 2 to run on the first core of our processor. Unfortuneatly first core is utilized most heavily by almost everything we have in our system any other app written to use up to DirectX 11 does so. So how about forcing Fallout to run on a different processor core than the first one but still limit it to 1 core?

    Simply put go to desktop and right click on empty space choose new => shortcut. a window will pop up where you need to put in: cmd.exe /C start "aplication name with quotes" /affinity # "full path to fallout's executable"

    # is a specific core number taken from binary where firstmost to the right is cpu0 and firstmost to the left is last cpu we have. Best to look up te task manager's "set affinity" to check how many we have now let's say we have 4 core cpu so it's: 0000 . 0 is a state of not used cpu and 1 is used and for fallout we need to use only one so it's eigther 0001 or 0010 or 0100 or 1000 and so on for more cores. the # value is hexadecimal value of this binary number so in order we use only one core we set:

    #=2=CPU1=second core only
    #=4=CPU2=third core only
    #=8=CPU3=fourth core only
    #=10=CPU4=fifth core only
    #=20=CPU5=sixth core only
    #=40=CPU6=seventh core only
    #=80=CPU7=eigth core only
    #=100=CPU8=nineth core only
    #=200=CPU9=tenth core only
    and then there's more 400;800;1000;2000;4000;8000;10000... and so on fro more cores

    For example Fallout2 located at C:\GoG\Fallout2\ and we want Fallout to run on CPU3 = 4'th core

    so in this shortcut we put in:
    cmd.exe /C start "FALLOUT2.EXE" /affinity 8 "C:\GoG\Fallout 2\fallout2.exe"
    click next
    change name it says cmd.exe change it to: Fallout2.exe
    click finish.
    You will have shortcut with command prompt icon. right click it and select prperties.
    as you can see Target window looks like this:
    C:\Windows\System32\cmd.exe /C start "FALLOUT2.EXE" /affinity 8 "C:\GoG\Fallout 2\fallout2.exe"
    leave it as is.
    Next change the field: Start in:
    from: C:\Windows\system32
    to: "C:\GoG\Fallout 2\"
    next click change icon and find your Fallout2.exe and click it choose vault bou icon. click Ok. then apply. voila shortcut ready.

    Now remember in order for the shortcut to have any use you must change ddraw.ini SingleCore=1 to SingleCore=0 as "1" in that field will always yeald affinity set to CPU0 (core 1).
    After setting in ddraw.ini SingleCore=0 You can launch the shortcut and alt tab to windows press alt+ctrl+del choose task manager and click set affinity to check wether You haven't made any mistake and Fallout2 runs in desiered core.

    Hope it helps somebody.
     
    • [Rad] [Rad] x 2