Fallout 2 utility Exit Grids Properties Change Incorrectly

Discussion in 'Fallout General Modding' started by Cory Macdonald, Jan 2, 2018.

  1. Cory Macdonald

    Cory Macdonald First time out of the vault

    Sep 12, 2016

    I've been putting together a map in the FO2 mapper, and I'm trying to get an elevator system working, where an elevator on elevation 0 goes to 1, the two elevators on elevation 1 can go to 0 or 2, and the elevator on elevation 2 goes to 1.
    And, when I adjust the properties of one elevator, by going into Set Exit Grid Data, typing into that, and then turning on Mark Exit Grids, clicking the correct elevator, pressing escape, saving, and testing, I find that it's adjusted the properties of both elevators, not just the one that I had clicked on in Mark Exit Grids. It's not changing the properties of another exit grid lower down on the map, which still works just fine every time though. I have also ensured that it doesn't place you on the exit grid of the next elevation when using these. Any help in getting these working properly, or another way to create elevators, would be much appreciated.

    Thank you.
  2. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    Oct 29, 2015
    Mark Exit Grids - Marks all nearby exit grid.

    Make the more distance between two exit zones, and mark them again, then move them back.
    You can use the Dims mapper and manually set parameters for exit grid.
  3. Cory Macdonald

    Cory Macdonald First time out of the vault

    Sep 12, 2016
    I couldn't get Dim's mapper working, an issue with loading proto files as far as I can gather. Also, I couldn't work out how to move tiles, as the copy function doesn't work on exit grids, however I did manage to solve the problem in a rather improvised way, thanks to the information that it marks nearby exit grids.

    Instead of marking the grids I needed, I added two more grids to either side of them, and marked those appropriately, which was far enough away so that both elevators weren't affected. After that, I could just delete the spare grids, and the elevators now both work fine.

    Thank you for that information! However, since you're there, might you provide some assistance on fixing that error with Dim's mapper? Specifically, I get:
    Need PRO file for ObjType = 2, ObjID = "155
    As the last line on the log file.
    Last edited: Jan 3, 2018
  4. Lexx

    Lexx Background Radiant

    Apr 24, 2005
    You could as well just make them real elevators and not use exit grids at all. Or you just put down spatial scripts, which can do pretty much the same.
  5. Cory Macdonald

    Cory Macdonald First time out of the vault

    Sep 12, 2016
    I have no idea how either of those work, but I'll look into them, thanks!
  6. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    Oct 29, 2015
    Try using the updated version of Mapper 0.99.3, maybe there will not be this error.
    although there may be a problem in your files, not in the Mapper.
  7. Zaius238

    Zaius238 Sunburn

    Jul 14, 2007
    Sorry for going a little out of topic, but I installed the updated program in my machine.
    I use some of your other stuff, like Proto editor (very handy), so I wanted to check that out, as well. Unfortunatelly it keeps giving me an error message, every time I try to run it (v0.98c works).
    "The ordinary 11 could not be located in the dynamic link library". I tried redownloading the file and changing the installation folder, but to no effect.
    I'm using Win 10 Pro, 64-bit.
    While I can use the BIS mapper, there's some nice features in the fan-made one, like editing maps in window, instead of fullscreen.

    A little hand, please.
  8. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    Oct 29, 2015
    Version v0.99.3 is based on the latest source code v0.99.1 (2011). Compiled code is very different from v0.98c (2003)
    You need to check the version v0.99.1 on your system, if it does not work, it means the program is not supported on win10.

    ps: On my win7 64 it works.
  9. Zaius238

    Zaius238 Sunburn

    Jul 14, 2007
    It seems my machine won't be able to run your version, properly, but thanks for replying Mr.Stalin.

    After hours with the PC turned off (while I was sleeping), I tried using the program (mapper2.exe) today, to edit some random encounters. Oddly, it opened this time, but trying to open the .map files always brought issues to the program, I was never able to load a file.

    From mapper.log:
    A page at teamx(dot)bgforge(dot)net implies it happens for users without DirectX (DirectX 7 at minimum).
    I'm not exactly thrilled about messing with my updated DirectX files, so I'll have to say 'no' to that idea. Not worth it, to me.
    Being able to run BIS mapper and the oldest version of Dim's mapper is not an issue to me.