Fallout 2 mod Fallout 2 Restoration Project 2.3.3 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 5, 2014.

  1. burn

    burn Still Mildly Glowing
    Modder

    Apr 22, 2012
    Launch install as administrator
     
  2. Shrimapan

    Shrimapan First time out of the vault

    May 18, 2016
    The error you saw was given to me while i ran the launcher as administrator
     
  3. burn

    burn Still Mildly Glowing
    Modder

    Apr 22, 2012
    Try disabling antivirus, maybe. It's some permission issue... or maybe you just don't have enough disk space?
     
  4. valcik

    valcik Sonny, I Watched the Vault Bein' Built!

    Dec 20, 2008
    Seems that RP installer cannot overwrite your gog-version included ddraw.dll file for some reason. Try deleting the file manually before installing RP. /edit: Or just rename it to ddraw.bck or something
     
  5. iron_bird

    iron_bird First time out of the vault

    May 7, 2017
    I'm having problem with npc's. After they level up I save the game, then reload from saved game and their progress vanish - their stats go back to lvl1. Besides RP I have installed also mod 'The lands of Mordor'. Does anyone met with such issue before or know how to fix my problem?
     
  6. Anonymous

    Anonymous First time out of the vault

    May 9, 2017
    experiencing crash in the NCR while trying to talk with Saltbeef about map (suggesting alcohol) :-/

    F2 1.02.31 RP 2.3.3 sfall 3.8.3 win2k
    PC's: win XP x32 & win8 x64
    save game: we.tl/HtFeOqMHD6
     

    Attached Files:

    Last edited: May 9, 2017
  7. NovaRain

    NovaRain Casual Modder

    Mar 10, 2007
    You need to update sfall to 3.8.4. There's a serious bug in 3.8.3 that will crash the game when scripts try to remove items using certain ways.
     
  8. JaW

    JaW Still Mildly Glowing

    Oct 1, 2006
    Hi, is it recommended to install the latest sfall (ddraw.dll) for RP 2.3.3 or is the version 3.3 (included in RP installation) bug-less with this mod?
     
  9. Anonymous

    Anonymous First time out of the vault

    May 9, 2017
    yes, that fixed the crash, thanks, NovaRain

     
  10. Gedna Relvel

    Gedna Relvel Bard and Lycanthrope

    May 16, 2017
    Hi. I just installed fallout 2 with the restoration project, when lauch the game, at the initial screen it shows;

    Fallout II 1.02.31
    RP 2.3.3
    SFALL 3.3a

    What is SFALL 3.3a? another mod or part of the restoration project/patch ?
    Thanks.
     
  11. burn

    burn Still Mildly Glowing
    Modder

    Apr 22, 2012
    It's an engine mod used by RP. You don't need to worry about that.
     
  12. bronsonfu

    bronsonfu First time out of the vault

    May 24, 2017
    Having an odd problem. I'm trying to use the Custom Perks script found on this page http://www.nirran.com/Fallout2Scripts.php. When I put everything into my fallout 2 folder and play the game, whenever I get into combat I end up attacking myself instead of the giant ant enemies. I tried setting the options in the CustomPerks.ini file provided to setting 2 (Restoration Project setting) to see if that would change anything but sadly no difference. Any ideas why this is happening? The other script I'm using from that link (Experience Multiplied) seems to work fine so I'm not sure what step I'm not following properly for the Custom Perks script.
     
  13. systems_vehicle

    systems_vehicle First time out of the vault

    May 25, 2017
    I'm trying to run Fallout 2 RP on Ubuntu 15.10 using Wine, with RP installed over GOG.com's FO2 installation.

    My first install worked in windowed mode. I so wish I'd counted my blessings and stopped tinkering there and then. Instead, dissatisfied with running it in windowed mode, I wiped .wine prefix and started afresh, since when I've repeatedly fallen at the load screen with error

    wmAreaInit::Error loading Cities!

    I run it in the Ubuntu terminal from the ~/.wine directory as suggested in F2RP Technical Info

    winedlloverrides="ddraw.dll=n" wine fallout2hr

    My screen resolution in f2_res.ini and ddraw.ini is identical; graphics mode in ddraw.ini set to 4, dx9 libraries installed; winecfging fallout2hr.exe makes no difference (win compatability on/off; emulation; whatever). I just don't know.

    I did get error messages in the terminal relating to Gallium at one point (this is my fifth or sixth clean install, second reformatted OS install).

    Sys specs:

    ubuntu 15.10
    HP Pavilion Notebook
    Processor: AMD A8-7410 APU with AMD Radeon R5 Graphics x 4
    Graphics: Gallium 0.4 on AMD MULLINS (DRM 2.43.0, LLVM 3.6.2)
    64-bit

    I did emulate 32-bit using PlayOnLinux without success and after similar tweaking about.

    I've also tried adding and removing the recommended installing wine prefix libraries with winetricks and adding/removing to/from the fallout2hr app's override; native list in winecfg. No change.

    If somebody can find the time to point me at or walk me through a fix or a functional install I promise to nod appreciatively in their direction.

    I'm posting from my phone ATM, but can upload / paste .dll and .ini upon request.

    Thanks.
     
  14. bronsonfu

    bronsonfu First time out of the vault

    May 24, 2017
    I ended up getting in contact with the creator who wrote the script and he was able to help me directly. In the end he sent me a new version of the script and it ended up working with the restoration project just fine! I've attached the files for his script just in case he doesn't get the chance to update his website.
     

    Attached Files:

  15. Makta

    Makta The DICKtator

    Jul 29, 2010
    Decided i wanted some mods for Fallout 2 but not the extras from the RP. Is it possible to just install some of the extra content like animations and such? Found the mods but at least 1 of those i wants haven't been updated besides in the RP.
     
  16. burn

    burn Still Mildly Glowing
    Modder

    Apr 22, 2012
    Yes you can extract parts (easier from manual install pack), but you have to know which files exactly do you need.
     
  17. Makta

    Makta The DICKtator

    Jul 29, 2010
    About that... :scratch: Too bad there wasn't an option to use the installer for this.
     
  18. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    I could try to help. What parts of the RP are you interested in?
     
  19. Makta

    Makta The DICKtator

    Jul 29, 2010
    That would be great!
    Difference apperance for your char.
    Better world map
    Party change apperance. The axtra armors for Marcus etc is not needed.
    New boxing apperance in New Reno
    Quick de-robeing for Goris
    Cassidy Talking head + voice.

    Also wasn't the mod for Miria and Dave "?" in the restoration project? Or am i remebering something wrong here. Seems like the old one i used back in the days is not working anymore.
     
  20. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    The various spouse mods have never been a part of the RP, and are not compatible these days (although they used to be).

    Appearance mod for the hero is easy to put in. Just some art folders and the rest should be handled by sfall. Worldmap too. I think the Goris animation is just an edited .FRM, so that should be really easy.

    The boxing model is a bit more challenging. The way this is done is quite nasty, the game gives you an invisible armor and keeps track of it with a global script and in OBJ_DUDE.ssl. I'll have to recompile nearly every script in the game because they're almost all touched by NEWRENO.h in some way.

    Then there are the NPC appearances and Cassidy's head which also require fiddling with their scripts. Cassidy will pretty much need the one from the RP. I really hope he doesnt have any references to the Abbey because of the heart pills.

    So in short, I'll need you to tell me exactly which mods you'll be using, and then I can edit their scripts to jam in the stuff you want. But Goris, the worldmap and the hero appearance should be okay on its own.