Fallout 2 mod Fallout 2 Restoration Project 2.3.3 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 5, 2014.

  1. Schezza

    Schezza First time out of the vault

    Sep 7, 2013
    visited tanker merchant already 20 times, still he's got no jet anticure. bug or worst terrible rng? judging from my experience, antidote pops up every 4th run.
    Last edited: Jul 31, 2014
  2. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Jet Antidote only appears in his stock after you found the cure, with 30% chance to stock 1~3 antidotes.
  3. dossantos

    dossantos First time out of the vault

    Oct 14, 2011
    Is the perk "Bonus H&H Damage" working? I chose it and the melee damage stayed the same, i thought it was supposed to increment it, at least it did with the GOG version without the Restoration Project.
  4. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    It has been. It now behaves the same way as Bonus Ranged Damage, which adds the +2 damage during the calculation. Just doesn't show up in the inventory with only weapon max damage increased.
  5. SilveradoNL

    SilveradoNL First time out of the vault

    Jul 19, 2014
    I found a tiny bug, but im not sure if this is the correct location to post this.

    When talking to Steve (Town Greeter) in Broken Hills, he tells me to put away my weapons before talking to him (which i did).
    The only way to get him to talk to me is by telling all my companions to wait.

    Seems the game is not just checking the player for equiped weapons, but also the followers.
  6. phobos2077

    phobos2077 Mildly Dipped

    Apr 24, 2010
    Don't know where else to post it, but my BIS Mapper keeps crashing when I try to open EPAMAIN1 or EPAMAIN2 maps. All other maps (including EPASL, EPAX) are working fine. Using latest hi-res patch and city patch.
    Do I need some additional EXE tweaks to open those two?

    Tried everything I could think of: clean RP installation, map files from RP 2.1, using original mapper EXE from 2002 with only city patch, different mapper2.cfg options, deleting .EDG files... Nothing works. There has to be a way killap created those maps :)

    Solution, thanks to NovaRain: art_cache_size=256 in mapper2.cfg
    Last edited: Aug 3, 2014
  7. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    My BIS mapper (with hi-res & city patch) is able to open those two maps normally, but I'm not sure why your mapper crashed. :\
  8. Mirak

    Mirak First time out of the vault

    Jul 17, 2010
    That's not a bug, it's intentional. You don't have to tell your companions to wait, just tell them to holster their weapons. Same goes for Vault City.
  9. Matthews

    Matthews It Wandered In From the Wastes

    Aug 29, 2012
    And NCR as well, to my knowledge. Made that mistake a few times to have my guns out, didn't end well for me. As he said, it be intentional as not everybody is feeling that safe with gunwaving adventurers around, who could potentially be raiders.
  10. Flamekebab

    Flamekebab First time out of the vault

    Apr 17, 2003
    This is probably some basic issue that everyone else solved long ago. I'm running the GoG version on my Mac. I've installed the RP and the high res patch. Things have been working fine so far but as soon as I try to visit The Den I just get a black map. I can move around it and the interface is there but it's just a blank, empty map.

    I'm guessing it's something to do with making sure certain folders or files are read-only but I'm really not sure where to look on that front. Marking too many things as read-only stops my saves from loading.

    Is it related to the case-sensitive nature of *nix operating systems by any chance?
  11. phobos2077

    phobos2077 Mildly Dipped

    Apr 24, 2010
    Found a bug in random encounters definitions for FRAN_Mercenaries and FRAN_Elronologists. Those crazy woman with 8 plasma grenades? She can't throw them. She basically hanging over powerful loot to you.
    Suggested solution: replace both PIDs with 16777257 (Tough Guard) and bump Throwing skill for those ladies.
  12. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    The Hubologists do throw those plasma grenades during my playthrough, and with some luck one can kill multiple NPCs stay close to me in one turn.
    But for some reason the female mercenary doesn't throw those grenades.
    Last edited: Aug 6, 2014
  13. phobos2077

    phobos2077 Mildly Dipped

    Apr 24, 2010
    It's because of their critter FID. I learned during my experiments: to give a critter some weapon, you need to first check if he has appropriate animation to wield it and if he has enough skill. Those women mentioned above can't throw anything and their throwing skill is strikingly low.
  14. Schezza

    Schezza First time out of the vault

    Sep 7, 2013
    and I thought they don't throw em because I don't have highest combat difficulty, I'm too lazy to test though.

    Too lazy again, Roboiog and Skynet don't have levels in the wiki. No Levelups confirmed?
  15. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    They do have levels, 4 for robodog and 5 for Skynet (cyberbrain only).
    Just because wiki doesn't have data, doesn't mean they have no levelups. Check DATA\Data\party.txt for NPC levels.
  16. Schezza

    Schezza First time out of the vault

    Sep 7, 2013
    Thx, you live on this forum, don't you? :P

    Man.... that freaking dexter just oneshot my 446 hp, what a scumbag

    I don't get old games. How can it be that like diablo Hellfire or other old games, even a freaking amiga 80s game, or Fallout get stretched from 800x600 to 1920x1080 and it looks amazing, but when you try to take an ingame screenshot, or use windows screenshotfunction or try to record the game via streaming software, it all ends in a horror???
    Last edited: Aug 7, 2014
  17. phobos2077

    phobos2077 Mildly Dipped

    Apr 24, 2010
    Found another problem with Script Sources. It's not an actual bug, but... Looks like NPC armor appearance mod is "disabled" (commented out) in all party member scripts. Since this is a default option when installing RP, I think it might be a good idea to enable this code in the scripts. Or otherwise add all versions of scripts to the Sources archive. OR (what I would do) just mention all such nuances in rp-source-readme.txt.

    PS: To toggle the mod on or off I would've used something like .INI setting or .MSG string ({0} - disabled, {1} - enabled, something like that), instead of compiling separate sets of scripts.
  18. lujo

    lujo Look, Ma! Two Heads!

    Jun 14, 2013
    Also, the "control party members in combat" option is stil using the old non-working command in the ddraw so you have to manually add the new command which is "ControlCombat=2" to ddraw. Should probably update that, too.
  19. teukros

    teukros It Wandered In From the Wastes

    Sep 5, 2010
    Here is something. It seems that the splash screen displaying feature of the hi-res patch is non-functional.

    (Does it work for ANYONE using the default 2.3.3 installation?)
  20. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    It works for me, with SPLASH_SCRN_TIME=10 I have to wait 10 sec for opening movies.