FO2 restoration project seems to have some old bugs that arent fixed...

Discussion in 'Fallout General Modding' started by Question2, Jun 24, 2017.

  1. Question2

    Question2 It Wandered In From the Wastes

    Jun 20, 2017
    I thought the restoration project was supposed to contain the unofficial patch? There are some old bugs that i remember being fixed in my patched playthrough which didnt have the restoration project years ago.

    For example :

    -When you throw the landmine down after Lloyd, you lose karma but for some reason you cannot climb down into the fallout shelter.

    -When you tell Renesco that you will pay Salvatore in exchange for a "discount", you can say that you will make your "purchase now" but all his goods are still at full value instead of $0.

    Not sure if this is a bug or not, but the wiki says that leather armor mk2 is sold at modoc/vault city, but i cannot get the shopkeepers to stock it, they NEVER stock it. Vault city never stocks doctor bags either.
     
  2. Question2

    Question2 It Wandered In From the Wastes

    Jun 20, 2017
    Anyone have the links to the other unofficial patches? They dont appear to be in the downloads section anymore...
     
  3. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
  4. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    The Fallout shelter is not a bug, but you have to use the Move cursor and step onto the hex where the grave is. "Using" the grave will not work.

    I did the quest with Renesco yesterday. He doesn't give his stuff for free, but I think he does give you a huge discount Not 100% sure about this one, you may be right.

    Leather Mk2 is definitely stocked in Vault City (Happy Harry's), not sure about Modoc.
     
  5. Question2

    Question2 It Wandered In From the Wastes

    Jun 20, 2017
  6. Question2

    Question2 It Wandered In From the Wastes

    Jun 20, 2017
    I have checked all vault city shopkeepers over a dozen times in my current playthrough. No leather armor mk 2. There was no discount in my playthroough when i did the renesco thing...stimpacks costed me $196 each before and after the dialogue line. And every single time i go back to him, he does the "Who the hell are you?" line which is strange...maybe a scripting error?

    Some other stuff I noticed with the restoration project :

    -Darion in vault 15 simply runs away after combat begins, even thouh he has a flamer. Maybe his model doesnt have animations for big guns, which is why he doesnt use it?

    -Chad initiates combat after discovering you searching his dresser, but then he runs away instead of fighting you. Same reason as Darion maybe?

    -If i try to leave a map without the car, i end up on the world map driving the car. I have to leave a map multiple times without the car to properly end up on the world map without the car. I once did a caravan run from redding to NCR, and when i left the NCR, i ended up on the world map with the car when i had parked the car at redding before the caravan run...

    -After helping Mom in the den with the oprhanage, the kids still do the steal animation everyitme i walk past them. Mom doesnt have anymore dialogue options about the orphanage either. Not sure if this part is just unfinished or something else.

    -The wiki says that big jesus mordino will give you a job if you are in combat or power armor, i wore combat armor but the first time round he simply refused to give me a job, told me to leave, then initiated combat. I had to reload the save and got the job the second time round.

    -Stark permanently has the "about the raiders..." line even after you have finished the entire questline and delivered westin's reply to lynette.

    -After getting the combination to Bishop's safe from Mrs Bishop, I tried to open the safe then triggered the trap. If i disarmed the trap, i still had to lockpick the safe instead of opening it with the safe combination.

    -The wrights flip out if you try to check any of the containers in their mansion, but somehow Mr Wright doesnt mind you picking the lock on his safe while he is in the room...

    -I take damage everytime i try to use the ladder leading to the power generator room outside the sierra army depot, but there is no "you triggered a trap" message, i simply take damage, and the traps or whatever is causing the damage never runs out.

    -When repairing some of the robots in the sierra army depot (to disable them), instead of 200 xp for disabling them, i get 75 xp for "completely repairing the robot".

    -Many bugs with the sierra army depot alarm system...triggering the alarm on level 1 via the terminal will cause the red lights to flash, but all the robots will remain friendly and the walls do not open. This is the same on all levels. The only way to open the walls seems to be to deliberately use the retinal scanner with your own eye.

    -The sentry bots on level 2 of the sierra army depot do not appear to have any weapons, at least the ones in the storage area with the loot containers. I triggered the alarm, they charged out of the storage area, but just tried to melee me to death and didnt fire any weapons at all.

    -A floating eye bot on level 4 keeps teleporting to right infront of the bio storage room everytime i enter the level, instead of staying in its recharging receptacle.

    -I can see a robo brain on level 4 stuck in the northern part of the map, even though there shouldnt be any walls in the northern area. Its behind the sentry bot to the north.
     
  7. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    VC leather armor:
    Have you checked all the Stuff on Harry's tables? A lot of shopkeepers have different inventory depending on whether you try to Use one of their tables, talk to them and ask to trade, or press the Barter button in the interface.

    Chad and Darion running away:
    Do you have a very high AC, or are you playing on Easy combat settings? Enemies will run away if they don't think they have a reasonable chance to hit you. Vault 15 in general is a bit bugged, see the link in my signature for a fix.

    Leaving the map without the car puts you in the car:
    This is a feature of the base game, not changed by the RP.

    Mom orphanage:
    The kids will disappear entirely when you complete this quest. Make sure you've talked to little Bobby and told the squatters they have a new job (if that's how you solved it). Also make sure to do as Mom says and wait a couple of days.

    Big Jesus:
    You can get a recommendation from Little Jesus downstairs, with the combat/power armor or ST 6. Big Jesus himself does not care. The reason Big Jesus attacked is because you failed a speech roll - getting Little Jesus' recommendation will make this roll easier.

    Repairing robots heals them:
    This is a feature of the base game, it happens if you critically fail a Repair roll.

    Robots melee attacking:
    Could this be related to the AC issue with Chad and Darion?
     
    Last edited: Jun 26, 2017
  8. Darek

    Darek is currently unavailable

    Jan 7, 2008
    This is what the unofficial patch notes have to say about Rensesco: "Discount modifier is no longer incorrectly applied with Renesco which allowed you to get all of his goods for $0". So that you can't get his stuff or free is no bug, it's a bug fix. If you get no discount at all however, then it is. I have no save close by so I cannot be bothered to check.


    You can't leave the car on a random encounter map as you then would lose it, but you should be able to leave it in town no problems. What you describe sounds very odd. I can't remember anyone ever having that problem before, so maybe it's a one of kind save game bug, or perhaps some fuck up with a save game editor if you are using one.


    Mrs Bishop gives you the combination to HER safe, not MR Bishop's safe.


    The wrights safe... is as it has always been. Mr Wright doesn't care cause he can't see you behind the chairs and the table. If he would see you he would mind very much (it's in his script), so yeah it's a bug that he can't see you.


    Sierra Army Depot:

    The damage you take outside of Sierra Army Depot is electrical, and not from traps. You are walking around in a fenced off area marked with "Danger, high voltage" signs, but they are probably only there for show, right?


    Triggering the robots to come out... use wrong password twice on level 1, fail to disable/enable the force fields (emitter) more than two times in a row, use hand on elevator, activate the trip wire on level 2, shoot/hit one of the security bots (not any of the ones in the storage area). Possible bug with setting off the alarm on the terminals though. It does work if you have managed to get the robots to attack you on another level already (the bots check for both a global and a map variable, while the terminal only sets the map variables, should probably set the global variable too).

    The lights do not flash from setting off the alarm with the terminal as you said though (they only come on when the robots come out). The warning lights goes on for the whole facility and do not get turned off by turning off the alarms (there is no code for that in the scripts, so I guess it was never meant to be turned off). Also, you can't use the terminals while in combat, so it's very hard to turn off the alarm if you accidentally set it off, before the bots come find you and start combat. If the the security bots where just randomly patrolling you could perhaps sneak around and hide a bit, and eventually get to the terminal and shut off the alarm, but the bots literally hone in on your location, so that is not possible. That leaves me wondering what the point is of having that feature, if you have to kill all the bots before you can turn off the alarm anyway?


    The sentry bots in the storage area on level 2 have no weapons so they can only use unarmed. I'm not sure they were supposed to join the fight (looking at their original scripts I don't think they where), so I'm not sure why killap added that. Also, all Sentry bots are unarmed on the map and they get AI and weapons assigned to them later by their scripts, this bit of code where not added to the scripts of the bots in the storage area (dedbots they are called).


    There are no Robobrain bots on level 4, so not sure how you can see one. There may however be a a few Mr. Handy bots trying to come and clean up after a fight. They don't work all that well. They can be jumping around a bit, skip animations and get stuck behind walls that they shouldn't be able to enter. They can also get locked out from the service area if they go out to clean up and the doors gets locked behind them too fast. It's also possible for a player to sneak into that area while the doors are open, only to get locked in when the door shuts (if the player has a low lock pick skill he/she may be locked in forever).
     
    • [Like] [Like] x 1
  9. Question2

    Question2 It Wandered In From the Wastes

    Jun 20, 2017
    Harry's tables all seem to be empty...as far as i know shopkeepers with multiple tables for inventory dont start to show up till much later, till you get to NCR IIRC.

    Chad and Darion running away : Enemies only seem to run if they are crippled/on low hp. Even low level thugs wont hesistate to attack you if you are in power armor. When i was in vault 15, i was wearing combat armor without the dodger perk, so my AC cant have been too high. Have you seen Darion use his flamer before?

    I downloaded your mod, im guessing it was a bug related to him having his item slots full. Chad probably has the same issue. Are there any other bug fix mods I should be aware of? Also, how do you edit NPC items, etc? Is it on a per map basis? Some of Bishop's guards seem bugged too (they have leather armor in their inventories).

    Kids in the den : Might have forgotten to tell the squatters they have a new job, will check that, thanks.

    Big Jesus : You are right, my bad. Unfortunatley, you only seem to get the recommendation option the first time you talk to Little Jesus (that or if you fail it, you dont get to try again).

    Repairing robots : Only seem to happen with soe of the sierra army depot robots. I was using stage 5 vic so i doubt it was a critical fail...i got 75 xp, i used repair again and could disable them, but i didnt get the 200 xp for disabling them afterwards. I thought that some of the robots might have been incorrectly flagged as damaged or some such, so you end up repairing them instead of disabling them.

    Robots melee attacking : Really doubt it for the same reasons with chad/darion. I think those specific ones might have bugged item slots or some such, because the other robots in the depot function correctly.
     
  10. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Like many other traders in the game, his goods are stored in a container outside of the map. Both Modoc and his shop never restock leather armor mk2 in their shop scripts.

    Editing the maps or using sfall scripts. And Bishop's bodyguards are not bugged, they just have a real armor in their armor slot, the same goes to Salvatore's bodyguards.

    Judging from their scripts, the repair check seems checking your skill.
    if (skill_success(dude_obj,skill,-40)) then begin
     
    Last edited: Jul 2, 2017
  11. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    Harry doesn't restock the armor, but according to Per's Fallout 2 guide there should be one in his shop inventory. Have you checked the map and seen if there is one in the box when you enter? I know for a fact he sells MFC, which doesn't restock either.

    Bishop's guards really shouldn't have armor in their inventories though, it should all be read from their proto file like the rest of the critters in the game. If their proto file has armor values and they also get the armor from the item, then effectively they get double armor. Either way I'd consider this a bug.

    The SAD script should be fixed. Doesn't the use proc get a pointer to the critter that actually does the fidgeting?
     
  12. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Yup, there's a leather armor mk2 and a MFC in his shop container in the map. But when player enters the map for the first time, they probably get removed by the shop scripts.
     
  13. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    But I've bought that MFC. Maybe it's removed when you leave the map and re-enter after a few days, i.e. the first time he restocks?
     
  14. Darek

    Darek is currently unavailable

    Jan 7, 2008
    It's not a bug and you do not get double armor. The mapper doesn't save the values from an armor in the armor slot, only when you stamp an armor or add the values manually, will it be saved.
     
    • [Like] [Like] x 1
  15. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    It's not a bug, but it's bad design since no other enemies in the game work like that, so for the sake of consistency it ought to be changed.
     
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I'm not personally disagreeing with you about changing it, but you will get a bit less loot, which may or may not be a good thing.
    Not sure what the devs were thinking here. There's just a few guys on all 4 families that have real armors, the toughest ones. They all have proto armors except for the two Wright sons (They have leather armors but no armor stats at all). So did the devs realize that armors don't add to the armor stats (as the mapper can't save those values) and added that manually, but forgot about the Wright sons, or did they not realize it and actually meant for some of the mobsters to be tougher than they are now?
     
  17. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    What I think is, New Reno is such a huge area that seems to have been done in a haste, that probably they had someone who was inexperienced with the mapper do it, to make it in time for the deadline. All the barter modifiers in New Reno are coded backwards too, so people overcharge you horribly the better your Barter skill. Not to mention T-Ray and how insanely bugged he is.

    Probably the same thing happened with Vault 15, resulting in the huge screwups with enemy itemizations there.
     
  18. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    OP, could you try to collate the bugs we've confirmed into a report and put it in the RP thread, or edit your first post to include them? So far it looks like the list is:

    Confirmed:
    Renesco does not give discount.

    SAD robots use Dude's repair skill even if Vic does it.

    Car behaves weirdly if you leave it in a town and then go on a caravan from that town (this has also been known to trigger the "ghost car" bug, where the world map shows you as driving, but the car never appears in any town map until you run out of fuel).

    Unconfirmed:

    Darion and Chad running away (Did the V15 fix even help? Can you upload a save? Can someone look at Darion's Big Guns skill and see if it's high enough that he won't run away from a player with average AC?)

    Stark won't shut up about Raiders.

    Questionable design, but not strictly bugs:

    Mobster guards have armor items.

    SAD dedbots fight you (they should be completely dormant IMO, since they look to be replacement units stored in the repair bay and not hooked up to the defense system).

    Papa Wright can't see you behind his table (I believe you can shoot through the table though, in which case the newest Sfall has a fix for this that you can enable in the ini).

    SAD bots magically know where you are (Makes getting the motivator nearly impossible without fighting them all. They CAN be calmed down if you ask Skynet to reset security, but you can only do this the first time you talk to him and you must choose only the friendly dialogue options).
     
  19. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    I think it's better to add them to the RP bug report wiki as well.
     
    • [Like] [Like] x 1
  20. Question2

    Question2 It Wandered In From the Wastes

    Jun 20, 2017
    I can post the bugs in the thread/wiki, but is anyone still working on the restoration project? I got the impression that all work on it stopped in 2014.

    According to Cubik's critter editor, Darion is number 166 (although he's named "Rondo" in it for some reason) and he does have big guns tagged (total skill of 110). I dont have a save before I clear out vault 15 anymore though...is there a way to reset the map? I tried deleting vault15.sav but the game refuses to load my save after that...

    Im guessing the leather armor mk 2 being deleted from the shop inventory is a bug then? It means you cant get it till New Reno, at which point metal armor mk 2 is available which is much better.

    The den orphanage is finally there...not sure why it took so long to show up though. I didnt need to do anything extra.

    Some other stuff that I noticed :

    Navarro NPCs seem to behave oddly if you are in power armor (and possibly advanced power armor). If you are wearing T-51b power armor, the sergeant thinks you are in uniform and never sends you to the quarter master to get your advanced power armor. The base commander reacts the same way.

    This is particularly strange if you get on the base by sneaking into the vertibird at the desert transaction. If you surrender, you get transported to the base commander but he simply says "The base is on alert and I don't recognize you soldier. Show me your papers", which I think is the standard line that hes supposed to say if you are in advanced power armor AND the base is on alert (with the lights flashing). At that point you can freely pick his locker and take the FOB and he won't react to you. The base lights are not flashing at this point and i think you still get to keep all your weapons despite "surrendering".

    I went back to Arroyo before the last dream and Smoke was still there, and Nagor didnt mention anything about Aunt Morris cooking Smoke. I will try to get a save of this. I couldnt seem to ask anyone about Kaga either.

    If you kill Bishop via trapping his safe, you don't seem to get any XP and his body (and loot) is completely missing after you go back up. No bits and pieces in his room.

    When you provoke Hoss in NCR to start a fight with you via dialogue, all your companions start pulling out their weapons to kill him, even if you told them to wait outside the cantina. This makes it kind of problematic to have him surrender after you hit him once.

    The pulse pistol fires an electrical bolt, but the pulse gun has no projectile selected so it just seems to shoot invisible projectiles. Not a big deal as it is easily fixed.

    Fred in the den ends up blocking the door to Flick's after winning at the casino. There is no option to move him out of the way. I uploaded the save here : http://www.mediafire.com/file/v2ptn2j7t96b6kp/SLOT01.rar since its too large for the forum.

    Not sure if bug :

    After becoming bishop's made man and if you have killed the raiders, bishop will stop you if he sees you. All the dialogue options at this point seem to lead to combat, although one has him demand that you do the work of twenty men, there is no option to say yes.

    When I went to kill Carlson, Merk and his guards were standing in his house but Merk had nothing to say to me. Is he even supposed to be there?

    In Broken Hills, you can just wait till its night time then rob the general store blind because the shop inventory is freely accessible on one of the tables, instead of hidden in a box off map.

    The door to Vic's room in klamath is trapped and has a very high difficulty lock on it. I cannot find any mention of this change in the documentation...its not in the changelog or anything. It doesnt make sense either.

    Several new quests seem to be missing a "0" for exp rewards. I think you get 50 xp for repairing the water pump in the Abbey, or one of the minor Abbey quests. Probably should be 500 xp?

    If you go into the Raider's hideout through the front door, shadow who walks has no reaction to you even after you kill eveyone there. He just remains standing there forever.

    The amenities office in vault city restocks the first aid, repair and science skill books infinitely even though the information office says that the last of the books are at the amenities office. Since they restock every time the shop restocks, you can just keep coming back to vault city and get those three skills to 91% without putting any points into them.
     
    Last edited: Jul 3, 2017