Megamod 2.43 technical issues and suggestions

Discussion in 'Fallout General Modding' started by MIB88, Dec 8, 2010.

  1. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!

    Feb 22, 2005
    Thanks for the image regarding Virgin Street. It's got to be something to do with one of the resolution mods (that I don't use). I thought the resolution mods got rid of the scroll blockers, though. There should be no reason why you should not be able to scroll left and see that part of the map... unless I am wrong about the scroll blockers. Hopefully someone else here can answer this.

    I was wrong about the pistol. It is supposed to shoot. However, the punch and single shot stats were reversed. I have fixed this for the next release.

    The item you found was supposed to be a painting. Not a problem for now, as it is not an item that is necessary in the current build.
  2. Legion

    Legion First time out of the vault

    Feb 26, 2011
    I only use the high-res patch because otherwise the game won't run in 16 bit color mode.I know there is a way to activate it through an ini-file but I can't get it to work.
  3. Nirran

    Nirran Vault Senior Citizen

    Apr 15, 2007
  4. Smoke

    Smoke First time out of the vault

    Apr 8, 2010
    I just removed from scripts folder and Dr. Fung works just fine with empty inventory:)
  5. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!

    Feb 22, 2005
    Yes, you can do that. However, any bugs from vanilla FO2 concerning Dr. Fung will now be there. That's why it is best to use another version of that script if you have an earlier version of the MM on your computer.
  6. MSlavko82

    MSlavko82 First time out of the vault

    Sep 16, 2009
    Smoke: Here is DrFung file from old megamod installation if you don't have it, works perfectly:

    Not that important, but just to mention: when player wears Power Armor (ordinary, not Advanced) it cannot climb up ladders. I don't know is it intended or nod, but can be annoying because you have to take off PA, climb ladders and then put it back on.

    Just remembered: Am I supposed to find Professional Power Armour in SF for free? It is basically best armour in the game, and it is in shack between Brotherhood and shop in SF. Just one trip to SF early in the game and job done... :lol:

    Edit: There is advanced power armor also! Hell, and I bought ordinary PA for Sulik :wall:
  7. Michi

    Michi First time out of the vault

    Dec 7, 2009
    Just curious if someone ever got the latest version to wok on Vista/Win7.

    A few of tried and got corrupted saves right at the beginning.
  8. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
  9. MSlavko82

    MSlavko82 First time out of the vault

    Sep 16, 2009
    I am using it on Win7 64bit, works perfectly. Just replace mentioned obj_dude script with older version and everything is OK.

    edit: I just realized that there are two different Carson maps in the game... However, normally, only one can be accessed, and that is what I played, solved that murder mission and little job for that bounty hunter & cheating girlfriend etc... Also, normally, Carson can not be accessed via vertibird, because it is not on the list. So you can't take verti to Carson.

    However, when I gain access to vertibird I played arround a little and throught verti accessed "other" Carson map, which looks different, but has same scripts - however, it is really not working well. Although it should not be possible :wink: Anyway, here it is:

    When I approached vertibird, menu appeared and I chosen wide Open mode option, changing it from off to on (images are in spoilers):

    In new screen, I chosen options [MORE AREAS] to see ohter locations (Locations in lists 1, 2, 3 can be accessed normally)

    And BAM - instead of getting list of other locations, here I am in some new settlement:


    After a little I realized it is Carson city. However, I can get murder quest, but cannot solve it. Also, if I leave Carson via western exit grid, I appear in Bunker 21, even if I didn't discovered his location already. If I exit via eastern exit grid, it is fine. Except that I cannot access normal Carson any more - foot, car, doesn't matter - it loads this new map... Minor, but intresting bug.

    What's the deal with two Carson's map? This other one looks better to me than original, then - it is buggy and original works good...
  10. Smoke

    Smoke First time out of the vault

    Apr 8, 2010
    Thanks :)

    I found 2 power armours, one of which is broken, and 4 impulse grenades lying on the ground at the entrance to vault 15 location...
    Lenny in armour tries to use flamer if he has one in inventory, and with flamer equipped and full health he runs away with the start of a combat.
  11. Nirran

    Nirran Vault Senior Citizen

    Apr 15, 2007
    carsona nd vertibird bug is my fault,means i entered the wrong map number for carson in the scripts,maybe look at it in a few days

    edit : "OHM"
  12. Bulletti

    Bulletti First time out of the vault

    Mar 4, 2011
    Where could I find a 2.42 I'm getting sick of the temple of trials now... Completed it 4 times already, with great frustration. The file wasn't included in 2.42 patch.

    Relating to load game failures.
  13. MSlavko82

    MSlavko82 First time out of the vault

    Sep 16, 2009
    Here you go:
  14. Bulletti

    Bulletti First time out of the vault

    Mar 4, 2011
    <3 <3 <3 <3

    EDIT: Working properly now, thanks everyone who pinpointed the problem and helped me out at the same time!
  15. pampam

    pampam First time out of the vault

    Mar 8, 2011
    Greetings to every1.
    I`m new to that forum, but I`m not new to Fallout.
    First of all, I`d like to thank all the Vault Modders who create that F2 mods. God bless you, guys, you are doing a great job!
    Recently I started playing megamod 2.43 and found some problems, 4 example savegame. Solved according to the 5th page of that forum. Problem with party members armor graphics solved according to the 4th page etc.
    Got some issues/questions about Megamod 2.43 I`d like to share/ask. Here are they:
    1.There is a new headshot animation on the main page on I haven`t seen it in game.
    2.I can`t seem to paint my old rusty car.
    3.In Den, before I bought the car and shortly after that there were items disappearing affair in the car trunk. Solved by travelling to other city and never met again.
    4.Vendors in New Reno seem to have a broken items trade list. Renesco does not have stimpaks and even jet, Eldrisch does not have any gun.
    5.After killing Metzger, I`ve released slaves, but there were no dialog option linked to locate slavers camp (sulik`s sister quest). How can I find her?
    6.The person in scrapyard promised me to give location of Necropolis after exileing the bands. He didn`t.
    7.Critters in random encounters always have 2/3 or 3/4 (etc) hit points. Like this "She has 69/239 hps and is wielding..."
    8.I can`t seem to enter Mr.Fixit ingame menu. It used to be right click on the PC and choose binoculars icon. It doesn`t work now.
    9.I`ve read about plenty of new locations, but I`ve never been to them. Abbey, EPA, Ghost town, Carson city...Most of accidentally found on worldmap locations are broken: Chosen One is exploring the black screen. The last: Is there a some kind of Megamod manual? I`d like to read it.
    Sorry 4 the overposting and my poor English.
  16. Bulletti

    Bulletti First time out of the vault

    Mar 4, 2011
    I can relate with the trunk problem. I stuffed the trunk full of loot, and when I bought the car, they disappeared. One time only. Car trunk reloads all weapons. I noticed this because I always unload all guns. I could unload the ammo for ammo, travel a bit, unload again. Repetable.

    Also having very random burst damage - not related to armor in any way, or to AP ammo, either. Mostly no damage, but occasionally normal damage. Criticals always do damage. Single shots to same targets gave normal damage figures.

    XP, clean FO2 install, clean megamod 2.43, v2.42, Weapons redone mod. Could be the mod. Most likely option.

    IMO ammo is too heavy for the stack sizes. I mean, 90 pounds for mere 350 rds of 10mm? bite me. IRL that wouldn't weigh anything over 15 pounds.
  17. MSlavko82

    MSlavko82 First time out of the vault

    Sep 16, 2009
    Don't put anything in trunk before you move car for the first time. After that first time, stuff won't dissapear, it works fine.

    Already mentioned. Check if you have in your script folder. If not, there is problem. Download Custom perks mod from Nirran's site (, copy from mod to scripts folder and voila - burst your enemies to destruction! Or you can install whole mod, it is very good really.

    Well, MM seriously reduce clips size, maybe weapons redone too, and increase their weigh. You can always use fwedit to easily make it right 8-)

    1. And who says it is in game? :mrgreen:
    2. Neither do I, I think it have to be implemented yet, in some future version...
    3. Already said - do not use trunk before you move it for first time. Kinda makes sense not to use trunk before you buy a car, right? Not like in vanilla game... :P
    4. Yes, I noticed that too, but forgot to mention it. Eldrige have no guns at all, and maybe 2~3 items to sell...
    5. You should ask Metzger when you talk to him (I did that), but I think that you should be able to ask slaves too...
    6. Necropolis is not in game, and Scraptown is full of (s)crap anyway :mrgreen: That is not implemented, and dialogs in Scraptown leaves a lot to be desired. Necropolis is F1 location, you won't find it in F2... yet :mrgreen:
    7. Didn't notice this in my game...
    8. Works for me, although it has quite a lag...
    9. Abbey:[spoiler:4f796c0fdc]Father Tully from New Reno will mark it for you, but you have to ask him when you talk to him for first time, so be careful.[/spoiler:4f796c0fdc]
    EPA: [spoiler:4f796c0fdc]When you recruit Myron, then dump him, he will tell you location of a secret Mordino stash in Golgotha. After you dig it, and dump Myron again, he will tell you location of EPA. However, if you don't dig Mordino stash, he won't tell you EPA location. I think it is possilbe to meet traveler in random encounter that will tell you EPA location, but I failed to meet him yet...[/spoiler:4f796c0fdc]
    Carson City: [spoiler:4f796c0fdc]Location of Carson city, along with BOS Facility, you will find in one of Abbey computers, it is part of mission actually. Location of BOS Bunker will be given to you when you finish BOS quest in SF [/spoiler:4f796c0fdc]
    Ghost Town - kinda makes sense you never find it :mrgreen: Just kidding, I never heard of that location... :puppy-dog:
  18. Bulletti

    Bulletti First time out of the vault

    Mar 4, 2011
    Editing for myself only would work, but that wasn't my point :P

    WR doesn't reduce anything unless you install it, and I did. The only issue is the weight. I seriously recommend to modify them back to default weights at least, since MM reduces clips by more than 50% in most cases. Either would be fine, but not both. Practically requires to have 8+ ST for that reason =/

    Yeah, the trunk. I figured out not to put anything inside until it's mine.
  19. MSlavko82

    MSlavko82 First time out of the vault

    Sep 16, 2009
    Yes, it is a bit too much. I personally edited them long ago, now I just use my proto files with new MM installation. However, you can take slaves in megamod, and they can carry a lot... :twisted: You even don't have to be evil :mrgreen: But that is just one more thing that should be changed :)

    Anyway, which version is WR mod you use? I used it long ago, then stopped, and it was good one! Is it working OK with megamod?
  20. Bulletti

    Bulletti First time out of the vault

    Mar 4, 2011
    Seemed to work just fine for me, Version 2.2
    messed up a savegame, but not that big of a deal, right? Who would want to skip the temple anyway?

    EDIT: F2WR seems to bug with ammo and anything related to it. Not only my trunk reloads all the weapons, but also fills all ammunition stacks when exiting and entering a map. No point in carrying more than 20 rounds for my magnum, since I can spend 19 rounds and have 20 at the next battle. I'd appreciate any help here =)