Missing something with mapper?

Discussion in 'Fallout General Modding' started by FDO, Jul 4, 2018.

  1. FDO

    FDO First time out of the vault

    Jul 4, 2018
    Hello Fallout modders,

    in the past few days I dug and fought my way in the 'figure it out yourself' styled tutorials of Fallout 2 modding. Obviously I found some helpful tips and tools in them, I managed to rework the vanilla worldmap into a working new one, locations included, got a scripting start to go somewhere, and even created a new critter art for a new unique character, plus some minor other things.
    So call me crazy but I think I might be on to a not so bad start for a total conversion mod. Short enough to keep my head on shoulders and the mod finishable that is, if my free time is enough for it.

    But there is one current issue I can't understand with the bis mapper tool. When I save a map in it, then test it with f8, the invisible blockers used to hide the map holes are working, I can't view any hole just like in the vanilla maps.
    However, when I try the very same map in game, my new saved maps have no boundaries at all, I can see the holes and scroll everywhere. You can see the problem?

    I tried searching of course, but I can't see what is causing this, and yes, the new saved maps do retain the blockers after changes/saving and so on. Does it ring a bell to someone? Did I miss something obvious in the mapper configuration?
    It's strange that the maps work normally in f8 mode, but not in game? Last precision, I always start a new game to test my changes.

    Thanks.
     
  2. Lexx

    Lexx Lived Through the Heat Death
    Moderator

    Apr 24, 2005
    What exactly do you mean with "no boundaries at all"? Map scroll blockers? With the high-res patch you define the scroll range not via placable scrollblocker objects, but via the edge-button on the interface. If you don't do this, you'll be able to "scroll everywhere" within fallout 2, as the high-res patch - by default - disables said scrollblocker objects.

    If you mean blockers like the scenery, wall, or sai stuff, then something else must be at fault. I've never heard of such an issue before, though.
     
  3. FDO

    FDO First time out of the vault

    Jul 4, 2018
    That's it, thank you. I just placed a rectangle on my starting map with the edge option and it solved the problem. Yes, I meant the scroll blocker, the wall blocker work on scenery objects.
    I actually don't use the res patch for myself, I just included it in my mod folder in case I do manage to finish it in any forseable future, or one of these days, as I figure most people probably aren't too fond of the original resolution anymore. (but I still like it somehow, so the res patch is on 640*480 by default)

    Thanks again.