UP and RP updates

Discussion in 'Fallout General Modding' started by burn, Jul 9, 2019.

  1. burn

    burn Where'd That 6th Toe Come From?

    Apr 22, 2012
    So I spent some time plowing through RP bug reports and packaged an update. In fact, it turned out that most of the issues were actually related to vanilla/UP, so I decided to package that one too.

    There's a few dozen fixes overall, plus spelling standartization and typo correction. And a new sfall version with engine fixes brought to us by our sfall overlords. That's on the outside.
    On the inside, there's also a lot of changes: various optimizations, some scripts were missing from the published sources, others weren't matching, build scripts were failing etc etc. All that had to be taken care of.
    Many fixes were made by @NovaRain, some by me, also there could be some snippets by other people.

    Unfortunately, many bug reports were missing savegames and other vital information, plus I only have so much time. It means that not all changes were thoroughly tested, some might've been not tested at all.
    But fortunately, the packages are incremental, and install into dedicated directories. Meaning that you can safely try them and if something goes horribly wrong - delete the package and use the old version like nothing happened.
    So, to be clear - version 1 is marked as experimental, but you shouldn't be too afraid to experiment.

    See the readmes for installation instructions, changelogs, and other information. If you find a problem, please submit it to the corresponding repo on Github. The forum is not a suitable tool for tracking bugs, and I do not check NMA regularly.

    UP update.
    RP update.
    Last edited: Jul 12, 2019 at 10:59 AM
    • [Rad] [Rad] x 4
  2. Hubal

    Hubal It Wandered In From the Wastes

    Sep 11, 2014
    So basically it is RP 2.34?
  3. Oracle

    Oracle Water Chip? Been There, Done That

    May 19, 2003
    great work guys! :)
  4. burn

    burn Where'd That 6th Toe Come From?

    Apr 22, 2012
    No, it's RPU v1. Separate package, at least for now.
  5. BigDuke66

    BigDuke66 First time out of the vault

    Feb 8, 2005
    Great news!
    Thanks to all who participate in continuing killap's work!
  6. Arathos

    Arathos First time out of the vault

    Feb 2, 2017
    Any plans to restore some new content in upcoming updates?
  7. BigDuke66

    BigDuke66 First time out of the vault

    Feb 8, 2005
    What content is still missing?
    I thought killap had covered all.
  8. Muttie

    Muttie It Wandered In From the Wastes

    Oct 9, 2017
    I may have completely misunderstood the install directions... That said, I was under the impression this patch is easy to remove (i.e. it doesn't overwrite anything of RP), it only adds a folder called “mods/rpu.dat...” which is used over “data”.

    I tested this and I can't load my old saves, nor can I save a game. Actually it triggers an “error”, then does save the game anyway but won't let me load it again. (This happened once, when I tried to reproduce it it wouldn't even let me do that, however, the save still does appear in the Savegame folder, just not in-game).

    Part 2 (I tested RPU) on a clean install (well, not exactly install, I just threw the basic files the game needs to run into a folder. That's excluding anything else like hi-res etc., just the fundamentals) and then included RPU (as “mods/rpu.dat...”). I know RPU is used (I can tell by the used text files etc.), but I can't save (again). But again it creates a save file. I just can't see or load it in-game.

    Part 3 (I then put all the RPU files into data) and then I can save the game and load (“ding”). However, I was under the impression that I can put “mods/rpu.dat...” into Fo2 and have it run (and I know that it works) but apparently it won't let me save (?).

    Or did I completely misunderstood the “just extract into Fo2” and “it can be easily removed again” part, and it was never supposed to be included as “mods/rpu.dat...” only, but always supposed to overwrite stuff in data? Although it does work when included as “mods/rpu.dat...”, except for the save/load thing...

    May be my fault for misunderstanding.
    And it does work (now), but it will overwrite more than just ddraw.ini.
    Anyway, perhaps the installation instruction could clarify that I can't just extract rpu_v1.7z into Fo2 but need to integrate the contents of “mods/rpu.dat...” into data. At least that seems to be the only way saving/loading works for me.

    P.S. When adding RPU to data I can now save/load, but when I want to load my old 2.3.3 saves I need to delete “sfallfs.sav & sfallgv.sav” from the save first.
  9. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    I think the content of upu.dat/rpu.dat should be packed into real .dat files instead of folders with fake filenames.
    Note: Files (scripts, maps, etc.) with the same name in your normal 'data\' folder are ignored by the game, since the files in upu.dat/rpu.dat have higher priority. Just like back in the day with patch000.dat.

    If you have smaller mods that would replace original UP/RP files and still want to use them with UPU/RPU, the easiest way is to treat UPU/RPU as direct patches to UP/RP: overwrite ddraw.dll/ini and move all files from mods\upu.dat\ or mods\rpu.dat\ folders to your 'data\' folder and overwrite existing UP/RP files. But you won't be able to roll back to original UP/RP easily (have to reinstall).
    Last edited: Jul 12, 2019 at 12:37 PM
  10. burn

    burn Where'd That 6th Toe Come From?

    Apr 22, 2012
    Yeah, that's strange. @NovaRain any idea why wouldn't it save?
  11. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    No idea. It's the same if you rename the "upu.dat" folder to "patch000.dat" and without sfall (UP can start without sfall, of course some scripts would break during the game but it's not the point of my test). Probably it's the vanilla engine behavior.
    One interesting thing is if you load an existing game you can re-save the game to other empty slots normally. But if starting a new game you can't save it.

    Personally I don't recommend naming "folder" as .dat files to trick the engine into loading its content. If I want to use patch files, I'll pack them into .dat properly. Maybe that trick works for main .dat (master/critters.dat), but I wouldn't do that for patch files. Maybe it's possible to add packing all stuff in .dat with dat2.exe to your auto build script on repo?
    Last edited: Jul 12, 2019 at 8:28 AM
  12. burn

    burn Where'd That 6th Toe Come From?

    Apr 22, 2012
    Possible of course, in fact I was going to do that in the beginning, but settled for dirs, because I planned to add readmes later, and readmes do no good inside .dat files.
    I'll add packing to .dat files for now, will think what to do with this after.
  13. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    I don't know why readmes would be in .dat files. Maybe just exclude them from the packing process?
  14. burn

    burn Where'd That 6th Toe Come From?

    Apr 22, 2012
    I mean that I wanted to put the readmes inside mod directories.
  15. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    Oct 29, 2015
    If DataLoadOrderPatch is enabled, the data load order will be: master_patches > critter_patches > PatchFileXX > mods > sfall.dat > patchXXX.dat
    Last edited: Jul 12, 2019 at 11:15 AM
  16. burn

    burn Where'd That 6th Toe Come From?

    Apr 22, 2012
    Updates pushed to github.
    Try with new version.

    Anyone knows how to pack a directory with dat2 recursively? I can't seem to find the right combination.
  17. Nirran

    Nirran Vault Senior Citizen

    Apr 15, 2007
    i may be way off base here but the cannot save bug is something i ran into before,it may be related to the base proto of party members not being in /data or the master dat,had prblems with it in ProcessDat2 program,i think it is related to the engine handling of base party member protos,it is finicky

    use dat2 frame,little outdated ,but it works,does all the work

    Attached Files:

  18. Muttie

    Muttie It Wandered In From the Wastes

    Oct 9, 2017
    It's yes & no now.
    I can now save & load without having to overwrite data.
    But old 2.3.3 saves can't be loaded without deleting “sfallfs.sav & sfallgv.sav”.
    And I can't overwrite old 2.3.3 saves either, btw. No matter if I delete “sfallfs.sav & sfallgv.sav” or not.
    Isn't this possibly a compatibility problem of switching from sfall 3.3a to 4.1.8? For example the save files are named differently. Changed from “sfallfs.sav & sfallgv.sav” to “sfalldb.sav & sfallgv.sav”.
    Anyway, I can save and load now so I guess it works, just old saves are semi lost (although it seems to work to delete the files “sfallfs.sav & sfallgv.sav”, load the save and just save it again (creates “sfalldb.sav & sfallgv.sav”). Not sure, however, if that will cause any problems down the line.
  19. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    Oct 29, 2015
    send a slot that can't be loaded
    Last edited: Jul 12, 2019 at 10:44 PM