A clean install FO2 from GOG then the MegaMod install BUT!

Discussion in 'Fallout General Modding' started by palmerwmd, Feb 8, 2011.

  1. palmerwmd

    palmerwmd It Wandered In From the Wastes

    163
    Sep 10, 2009
    But..

    When I try to run the game iether via the FO tab in programs or the "megamOd" tab in programs it gives me an error message and the game wont boot up.
    "Fallout appears to be running in compatibility mode"

    prior to the addition of MegaMod it would run ( I tested it with one game which I did not save)

    I never enabled compatibility mode on FO and am not sure i know how even if i wnated to.

    a) Is this really the probllem?
    b) if so how to I run it in normal mode?
     
  2. palmerwmd

    palmerwmd It Wandered In From the Wastes

    163
    Sep 10, 2009
    Ooops, I checked..
    and it is <not> running in compatibility mode????

    a other it of info: I insatalled the Mod directly into the fallout directory <during> installation. so no cope/paste from a seperate folder. This is what I interpreted the installer wanting me to do.
     
  3. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    work around is use the official patch exe and update sfall to newest version,delete extraCRC= in ddraw.ini,make sure to not over-write ddraw.ini when sfall is installed

    Nirran
     
  4. palmerwmd

    palmerwmd It Wandered In From the Wastes

    163
    Sep 10, 2009
    So next time I wont delete officialpatch.exe when I install the megamod on top of the fresh install.
    I will go search for a version of sfall that is newer than the one in the latest megamod but
    how do I installl sfall seperatly from the Megamod, isnt it part of it?

    And once a new sfall is insatalled on top of the megamod Can I just keep a copy of the edited ddraw and paste that on top of the ddraw sfall put in?
     
  5. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    1 - install fo2

    2 - install megamod

    3 - copy official patch(exe only) to fo2 folder

    4 - download sFall

    5 - copy Only the dll file ddraw.dll into fallout 2 folder

    may have to alter the ddraw.ini graphic mode,i use 0 and my os is win7 64

    should fix the problem

    Nirran
     
  6. palmerwmd

    palmerwmd It Wandered In From the Wastes

    163
    Sep 10, 2009
    Thanks!! Ill go try this right away! :)
     
  7. palmerwmd

    palmerwmd It Wandered In From the Wastes

    163
    Sep 10, 2009
    deleted
     
  8. palmerwmd

    palmerwmd It Wandered In From the Wastes

    163
    Sep 10, 2009
    I am obviosuly abig Noob with modding and must havemissed someting?

    still getting same "compatibility mode" error message.

    I really want to make the megamod work.
     
  9. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    It's a packed archive file. First, you need to extract it somewhere; inside of that package you will find the ddraw.dll file.
     
  10. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
  11. palmerwmd

    palmerwmd It Wandered In From the Wastes

    163
    Sep 10, 2009
    Ok guys:

    went back took out the sfall. unzipped it. took only the ddraw/dll file into the FO folder. Still didnt work same error message. I will restart now and see if that helps....

    EDIT: still sam errror message will not boot up
     
  12. Soda_fr

    Soda_fr It Wandered In From the Wastes

    137
    Dec 31, 2009
    Hi!

    I also have the GoG version of F2. I've done a clean install (F2+
    Megamod) and the "compatibility mode" message also appears
    on my laptop (Win7 64).

    To get rid of it I have to go to my Fallout2 folder, right click on fallout2.exe, choose "properties" and check the compatibility tab.
    On my computer, don't know why, fallout2.exe runs by default in 256 colors. Just uncheck the box and you're good (at least it works for me...)




    Hope this help !

    --
    Aguirre
     
  13. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    that is the problem,make sure the exe is from the official patch,is .exe extension

    this is a link to it

    http://www.nma-fallout.com/forum/dload.php?action=file&file_id=82

    that should do it

    also check what Aguirre said,(learned me)

    maybe a hella lot easier

    Nirran
     
  14. palmerwmd

    palmerwmd It Wandered In From the Wastes

    163
    Sep 10, 2009
    I did what Agguire recommended and it no lonegr gives me the compatibility error message. But it still wont boot up and says
    "couldnt find/load text fonts" :(
    But the game does run justas a straight FO2 w/o the Mod.

    Which is the same problems i was never able to solve when I tried an install a few months back..

    Also I zipped the patch file that Nirran linked into my FO directory but no patch .exe showed up..

    I know I am probaly missing some basic steps understood by all?
     
  15. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Unpack the downloaded official patch file into a separate directory, there will be a "fallout2.exe" file inside. Grab it and put into your FO2 directory.
     
  16. palmerwmd

    palmerwmd It Wandered In From the Wastes

    163
    Sep 10, 2009
    Thanks valcik, I redid everything but am not at that spot yet. I reinstalled FO2, installed the MM on top ofit and tried ot see if it would play but now it give me a msg i need ot update my directX.. so I did that and insatlled it to my program files but am stiull gettign same error message.

    any other plac ei sshould ahve put it to?

    restarting now
     
  17. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    You need an updated DirectX 9.0c in order to run the MegaMod (sfall requires it).
    Try the online updater, or download and install a latest DirectX 9.0c redist package. Then restart the computer and try to run game.
    Don't worry, I was confused even more, when I'd install the MM for first time. But it's worthy of it. :)

    edit:
    DirectX may be placed in the Progam Files directory, that's okay. In fact, it belongs there.
     
  18. palmerwmd

    palmerwmd It Wandered In From the Wastes

    163
    Sep 10, 2009
    Thanks for all the input guys!!

    I am still getting an erroe message about the direct x when I clock on the FO icon in FO and if I try to start play via the megamod icon in program tabs I get the Cant load/find text fonts.

    Even though i am a modding noob I thought I was fully computer literate but still haing tehse problems.

    Walmart has a s
    Directx is prelaoded on CD's right?

    Walmart has a special selling FO1, FO2 and FO tactics in one packet for 20 dollars. Does anyone think I will have less problems if i load the game form CD vs GOG?

    I still have a FO 2 CD here somehwer ei cna use but its years old and probably doesnt have the latest directx loaded..and in any event i didnt use it for this install.

    I think this entire process helps increase this old man's computer literacy ;)

    FO2 was my first and only love in crpg's .

    I offered it a year or two back for for anyone writing new mods I will gladly consult for free to Nuclear or Biological content as a thank you, as I do those things professionally.
     
  19. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    the fonts error is because sfall is not loading(ddraw.dll),get directx from here

    that is the complete package for dirrectx 9.c(it will not affect your current directx,they are compatable)

    prolly wont be able to use the menu button to run fo2,have to click directly on exe

    Nirran
     
  20. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Yes, your DirectX installer, distributed on a CD along with game, is definitely outdated. Read a sfall's FAQ on sourceforge.net:
    Code:
    Q: fallout crashes on startup with an error about directx not being installed
    
    A: If you're using graphics mode 4 or 5, then make sure your DirectX 9 installation is up to date. If you're on vista/win 7 and have DirectX 10/11 then it doesn't automatically mean that you have the latest version of DirectX9, so install it. 
    Check the MS download center; there are actual versions of DX9.0c available, try this one:
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=0cef8180-e94a-4f56-b157-5ab8109cb4f5

    Well, it's a great training of an english grammary for me. I'm still surprised, if someone can understand my writting. :)