Current EPA Project

Discussion in 'Fallout General Modding' started by Chris Parks, Jun 18, 2006.

  1. Dude101

    Dude101 Vault Fossil
    Modder

    Aug 3, 2005
    Thanks for putting in such an effort, I look forward to playing the mod :)
     
  2. thinkpad

    thinkpad First time out of the vault

    22
    Jul 2, 2004
    The game crashes for me just after finishing the Temple of Trials.
     
  3. Dude101

    Dude101 Vault Fossil
    Modder

    Aug 3, 2005
    Works fine for me, did you delete patch000.dat?

    1 prob so far: I cant pick the doors of the two shacks.

    It took me a while to work out how to get in then I slapped my self on the head for not working it out sooner.

    edit

    The desk in the bottom left hand corner of the automatic repair bay cannot be opened.

    MR Handy is wandering inside a wall, you can get behind the wall on the corner of the second lift on the left.

    You can run though the wall on level four by the lift on the right side.

    You can run though the air processing pipes on the bottom right hand side of the crazy docs place.

    You can run trough the wall in the bottom left hand side of the first map.

    two plank brides across the toxic river outside the docs place cannot be walked over, although thats not important.

    Using the bug spray in combat crashed F2.

    and of course the known bug

    1 minor complaint: It is not so obvious on the town world map that in bottom button takes you to the crazy docs area, it looks like you are going to a level in EPA its self. Perhaps sticking the button on the side or something it better?

    Its good so far, I enjoyed the dead red shirts all around the docs place, that always makes me laugh.
     
  4. thinkpad

    thinkpad First time out of the vault

    22
    Jul 2, 2004
    So I should delete patch000.dat?
     
  5. Silencer

    Silencer Night Watchman Staff Member Admin

    Nov 7, 2003
    Better rename it to patch000.000
     
  6. thinkpad

    thinkpad First time out of the vault

    22
    Jul 2, 2004
    I tried that and the game crashed on loading. Could someone send me a save game after they've found the EPA but before they have entered it? I have the US edition with 1.02d and Killap's patch installed. PM me with a link to the saved game or for my e-mail to send it to me. Thank you very much
     
  7. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Just a few things:

    In the pro_crit file, you skip from critter 490 to 492. But there is a proto file for 491. Only 12 critters are in that file, but there are 13 new protos. Has it been removed? Or is there some other problem.

    Is there any particular reason why you included the worldmp.msg file?

    It should be 'Tesla' armor.

    For epac3, line 260 - 'masks' and 'to'

    Also, could you look back at scripts epac14 and epai16. I am not sure if it will make a difference in gameplay, but I think you referenced the wrong numbers in the dialog line.

    I am slowly putting this stuff in the Megamod. It looks really awesome. Nice job.
     
  8. forddieselguy

    forddieselguy Still Mildly Glowing

    229
    Aug 31, 2005
    Is this mod compatible with Killap's patch?
    Checked the thread and couldn't find an answer. I know Killap was involved somehow, but not sure in what aspect, possibly for the add-on but not the patch.
     
  9. Chris Parks

    Chris Parks Vault Senior Citizen

    Jun 10, 2006
    Hi guys,

    Right then, I've tried to fix all the holes in the maps. Having to check 8 maps by myself has been tough to spot them all!!

    I've also altered the two plank bridges and after considering, taken them out. (they weren't needed anyway)

    The bug spray problem... I assume this was the first time you used the spray? The first time brings up the dialogue box so this is why it crashed. Use it at least once first as it gives some information on what it is. It also cannot be used in combat as the code will not work. It only works out of combat.

    As for the town map screen, this one was my fault. This was the last thing I worked on before it was released and it needs a bit more work. I've asked killap to work on adding names to the map.


    To MIB88

    The proto file 192 I believe was from another mod that I was running with this mod. I'd adapted it at the time to run with changeable armour, friendly klint and the abbey location. I think he was from the klint mod and as such is no longer needed.

    Worldmp.msg was not needed. I left it in by mistake.

    Telsa armour has been altered. I knew how to spell this but just typed it wrong!!

    EPAC3 dialogue is no longer used and shouldn't have been included. The script wasn't included either.

    I also checked through the plant and ant scripts but couldn't see a referencing problem. Could you be more specific as to what's wrong?

    As for killap's patch, I haven't tested my mod with his so I'm not sure it will be compatible. Maybe killap is the person to ask here.

    Finally, MIB88, would the header files and decompiled scripts be useful to you? I could send them if you want.

    I'm glad there are no major problems with the mod. It mainly just seems to be map fixes that I've missed. Once everyone's played it a bit more, I'll update it to alter the problems.

    In the meantime, I can get on with the next project...
     
  10. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    I took this out of the epac14:

    procedure talk_p_proc
    begin
    op_set_local_var(4, 1);
    op_start_gdialog(1342, op_self_obj(), 4, -1, -1);
    maybe_start_dialog();
    call Node001();
    maybe_close_dialog();
    maybe_op_end_gdialog();
    end

    but in the 'use' procedure, the script referenced is:
    op_float_msg(op_dude_obj(), op_msg_string(1394, 101), 8 );
    else

    It was a similar issue in epai16. Remember, I am no master of scripting, but the numbers (1342, then 1394) made no sense to me and seemed to reference scripts and dialog that were not there (the number in the talk procedure).

    And I appreciate the offer to send me those files. I don't think I need them just yet, though. This way, for consistency, I am working with the same format for scripts. If I run into problems decompiling them, though, I may need your help. Thanks.

    Oh, and for the bug spray: 'ingestion' and inhalation'.

    Can't wait to see the next project...if it's Fallout-related, that is. :)

    Edit: I did think of something I could use your help on. Could you tell me the item that each new item .frm goes with? Things are gonna get really messed up when I open up the new items and need to match the inventory pic and ground pic with the proper item.
     
  11. Skynet

    Skynet Mildly Dipped

    501
    Jun 5, 2003
    I just made a quick run and...

    -You can run into one of the holding cells in doc's warehouse.
    -Beneath the doc's warehouse (access via manhole) is a place with a lot of lockers. You can run through them all.


    Also, EPA is too easy. Just a ants, fruit flies and plants (althrough the plants have a purpose). A few aliens in elevator shaft tunnels and a couple of deathclaws (there are deathclaw eggs everywhere) some other place would be nice. It would make more sense, cause the surrounding wordmap area near EPA has these creatures.

    Also, there are a lot of robot recharging stations, but not a single combat bots in them.

    So basically if you play the game normally and finally reach EPA, it won't offer much a challenge.
     
  12. phr34ky5tyl3y

    phr34ky5tyl3y First time out of the vault

    7
    Aug 28, 2006
    I'm not finding the EPA in the world map. Is there a quest I have to complete first or something in order for it to appear?
     
  13. Chris Parks

    Chris Parks Vault Senior Citizen

    Jun 10, 2006
    Hi everyone

    MIB88,

    In my header files, the number of the actual script is 1342, which corresponds to NAME when compiling the files. The message file it uses is 1394. I don't know exactly why there's a difference, but the spray seems to work as it should do.

    I'll sort out what frm files go to which proto and send you them tomorrow, (or tonight if I get them all done)

    As to your other point, the next project is definitely fallout related. It's the Primitive Tribe.

    Skynet

    The EPA may be easy to get in, but many of the quests require reasonably high skills to complete, so it couldn't be completed too early in the game. However, I do understand what you say. If you enter it later in the game for the first time, it is easy to get in.

    What are other people's thoughts on this? WOuld you like to see more deathclaws and aliens on maybe the entrance map and ducts? As well as robots inside? This wouldn't dramatically alter the gameplay, but as they weren't mentioned too much in the design documents, I left them out.


    phr34ky5tyl3y,

    you don't need a quest to get the EPA. It's west of NEW RENO, in the middle of the deathclaw and alien area. I'm not sure yet what your problem could be. Are you running any other mods with this one?
     
  14. nny_ix

    nny_ix First time out of the vault

    15
    Aug 30, 2006
    actually I can't find it either, I'm using 1.02d with no patches or mods whatsoever, I loaded from a Save Game right after i beat the game and I can't seem to find the EPA, can you tell me what I'm doing wrong or what I could do to make it work, I read through the Fallout Bible and the EPA was my favorite thing about them.
     
  15. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    If I remember correctly, if you have already entered the worldmap before, or at least that square before, the new location won't appear. When you enter the worldmap the first time, I think all locations are created then.
     
  16. nny_ix

    nny_ix First time out of the vault

    15
    Aug 30, 2006
    So I have to start the game over and get there, eventually trekking through the EPA?

    If it's not too much to ask, do you think you could add script for those of us that beat the game and just want to travel there with a save where someone will mention the location and it appears in your map ala every other location?

    ^^To the creator of the wonderful mod btw.
     
  17. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Well, a few things. First, this is not my project, but Chris Parks. :) Second, if I am right, then I don't think a simple script would work. I don't think you can add to the worldmap at all after it has been created. And then, even if you could, where would he put the trigger? If you have finished the game and talk to Renesco? Or Tubby? What about those who haven't finished the game? Or what if you killed the person who had the triggering script? I'm not picking on you, I just wanted to point out that it would probably be more difficult than you might think.
     
  18. Skynet

    Skynet Mildly Dipped

    501
    Jun 5, 2003
    Just delete the wordmap.dat. This forces game to recreate the file and the location should then show up.
     
  19. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Really!? Crap. I thought that would totally mess up any previously saved games. Good to know.
     
  20. phr34ky5tyl3y

    phr34ky5tyl3y First time out of the vault

    7
    Aug 28, 2006
    for all those guys having problems running the mod, chris helped me out and showed me how to fix it.

    First, you have to download the City Limit patch that's in NMA somewhere. Once you've installed the patch, delete patch000.dat, install the mod, and start a new game.