Fallout 2 Restoration Project 1.1 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jan 13, 2008.

Thread Status:
Not open for further replies.
  1. holyshoot13

    holyshoot13 First time out of the vault

    6
    Jan 7, 2008
    Yeah, The Brain seems to be bugged -- I also can't seem ask him to stop the molerat attacks like I could in 1.0 (although there I could ask him to stop the attacks even before I knew about them).
     
  2. MutantOne

    MutantOne First time out of the vault

    8
    Jan 16, 2008
    Same here :? And that means I can't explore the EPA... In fact, the game crashes as soon as I try using the elevator.

    Anyway, THANK YOU killap for completing Fallout !!!!


    EDIT : oh well, I just got in through another way and I have the exact same problem... the elevators crashes the game.
     
  3. ***F.E.A.R.***MaNiaC

    ***F.E.A.R.***MaNiaC First time out of the vault

    65
    Sep 22, 2007


    you found the second elevator, with the same script on it? ;-)

    seems like the game has troubles changing the map..

    btw, thanks from me too... didnt thank you before, was too excited... and I'm emotionally crippled anyway
     
  4. hakan

    hakan First time out of the vault

    13
    Jul 1, 2007
    More on encounters:

    Deever is right.
    the graphics mode has a huge influence on travel speed and encounters.

    If i switch from mode 5 to mode 2 I travel about three times as fast (the "range-time passed" relation stays about the same it seems) and get MUCH less encounters...
    Extremely few even. I can travel vault city-NCR route by feet and have less than two encounters on average on the hole track (sometimes none, sometimes 2...)

    Also, have the encounters been buffed?
    While I was testing the route I encountered raiders a few times, and they completely ripped me to shreds.
    I get hit for 30-50 HP(non critical) from across half the screen by single bursts and dont survive a single round (My bursts with a looted CWAS do about 5-10 damage at this range...).
    I wear the quest leather armour from modoc so I'm not really that well armoured, but meeting a group of eight(!) raiders, each(!) of which hits me for 30+damage in bursts from half the combat map away seems a bit excessive.
     
  5. Yoshi525

    Yoshi525 Vault Senior Citizen
    Orderite

    Dec 10, 2006
    Cheers! Great work.
     
  6. tomten

    tomten It Wandered In From the Wastes

    164
    Jan 6, 2008
    Same here; if I even go close to the south parts of the world map there's always people with huge laser guns against whom I've no chance (enclave patrols, raiders, ...). I don't remember this from vanilla FO2...
     
  7. nephwork

    nephwork First time out of the vault

    5
    Jan 16, 2008
    car trunk problem

    I just went to Den and gave to smitty the fuel cell controller and after bought it, then I gave him the regulator and then I went to the car and click on the trunk to put my stuff there...and when I clicked the trunk my character picked the cartrunk to the inventory (it also disppeared from the car). it shows in the top of the inventory as a blank space but the binoculars-cursor works on it and says 'Cartrunk' when I drag it to the blank space.

    After that I tried to use the car and then came a windows pop-up where was this text:

    Error!: partyMemberPrepItemSaveAll: Can't find script!
     
  8. MutantOne

    MutantOne First time out of the vault

    8
    Jan 16, 2008
    Well, there's a place with 1 elevator and another one with 3 or 4, and they all crash my game :(
    I had this problem 1.0 so I started a new game with 1.1 and this didn't work :? (it means that i have 2 different savegames for the same error)

    Anyway, I'm glad to see that I'm not alone :P
     
  9. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Re: car trunk problem

    No idea. Never heard of this before. Are we sure that everything was installed correctly to their proper locations?

    Sigh, so here's the story with the EPA. The maps I used were from Chris Park's mod which I then proceeded to heavily modify to fit my mod. When I first implemented his maps I too got the same crash you guys are describing. I had no idea what the hell caused it and got highly frustrated since there was no way I would recreate the maps - I'm a programmer not a mapper. Still, I really liked the how Chris did the maps, so I decided to redo the map with the elevators. When I did this it worked for me and I could use the elevators. It didn't make any sense to me, but I shrugged it off hoping that the "problem" had vanished. Apparently this is not the case. The problem seems to be that when you leave the map, the games is saving some data and crashes in the process of doing so. When I suffered from this problem I also noticed that if I would save in the maintenance area (where the 2 elevators are), exit to the game menu, and then reload that save the game would crash. Out of curiosity does this happen to you guys as well? What is odd is that it seems only a select few have this problem. Because of this fact, I really don't know what the problem truly is.

    @those with high encounter rates
    Like I said don't fret. There will be a way to nicely customize the frequency in the next update.
     
  10. wastelandhero

    wastelandhero First time out of the vault

    34
    Jul 5, 2007
    This is probably the best place for this comment, It neither a bug nor a gameplay issue, just a comment on something I noticed.

    After helping Lara fight at the church I got the option to wait before the next battle. Haven taken a lucky hit and lost a lot of HP, I used this time to heal myself and my party. Well it took almost 2 days to fully heal. Then told Lara I was ready to go. We then proceeded to the residential area to fight Tyler.

    It seems a little odd and out of place that Tyler was still partying in the middle of the day almost 2 days after the church fight, don't you think?

    Maybe there should be a time limit on how long you can wait before Lara tells you to get your ass in gear or bail on the fight.
     
  11. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Heh, yeah I realized this when I wrote the quest, but if I remember there are other such situations in the original game where no one really takes time into account.
     
  12. ***F.E.A.R.***MaNiaC

    ***F.E.A.R.***MaNiaC First time out of the vault

    65
    Sep 22, 2007
    I was about to check the loading-issue... when sulik showed me sth:

    The Elevator on the right side in the utility-level isnt solid at all... gonna check if its the same at the other elevator.
    You can get behind the elevator if you step into it, click "leave" and step further, click "leave" and so on... now i'm walking behind the elevator... maybe thats part of the problem...

    other things i thought up are, if it crashes while trying to save sth... what about the entry/exit areas in the other maps and this map? maybe theres some leak which leads to corrupt information to be saved and boing... your outta.

    Since this is no regular elevator, you could try to bypass it by attaching the script to the elevator-button instead of the elevator interior. Since then it would be a simple beam and may work... or if it doesnt work, you may find out what the heck is screwing up.

    /edit
    ok, the left elevator is "solid"

    no save/load issue so far... gonna keep testing a bit
     
  13. wastelandhero

    wastelandhero First time out of the vault

    34
    Jul 5, 2007
    Now that I think of it, Whisky Bob is the only exception, because he gives you 1 day to refuel the still. Although I never actually tested this to see what would happen if you took too long.
    Everyone else I guess is in no real rush to get things done.

    But a time limit on it would make this quest seem more realistic given the nature of the events happening. Other quests don't seem to have this type of priority, so a time limit would be redundant.
     
  14. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I agree about it being more realistic with a time limit. I'll consider the idea.


    @***F.E.A.R.***MaNiaC or those with an EPA crash
    Anything you can come up with will hopefully aid me in getting to the bottom of the issue. Hopefully it isn't just something amiss with the Fallout engine which only plagues a select few.
     
  15. laclongquan

    laclongquan Boned Hunter of Sister

    512
    Jan 11, 2008
    But it's strange that a selected few got this problem. I was running around in EPA for hours and nothing like that happened.

    On another matter, the door to the botanical garden dont have the line of password to open. If I choose a pass, it said wrong pass and ask Head of PR for pass. But then go to the gal in level one (4 holograms) did nothing as the girl just moaning what had she done. So, it's a bug or a feature? is there anyway to open the botanical garden?
     
  16. Polynikes

    Polynikes It Wandered In From the Wastes

    117
    Jun 19, 2007
    This may very well be true, I'm running 1.1 on Win98 without any Win98-specific sfall.dll or ddraw.ini and my encounter rate is very low, between 0 and 3 encounters between the Den and VC.
     
  17. MutantOne

    MutantOne First time out of the vault

    8
    Jan 16, 2008
    Thanks for the explanation. But... I don't have access to the maintenance area : here's where my elevators are : the chemical area (1 elevator) + the utilities area (3 elevators-1 broken).


    Here's a link to my 2 savegames :
    http://rapidshare.com/files/84317611/EPA_problems.zip

    I don't know if it will help but it's the best I can do for now.

    And thanks for taking care of us :D :D
     
  18. sonarone

    sonarone First time out of the vault

    10
    Jan 15, 2008
    The orphans quest bug:

    I got the quest, talked to mom, went to the squatters and spoke to them. They told me that they wont move and they will fight for their turf. When the dialoge ended nothing happened, so without moving my char i spoke to the squatter again and this time he agreed to leave the building peacefully. When the dialoge ended again and i went towards the exit , they attacked me. I killed them all except one girl who kept running outside the grid. After a few days i came back and the kids were in the building, but the squatters were resurected and standing outside the building, when i came close they attacked me. Anyway the quest was completed but when i was speaking to the keeper of the orphanage she kept telling me how the squatters were a great help to the orphanage.

    Too many encounters on the map.

    Sometimes while aiming the enemies the aiming percentage dissapears, while on the enemy.

    Thats all the bug i found so far
     
  19. nephwork

    nephwork First time out of the vault

    5
    Jan 16, 2008
    bvbdsdbhadfg

    "killap: No idea. Never heard of this before. Are we sure that everything was installed correctly to their proper locations? "

    just to be sure...can you tell me the proper locations of.....everything =)
     
  20. sonarone

    sonarone First time out of the vault

    10
    Jan 15, 2008
    It was the fault of the Fallout 2 graphic update ALPHA1 mod, it is not compatible with your mod.
     
Thread Status:
Not open for further replies.