Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. Faraday

    Faraday First time out of the vault

    22
    Mar 11, 2010
    My understanding is that having a kid with one of the Bishops means that ending takes priority over any other endings. But I -think- that as of now, entering SAD for the Wrights causes them to take over violently. Surely, entering SAD then returning to the Wrights should cause this ending to happen, not just the process of entering the Depot.
     
  2. Ylenard

    Ylenard First time out of the vault

    16
    Sep 18, 2007
    Small bug from Arroyo(not sure if it's worth the time to fix it):
    -If you try to steal from Hakunins chest and get noticed, opening the chest animation gets interrupted and Hakunin displays a floating warning "Those who steal carry a great burden" or something like that.
    -If you get noticed 3 times, combat starts.
    (so far so good)
    -Hakunin then runs out of the tent.
    -You can end the combat as he no longer sees you.
    -Hakunin will continue standing in whatever place he ran to.(strange, but acceptable)
    -It becomes impossible to steal from Hakunins chest. Animation get's interrupted as if he saw you, even though he doesn't as he is standing outside of the tent, and no float appears.

    That's the bug. I told you it's a small one:P. I'm not even sure if it's worth putting it on the wiki.
     
  3. lac

    lac First time out of the vault

    58
    Mar 17, 2010
    sprukrian: I was able to find out who was rustling the brahmins with a char of 3. Of course, I had speech 99 by that time, since I do the den quests before I do the klamath ones. The order I did things was
    a) talk to Mrs Brukner about what is going on in town. b) guard the brahminc) confront the twins with the fake scorion parts. d) talk to Mrs Brukner again, and say that the twins confessed. She doesn't take that as definitive, which surprised me. e) go over to the Brahmin pens behind the twins' house (which up until this point I had always thought was Torr's house, so I never stole from it) and examine the Brahmin. Go back to Mrs Bruckner and say you have more evidence. Then the quest is solved.

    hichief: do you have 200 dollars in your inventory after talking to Fred? You don't get that conversational option until you have the possibility of returning 200 to Rebecca, so if you talked to Fred and only took 50 dollars from him, and had less than 150 dollars when you started, you will have to sell some things and go over 200 before that conversation path opens.

    Grävling
     
  4. carpediem99

    carpediem99 First time out of the vault

    27
    Apr 2, 2010
    Nvm, found what I was looking for.
     
  5. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Yes, yes, no.
    Entering SAD is enough, since you leave it wide open after you. Remember, they know where it's at, they just can't get in.
    If you don't want the violent takeover ending, extract a virus down on level four (you've got 4 min to get out, which is enough to get Skynet if you're prepared). The only drawback is that you can't become a made man for the Wrights then.

    You can safely kill the Dunton's out on the grazing area or then kill them in their house after you've locked the door.
     
  6. Brunzer

    Brunzer First time out of the vault

    97
    Apr 9, 2010
    I did a caravan drive from the NCR, and encountered some issues. The first encounter went normal, I ran into some marauders and after they were killed, Stanwell says a floating message about the coast being clear. When I leave the map though, I get two different scenario's: 1. an empty encounter (with Stanwell, and the NCR caravan). 2. an empty encounter, but I seem to be part of a different caravan. All the guards are wearing leather armor (instead of the ncr police uniform) and Stanwell is replaced by a woman called 'grand master trader'.

    If I run of the map after one of these encounters mentioned above, I am teleported to redding, to the mining camp map in the center of the caravan tents. However there is no caravan master there, and thus no message stating that I've completed the NCR caravan drive (and no 2000$ :cry: )

    Here's my savegame: http://www.megaupload.com/?d=9SOVH2XR

    On a side note; I would love to hear a spoiler about getting access to Navarro by using the vertibird from New Reno. No matter what I try, all dialogue with the base commander seems to get her hostile. I've boosted my charisma to 8 and my speech to 110%. Do I need to have some inside information about the Salvatores in order to pretend to be one of them?

    @The people having difficulty with exposing the Duntons as the cattle rustlers in Klamath:
    You'll need a speech of about 70+ and probably some charisma to. My character had CH6 and INT8. Furthermore you need to confront them with the radscorpion limbs, then pass the speechcheck. Afterwards tell Ardin Buckner about their scheme, she will ask for more proof. Check the Brahmin behind the Dunton house for double brandings. Talk to Ardin again, and the quest is solved. The Dunton brothers disappear from Klamath afterwards.
     
  7. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I don't think there's a non-hostile way out of it, but I will look into it.
    EDIT: The commander has no text for letting you go. Your only option is to fight.
    You only need speech 51 to be able to get the correct dialog option.
    After that there is a roll check to see if you are convincing enough (with speech 51 you've got a 51% chance to pass).
     
  8. Brunzer

    Brunzer First time out of the vault

    97
    Apr 9, 2010
    Thanks!

    I've just fought my way out of there. And I was wondering if you actually need the Enclave main base coördinates from their computer. Due to the base being on alert the computer is inaccessible. That might be game-breaking if those coördinates are required, and you have no other option than to fight your way out of Navarro.
     
  9. lac

    lac First time out of the vault

    58
    Mar 17, 2010
    bug: Flying Dragon 8 and south table Red Guns 888

    When they restock, they don't restock money. The North table has some. When you pay for things, that money disappears in the next restocking.

    Gräving
     
  10. BassPlayaKEK

    BassPlayaKEK First time out of the vault

    48
    Jan 17, 2008
    Does Liz in Broken Hills still have a secret stash of weapons? I get the tip from phil and liz gives me the ok to get the weapons, but I don't see the entrance to the basement. Am I missing something?
     
  11. kungfujoe

    kungfujoe First time out of the vault

    83
    Sep 28, 2008
    Re: annoying battle saved game issues

    Then you've gotten lucky. The Fallout engine, from the very beginning, has had major flaws when it comes to saving in combat. Come to think of it, the Fallout engine was bug-ridden in too many ways to count, but one of the constants, ever since 1997, has been that saving the game in combat produced unpredictable results. Sometimes it worked fine, sometimes it caused minor problems, and sometimes it screwed the game up royally.

    If you want to save during combat, accept that there's a decent chance that you'll have major problems, and don't come crying to Killap about it. ;) Since it's a core engine problem, and not a script problem, I'm not sure if he could fix it even if he knew how. The best that might be possible would be to check whether a user is in combat or not and refuse to allow the user to save the game if he or she is in combat, but I don't even know if that could be done with a user-made mod.
     
  12. hichief

    hichief First time out of the vault

    2
    Apr 11, 2010
    Oh WOW that is embarrassing. :oops: Such a simple overlook! You are absolutely right. Thank you, and I apologize for cluttering the thread. :oops:
     
  13. BuxnaMan

    BuxnaMan First time out of the vault

    61
    Mar 26, 2010
    Re: bug: Flying Dragon 8 and south table Red Guns 888

    off topic but what is Gräving? Do you mean grävling with an "L"?
     
  14. Faraday

    Faraday First time out of the vault

    22
    Mar 11, 2010
    Ahh, that's perfect - never knew about the virus before, usually just headed straight for SkyNet & left ^^
    Cheers! Always just assumed it was a bug :o
     
  15. MoonScar119

    MoonScar119 First time out of the vault

    24
    Sep 14, 2006
    Re: annoying battle saved game issues

    I was merely pointing out what happened... i was not blaming or crying at all. I was merely stating what happened to my game after installing the RP. it's that simple. I appreciate your cander, but please, my games have been 100% mid-battle-save error free forever until this mod was applied
     
  16. blanca

    blanca First time out of the vault

    4
    Apr 8, 2010
    i got proplem i cant go in den whitout crash.. but i can go all other towns..

    its says The instruction at 0048d9c4 referenced memory at 0000001a
    The memory could not be read from on crash.

    i got windows 7 64bit
     
  17. sardin

    sardin First time out of the vault

    3
    Apr 5, 2010
    Re: annoying battle saved game issues

    Actually, I had the same problem with saving during combat.
    It never happened before (both in vanilla and RP 1.2), and it happened throughout all of my current game (RP 2.0) every time I saved in combat.
     
  18. boundrose

    boundrose First time out of the vault

    37
    Oct 10, 2008
    Not sure it has been reported before, but:
    -in Den, i did the job for Lara. During a second stage of the fight(not included in the vanilla game) one of the Lara's gang member died during the fight, but was still allive when we met back at the church.

    -i think that "Swift Learner" perk could really use some love, so it works as it is advertised ("whenever you gain exp"). I noticed it does not work with combat exp and exp for quests.
     
  19. Mr Maigo

    Mr Maigo First time out of the vault

    22
    Apr 2, 2003
    See, plenty of people save during combat. We're evil cheaters that love to kill packs of death claws at 600 yards by critting them in the eyes with a Red Rider LE. It's fun. So, can we please drop this bit about 'you shouldn't do it'?

    The problem is saves don't work during combat. Damage is delt, but it doesn't stick(?) and it doesn't show up in the window. You can kill/be killed but you don't stay dead.
    Here's a save that I just did for fun. Let the wolf kill you, get up and kill the wolf, the wolf will get up and do it again :twisted:
    Head over to Reno a pixel away (pure luck) and start killing people to see combat still does work.
    save


    --Unrelated--
    Mobsters in random encounters are carrying sniper rifles and no extra ammo. Not the big guys, but the entourage in leather armor. Shouldn't they have Tommy, grease guns and, idk, needle guns?
     
  20. Unkillable Cat

    Unkillable Cat Mildly Dipped

    562
    Jan 5, 2004
    The lastest batch of bugs I've encountered.

    Vault City:

    # If you stand directly behind Dr. Troy, you cannot talk to him. The old "You cannot get there" error pops up.


    Gecko:

    # Lumpy's dialogue needs another look at. While his script takes into account whether you're talking to him during the day (guarding brahmin) or during the night (in his house), it doesn't seem to do so in relations to Skeeter. Skeeter is always "just over there", and you can ask Lumpy about Skeeter without even knowing that Skeeter exists.

    # When encountering the Enclave patrol that's dispatched to Gecko to try to find you if you access the Enclave computer from the reactor, I experience a massive slowdown in the game. I think it's because of all the critters moving around at once.


    Vault Village:

    # When talking to Connor about having brokered a deal with Vault City, one of your replies goes "It's true -- trust me. I was able pull some strings..." There's a "to" missing in that sentence.


    Raiders:

    # None of the unlocked doors in the manhole-entrance map have the lock/unlock script on them, so you can't (un)lock them.

    # The Cattle Prod that can be found in the manhole-entrance map is loaded with "None" charges. It can be used, but you can't unload the ammo from it.
     
Thread Status:
Not open for further replies.