Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. BgGuy

    BgGuy First time out of the vault

    May 3, 2010
    I have found second bug (not 100% sure)

    In Primitive Tribe there's a quest for a Krom where you have to accompany Krom to meet with the trader. After quest is done and talk to Krom il get random stuff in inventory (first time Wall and overweight 11000/150 and second 2x "Desert Weed" wich you can plant by dropping them as a map spawn :P) But im not sure if its bug or just me but there's maybe mistake in code...

    Sorry for my bad english hope you understood :P
  2. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Hmm, I've heard reports of this before. Do you happen to have a save game?

    Interesting. I thought this only happened to party members. If all critters are affected in the game, then that's distressing. A script fix wouldn't be practical then. Perhaps something can be modified in the engine.

    These are all part of the enhanced map pack. I don't plan on making the maps an installer choice as mentioned previously in this thread. However, things like explosions, etc could be made separate. I'll have to look into this.
  3. joochian

    joochian It Wandered In From the Wastes

    Apr 1, 2010
    LMAO.. NOW THAT U MENTIONED IT.. AND SCREENSHOT IT.. YOU'RE RIGHT.. too many pipes, too many rugs..

    i guess i vote for quality than for quantity.. perhaps ravanger can be the judge of which pipe goes where and how many it should be?
  4. BuxnaMan

    BuxnaMan First time out of the vault

    Mar 26, 2010
    I guess everyone likes different things. Many had problems with map enhancements and such but explosions? Come on! No way you actually want old ones back... :roll:
  5. Ian007

    Ian007 First time out of the vault

    Apr 21, 2010
    It's always seemed to me that Cassidy spams his few text floats far more than any other recruitable character. Every few minutes we have to hear how he was named after a comic book character or how if he was 20 years younger, he'd go explore the midwest. Could his text floats be toned down to about half the frequency they're currently at?
  6. Mr. Bazooka

    Mr. Bazooka First time out of the vault

    Apr 21, 2010
    When doing the pretty boy Lloyd quest for the Salvatores, I got Lloyd to dig up the money, but if i drop the bomb into the grave after he goes down into the cave, I can't enter to recover the money. I can only get the money if I follow him down and kill him.
  7. Mirr

    Mirr First time out of the vault

    May 1, 2010
    Try to move as close to the hole as you can.I think it is like when you need to go to the green part of map to exit/enter.
  8. Josan12

    Josan12 Vault Senior Citizen

    Oct 15, 2007
    I second this ....
  9. ralphrepo

    ralphrepo First time out of the vault

    May 1, 2010
    The YK42B Pulse Rifle seems to be missing its attendant graphic when it fires; you hear the noise but nothing is seen coming from the weapon (the YK32 Pulse Pistol shows a nice purple discharge).

    On another note, I married Miria, the girl from Modoc, and gave her Combat Armor. Apparently, there is no attendant graphic for that, like the other NPCs. I know she's not a "real" combat NPC; but it would be nice for those of us that have her along if she could dress the part, LOL...

    I agree, but he's not the only one; Marcus is always floating his "...cut the muffin" bit or some such. It's funny the first time. But after the 30th, it starts to be an eye sore.

    Not a bug, per se, but it seems a little odd that one should lose Karma for killing a regular Mobster, but gain Karma for Killing a Japanese Mobster (Yakuza). IMHO you should gain Karma for killing either (along with the other Robbers and Highwaymen).

    Don't know if this is a bug or not, but I met a Traveler, and she gave me directions to "An Abandoned Mine." However, once I got into the world map, it was nowhere to be found.

    When taking on a caravan escort mission, I noticed that once the caravan master announces, "the coast is clear" and you leave the screen, you're automatically returned to the exact same screen. Only when you "leave" a second time, do you actually go on to your next encounter.

    While on a caravan with Savinelli (from Redding to New Reno), in one instance of a caravan screen, he was oddly changed to someone called "Grand Master Trader" and was a female sprite instead.

    In line with what respondent Big Guy stated about getting a Wall in his inventory, I noticed on several occasions, as I tried to gain access to either bookcases or dressers, if the hand icon is a little towards the rear of the graphic, the games seems to think that I intend to pick up the wall behind it. It then tells me that I can't because I'm at maximum weight capacity.

    In another oddity; I was standing outside of VC's main gate, when I clicked on Vic, instead of being given the NPC dialog screen, I was given the typical steal or take from dead body screen. I could then take whatever he had in his inventory, including the Power Armor he was wearing, like if he was a bookcase.
  10. BgGuy

    BgGuy First time out of the vault

    May 3, 2010
    Yeah I tested it and probably all the critters are affected. Also i don't have savegame in Primitive Tribe it was long ago :(


    Also there is no notice in Status -> Primitive Tribe for the quest where you have to bring to the shaman 5 broc flowers and 3 xander root (idk if not bug) and also the merchant in Abbey in quest "Repair the waterpump and report the status to the headmonk." tell you only once name of the guy from who you are taking the parts so i just forget this guy name :P
  11. .Pixote.

    .Pixote. Antediluvian as Feck

    Sep 14, 2009
    He is more than welcome to build his own maps, but the pipes aren’t original. Fallout Pipes . I know this is a concept image for the movie sequence, regardless the pipes stay. :wink:
  12. Da_Dude

    Da_Dude First time out of the vault

    May 5, 2010
    Right, first of all the mandatory praise to the creator. I'm a long-time lurker, first time poster etcetera.

    I also have a problem with dropping the mine on Lloyd. After I drop it I don't automatically follow him and when I click the grave the "loot the grave" screen pops up. Same thing if I climb down after him, kill him and then get up.

    Also, somewhat unrealted, I've been playing the long-haired dude but now that I have the bridgekeeper's robe I'm starting to miss not being able to use the cool new sniper animation. Is there a way to change this with a F2se or something? I know absolutely nothing about file-editing so if someone could help me I would really appretiate it.
  13. Darek

    Darek is currently unavailable

    Jan 7, 2008
    This was answered just a couple of post above yours.

    Maybe, just maybe, this can be changed in-game while playing. ;)
  14. patsak

    patsak First time out of the vault

    Apr 29, 2010
    Killap, нou will consider bugs which I have specified?

    Thanks Killap for great work in any case.

    I will play 2.1 in any case
  15. xzel87

    xzel87 First time out of the vault

    May 5, 2010
    Vic joins party even when he clearly rejected in the Den, and i already have max party limit with Sulik at 2 Charisma. If i ask Vic to wait he won't join up with me anymore though.

    I didn't pay Metzger to free Vic, but i killed them all.

    drugged up beforehand though, 3 jet, 2 buffout and 1 psycho.

    here is the save file after killing everyone and right before talking to vix to free him.


    another problem is that when fighting the slavers, sometimes i get a comma in the status box and the battle speeds by with me receiving damage without the respective animations...i'm not surrounded by enemies on all sides, just that they are all around me in different directions.
  16. Prosper

    Prosper Where'd That 6th Toe Come From?

    Aug 25, 2007
    Hey Killap! I am wondering what type of critters are needed for you to further the story of this un-official expansion?

    Here is a sample of a completely custom piece of art i made. It is animated to rotate around so you can see the valuable angles.

    I had no fo2 template for the view, so i used my FOT view template for it.


    I understand if it doesn't fit. :)
    I just want to contribute..
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yes, the bugs you reported should be addressed for 2.1

    The Vic issue is known and fixed in the upcoming release.

    Good job with that model! I'm always envious of people who can create graphics.

    The RP doesn't need any new artwork at this time, but I appreciate the offer.

    Does anyone happen to have a save game near or inside the EPA and has Vic in their party? If so, I really could use it to do some testing. :)
  18. Endocore

    Endocore Look, Ma! Two Heads!

    Mar 14, 2010

    The "abandoned mine" the Traveler tells you about is the Military Base.


    A few problems I haven't seen mentioned elsewhere:

    --There's no question at this point in my game, npcs are definitely (still) not affected by either poison or radiation;

    --There's a two-part bug in epac2.int (Director of Science). The player's response in Node012 ends the conversation (Node999) rather than leading further into the dialogue (Node013); however the global variable (775) for completing the quest is also set here at the same time (it should actually be set to 2 here rather than 3). The end result is that the scorcher quest, which the player doesn't get a chance to discuss with the doctor, appears as a crossed-out/completed quest in the PipBoy list for EPA quests.

    --In the area of the EPA zoo with the wannamingos, some secret blocking hexes are set around the small cave with the eggs, preventing access. If the player doesn't have any guns or thrown weapons, the eggs therefore cannot be destroyed.

    --There's an error in Node012 of fcmarc.int that causes a normal pc's conversation to be redirected into the "stupid" conversation set. The errant line

    op_giq_option(4, 977, 149, @Node003, 50);

    is most likely supposed to read

    op_giq_option(4, 977, 149, @Node002, 50);
  19. Da_Dude

    Da_Dude First time out of the vault

    May 5, 2010
    Gah, misseg it. Thanks.

    Any hints? I tried swining by Navarro to see if teh wanted to give the new recruit a buzz but no dice. :(

    Also, I've tried using the cigarettes but nothing happens. Not even Cassidy wants a smoke. :/
  20. killap

    killap Bear Dude Moderator Modder

    May 16, 2005

    You chose to install the new animations from the installer?
Thread Status:
Not open for further replies.