Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. hicarus87

    hicarus87 First time out of the vault

    2
    May 7, 2010
    Hi,
    I have a problem with savegames. I tried to install Fallout 2 with restoration mod both on Windows Vista and Ubuntu but I can't save the game and the message error is "Error saving game, unable to save game". Moreover on Ubuntu i tried to play the game only with the official patch and the game works properly.

    Thank you.
     
  2. Kwiatmen666

    Kwiatmen666 It Wandered In From the Wastes

    160
    Aug 28, 2006
    Regretfully I hardly took part in bug-hunting for this one, but I'm sure it is a masterpiece. I've known of this for some time now, but only now have I started downloading (I have to live some life after all;P).

    Can't wait to finally play it. Great job Killap! And big thanks to all you guys who took some part in this great undertaking.
     
  3. Mirr

    Mirr First time out of the vault

    48
    May 1, 2010
    Maybe another MASTER.DAT problem...see page 59 at the bottom or this.
     
  4. PainlessDocM

    PainlessDocM Sonny, I Watched the Vault Bein' Built!

    Feb 5, 2010
    The Den disappeared?




    This is what happens when I first arrive at this location. (game is updated with the latest update)
     
  5. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    If you can wait another 2 weeks, then you'll really enjoy the 2.x line of the Restoration Project.

    @PainlessDocM
    I really wish I knew what was wrong with the Den for several member here. I cannot reproduce any of the problems. Are you running the resolution patch?
     
  6. PainlessDocM

    PainlessDocM Sonny, I Watched the Vault Bein' Built!

    Feb 5, 2010
    @Killap

    I did a full install (all the extra's) and I can change the resolution ingame but I haven't installed any other resolution patches or anything.

    edit1: I'm using the GOG version of F2 perhaps that has something to do with this bug?

    edit2: This didn't happen before using your latest update (I started a new game after applying that update)

    edit3: Thanks for this great mod and all the post release support :clap:
     
  7. ufo_hunter

    ufo_hunter First time out of the vault

    59
    Feb 29, 2008
    A bit OT I know, but while waiting for the RP2.1 to come out might as well grab the good old Fallout 1 and beef it up with team x's patches and mods. Great way to spend some time and get a dose of Fallout! =)
     
  8. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Interesting. Actually, someone else mentioned this about the latest 2.0.2e update. Try this: Reinstall the RP (version 2.0.2d) and then when you apply the 2.0.2e patch, don't copy over denbus1.map to the maps directory. Be sure to save right before you enter the Den in case we need to do further testing. Let me know what happens.
     
  9. PainlessDocM

    PainlessDocM Sonny, I Watched the Vault Bein' Built!

    Feb 5, 2010
    Will certainly try that later today.

    edit:

    I reinstalled F2 + did what you suggested and I can now enter the Den.

    Thanks :)
     
  10. RtotheDizzy

    RtotheDizzy First time out of the vault

    2
    May 7, 2010
    bugs

    I have two bugs to report:

    While boxing in new reno in the first match every time I get hit for what should be damage I just get a message "." and take no damage. When I'm hit for no damage or he misses I get the correct messages.

    In the abby while talking to the trader trying to get the mutant armor some of his dialog appears as dialog options for me and I am unable to acquire the armor. Whether I select what I assume should be my dialog option or what looks like his dialog option it just goes back the the initial conversation either way.

    Sorry if these have been reported already but I hadn't seen them.

    I'm using version e and have all options installed except for ammo mod and random level ups.
     
  11. Black_Tom

    Black_Tom First time out of the vault

    1
    May 7, 2010
    Haven't read this before, so here's one from me:

    My game crashes when I try to enter the council area of Vault City. This only happens when I don't get the quest to scout Gecko before entering the area. Though it could be using the left side of the green grid, not sure, since after the crash I usually get the quest first, and enter through the center/right side of the grid.
     
  12. ocelot

    ocelot It Wandered In From the Wastes

    109
    Sep 17, 2003
    Killap: I think you and your friends have also added in a lot of items of value to random encounter maps? For instance, just today I found 180 BB's in a Destroyed City map. I don't think one could run across anything like that before. And I seem to be noticing similar....abundance in many other random encounter maps too. This is not criticism, just checking if I'm right.
     
  13. YujiTFD

    YujiTFD First time out of the vault

    7
    Apr 13, 2010
    Hello again!

    Wanted to thank everyone with helping me in the past and ask for another thing, which is troubles me.

    In New Reno I picked up "Bust up Wright's still" quest. Tried skills (science 82, repair 88) - fail to learn anything, cannot repair that. Tried crowbar (wielding it and using backpack item) - that does nothing.

    I clearly remember it never gave me such "attitude" before and I'm out of ideas. Here is my savegame for debugging. Thank you in advance.

    P.S. How long Mrs. Wright will wait me finish the quest?
     
  14. Darek

    Darek is currently unavailable

    Jan 7, 2008
    You are trying to break the wrong still. :)
    It's those eight tanks on the northern wall that are the real still.
    With science or repair in the eighties you may need a few tries but the crowbar should do it every time.

    killap, I think you should remove the newly added small still to not cause more confusion.
     
  15. YujiTFD

    YujiTFD First time out of the vault

    7
    Apr 13, 2010
    Do I? :o Was perfectly sure it's the one, kudos for helping, buddy :D

    I guess I second that, but I'd prefer to let it steam (looks like somebody is distilling his own hootch :lol:), just make it unusable, because it's the open palm cursor over it, that creates confusion :P
     
  16. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Oh Pixote and his map additions...
     
  17. gn0mish

    gn0mish First time out of the vault

    15
    Dec 15, 2008
    Re: Some Issues...

    4. Party-members are shoting at my opponent during ring-fight at SF.
     
  18. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Don't know if it's a bug. In 2.0.2e, I put all mutant-haters in jail in Broken Hills and have Marcus in my party till the end (including the Oil Rig). But in the ending slide, Broken Hills still got racial wars ending. Does this have something to do with the accidentally included debug version of Marcus?

    BTW:
    [spoiler:8a9543123f]After the Star-Wars encounter (that's a really big surprise! :clap:), I drive to Primitive Tribe and talk to the leader. And when he got hit 10000 HP, the conversation window displays nothing and stays on my screen forever. I managed to talk to other people that have conversation window and leave the dialog to clear the conversation window. Dunno why this happens.[/spoiler:8a9543123f]
     
  19. ocelot

    ocelot It Wandered In From the Wastes

    109
    Sep 17, 2003
    The inventory that the doctor in Redding has for sale never refreshes. You can buy stims from him once, and then they're gone forever.

    I also experienced my NPC's gunning down my opponents when fighting in the San Fransisco Ring.

    I also experienced the combat message "." when receiving a targeted blow in combat.

    There were also minor typos in some of the new dialog. "Minors strike" for "Miners's strike" comes to mind. No biggie tho.

    I got the "you massacred the deathclaws" ending though I did no such thing.

    I also did not get the good ending for Gecko though I optimized the powerplant and did not tell Vault City. Dunno what I shoulda done differently,
     
  20. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Got a save game before you see the ending slides?
     
Thread Status:
Not open for further replies.