Fallout 2 mod Megamod version 2.47 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Mar 20, 2017.

  1. CritToTheEye

    CritToTheEye First time out of the vault

    2
    Jan 25, 2020
    I suggest putting a limit of a week or month on New Reno casinos. It's TOO easy to get millionaire there with the 1000 wager. I only needed about 110 gambling. Put a limit on the winnings, like 5k max per month.

    Also, thanks for keeping the mod alive!
     
  2. Alf_Pacino

    Alf_Pacino First time out of the vault

    17
    Sep 14, 2017
    Bugs I found so far:


    • Raiders and Robbers do Kaga combat taunts
    • Sometimes when taking all items from a container, the game crashes. Rarely Happens
    • Myron's voice sounds like using power armor, even without one.
    • Laura did not appear in the church after winning the fight in the den
    • Crashes randomly when searching for containers. Does not happen twice in the same container.
    • After paying Dr. Troy in vault city for new recipes, no new recipes appear on Mr. Fixit, and on the log, it reads "optained" instead of obtained.
    • Francis the arm wrestler sees you as evil after acquiring the Cult of Personality perk. Only talks to you properly after completing the missions on Broken Hills
    • Car is on Exit grid on Toxic Caves. Can be accessed only sometimes
    • "Error" messages from singers on New Seno Street
    • Bug when entering broken hills mines. An ant attacks as soon as I enter, but after it moves the turn keeps going as if another creature is moving, which never happens and the Combat turn never ends. It gets stuck in that instance, and even when the ant is close enough to attack, it doesn't.
    • Dead vault dwellers appeared in guns merchant stock in NCR
    • Dead Vault Dweller.png
    • Jet Cure won't take the addiction away after you "recover" from it by time. It does not figure in the main screen, only in CHAR. Perception won't be regained after curing Jet Addiction.
    • Dialogs in Slaver Camp breaks the engine by making dialogs overlap with everything, but not functioning as dialogs: Screen appears but the game still works as the dialog screen is not there making the salver camp mission impossible; the bug is so big that you have to restart the game because the error persists between games.
    • The 12.7 pistol sometimes crashes the game when shooting, the firing sound happens right when it crashes.
    • BoS Siege Error Dialogs when entering the location on both sides and the chosen one. The battle starts after that
    • Sometimes it crashes when entering "Car out of Fuel"
    • If you already traveled no NCR when you are given the reckon job from Vault City, you can go through dialog infinite times to gain XP and motion sensors. No idea if this works if you did not go to NCR beforehand.
    • When the car breaks down, it's still used after exiting the location for that travel only
    • Goris has Green Highlight in vault 13 when Deathclaws are killed. It stays that way.
    • Goris.png
     
  3. ThunderGod

    ThunderGod Have Hammer; Will Smite

    10
    Oct 20, 2009
    Carson City - the slut has the same dialog with a female PC that she does with a male PC.



    Edit: All dialogue in Carson City/Reactor does not differentiate between a male or female PC.

    It would also be nice if the ability to look at the car and see its fuel level was re-activated. Also, using Super-Stims to assassinate.
     
    Last edited: Apr 15, 2021
  4. Aleksandar Kukolj

    Aleksandar Kukolj First time out of the vault

    5
    Apr 9, 2021
    Super stims settings is in ddraw.ini, set it to 0 and you can use them for assasination again.

    As for the car, I can not even recharge it until I paint it in Chop shop back to original color... Also, if I paint them to black, I can not charge it again...

    EDIT: I can not find Kruger... In Primitive Tribe no-one mentions it, and as far as I remember, in previous version I simply run into him in Broken Hills - now he is not found anywhere.

    Is there any way to find him? Maybe by editing save game with editor - which GVAR values should be set?
     
    Last edited: Apr 17, 2021
  5. ThunderGod

    ThunderGod Have Hammer; Will Smite

    10
    Oct 20, 2009
    Thanks, I modified my ddraw.ini.

    Not sure about refueling the car after painting, as I have not had that error. Did you primer first?

    The two places I known to find Kruger are:

    Broken Hills Residential and Gecko near Skeeter
     
  6. ThunderGod

    ThunderGod Have Hammer; Will Smite

    10
    Oct 20, 2009
    Man, if I was better at modding FO2, I would use the slot machine proto and rework the script to make a Jimmy Hats dispenser.
     
  7. flowerpunkt

    flowerpunkt First time out of the vault

    2
    Apr 19, 2021
    Hello,

    Im currently playing this mod, latest version from post here. Game works quite fine and its quite fun mod compilation, in 5 hours I had 2 crashes, however I found bug in Colly.

    Youn cant actually seduce Leyla. When she takes you to place where "no one will find us here" dialog window pop up and freeze. You cant even load a saved game, you have to exit game to windows and then load again. Also not sure if dialogues with Josie works as intented (cant persuade him to attack his brother Humprey, cant give him a gun, but maybe I missed something)
     
  8. Aleksandar Kukolj

    Aleksandar Kukolj First time out of the vault

    5
    Apr 9, 2021
    Leyla dialogue is bugged, same way as Slaver camp is. Luckily, everything else works, just seduction does not.

    As for Josie, it works OK, you can reach to the point of giving him the gun, but it is very complicated to do so... If you check Megamod guide, you will see it is outdated... But you can persuade him with right choices (and probably right speech skill), it is just hard...
     
  9. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    wonder if this in ddraw.ini is set to 1>?

    ;Set to 1 to fix the issue with being able to charge the car by using cells on other scenary/critters
    ;Set to 0 if another mod you're using has custom vehicles
    CarChargingFix=0
     
  10. Aleksandar Kukolj

    Aleksandar Kukolj First time out of the vault

    5
    Apr 9, 2021
    Did anyone tried Monastery (former Abbey)?

    I became a member, but instead of implant, I took a holodisk. Holodisk is marked as "Abbey Holodisk", but despite copying stuff from NCR, Reactor 7 computers, I can not report to monk or import data into their computer? How does this part work? EDIT: it works simply enough, just "use" holodisk on computer, I am an idiot.

    Also, I brought them Vertibird plans, and had option that "Shi asked for vertibird plans" (thought I also have active quest from Hubologist and Brotherhood, they are not mentioned). They gave me "Fake vertibird plans", but when I took them to Shi, they attacked me after I gave them those fake plans - maybe it is supposed to be like that?

    I played with this - if I set it to 0, it behaves like I already spoke - I can not refill car until they are painted with primer in Chop Shop. If I set it to 1, I can not fill them even when they are painted with primer :) But I am already late in the game, who knows what I broken until now... :)

    EDIT: Siege for BOS don't work, dialogues are all error, and once combat finish, BOS knight approach to say something, but games crash to desktop every time...
     
    Last edited: Apr 21, 2021
  11. Muttie

    Muttie It Wandered In From the Wastes

    198
    Oct 9, 2017
    Slaver Camp
    The missing script is: slvcc4.int
    Find an old version of MegaMod, take the script and add it to data/scripts (in the MegaMod folder) and it works.
    If you can't, this is a version from 2.47.4.1: http://www.filedropper.com/slvcc4
    Alternatively, the MegaMod version at the bottom of MIB88's posts (MM 2.47.4) should also include a version of that script.
    Not checked if the script itself works within 2.47.6 (should though), but adding it will fix the dialogue freeze (tested).

    As Aleksandar Kukolj (quote below*) said it does work... Josie is just a bit weird. There is a timer and randomizing effect in his dialogue (I never really figured it out), but you can skip one of the steps (randomizer) and the final step requires that "time has passed", I think. At least, during tests I found that it was necessary at times to rest for 10 minutes to get Josie to ask for a gun. Try that, if he won't trigger.
    [*and there is no speech (or any other) skill involved :)]
    Edit: However, you must be a Lumpen...
    And... because why not here is the fully detailed way of handling Josie... Heavy spoiler!
    Josie. Josie is the younger brother of Humphrey Snag, the Lumpen Gang leader. You can trigger a special conversation tree with him that starts by delivering Berk's book.
    1. After you returned Berk's book, you get an option to talk with Josie about reading books. You can trigger this discussion immediately, or later. This dialogue seems complicated but is fairly forgiving. The main goal is to mock books, but not to go overboard with it. However, you can circle around it in any one way, even defending books at first. The important crossroads (of no return) are “But to think well, books are a rare piece of shit.” and “Oh, buddy, your hate for books is boundless. I give up.”. Those you need to hit. If you do, you get 350 XP "For finding common ground with Josie", and a Dean's Electronics book (accompanied by the fluff that Humphrey once thought Josie could build a distiller with it, but it failed).
    2. After finding common ground with Josie, wait for 10 minutes. Then talk to Josie again. He'll ask for a drink and you can end up giving him up to 2 drinks (one at the start and one at the end of the dialogue), however, neither is required. Again this dialogue has no impact until the final choices. Those are important, though, as they will set Josie's mood. Basically Josie sits at a mood of 20. And when that mood is above 20 he is optimistic, when it is 20 or lower he is suicidal. This mood will decide his actions when you give him a gun during step 4. The options you have now are: “leave for Klamath” (+3), “kill yourself” (-3) (both give 150 XP) and “cracking up” (-1), which is only worth 100 XP. Either way "You talked to Josie about the meaning of life".
      [Note: at this point you can skip step 3 and trigger step 4 “Josie asks for a gun”. The only way to prevent this is to either not join the Lumpen gang, or not to have a pistol on you. In that case you get a “I can give you a melee weapon” option, but the choice is postponed. [If you struggle to trigger the gun demand after postponing it once, try to rest 10 minutes.] When you trigger the gun option while carrying a pistol, then the conversation is locked in and step 3 will be skipped.]
    3. After you talked to Josie about the meaning of life, you got a 1 in 4 chance to trigger a dialogue about poetry. Keep hitting Josie until it triggers. Talk to Josie about poetry. 100 XP. Your choices don't matter again until the last options, which will influence Josie's mood: “great poem” (+3), “need practice” (+2), “it's trash” (-3), “dunno” (-1).
    4. This is the last step and you must be a Lumpen to trigger it. If you are, and carry a pistol (that's: 8 (Colt), 122 (9mm Mauser), 122 (Mauser again, was meant to be 9; 10mm SMG; now it's 536 (Pistol)), 313 (.44 Magnum Revolver), 398 (.44 Magnum Revolver Speed Load), 18 (Desert Eagle), 404 (Desert Eagle Expanded Magazine), 22 (14mm Pistol) or 241 (.223 Pistol), the script checks in this order), then Josie will ask for it and not stop until you relent. Mind you that there is only one outcome where you get your gun back naturally (you may still steal & kill, I guess). Anyway, if you have PE 8, you can notice that Josie is “overexcited”, mention this and depending on his mood you will realize he (either intends to commit suicide or to kill Humphrey), you then get the choice to let him continue (see final note below) or talk him out of it and leave for the Den. 250 XP (however, this path is currently bugged, faulty local check, and just throws you out of dialogue).
    When you reach the 4th conversation step and don't talk Josie into leaving town, then depending on his mood he'll either commit suicide (200 XP, and Humphrey will pick up your pistol... bastard), or he will shot Humphrey (see the Grizzly John section on how that plays out).

    And an Update:
    Leyla “should” work when you go into data/scripts, copy red.int and rename the copy rusty.int (same as above, engine gets stuck in these specific dialogue cases (i.e. dialogue can't start from critter_proc when the map uses an non-existent script).
    However, there was another dialogue bug with Leyla that could get her dialogue stuck, but that should also be fixed in 2.47.6.
    Should all work once you add rusty.int.

    Btw, I really do like Colly, I think it's a well designed place with lots of interesting ideas (code and story wise), it was just rather difficult to reverse engineer it (if that's the right word) to find the bugs and how to fix them. In parts Colly is really complex, like for example the initial check when entering the town (with food & drink); there's a lot going on. There's even stuff I haven't understood yet, I only know that it works... which good enough for me :).
     
    Last edited: Apr 24, 2021
  12. ThunderGod

    ThunderGod Have Hammer; Will Smite

    10
    Oct 20, 2009
    Nope, changing ddraw.ini did not return the super stimpak usage; I still got a "CHEATER" message when I used one on AHS1 and all of my super-stims were removed from the PC. How is using a frigging game design function cheating? What script do I need to delete to get this BS out of my game?
     
  13. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    haha i wrote that,unzpi this into data\scripts folder,i removed the code for u
     

    Attached Files:

  14. ThunderGod

    ThunderGod Have Hammer; Will Smite

    10
    Oct 20, 2009
    Thanks!!!!
     
  15. Aleksandar Kukolj

    Aleksandar Kukolj First time out of the vault

    5
    Apr 9, 2021
    :lol::lol::lol: You are one evil person, you know? I laughed my ass off when I saw message for the first time - that taking away all super stimpacks was painful, indeed.

    However, returtning settings to 0 worked for me in ddraw.ini. But some other setting does not work (for example, changing explosive strength, or controling party members in combat). I thought I borked something during installation...
     
  16. Lyle.pt

    Lyle.pt First time out of the vault

    6
    Saturday
    is this compatible with Windows10?
    :monocle: