Help, I bugged Goris

Discussion in 'Fallout RPG Gameplay & Tech' started by unchained, Feb 26, 2018.

  1. unchained

    unchained First time out of the vault

    Feb 26, 2018
    Hello and sorry, english is not my first language...

    So because I am stupid, I managed to bug Goris and ofcourse I accidentally overwritten save I needed. Loading one of the older saves is pretty much the same as starting over since I am almost at the end of the game. Playing Fallout 2 Restoration Project.

    How I fu*ked up?
    I completely forgot that I promised Chip to get back his spleen if San Fran and left him waiting too long. He disappeared. I am trying completionist gameplay so I tried to download save editor to try "fix" it somehow. Everything was fine until I did two things... I changed 367:GVAR_SAN_FRAN _SPLEEN to 0 in hope that Chip will be back and I will be able to pick up the quest again. That didn't happen so I opened the editor again and found another GVAR_SAN_FRAN_SPLEEN_TIME and changed the value also to 0 because I stupidly thought that would reset the timer and... I don't know what I thought, I just tried...

    What happened?
    It obviously didn't help so I said "fu*k it, at least I don't have the quest in my pipboy anymore" and continued. I traded some stuff in tanker shops, stupidly ovewritten two important saves and only after that I noticed that my party is not following me.
    I clicked on them and Sulik, Cassidy and Marcus had dialogue opitons like we just met. I got them to join me like it was for the first time and like we were not in San Fran almost ready to take on Enclave but Goris won't talk to me. He's just standing in the dock and I can't interact with him. I can push him like any NPC, I can use stimpack on him, if I activate battle, he derobes and he's "hostile" - not attacking me, just red.

    Is there any way to "repair" him or is he lost for good?
    If anyone has any tips about what can be done, please write them like you would for an eight year old girl with learning disability because that's how I feel right now. Thank you, any help appreciated.
     
  2. Walpknut

    Walpknut This ghoul has seen it all

    Dec 30, 2010
    So you didn't bug Goris, you just fucked up your save with improper use of the console. No solution other than reloading a save precious to the fuck up, really.
     
  3. unchained

    unchained First time out of the vault

    Feb 26, 2018
    Thank you very much, I just wanted to be sure. I quess I'll finish without Goris this time.
     
  4. QuantumApprentice

    QuantumApprentice First time out of the vault

    Feb 9, 2018
    I'm not sure if this is the case, but your bug sounds similar to a bug that Per Jorner notes in his walkthrough:
    "There's a nasty bug here you have to look out for: if you sleep with Miria or Davin and don't follow through with the wedding, your party members stop following you; they will come with you from map to map but stay rooted except in combat mode. This can be fixed by either of the following: 1) Getting married. 2) Having the Val/Vic conversation in Vault City. 3) Watching the Vault 13 video sequence. 4) Watching the Brotherhood video sequence in SF. Note that even if you don't have any party members at the time, you will still experience the effects of the bug if you should ever pick up any."
    Full walkthrough found here:
    https://fallout.gamepedia.com/The_Nearly_Ultimate_Fallout_2_Guide
    or here:
    http://www.nma-fallout.com/resources/pers-the-nearly-ultimate-fallout-2-guide.81/
    I'm curious if the solution presented here will also fix your problem, though I feel doubtful as Goris is not mentioned by himself regarding this bug.
     
  5. unchained

    unchained First time out of the vault

    Feb 26, 2018
    Thank you for your tip, QuantumApprentice, but my "bug" (more like fuck up) is different.
    Goris won't even jump with me from map to map, he's just standing at one place.
    I can push him, use things on him and attack him, but he's not "talkable".
     
  6. QuantumApprentice

    QuantumApprentice First time out of the vault

    Feb 9, 2018
    lol Yep, that's a little different from the bug I mentioned. Sorry I can't help :(