Megamod 2.3 technical issues and suggestions

Discussion in 'Fallout General Modding' started by MIB88, Dec 6, 2007.

  1. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
     
  2. Unno

    Unno First time out of the vault

    Mar 17, 2009
    :eyebrow: ..I see. So to make it look more "realistic", I would have to use one elevation from the "tribe01", and the other elevation from the "tribe02".. Hmm, this raises only more question, but I'll stop here.

    I'll be sure to find that patch. As to the corruptions - I got condoms.. erhm.. backups all over the place. :salute:
     
  3. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Carson City:
    Bugs with the mayor: lcmer.msg has the wrong format (Unicode instead of ANSI) and crashes the game for me.
    In Node010, when you get the 3500xp, it also displays "error". It's looking for line 803 but it don't exist.
    Can confront him about the murder again and again for infinite xp.

    Generally bad English in all of Carson.
    Aren't Lars1.map and Lars2.map a better version of Carson City than the one currently used?
     
  4. Demonslayer

    Demonslayer Water Chip? Been There, Done That

    Aug 8, 2005
    It's been a while since i last played this so i have to ask:
    Did that golden eagle mod get implemented?
     
  5. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    @Darek:
    I'll correct the lars.txt file and make sure that it is saved as an ANSI file. I'll see what 803 is supposed to be and add another dialog line.

    As for which map to use, I think you are right: those other maps do look good. But, I think those were just sample maps because - if I remember correctly - when I opened the mod, none of the critters had any scripts attached.

    @Demonslayer: The golden eagle mod was never added. I could add the golden desert eagle item. However, the artwork for Lil Jesus Mordino that was being worked on had some problems when placed in the game. It was never fixed.
     
  6. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ MIB88
    Those other Carson maps definitely needs some work if they are to be used. They do have a few of the right scripts, and they have the hunters that are mentioned in the mayors text file. I was mostly wondering what was up with those maps.

    more bugs:

    It has been reported as a bug that Matthew in San Fran won't disappear after you give him the verti plans. This is no bug though, he is not supposed to die until you have done the "Discover the reconnaissance troop's fate" quest for the BOS Bunker.

    There is a problem with the "alternative" solution to the above mentioned quest though, one that makes it unsolvable (and if you start with the "pacifist" way you can't fight later) .
    Instead of fighting you flee back to the BOS Bunker and then go to San Fran to get help, Matthew says he'll help but nothing happens.
    Code:
    Fcfmatt.ssl: 
    Nodeo23: "gsay_option(1158, 310, Node024, -1);" should be "gsay_option(1158, 310, Node023a, -1);".
    Also, you get no xp for going with the alternative option. The mission is to discover the troops faith, not to save them, and after running around TRYING, you should at least get some xp, although less than if saving them. Or maybe access to the BOS Bunker is reward enough?

    Missing line #510 and #520 in brhdhlp.msg resulting in ERROR message when entering the "Siege" map.
    The brohdent.msg file is missing, it should contain lines #100 and #101, resulting in ERROR message when entering the "BOS Bunker" entrance map.
     
  7. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ MIB88

    I fixed that strange "vault 13" bug in the vault 23 map.

    I have no idea how it happened but vault13.int somehow got "embedded" as an invisible map script.
    I cleared all the levels and all scripts with the mapper, but the damned thing still remained.
    When I saved the map as a text file I could actually see the script and remove it. Too bad that screws up the exit grids and since I didn't want to potentially repeat the problems with the Primitive tribe map, I had to resort to hex-editing. After having some trouble figuring it out I removed all scripts with the mapper, and then it was easy to edit out that stubborn last one. Put all the scripts back in and now it's working as it should.

    You can get map and gam-file here. You need to set vault23.int as the map script (it's in the script folder but not added to the script list).


    I wanted to fix that broken exit grid on level 3, but I don't know how. The Mapper won't let me put any map numbers higher than 160. How do you do that?

    A few minor issues with the vault 23 location:

    Vault23.ssl:
    procedure map_enter_p_proc:
    Code:
    if (global_var(767) == 0) then begin
    		display_msg(message_str(291, 10));
    The Gvar should probably be changed to "if (global_var(767) < 2)"
    Message string is supposed to go to Vault23.msg but doesn't.

    v23lift.ssl:
    procedure use_p_proc:
    Code:
    		display_msg(message_str(291, 20));
    Message string is supposed to go to Vault23.msg but doesn't.

    vlt23ent.ssl - Map script for vault 23 entrance:
    Only updates lightlevel when entering map, I'd bet the reason is that map_update_p_proc is empty.
    Worldmap status for Vault 23 remains as "Unknown", I'm guessing that's in here somewhere.
     
  8. Unno

    Unno First time out of the vault

    Mar 17, 2009
    Here's a patch for the mapper that will up the limit to 255.
     
  9. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Thanks, I'll check it out. :)
    I knew there had to be a way to do it, but my searches all came up empty. :roll:
     
  10. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    @Darek: You are a lifesaver! Thank you very much. I'll make sure to add your files to the MM and make those necessary dialog changes/additions.
     
  11. Darek

    Darek is currently unavailable

    Jan 7, 2008
    You're welcome. :)

    I just found out that the exit grid ain't broken.
    It's just a map mislabeled in MAPS.TXT :lol:

    Code:
    [Map 204]
    map_name=v23Boss need to be changed to map_name=vlt23Bos in MAPS.TEXT
    I'm assuming that is the map you intended to use.
    Would that be with vt23cav.int as map script? It's too light without any.

    There is some problem with v23boss.int, the map crashes (both in-game and in the Mapper) when it is being used.
    Remove it and everything is hunky-dory. I haven't looked at it yet.

    If you are sitting on other versions of these maps you plan to use, please do say so.
     
  12. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    In the original Vault 23 mod, there are 3 maps: the entrance map and two levels of the vault, a map with caves, and then the boss lair. I could never get the map with caves to work... could not even get it open! So, I bypassed that map, so the player now goes directly from the Vault level to the boss lair.

    Yeah, I found that problem with the boss script a while ago. I already changed it, and that level works fine now. I am pretty sure I worked out the issues with the boss lair. I try to test things the old-fashioned way - in game, without an editor. I will test my latest versions again to make sure some of my changes took. Then, I can send you my latest version, if you want.
     
  13. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Yeah sure, I'd like that.

    Anyway, I was going through some old stuff before I got sidetracked with Vault 23.

    * Sajag, Duntons and Torr: The brahmin rustle quest. The reason this quest can't be completed is because there are too many dialog options in Sajags dialog window, so the line to complete this quest won't show up.
    Code:
    KCSajag.ssl Node000 Line 224 or 226 won't show up. Just throwing in a "and not (global_var(654) == 14) then begin" in front of a couple of the other lines should fix it? 
    * When flying the vertibird, I picked "choose a city", and then I was teleported to Vault 23 Ent, when I later tried it I always got teleported to the Shack (different saves though), either way I lost the verti.

    Also I read through this whole thread, I'd like to comment on a few things, though they are probably not relevant anymore:

    *You said you were thinking of giving something more than just karma if you give the spectacles to Renesco. Well you already do get something more, check Per's Guide.
    * You still haven't fixed the shelf with the heart pills in NCR. Need to remove "script_overrides;" in procedure use_p_proc to sidshelf.int, or better yet, just delete that script since there is no other difference between that and the original one. Unless it was disabled on purpose because of Mr. Chemmie of course.
    * The heart pills are not working on Cassidy because of his talking head mod. I haven't looked into what the problem is, but know that killap fixed it for the RP.
     
  14. Oracle

    Oracle Water Chip? Been There, Done That

    May 19, 2003
    So MIBB what a are you mainly working on for your coming release (next to all the bug fixes)? Are you going to wait for the next RP from killap?

    Any crazy rusian mod currently you're going to implent?
     
  15. Unno

    Unno First time out of the vault

    Mar 17, 2009
    Don't know if this has been "fixed" or not, but.. remember those Giant Scorpions on the Primitive Tribe/Woodland area, which were referred to as Lesser Scorpions by the game.

    I changed their scripts from ZCIScorp[Generic lesser scorpion] to iiScorp[Raiders Scorpions 2X poison], and they are now Giant Scorpions[in and out of combat].

    I'm wondering has anyone tried this.. but more importantly: has anyone had any problems(retina burns) while doing this? -As far as I can see, the only "downside" is.. stronger poison.

    Also, the real lesser scorpions on this map have no scripts at all.
     
  16. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    I finally got a chance to really look at this. There wasn't anything mislabeled there. The lookup name can be anything, as long as it is called the came thing in the city.txt file.

    Also, did you actually get the vault 23 cave map open? I have changed its name a couple of times, but it was called crisicav at one point.


    @Unno: I have added scripts to the lesser scorpions. I never noticed a problem with the larger scorpions, but you are right: it would be very easy to change the assigned script.

    @Oracle: I was trying to get the Colly/Sokil mod into the Megamod. After some serious problems, I finally got it. However, there is one dialog left to do. A character named Red has about 95 percent of his dialog translated. However, a lot of words still appear untranslated (in addition to the language that I just need to try to clean up anyway). No other big mods. Like everyone else, also waiting for the latest RP, so I can start include it.
    As for smaller stuff, there is new art, as well as a special encounter from Josan12. Other than that there is just other smaller ideas being fleshed out (including the disguise kit, making the threat of radiation a little more prevalent, and a few others).
     
  17. Unno

    Unno First time out of the vault

    Mar 17, 2009
    @MIB88

    Just to elaborate the bit about large scorpions:

    It's mostly visible in combat.. such as - "Lesser scorpion missed", or "Lesser scorpion was hit for XX." - even tho they're mutated/large scorpions. It seems that those(combat) messages are somehow related to the script a critter is equipped with, rather than the critter itself.

    It's a minor thing, but...
     
  18. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ MIB88
    I'm getting a bit confused here...
    I only have access to the files that came with the MM 2.34 so that's what I played around with.

    It was the map name that was wrong not the lookup name, and I did nothing in city.txt. The only thing in there regarding Vault 23 is the entrance map.

    If the vault 23 cave map is the one with a new big rat in a cave, then yes, I got it open. It's called vlt23Bos.map now.
    By changing the map name in maps.txt, instead of being spawned into the wall behind the elevator I correctly landed on the rat boss map.
     
  19. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    Ah, yeah, that problem. Yes, I fixed that a while back (after having messed it up, of course). And what I was wondering was, if in the data folders I might have left a copy of the original cave maps that are supposed to appear after you leave the vault but before you get to the actual boss.

    And, I was only referring to the name in the city text because... well, it doesn't really matter. It was just something I learned a while ago about how the city.txt file works alongside the maps.txt file. Sorry for the confusion.

    Edit: Thanks for that info on Vault 23. Been able to get that stuff resolved. I never recognized that the map script wasn't there because it wasn't added to the end of the list by the original creators. Instead, the map script (and corresponding dialog file) were added in at space 291... way at the beginning of the list.

    I have added in the map script and made sure that the dialog file is properly called. (Due to something I discovered with the engine and dialog files, dialog isn't pulled from vault23.msg). I used the same dialog fix for the elevator (v23lift) as well. I also changed the global variable as you suggested.

    Still looking into the issue with the light level on the entrance map and why it appears as unknown on the worldmap.
     
  20. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Nice to hear you are making a lot of progress.

    For the lightning issues, I think it is enough to just copy the entire set_light_level section from "procedure map_enter_p_proc" into "procedure map_update_p_proc".

    This is what I meant with the blocking hexes:


    That could still cause a problem for unarmed/melee characters, but they could just go and get a gun.
    Meh, never mind I just read your message. Leave the pic anyway...

    I had another look at the BoS guard at the research facility, so if you haven't fixed that yet:
    Missing dialog lines for the entrance guards, #750 (I believe #900 is the one meant to be used here.) and #760 (Maybe supposed to be "Yes Sir", "OK", "Thanks" or something similar.) in bosknig.msg (bosepgrd.ssl).