Fallout 2 mod Megamod version 2.47 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Mar 20, 2017.

  1. chieftain486

    chieftain486 War. War never changes...

    Apr 9, 2017
    I remember that I had the same problem and I had to use Ctrl-R exploit to install the purifier. As far as I remember, when I installed the part the problem with those "freezes" disappeared and I was able to play normally.
     
  2. Neriman

    Neriman First time out of the vault

    Nov 29, 2015
    Did you install the purifier with the Ctrl R ? didnt know that was how it worked. The freeze im talking about is when you start combat. You cant move, you cant access any menu but you can move the camera freely. If it is a mod issue then i hope it gets fixed :c

    Edit: Thanks, i figured out how to use that exploit.
     
    Last edited: Aug 27, 2017
  3. MPPlantOfficial

    MPPlantOfficial First time out of the vault

    Aug 24, 2017
    Sorry in advance if I haven't had the time to read through all 10 pages but I'm encountering a strange bug in Broken Hills.

    At the part where you enter the mine to fix the air purifier, I get attacked by ants as soon as I enter. When I end my turn the cursor is stuck in the "wait" symbol and does not allow the game to continue.
    clicking right click does nothing.

    Also I can't seem to get out of the game. I try Alt + Tab I'm still in the game. CTRL + Alt + Del allows me to open Task Manager but once it's open, I'm still in Fallout 2.

    The only solution was to force shutdown computer. This happened to me 3 times already. I'm guessing, sneaking in wearing an activated stealthboy + EPA Gas mask is the only solution so as not to have to initiate combat?

    Anyone else having problems?
     
  4. chieftain486

    chieftain486 War. War never changes...

    Apr 9, 2017
    The [temporarily] solution is:
    1) Make save right before entering the mine.
    2) Quit from the current game to the starting screen (with "New game", "Load game", etc.)
    3) Press Ctrl-R, choose whatever map, then load that save file from 1). Now you're invisible for enemies. Run through the mine and install the part into air purifier.
    4) Make save (to the different slot!).
    5) Quit the game. Start the game. Load the last save. From this moment you will be playing the game normally.
     
  5. Parto

    Parto First time out of the vault

    Jun 20, 2016
    knows anyone how to fix sulik's sister ? she is "error" in spyglasses look ... her text's are missing ... its pretty annoying, but on the other way, whole tribe map works perfect for me, so good work done there from 2.46 ...:ok:

    some duplicate armors/robes in hubologists base still present but thats only cosmetic, still have half way trought the game but dont find any bug in Arroyo, Primitive tribe, Klamath, Den, Redding, Vault city, Gecko, Abbey, Broken hills, NCR, V15, V13, SF and Military base in this 2.47.1 so :ok::ok::ok:
     
  6. MPPlantOfficial

    MPPlantOfficial First time out of the vault

    Aug 24, 2017
    I have yet to encounter this bug myself since I can't get to his sister in the first place.
    It must have something to do with the rangers quest.
    I'm now a ranger but am still able to interact and talk with the Slavers even though they immediately turn hostile after.
    After killing everyone in the base, I try to open the door to Sulik's sister it says "everyone will hear you." even when I have the keys.
    Tried blowing it up with dynamite but it seems to be protected by plot.
     
  7. MPPlantOfficial

    MPPlantOfficial First time out of the vault

    Aug 24, 2017
    Anyone else notice Vic and Cassidy are extra aggressive in this mod?
    I've set Cassidy's combat mode to "defensive" but he's killed Chosen, Vic and Sulik more times than legitimate party deaths from other critters.
     
  8. Matt Drax

    Matt Drax Smart Ass

    Sep 4, 2010
    I see that bug is still not squashed? Tsktsktsk... It's because two of the slavers (the ones in the SW iirc) are not correctly flagged for the killing script and are therefore not counted as "All Slavers killed".
    A quick fix after you killed them is to save your game and open it in F12SE, then go to the "Maps" tab open the "SLVCAMP.SAV" either by doubleclick or mark it and click edit and set "MVAR_Slaver_Count" to 0. Don't forget to save your changes and load up your savegame again. All Done ^^
     
    Last edited: Aug 30, 2017
  9. MPPlantOfficial

    MPPlantOfficial First time out of the vault

    Aug 24, 2017
    All right. Thanks for the help. Will probably try that on my next playthrough. Right now I'm playing megamod for the first time to enjoy the content
     
  10. Perkyguy

    Perkyguy First time out of the vault

    May 21, 2008
    Do i still have to delete hs_combatdamage file (remember that raider burst across the screen for 60 on adv.PA markII?) in 2.47?

    And does ammo still weigh 2-3 times more than in the original?

    Ammo files and combatdamage have always been instadeletes for the past 7 years of playing this

    EDIT: well, the ants in the temple were doing 4-7 dmg with hs_comdmg on, so i guess thats not changed
     
    Last edited: Aug 31, 2017
  11. Crafty

    Crafty First time out of the vault

    Apr 30, 2015
    Any variation of sfall[2] does not process variables with text values inside CriticalOverrides.ini. Therefore, the constructions "*StatCheck=En" or "*FailureEffect=Knockdown" is useless.
    I assume that the text markers was taken from http://falloutmods.wikia.com/wiki/Critical_hit_tables, but it's just converted values into a readable format.
    It is necessary to correct to a numerical variant, only for effects do not use the values from the table by link, because they are in little-endian format, and to take from the scripting define.h.
    Code:
    and thus:
    
    e1_StatCheck=En
    e1_FailureEffect=Knockdown
    e5_EffectFlags=Death
    e0_StatCheck=Ag
    e5_EffectFlags=Knockdown, Crippled right leg
    
    should be defined as:
    
    e1_StatCheck=2
    e1_FailureEffect=2
    e5_EffectFlags=128
    e0_StatCheck=5
    e5_EffectFlags=10
    
    Etc.
    There are still "*StatCheck=0", which, I believe, should be considered as unused, but in fact this is a validation of the strength (STAT_st=0). To avoid checking for stat you need to use -1 ("*StatCheck=-1").
     
  12. antichosen

    antichosen First time out of the vault

    Sep 4, 2017
    In the temple of trials when I try to talk to the guy at the last room (the one you gotta fight) I see "error" instead of EVERY dialogue, both his and mine.
    BTW I play as a female character and a hiRes mod. Also Kilin was protecting me in other rooms.
    Here my savegame
     

    Attached Files:

  13. Parto

    Parto First time out of the vault

    Jun 20, 2016
    Have you 1.02 version of game ? this save i couldnt load in my Megamod, so think thats the problem ...
     
  14. antichosen

    antichosen First time out of the vault

    Sep 4, 2017
    I have a GOG version. Also I launched falloutHR.exe. Could this be problem?
     
  15. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    @antichosen

    Do you have a file called patch000.dat in your fallout folder? If so, you need to remove or delete it.

    @Crafty

    Thank you. I'll make sure to fix that file.

    @everyone

    Got a new hard drive in the mail today with the recovered data from my old hard drive. Yay! Work on the Megamod can now resume.
     
    • [Like] [Like] x 1
  16. Parto

    Parto First time out of the vault

    Jun 20, 2016
    very good news, hopefully data recovery was sucessfull ... :-)
     
  17. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    They were able to recover about 98% of what was on the drive. Fortunately, that remaining 2% was either old, obsolete files, had nothing to do with Fallout, or was backed up on other drives. So, yes, it was very successful.
     
    • [Like] [Like] x 2
  18. antichosen

    antichosen First time out of the vault

    Sep 4, 2017
     
  19. VonZorch

    VonZorch First time out of the vault

    Jan 1, 2012
    You may want to put this instruction to Linux users in megamod 2.47.1 readme.txt.

    Remember that Linux file names are case sensitive.
    Extract MegaMod to an empty directory. Then rename all directories and files in the folder you will be playing from and the extraction folder so that cases agree. This best done with a bulk renamer such as Thunar.
    Then copy from the extraction folder to the actual game folder.

    Most Linux users already know this but it doesn't hurt to warn them.
    If this is not done Megamod doesn't include all the content and you will get an error when saving games.
     
    • [Like] [Like] x 1
  20. VonZorch

    VonZorch First time out of the vault

    Jan 1, 2012
    An additional problem when running on Debian 9.1 using wine 1.8.7-2 with the Mate desktop if you try to run from a user account with administrator privileges you WILL get an wmAreaInit: Error Loading Cities error after the splash screen that cannot be fixed by setting ddraw to native in winecfg.
    This may happen on other Linux versions but I don't currently have the means to test for that.