Fallout 2 mod Megamod version 2.47 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Mar 20, 2017.

  1. SPIT

    SPIT First time out of the vault

    Nov 20, 2003
    I'm getting a weird problem, the mod works ok except for Slavers Camp - when I try to open the door (dialogue window opens), or talk to the slaves, the game crashes.
     
  2. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    that is suliks sister, she is so heavy bugged ... so dont talk to her
     
  3. SPIT

    SPIT First time out of the vault

    Nov 20, 2003
    I figured that as well, so there's no way to save her in this version?
     
  4. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    sure but not in playing, just by editing some GVARs
     
  5. MathijsH

    MathijsH First time out of the vault

    Sep 9, 2017
    Hi Chieftain, i have the same issue with the NPC levelling, but I dont quite understand the working solution posted by you/Pyran... How can i make sure NPC levelling goes correctly?

    Cheers!
     
  6. MIB88

    MIB88 Sonny, I Watched the Vault Bein' Built!
    Modder

    Feb 22, 2005
    I always played the slaver camp the same way... Maybe that's why I didn't get the problems that are being reported. I always went in with a high speech and got into the shed by convincing him to give me the keys. Then, I still end up slaughtering all the slavers. No problems. But I'll recheck this.

    As for the NPC level problems: are you all running processdat2.exe after the archive is unpacked?
     
  7. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    i dont have problems with leveling NPCs:

     
  8. Samhain

    Samhain First time out of the vault

    Oct 9, 2017
    So, this breaks my heart. I have read everything I can and I still can't seem to get this mod to work.
    I've gotten it to work to a degree. I want to try and run the mod with a few other tweaks as well.
    The weapon mod Finesse. Since the default weapon art is ugly as sin after having played with the Finesse mod.
    And the mod to change the Highwayman into a Truck. Since the default art is o.k. at best, but I love the truck art.

    Maybe someone can help, or at least clarify the error...
    1. I start with a fresh Steam installation.
    2. Copy all of the MegaMod files directly into the Fallout 2 folder.
    3. Run the bat file included in the Megamod archive.
    4. Make Damn sure Proto folder and all files in it are set to READ-ONLY.
    5. Delete Patch000.dat

    Now, if I run the game here. It runs. But most of the items have a <None> name.
    No descriptions or use.
    Using of any kind of save editor causes all saved games to become unloadable.
    If I try to use Klint the Generous mod, it loads, but the game scenery is black, there is no background. My character is simply running in a black void.

    There is more I'm sure I have done and tried but after working on it all day today, I'm too tired to type. I think this is a good enough place to start...
     
    Last edited: Oct 9, 2017
  9. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    5. Delete Patch000.dat should be 2.

    if 3. have some errors, then there is problem, you must watch the process

    about compatibility with other mods try contact autors, but if its only graphics, then it could works

    oh and after run ProcessDat2.exe look at your master.dat file it should have 325.299 kB
     
    Last edited: Oct 9, 2017
  10. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    How about:
    1. Instal F2 (and check if is 1.2d?)
    2. delete patch000
    3. run and exit game
    4. move mm
    5. check if is msvcr71.dll present in folder
    6. run bat (its need msvcr71.dll)
    7. check protos?
     
  11. Arathos

    Arathos First time out of the vault

    Feb 2, 2017
    I've got a problem with a sidequest.

    I've arrived to the Ghost town and talked with Johnny before talking with his father first and now after I did go to Balthas to inform him that his kid is alive(after making it so that Modoc and the Slags make peace) the only option to conclude this quest seems to be by telling him that the Slags are bad folks and need to be attacked to save the kid.

    When I go talk to the kid after telling the father that he is alright I get no dialogue options aside from trying to give Johnny a candy(which is not a good idea).
     
  12. Matt Drax

    Matt Drax Smart Ass

    Sep 4, 2010
    You have to talk to Vegir about bringing Johnny home
     
  13. Darek

    Darek is currently unavailable

    Jan 7, 2008
    This is an old vanilla bug. Download this script and put it in wherever you installed the Megamod \DATA\SCRIPTS folder (overwriting the existing script).
    Then go talk to Balthas again and tell him you know where Johnny is. After that you can go and talk to Johnny and/or Vegair about bringing him home.
     
    • [Like] [Like] x 2
  14. Samhain

    Samhain First time out of the vault

    Oct 9, 2017
    So I tried the Installer version of the mod since I received these errors unpacking the mod from archive form...

    ! ...Megamod_2.47.1.7z: CRC failed in Megamod_2.47.1\Data\art\critters\NMJMPBGG.FRM. The file is corrupt
    ! ...Megamod_2.47.1.7z: CRC failed in Megamod_2.47.1\Data\art\critters\player character test\HAPOWRBB.FR4. The file is corrupt
    ! ...Megamod_2.47.1.7z: Error - operation failed

    And in using the installer version I couldn't get the game to run either. When it didn't delete my Fallout.exe, Fallout Hi-res config.exe,
    launching the game resulted in "Couldn't Find/Load Txt Fonts"

    If all you're going to say is read the readme, then which one? Since there are 54 of them.

    ***Edit, Ok After a lot of work, (over three days) I believe I have it in working order. I had to extract the files that were corrupted manually, individually. I extracted them from the desktop to the desktop, keeping file path lengths to a minimum.

    I followed the suggested install order. Deleting Patch000 right away before installing MM, running the included .bat file. Setting everything to read-only twice.

    No I know that installing mods on top of MM is frowned upon. But I HATE the regular Highwayman art. I used .DatExplorer to unpack the Truck_mod.dat mod and move the files from it into the Art folder, but the Highwayman still looks like its a rust bucket.

    Are there any new quests or flags that are keeping the highwayman unchanged? Since I see in the art files there are quite a few .frm's referring to Cars and Car trunks.
     
    Last edited: Oct 11, 2017
  15. Samhain

    Samhain First time out of the vault

    Oct 9, 2017
    Ha, well played it for about 6 hours.
    Everything was going fine until I tried to enter modoc.
    Game crashes with a "Integer was divided by zero" error.
    I loaded up the game again and tried entering Modoc without my car, same error.
     
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @Samhain Installing mods on top of other mods is not just "frowned upon". You are told not to, because if you don't know exactly what you are doing, you risk breaking the game. Mods in Fallout don't always play nice with each other as they often modify the same files, and so when you install another mod on top you risk overwriting stuff the first mod needed. Simple as that.
    You are of course free to modify your game however you want, but don't complain or expect help from the mod creators when it don't work.

    Anyway, the truck mod don't work because the Megamod has a "paint" mod included. When you added the truck art, you replaced the art for the normal car, not the art for the rust bucket. So find out what what file that is and rename the truck mod art to that.
    Or you can continue to play and wait until you find some paint, then go to the New Reno Chop shop and have the car painted (it should then turn into the truck).

    You can also use the save game editor to set global variable 1644 to 1 (= normal car paint stage) and then load your game and drive off the map. Next time you enter a map, the truck should show up.

    I don't know what truck mod you added, but if it's the tanker truck, then funnily enough that is already included in the Megamod.
    You just have to set global variable 1644 to 3 after you have bought the car and drive off the map and it will appear.

    As for your crash, no idea. You could always upload your save, so someone can test it and see if it's a save game corruption or something wrong on your end.
     
  17. Samhain

    Samhain First time out of the vault

    Oct 9, 2017
    -----------------------------------------------------------------------------------------------------------------------------------------------------------------
    Thank you Darek for replying! :D Yup, the mod I installed was the Tanker truck mod. :D I truly did try to read all of the readme's. Just didn't see were it was mentioned. You have to admit, the readme folder is a bit daunting. Sorry if I sound like a prick, I've not had the best experience in getting help in such matters. Plus, due to Steam updates three of my other heavily modded games just recently broke. So I can be a bit prickly. :(

    I didn't try to install any other kind of total conversion mod, only texture/art mods. Such as, only Finesse's weapon art files and not the proto's, pro_items.msg or sound.lst. And the truck art mod that only modified two .frm files.

    As for editing global variables. I noticed that some entries in F12Se.exe ARE corrupted after playing for a while. I can start up a new game just fine, edit the save before the temple just fine, play for 45 minutes to an hour, save, try to edit that file, and it might say I've killed 8675309 men or something like that. I didn't bother trying to continue playing that save, as I figured something, somewhere had become corrupted. What program is the safest to use for editing global variables in the save?
     
  18. Parto

    Parto It Wandered In From the Wastes

    Jun 20, 2016
    F2 SE, F12SE or F2_item_editor

    but in this case the numbers corrupte Megamod, not your editing savegame, i have simmilar experience, but it dont make any crashes or something else ... so far i can say

     
    Last edited: Oct 11, 2017
  19. Samhain

    Samhain First time out of the vault

    Oct 9, 2017
    Ah, you know what I'm talking about. :) I see you have been the scourge of the wastes. ;) At least it doesn't say you've killed a billion children and gives you the child killer perk. :D

    I'm having a blast with the mod now. Modoc loads just fine, I now have Bess following my every move. It's nice to have a friendly cow on my side instead of a Hellish Bovine from Diablo. ;)

    I've noticed I can edit everything about my save except my inventory. For some reason when F12SE reads the item data, and I add an item to my inventory. I can not load that save. I can edit the amount of items already in my inventory. Just not access the items list to add anything. But that's not a big deal.

    I can give my char perfect stats, add every perk, edit anything I want. Expect adding items. I suspect that this is due to a edited master.dat or F12SE programming, and not the responsibility of the mod.
    I guess I just have to play with only a certain amount of game breaking OP'ness. ;)
     
  20. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @Samhain Here we go with not looking at the "Readme"s again. ;)
    (I know... I don't always read them either.)

    In my experience, adding new items with F12se rarely works out. The game doesn't always crash right away, but the save usually becomes unstable and crashes a bit later (Granted that I haven't tried to add that many items since noticing it's not working well, so I can't really say how often it will work or not).
    Changing one item into another works well though. I have done that a lot and never experienced a crash that I can say is related to that.

    About the kill count being off... I have only seen it happen with the Megamod, and it looks fine in-game, so I believe the save editor is just having trouble reading some data, but it will not have any real effect unless you start editing the kill count.
    The problem might be because of new added critter types or something.