Fallout 2 Restoration Project 1.1 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jan 13, 2008.

Thread Status:
Not open for further replies.
  1. csirifiszkio

    csirifiszkio First time out of the vault

    Jan 12, 2008
    Well I saved last night in Trapper Town. Loaded today and noticed that Sulik disappeared from the party. Maybe the bad luck dog caused this?
  2. wastelandhero

    wastelandhero First time out of the vault

    Jul 5, 2007
    Win XP Auto installer 1.1. B-team mod and Cassidy's head options.
    Sulik will equip rifles/shotguns now. Is this intentional or accidental?

    Not that I mind Sulik using weapons other than machine guns.
  3. hakan

    hakan First time out of the vault

    Jul 1, 2007
    So what about the difficulty of the encounters?

    Was there a change in difficulty or have I just become a sissy over the years? ;)
  4. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    This is probably because of the b-team mod.

    Never touched the difficulty. Perhaps your character is not strong enough? In addition, if you are running win2000,2003,xp,vista that is, did you try the updated ddraw.dll file I posted?

    Odd. No idea what might have caused the Trapper town issue. Out of curiosity, is the map reset? (ie are containers you previously empty now full, etc)

    Thought the graphic mod might be the problem. I will also look into the Den quest issue you speak of.

    Oops, I meant to say utilities area, not maintenance area.

    Well, first tell me more about your setup. Like OS, Fallout version (lang, etc), how you installed the expansion. As for file structure, inside your Fallout2 directory you should see a directory called data, an exe file, ddraw.ini, and ddraw.ddl/sfall.dll Inside the data folder should be folders such as Text, Scripts, Maps, Sound, Proto, Data, Art. When you go inside the Proto folder, make sure that all the files inside the folders found there are set as readonly. The installer should have done this automatically for you assuming you used the installer.

    Yes, changing graphics mode will indeed effect the speed of moving across the world map.
  5. MutantOne

    MutantOne First time out of the vault

    Jan 16, 2008
    Nope, the game doesn't crash :(
    well, I think I'll wait for my new computer next month...
  6. wastelandhero

    wastelandhero First time out of the vault

    Jul 5, 2007
    Yeah, I realise that. I guess I should have been clearer.

    Was it always like this, even before the restoration pack?

    Is there anyone working on changing it?

    The challenge of having Sulik is partly due to the shortage of available high powered weapons he can use. Decent submachine-guns are hard to find. That is what I like about him. I don't want him just grabbing any weapon in his inventory because he is carrying ammo for it. This takes away the personality that is Sulik.
  7. Crowley

    Crowley It Wandered In From the Wastes

    Dec 12, 2003
    I can't open the gate in the fence at the slaver camp. I can unlock it with the key or pick the lock, but not open the door. When I try to use it, the fiddling animation plays, but nothing else happens. With the door unlocked, I can't walk inside and automatically open it either.

    I'm doing this early on in the game without ranger backing.
  8. hakan

    hakan First time out of the vault

    Jul 1, 2007
    About difficulty:

    How could I be stronger though?
    Leather and metal armour is the best there is in the north, and 30+ damage per salvo from every single raider in an eight man group from the far end of the combat map is simply overwhelming.

    Im lv 12 and I know that the main problem is armour (both metal and leather have very limited normal protection).
    I just dont see how anyone could survive such an encounter in a normal game.

    Sorry if it sounds like whining...
    I just think that the balance is somewhat off for some reason.
    I guess Ill test it with a vanilla 1.2 Game.
  9. wastelandhero

    wastelandhero First time out of the vault

    Jul 5, 2007
    I have run into that before also when carrying the CAWS shotgun, on a stock game or with Killaps patch. I think the engine sets up the encounters based on what weapons you carry. I usually just sell them off for ammo and let someone else carry them. I find using high powered weapons with low armor is a pain.
  10. Paja

    Paja First time out of the vault

    Jan 14, 2008
    Slave camp

    I had the same problem in slave camp with lock cage. Even c4 did nothing:( than I tried save and load game - and voila: klick on the door and open. Maybe just luck, or try;)
  11. hakan

    hakan First time out of the vault

    Jul 1, 2007
    More about difficulty:

    I just thought of something.

    Aren't encounters based on level?
    Shop inventory is too IIRC, but there is a certain maximum to individual shops.

    That means the maximum equipment stays the same in the north because the shops reach their maximum level.

    However, because of all the new quests (and the many encounters in my case) my level is probably higher(much higher even) than in vanilla 1.2 resulting in more difficult encounters with the same crappy equipment.
  12. Maade

    Maade First time out of the vault

    Jan 16, 2008
    @killap (Long post)

    First a big "THANK YOU!" for your mod and time you have put into it :)

    Now to some bug crunching ->

    This is exactly what happened to me, and there seems to be no way of fixing it. You can still drive with the car, but when you try to access the trunk you just pick it up (You can carry it around and drop it somewhere else too :roll: ). The game crashes with that message if you try to leave the map you are in with the trunk in your inventory. However, if you drop it before leaving you can move freely where ever you like.

    I have tried leaving the car behind, recruiting NPC's and doing quests that transfer you to another area but nothing helps. Oh and by the way, shouldn't there be a "backbag" icon when you access the trunk? I only have the "look" and "use" actions.

    I also tried to create a dummy file named "partyMemberPrepItemSaveAll" but the error message doesn't change, it says it still can't find the file.

    This happened to me the moment I got the GECK and exited Vault 13. After the video I fought against some bandits and the trunk got bugged. I'm not sure if this helps, but as I have never seen this bug before I'm pretty sure it has something to do with your mod. TimeSlips dll hack has never caused this to me before alone.

    Also I noticed that in Vault 13 there was some character named Dalia who seemed to know me but I can't remember ever meeting her. I belive she's from Den "orphans" quest but I don't remember ever meeting her there.

    * Primitive Village *

    The spears you can find around the village are all "Sharpened Spears". As for the quest you need normal ones, I assume this is a bug?

    Also, I never got the "Lost Hunters" quest completed. I found the hunters and saved the other one and the quest giver thanked me, but the quest was never completed. I still got the EXP though.

    * The Den *

    I'm not completely sure why, but it seems that after installing your mod some of the Slaver Guild Guards seem to have insane damage resistance. .44 revolver, shotgun and hunting rifle only does 2-3 damage no matter where you hit them. The only way I managed to kill them was changing the combat difficulty to whimpy, aiming them to eyes and hoping for critical hits.

    * Klamath *

    I'm not sure if it's supposed to be like this but I don't think so, so I'll list this anyway. The Vic's houses inner door is now locked, can't be kicked in and it requires something like 70-80% lock picking skill to get it open (And some luck). That's quite high in my opinion, since it's the first town in the game.

    * Other stuff *

    There still seems to be one empty encounter right after the first Kaga battle. I haven't seen any other empty encounters after that though (Tried few times, both new games and fresh Fallout 2 and 1.1 mod installs).

    About the "Dear god, what's with all these encounters?!" problem, I'm having them too. I don't claim to understand much about C, but if you ask me, trusting to "loop" alone is pretty bad idea as it still depends on processor speed. Much better way to deal with the problem (In my opinion) would be generating random number every few seconds and checking if it's under or over some fixed number. If it is, let the game engine run it's checks, if it's not run the thing again after few seconds.

    If I could remember the basic stuff I could code a simple example, but it's been too many years and I haven't ever really used C..

    SHADOW-XIII First time out of the vault

    Nov 19, 2007
    Things I noticed:

    - 2nd Kaga fight, I did critical to his eyes & Sulik knocked Kaga down ... fight over, Kaga's alive but sleeping, after some time weaks up - no script was run, no text was displayed ...

    - this is common problem: auto dialogs appearings, they are, well, too slow, it's often when I enter a bulding and click on a person to talk, talk is started, after finishing it, whole talking reappears again, I think "area" which NPC should start talking to me is too small or too close to him - found in most of dialogs added in expansion
  14. wastelandhero

    wastelandhero First time out of the vault

    Jul 5, 2007
    Noticed also in the Den after you finish the orphans quest and the pick pockets are off the streets, Flick still talks about them as if they're still there.

    Maybe something to look into for future release.
  15. Crowley

    Crowley It Wandered In From the Wastes

    Dec 12, 2003
    I was thinking that it would be a nice touch to have Flick get pissed of at you for setting up the orphanage and refusing to trade with you. It would be a nice win some-lose some situation.

    I am not sure if this is a bug, but Sulik doesn't return to my party after I leave his village.
  16. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Did you talk with him before leaving?
  17. ElectricSheep

    ElectricSheep First time out of the vault

    Jan 13, 2008

    - I'm playing the current version of the restoration mod, no other mods and encounters are fine. Just as they were when I played the game originally, on my old computer many years ago.
    I think some people here forget that the wasteland is a harsh and uncompromising place. Don't be too proud to run away ;)
    As far as I can see, encounters are functioning as they should, with the frequency they should (I have maybe 1 encounter per sector, maybe 1 per 2 sectors approximately)

    - I have also encountered the bug with not being able to optimize Geckos power plant due to the fact that there's no option to download the data at the Vault City Central Computer

    - I have encountered another strange thing though: Being an asshole, I killed Skeeter to get the Fuel Cell thingy. Which promptly changed my Vault City reputation of "Liked" to "Accepted"...
    Not sure if this is a leftover from the original programming though, haven't really bothered to look for bugs before

    - For that matter, in Vault City, if I promise to get Joshua out of the Servant Allocation Center in exchange for sex with his wife (like I said, I'm an asshole) my city rep takes a large hit. Seems odd, considering she won't tell anyone about it...
  18. Polynikes

    Polynikes It Wandered In From the Wastes

    Jun 19, 2007
    I ran into this problem the first time I accessed the computer, but after exiting out of the menu and going back in, the option was there.
  19. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yep, you are right. For some reason the original devs had him marked as a VC critter.
  20. samca

    samca First time out of the vault

    Jan 4, 2008
    Hm. I didn't get any options for optimization in dialogue or at the computer, and talking to Festus just results in a floater-dialogue over his head saying we'll have time to talk after the plant is optimized.
Thread Status:
Not open for further replies.