Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. MarkD

    MarkD First time out of the vault

    5
    Jun 12, 2008
    Well, just dropping by to report that my 1.2 run ended about three weeks ago, when I was hit by a very old bug... got the Ramirez quest, delivered the package full of Jet, my car disappeared from New Reno. Sucks 'cause I didn't expect that to happen at such a high patch revision.

    Oh well. Hope you can get rid of that bug once and for all, killap...
     
  2. Phelanpatrick

    Phelanpatrick First time out of the vault

    24
    Jun 3, 2008
    thats not a bug
     
  3. Darek

    Darek is currently unavailable

    Jan 7, 2008
    He, I never tried that one, didn't know what it was. I thought it was just another container.

    Anyway, I'm not sure at all it's about scripts since there are a few holodisks that have scripts but are not crashing...
    And then there are the Fallout 1 holo's, they are not using their original scripts anymore, are they?
    I have tested with only Fallout 2 stuff on the map so it's not F1 stuff causing the problem I think.

    I have a question for you. Both the Hubologist Holodisk and the Teachings Holodisk say FIElrDsk.int is their script.
    Hubologist Holodisk is the one you get in San Fran, the other is not in the game is it? Only Teachings Holodisk crash the game. Why?
     
  4. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    @MarkD
    You sure the car wasn't stolen?

    @Darek
    Well, if you could test to see if moving scripts from items that crash to items that don't crash that would perhaps narrow some things down.

    F1 items are not using original scripts but are instead pointing to random (not really actually) F2 scripts.

    The Teachings Holodisk has FIElrDsk.int attached from the start. The Hubologist holodisk doesn't have anything attached originally, but when it is placed in the player's inventory in San Fran, the above script is attached to it. It seems only the Hubologist disk is used and the other is an unused duplicate.
     
  5. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I put up the 26 F2 only items on a map and edited them to arroyo broc and xander scripts. Saved the map, started a new game, picked up the stuff, did the leave and come back routine, game still crashed.
    Meh, I hope I did it the right way, haven't done that before.

    So, wtf does this leave us? If it's not the scripts, then what?


    EDIT: I put the scripts to none on the items and redid the test. It did not crash. Now what?
     
  6. dalponis

    dalponis First time out of the vault

    56
    Aug 10, 2003
    Bear dude! I have news and questions!

    ---
    First news:

    Even though you disarm the trap on Vic's door in Klamath, if you try to open the door without unlocking it next, you still set off a trap?
    ---

    ---
    Questions:

    How do I find out what's bugging the Shaman in the Primitive tribe?

    How do I solve the brahmin mutilation quest in Klamath?

    How do I open the jail cell filled with slaves in Slaver's Camp with the keys I was given, without the guards becomming agro?
     
  7. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    You did reset the proto files to read only, yes? You can only edit them if they are read-only and if you start a game without them read-only they are removed.

    Well, the above test and this tidbit of information seems to indicate that the items themselves are not at fault nor the scripts. It seems that perhaps leaving the map with too many items that contain scripts is the problem. Now why this is, I do not know. Still, I believe Skynet's comment is our best solution for the time being. I am in the process of converting most (not all) the items to have their script calls done through the player script (dude_obj.int) rather than their individual scripts. This way only 3-4 items will have scripts attached, which should hopefully not cause a crash on any map.


    EDIT:
    @dalponis

    I will look into the Vic door issue.

    As for your other questions, keep them in the gameplay thread.
    Also, this will help.
     
  8. MarkD

    MarkD First time out of the vault

    5
    Jun 12, 2008
    Car had been stolen much prior. It really was a teleport bug.
     
  9. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Send me a savegame to the address found in the RP readme.
     
  10. dalponis

    dalponis First time out of the vault

    56
    Aug 10, 2003
    Thanks for that hint link killap.

    Ever consider making a way to get back to that area Toor was guardian in Kladmath?
     
  11. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I don't understand what you are saying, don't you mean remove the read only to edit them and then put the read only back afterward?
    Anyway, I didn't touch the proto's. In the mapper I did not use the "Prototype editor" since it refused to save (read only I suppose).
    I put the items on the map and used the "Item Instance Editor" to change the script association instead. Dunno where that info gets saved to. Does me doing it this way change anything in regards to my test result?

    Ok, cool. Good luck and please let me know how it works out. I wouldn't mind testing it when you are done.

    Oh, and I should probably change the "Teachings Holodisk" to "Hubologist Holodisk" in my list
     
  12. vorob

    vorob First time out of the vault

    11
    Jul 5, 2008
    I don’t get it, to manually install RP I need to unpack rar archive to game folder, overriding data folder and fallout2.exe? That’s it?
     
  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yes. Also, the installer does this all for you. No reason to avoid using it unless you know what you are doing and like to see what files are really being installed.

    Yes, I mean to say you can only edit them if they are NOT read only. Anyway, what you did is fine. I'll report back here once I have finished the task.
     
  14. Dittersdorf

    Dittersdorf First time out of the vault

    13
    Jan 31, 2008
    So far, just got out of Arroyo with a new game, with the latest 1.2 on. I've been looking forward to this!

    I just wanted to point out a critique that I mentioned before: there's no way that the Chosen One wouldn't know, or at least have heard of, Kaga. Even if the village were really a large town (which it isn't), Kaga would have been a celebrity for passing the Temple of Trials. And yet, Kaga, supposedly the star warrior from the same tiny village, is a complete unknown to the PC. That's just not possible.

    Tiny, meaningless error: part of a Kaga sentence in the first encounter ends with "banished never to return". It should be "banished, never to return".

    Anyway, this thing is just great... no, Great with a capital G. Anything that improves what is already one of the two greatest games ever made is just unreal and fantastic.
     
  15. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    You haven't talked with everyone in Arroyo, have you? 1.2 has new dialogue regarding Kaga's origin.

    I shall change this.
     
  16. Animotion

    Animotion First time out of the vault

    1
    Jul 8, 2008
    Hi thanks for the mod , but i'm having problems with getting through temple of trails an not sure if its a bug or not but i've tried 20 plus times to use the explosive on the door (in temple of trails) an it never opens.

    It just keeps saying there is bearly a scratch, i can't get any further in the game without getting through this door. :( its getting really annoying.

    I installed the patch over existing game. an the rock says 1.2.2 :)

    I can send you a save game if that will help?

    Great forum btw looks the best place for fallout stuff :D
     
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Did you install the MegaMod previously or perhaps the New Vision mod? Either way, I suggest making a backup of your save games, uninstalling the game completely, reinstalling using a humongous install, and then the RP.
     
  18. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I have a question about shelves. Why do all the big one's facing in this direction have an extra half shelf merged on the side?
    Here's a pic from Redding



    And why do the extra shelf have the action flag set to pick up, but at the same time the weight have been increased to 1099 so it's impossible to pick up? I mean, what's the point?

     
  19. Skynet

    Skynet Mildly Dipped

    501
    Jun 5, 2003

    Because It partly fixes the clipping issue with the shelf.


    I think this was made to avoid a confusion if player for example plants a item on shelf, then later in game uses the shelf from differend spot and wonders where the item vanished.
     
  20. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Ah, thanks. I wasn't even aware there was a clipping problem. I knew the devs didn't put them up just for fun but...

    I'm not quite sure if that answers my question. :scratch:
    That extra shelf can't hold any items, it's not even an option. Or are you saying that setting the action flag to "pick up" removes the shelf's storing ability? If so that's a pretty lazy and ugly workaround by the devs.
     
Thread Status:
Not open for further replies.