Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. Limbabnees

    Limbabnees Still Mildly Glowing

    Jun 17, 2007
    Wenn attempt to trap the safe from Bishop.

    Wenn failed get wrong message.

    Bess fails to trap the safe. Damm cow follows me everywhere :D

    After restart game i got this message:
    (Critter) fails to trap the safe.

    * Edit:
    Dont get the Botany Holodisk from the computer Level East 3
    Access Information Database/Access file on botany/Back

    Nothing more happends.
  2. narth

    narth First time out of the vault

    Sep 21, 2008
    oh wow great

    oh yay i put about 12 or so hours into my game and now it will never stop crashing at san fran! god that is so awesome, oh and that fix really helps(load up an old save game!!)when you have already visited san fran a long time ago and all your saves are WAY past that point! So now I am stuck with EVERY SINGLE save file being corrupt, and apparently no way whatsoever to fix it. This is probably around my tenth playthrough of fallout 2, and I have NEVER encountered a bug that is this retarded(and yes, i have had many of the crash items with me on my previous games).

    I really like all the extra content, I thought it was a blast, but a bug that can effectively waste ALL the time you spent playing is, well, horrible. I have tried emptying my car, npcs, etc, nothing will work at all and like I said, can't load up an older save that isnt corrupt since i visited san fran a long time ago ingame. You should probably work on this for the final release, or maybe give some kind of warning somewhere more obvious, having to search for the fix only to not have it help at all kind of sucked.
  3. narth

    narth First time out of the vault

    Sep 21, 2008
    ah there we go!

    Ah! After a while of digging around I found a fix which has apparently worked. Ctrl-R at the title screen, load up whatever map isn't loading up right and save it to a slot, and bam a new non-corrupt map! I really wish I had known about this nifty feature earlier, maybe it would be a good idea to toss it into the OP? Definitely would have saved me some time. I figured it'd mess with my quests that I've done, and it err, kinda did. Nothing too weird, Matt just came back to life and thats cool with me!
  4. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ narth,

    Good you got it working.
    Now instead of complaining, feel free to add your info to the wikia. You don't have to sign up to add anything there.

    Now seriously, be a little bit more appreciative of killap and the people trying to help out around here.
  5. narth

    narth First time out of the vault

    Sep 21, 2008
    The info is already there, in parts, and it can be annoying to find if you don't know what you're looking for. I also didn't find anything at all about the Ctrl-r feature except from an oooooold regular FO2 thread after a bit of searching. The mod is great, but it adds in lots of new stuff that, combined with old stuff you are used to lugging around pre-restoration games, has a good chance of corrupting a few maps, and that can be really confusing to someone who has never encountered it before. It would save everyone who has this issue a ton of time for it to be at least mentioned somewhere earlier than page 68 in the megathread concerning its bugs.
  6. Ziomster

    Ziomster First time out of the vault

    Sep 16, 2008
    Is it alright if I post a bug in here that I've encountered, right lol?

    I just encountered a strange error I've never encountered before (starting to play with this amazing RP mod ;)), so I'm guessing it is something RP-related? After fighting the 5 (or was it 6?) students of The Dragon, the game randomly crashes as soon as it comes to one of the student's turns. One time the game crashed at the fourth one, and the second time at the fith student.

    Is there any work-around or fix for this, and is this a common problem?

    EDIT: Found a workaround, well... at least it worked for me xD After going through the fights a few times, with about 3 fights being crashed and trying to fight under different conditions (that is: 1) At night 2) After 12 hours of game's time)), I succeded the 4th time without any problems =D This is probably one of those random crashes...
  7. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ narth,

    I agree that things could be a bit more organized, but who is gonna do it? Also this is a work in progress, which makes it a bit harder.

    I've written about the workaround "fix" several times, though i may have forgotten to mention the Ctrl-r trick.
    But it is mentioned in Per's Nearly Ultimate Fallout 2 Guide which all Fallout fans should read.
    So you should have known. :P

    @ Ziomster,

    It may also have something to do with saving and loading during the fights. Not saying you did, but in case you were, don't.
  8. Ziomster

    Ziomster First time out of the vault

    Sep 16, 2008
    There's my answer :O no one make the mistake that I made! At least know that there is a chance that the crash won't happen!
  9. Limbabnees

    Limbabnees Still Mildly Glowing

    Jun 17, 2007
    Is it correct wenn my Party member wenn wear a Combat Armor get the Power Armor Bonus?

    Sulik, Cassidy & Miria get extra St & 2 AP

    Imported Miria's scripts but use other Level up Pid Code.
    Not wenna have more AP's for Party members...
    Even wenn naked they still hold the extra Strenght & AP's

    Not work for Myron.
  10. 1magus

    1magus First time out of the vault

    Sep 21, 2008
    Everytime I leave the first town you are in to go anywhere it tries to load an encounter and freezes for me Sad and I have tried reinstalling soooo what to do what to do?
    The Error: The instruction at 004550d7 referenced memory at 00000064 The Memory could not be read from
    The Fallout: Fallout 2 Restoration Project.
    AMD Dual Core 64x 4400+
    XP Home 32 Bit SP3
    GeForce 8800 GTS 320MB
    2GB of DDRII 4200 RAM
    PLEASE HELP! I really wanna play this, I just beat the first one
  11. 1magus

    1magus First time out of the vault

    Sep 21, 2008
    Seriously anybody? Should I uninstall SP3 and go back to 2??
  12. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Maybe no one knows?
    I've only seen this come up twice. Here is one of the posts (could not find the other one). If you follow Luciphear's posts you will see that he got it fixed, but that he does not know how exactly. He did a few manual installs of the game ( I'm not sure if by game he means fallout or just the RP), and all of a sudden it worked.

    Anyway, I suggest you start by removing everything of the game, and then do a manual install of Fallout 2.
    Then use the RP installer, if that doesn't work you can try with the RP manual install.

    There is one other thing you can try before you do anything else though. I believe your game is trying to load the first Kaga encounter, when it crashes.
    If you go to your \Fallout2\data\Scripts folder and temporarily remove the file "glkagaen.int", then the game should stop trying to load that encounter and shouldn't crash.
    If that works it's up to you to decide if you want to keep on playing or if Kaga is important enough to reinstall your game.
  13. 1magus

    1magus First time out of the vault

    Sep 21, 2008
    THANK YOU! I will be trying these out, I cannot belive somebody on this forum helped me~! :clap:
  14. 1magus

    1magus First time out of the vault

    Sep 21, 2008
    More problems with San Francisco it loads and is completly bugged than it wont crash ever but I know its messed up!
  15. Limbabnees

    Limbabnees Still Mildly Glowing

    Jun 17, 2007
    Of cource you be helped here, but need the answers to help you, fren...

    It seems the Agility you get from the Doc in EPA does not work good. Mostly of the time (AG 10) start in combat with 9 AP. Next round i have 10 AP.

    I not get the location of the Slaver Camp anymore.
    I forgot to ask Metzger in beginning of the game. Now a few months later wenn get the line where he got his slaves, only get the answer: "here and there", wenn kill him and free the slaves also NOT get the location.

    Now need load a savegame from FIRST time i visite the Den.
    Well cost me only 14 levels :D

    Fallout2 - The never ending game.
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Care to explain a bit more? We're not mind readers you know. :)
    Since you're in San Fran now, you must have gotten out of Arroyo okey, what did you do to fix that? Also, how did you manage to get there so fast? Please tell me you didn't go after the power armor straight away, that is cheating, and it makes the game a lot less fun.

    EDIT: Just saw your PM. So removing "glkagaen.int stopped the crashing, that confirms that the problem is with the first Kaga encounter. If you're up for it you can try doing a manual install of the game and see if that fixes it, but if you rater not, you are not missing anything important.

    I never had a problem with the stat gain in EPA, but what you describe can happen if you use FALCHE. If you've used that or if the stat gain works in a similar way, things will work properly again after you open up your character screen (before you enter battle).

    To find the location you first have to have had Sulik in your party (to get his missing sister quest), and then talk to Mezger (speech 61%) or one of his slaves. I'm pretty sure it doesn't matter if you talk to him early or late in the game.
  17. Groo the blunderer

    Groo the blunderer First time out of the vault

    Aug 16, 2008
    Can anyone offer some advice as to how to get around the problem in the EPA where you re-enter to first map and it is off center and will not scroll?

    In a moment of randomness, I realised I could walk my character, sight unseen to the to the bottom left corner of the screen. Companions followed, spoke to a talking head and the map was "released" for want of a better term.

    Hope this helps some others out there.

    (I can't believe I tried stuff and googled for an hour before posting only to do this about 45 seconds after) :oops:
  18. Limbabnees

    Limbabnees Still Mildly Glowing

    Jun 17, 2007
    > Groo the blunderer

    Do you use the Resolution Patch? If so you need to get experience with this problem, learn to find a way to handle this issue :D

    EPA in combination with F2 Combat Overhaul Mod.
    Did a new install without the Overhaul Mod and now have 10 AP wenn go in combat mode
    Have (Had) Primitive Tribe already located on the Worldmap.

    F2 Overhaul Mod really messed up alot. But still the Sequence issue is a Restoration problem, wenn use a modified proto file (read only).

    I tested several weeks the new RP in combination with Weapons Redone v1.7 & F2 Combat Overhaul Mod. Modified by myself alot.
    Some mods mess up some scripts too. The Ranger's map & Merks script (basement fight) not work correctly in those mods.

    Why change Combat Armor & Powered armors the Sequence from party members into a lower than original, and Max HP +3, wenn use a modified proto ?
    Reason why im a little angry with the Combat & Powered armors is because i play 99% with Kamikaze Trait, make other proto's for some party members (Miria & Sulik).

    Same for Marcus or Dogmeat ( wenn play with them) wenn they gets the Armor. Need to modify the proto's for the (so called) Armor. Needs to be realistic wenn wear a armor.
    Al least now you can shoot at your party members=good for testing armor stats. :D
    Only use Flasche for testing levelup from party members, not make myself a HERO(no fun, take Lifegiver LvL 12) All Party members have only 1 levelup pid.

    I even needed to kill Metzger & Gang to get Vic, because i didnt had enough Lockpick to get the radio.

    Lol, still not seen the Enclave or used the Vertibird to go there.... :D
    Try to make a good balance is hard.

    Only {37800}{}{Vic - Stage 6} is added in the new Master.dat, so...
    What if... modify proto's and and extract it again in the Master.dat.
    Wenn use modified proto's, somehow they changed, i dont know why.
  19. Glovz

    Glovz Vault Dweller

    Sep 16, 2005
    With regards to the Combat Overhaul Mod, the proto files that were modified are all from the RP, and given the only scripts in my mod affect two merchants in the game, I can't see how my mod would mess anything up with regards to Action Points, Sequence, or Hit points. To the best of my knowledge, proto files do not affect those stats.

    Other than this unless you can give me specifics like - when I equip with this armor or this weapon my character does this - then I wouldn't know where to start looking.
  20. Limbabnees

    Limbabnees Still Mildly Glowing

    Jun 17, 2007
    Wenn i find an answer i let you know.

    Btw, check the scripts from Merk in NCR (fighting Mutant in basement) & NCR Ranger's map please.

    Today only stayed in arroya with Miria & Sulik.
    Have save (cheat)map with all Party Member in the Caves. Fun, you can enter Klamath the first time and have Sulik already, still you get the 500 XP for free him :D Get Smiley and you get your reward.
    Wenn official wanna Marrie Miria just let her wait in the waste or let her die before you enter Modoc.
    Just tried out all kinds of modified proto's.
    Have 100 Cookies in my pocket and wenn change/add Strength, sequence/hitpoints/AP's goes down. Just keep switching Alt-Tab & Quicksave after change the cookie settings.
    Wenn have ST 10 and take the Power Armor or a Combat Armor, all ok, has something to do with the S.P.E.C.I.A.L . engine i think.
    Wenn add sequence/AP's,HP's ect. after ST =10 then its no problem anymore.

    Leaving Arroya now with Sulik & Miria. With Cookies i modified the stats. Only skills cannot changed with it. All DR & DT are 0.

    I used proto 287 Mysterious Stranger PID 16777503 and tried to reduse to DT & DR to 0 (with cookies), but still no damage to Miria with the Sniper Rifle.

    Time to go to Klamath (again). Damm rats pfff.
Thread Status:
Not open for further replies.