Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. Skiewolf

    Skiewolf First time out of the vault

    24
    Mar 31, 2010
    Just to note for both. Getting attacked my an addict in The Den is and always was part of vanilla Fallout2, this is not a bug.
     
  2. Unkillable Cat

    Unkillable Cat Mildly Dipped

    562
    Jan 5, 2004
    killap: Thank you very much!

    One thing I did notice, in regards to the Kaga encounters - they're not like the Morton Bros encounters. If you can avoid Kaga, you've lost him for good...or at least until the next encounter in the line is due.

    Two little bugs in the Raiders map:

    # If you choose to enter via the "Cliff" map (after having visited the location more than once) you can scroll too far to the left and down with the camera. At least that is the case when you arrive by car.

    # Your party members take no damage from falling down the pits in the Raider caves.
     
  3. niteowl2k

    niteowl2k First time out of the vault

    4
    Apr 12, 2010
    FO2 patching guide?

    First of all, thank you VERY much killap for all you do for us FO2 fans!!! It is much appreciated.

    I had a working FO2 installation running the official 1.02d patch. Wasn't too far into it this time, so I'm not worried about saving the savegames. I tried installing three patches, and am now getting AreaInit errors. When I reinstall, which of these do I need to put in, and what is the proper order?

    Official FO2 Patch v1.02d
    Killap's Unofficial FO2 Patch v1.02.26
    Killap's FO2 Restoration Project v2.0
    Mash's Fallout2 High Resolution Patch v2.2b

    I run Win7Pro in 1440x900 32-bit, and the colors look funky when I load FO2. I really don't need the game itself hi-res, but I would like the colors to not be inverted/flaky.

    Thanks for your time.
     
  4. spukrian

    spukrian First time out of the vault

    30
    Apr 1, 2010
    Don´t install the Official Patch! It will cause errorrs.

    Only Install FallOut 2 and the Restoration Project. The installer includes everything that is needed.
     
  5. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Re: FO2 patching guide?

    1. Install Fallout 2.
    2. Do not install any patches.
    3. Install the Restoration project. In the installer options you can choose whatever extras you want, but be sure to pick the high-res one as it's needed for a couple of maps to work correctly.
    4. Add any updates from the the first post of this thread.
    5. Please don't install any other mods unless compatibility is confirmed.
    6. Enjoy 8-)
     
  6. BuxnaMan

    BuxnaMan First time out of the vault

    61
    Mar 26, 2010
    Re: FO2 patching guide?

    Make sure you install it in some directory like C:\f2 or c:\fallout since putting it in Program Files can result in many errors on Windows 7
    Also use DirectX Web Setup to download any missing DirectX files since DirectX 11 from Windows 7 does not have all files from pervious versions.
    For colors not to be funky in Fallout go OPTIONS - SCRN and set color to 16bit. That will fix it.
     
  7. BassPlayaKEK

    BassPlayaKEK First time out of the vault

    48
    Jan 17, 2008
    In Broken Hills:

    I don't get the 500 xp for finding the missing people in the caves, and can't tell Dan about his wife. There any fixes for this?

    Is it possible to get Liz's weapons stash also? I get the dialog, but a rug is where the manhole used to be. Help would be appreciated. Thank you!
     
  8. skalderis

    skalderis First time out of the vault

    5
    Apr 12, 2010
    Hey ye. I have some serious issues. After some save loads (maybe ~5 in fight) I can't do any damage to anyone. Also enemy doesn't do any damage. So you basically stuck. Its does help to run away to "green area" and come back. Everything ok then. But at this stage for me its unplayable. Is it just me?
     
  9. SilverM

    SilverM It Wandered In From the Wastes

    103
    Feb 16, 2008
    no it happened to other people who save in combat. it's an engine thing, not RP. so as a general rule, don't save in combat.
     
  10. BuxnaMan

    BuxnaMan First time out of the vault

    61
    Mar 26, 2010
    No it is not just you it is all over this thread.
    However there is a simple solution: Do not save during combat!
    If you feel need to cheat download Fallout 2 Save Game Editor
     
  11. skalderis

    skalderis First time out of the vault

    5
    Apr 12, 2010
    So "jagged alliance" mode :) I can live with that.
     
  12. Hadanelith

    Hadanelith First time out of the vault

    17
    Jul 27, 2008
    So, about the Den - still can't get in there at all without a crash. Someone else by the screenname blanca seems to be having the same trouble I am, with the same error message. The suggested fix was to use an uploaded set of Den maps (which, I presume, were working for that person). Doing so changed nothing - I still couldn't get into the Den without the same crash and message. To answer a question asked of blanca: Yes, I have the hi-res patch installed, and am playing at 800x600. To answer other possible questions: no, not using Dx9 mode at all. I am using the appearance mod - my char is a long haired dude, just for the variety. Any thoughts?
     
  13. Harold

    Harold First time out of the vault

    24
    Feb 21, 2010
    Movement was lagging for me in the Den but only when the ghost (Anna) was visible (it never lagged during the day), and only on that map. As soon as I gave her the amulet (and she disappeared) the lagging stopped. I don't have a save unfortunately. (This was also without the high-res patch.)

    Maybe the lagging is related to why the Den is crashing for some people.
     
  14. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Do people with Den crashes have the resolution patch installed? Also, people with Den crashes, please post a save game.
     
  15. boundrose

    boundrose First time out of the vault

    37
    Oct 10, 2008
    Thanks for explaining Timeslip :)

    I do not have time and will to scout through all these 40 pages and I did not noticed the bug tracker of any sort, so please forgive me.

    But i can't help myself and not thank you all for this mod by not supplying my feedback(at least that i can do).

    Another bug i submit is:
    -in Modoc, after you talk with Vegir and get back to Modoc; Balthas, when you click to chat with Balthas, you see the "final" words you've heard from Johnny (like: "please talk to Vegir, because i want to go home") and the only dialog option you have is: "go on". After you chose it, conversation ends. I know it is minor, but i am just letting you know :)

    Will post more bugs I encounter unless you tell me to stop (or point to some kind of bugzilla or something)

    Thank you :)
     
  16. kungfujoe

    kungfujoe First time out of the vault

    83
    Sep 28, 2008
    There's nothing so elaborate available, but any bugs for the restoration project should be posted on the F2RP Technical Info wiki page.
     
  17. Iguana Bob

    Iguana Bob First time out of the vault

    10
    Nov 8, 2008
    First of all, thank you killap for your hard work!!!
    Now, to my problem: it´s quite simple really, I can´t save. Anyone knows what might be wrong?
     
  18. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    If you are not using the new long hair critter model, then go to your main F2 directory, open up ddraw.ini and change EnableHeroAppearanceMod to 0
     
  19. Iguana Bob

    Iguana Bob First time out of the vault

    10
    Nov 8, 2008
    I did that, but I keep getting the same thing: "Error saving game! Unable to save game"...
    By the way, the game works fine with the unnoficial patch, but it´s the restoration project the problematic one.
     
  20. Darek

    Darek is currently unavailable

    Jan 7, 2008
    The hero mod only messes with loading saves made while in combat.
    The problem here seem to be stuff remaining in the registry from a previous Fallout install (maybe only RP install?). Reinstalling to a folder outside of C:\Program Files has helped some but not all. Also, the Windows version does not seem to matter. I think there's a thread somewhere about this.
    Anyway, I would suggest trying a registry cleaning program like CCleaner.

    killap, could you tell where your installer puts stuff in the registry?
    It might be helpful.
     
Thread Status:
Not open for further replies.