Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. drizzt561

    drizzt561 First time out of the vault

    38
    Mar 30, 2010
    Are you installing RP over the patch? Try a fresh install without any patches. And also if you're on win 7 of vista, don't use the default installation folder. Use something like c:/fallout2
     
  2. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    The only key I know that the RP adds is:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Management\ARPCache\Fallout 2 Restoration Project_is1

    But the default installation folder should be where the registry says you installed F2 to. Is this not the case for the Vista/7 users?
     
  3. drizzt561

    drizzt561 First time out of the vault

    38
    Mar 30, 2010
    I just mean people on win 7/vista have been having problems when installing into c:/program files/ so avoid using that which is the default installation path for fallout2.
     
  4. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Ah, of course. I thought you were telling people to install the RP to a different directory than what the RP installer is saying. This fine so long as you are truly installing to the directory where F2 is installed and the RP installer couldn't detect the location for some reason.

    But yes, what you say seems to work for some people.
     
  5. MoonScar119

    MoonScar119 First time out of the vault

    24
    Sep 14, 2006
    Thank you so much for pinpointing the issue. Hopefilly the newest patch will have a fix included
     
  6. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Oh, it will. Mash has already fixed the issue and we are waiting on Timeslip to incorporate the fix in sfall. When this happens, I'll probably release an emergency fix (ie just download the latest version of sfall). It will obviously be included in the RP 2.1 update due out at the end of the month.
     
  7. Hadanelith

    Hadanelith First time out of the vault

    17
    Jul 27, 2008
  8. Timeslip

    Timeslip Water Chip? Been There, Done That
    Modder

    921
    Aug 15, 2007
    Just waiting on mash to let me know he's done, (there seems to be something else he was fixing at the same time; not certain if it's finished yet,) and then I'll reupload it.

    I've fixed the alt-tab problem too, while I was at it. It must have been there at least since the gpublt option was added, and probably earlier. I'm surprised no-one has complained before...
     
  9. carpediem99

    carpediem99 First time out of the vault

    27
    Apr 2, 2010
    Sweet, I'm looking forwards to playing it again after these new fixes are released. Much appreciated.
     
  10. SHADOW-XIII

    SHADOW-XIII First time out of the vault

    98
    Nov 19, 2007
    In Windows 7 I would strongly discourage from using drive C:, it might not go well along with UAC/administrator rights. I suggest using other partition like D:\ or if not having another drive then installing it on C:\Users\<XXX>\Desktop (where XXX will be your system name) (and instead of "Desktop" you can use different folder, like Documents etc)
     
  11. Ravager69

    Ravager69 Sonny, I Watched the Vault Bein' Built!

    Dec 21, 2007
    Just a side comment, but since when crashed vertibirds bleed green goo? Looks odd, in my opinion.
     
  12. Brunzer

    Brunzer First time out of the vault

    97
    Apr 9, 2010
    Because it's actually a squashed metal insect :P. I've to agree with you though, it would make more sense if the green stuff were labelled 'hydraulics oil' or something. But this not a bug, and should go into the suggestions thread: http://www.nma-fallout.com/forum/viewtopic.php?t=18208

    A few San Francisco bugs:
    -inside the tanker, the southernmost table of Jenna the merchant is not accessible.
    -The wall safe in the first room of doctor Fung's house is accessible from both sides of the wall. Though my character is wearing power armor, I don't think he should be able to stick his hands through walls.
    -I get stuck in dialogue when offering Lao Chou to 'make it worth his while' in exchange for info on the tanker. You need to take some mentats to boost charisma before you talk to him in this savegame: http://www.megaupload.com/?d=WUFQSD95
    -When using the charisma enhancement in the brotherhood of steel bunker, my charisma is raised by 2 points, from 6 to 8. I thought it should give only a +1 stat increase. The same savegame as posted above can be used.

    Navarro:
    - I went to Navarro by using the vertibird desert encounter in New Reno, after fighting my way out of there and leaving the map, Navarro is not marked on the world map.
     
  13. BuxnaMan

    BuxnaMan First time out of the vault

    61
    Mar 26, 2010
    Well I noticed it is absent if you turn of DX-9 rendering and jut use plain HI-RES so I suggested so to others. And you or Mash told me that it is baisicly same unless I'm trying to run in a window.

    I installed in C:\Fallout and had no problems. I have Windows 7 with UAC enabled. I think only problem is with Program Files.
     
  14. spukrian

    spukrian First time out of the vault

    30
    Apr 1, 2010
    Some more stuff:

    NEW RENO:
    - The first time I talked with that Monte guy he accused me of cheating.

    ARROYO:
    - I don´t remember finding a GECK in Arroyo after the Enclave attack in vanilla FO2. It is lying in the canyon. It´s not there in the beginning of the game.

    BROKEN HILLS:
    - I´ve installed those quickfixes that are available in this thread.
    - Finding the missing people works! Great, thanks to the guy who made it (sorry, can´t remember your name at the moment :oops: ) But Francis... well, he doesn´t crash the game, but I don´t get any dialogue options when talking to him, (except [DONE] which ends the dialogue). So I can´t confront him about the missing people. However, I had visited Broken Hills once already before installing the quickfixes so it might be because of that.
     
  15. Timeslip

    Timeslip Water Chip? Been There, Done That
    Modder

    921
    Aug 15, 2007
    It was something that only effected graphics mode 4. When a fullscreen application loses focus, all resources in video memory get tossed out, and there was an extra texture I'd added at some point that wasn't being correctly restored. All other graphics modes worked correctly.

    If you don't mind the monitor mode switching, don't suffer the blackout problem, aren't using shaders and don't want to play in a window, then no, there's no advantage to using sfall's DX9 mode over the hi-res patches 16 bit mode.

    Seconded. There's really no need at all to install outside of the system drive. Just ensure you avoid the program files directories like the plague for any game you intend to mod, or any game older than a few years. (Personally I have a C:\games folder to install my games to.)
     
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    It was directed to you. :P

    I'll look into it.
     
  17. maglalosus

    maglalosus First time out of the vault

    5
    Apr 13, 2010
    Hello

    Having problems saving with the new v2.0 expansion. I used the windows installer and am running Vista, and have no patches on. The expansion installed correctly ( i see the version on front page and the stone at ToT) I installed the game to the default location C\program files ....

    When i save i get this as a pop up... "save game error... unable to save game"

    any ideas?

    I tried emailing killap but his email on his website doesnt work (sniper@ etc)
     
  18. .Pixote.

    .Pixote. Antediluvian as Feck
    Modder

    Sep 14, 2009
    I thought they might have a nuclear power plant of some sort…green goo = nuclear spill. :look:
    It was a joke that should have been removed before the release… :roll:
     
  19. MoonScar119

    MoonScar119 First time out of the vault

    24
    Sep 14, 2006
    You guys are so great. You truely are. Words can not express my appreciation that I have for you. Keep up the great work.
     
  20. BuxnaMan

    BuxnaMan First time out of the vault

    61
    Mar 26, 2010
    Install in C:\Fallout or anything else other than Program Files since it creates bunch of errors in Windows Vista/7
    Also make sure you update your DirectX since DX11 doesn't have all files from previous versions using DirectX Web Setup which will download missing files.

    Hope this helps
     
Thread Status:
Not open for further replies.