Fallout 2 Restoration Project 2.1.2b (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Sep 18, 2010.

Thread Status:
Not open for further replies.
  1. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    There's no need to install the unofficial patch, it's already included in RP.
  2. Mattij

    Mattij First time out of the vault

    Jul 12, 2013
    Must say I've had an absolute nightmare intsalling this mod. Funnily enough it was mostly my own fault for getting creative with some of the problems. Firstly, I tried to install the automatic installation, but the rig I've got fallout installed on is an ancient AMD 500mhz win 98 machine. Everything installed ok up until the end when it tried to access my master.bat file. The master.bat just wouldn't be modified. It's stopped me being able to save ingame. Afterwards, I tried to install the manual version, but ran into the same problem of not being able to save the game. When I shifted things around again I found I could save the game, but half of the new quests were broken and would either not start at all, or be impossible to finish (this would be around the time I started to imagine the violent deaths of the mod creators...).

    So after days of banging my head against the keyboard and stubbornly searching the net for answers, I finally managed to piece everything together and get a proper install. I think the issues were that the first install was still in the registry and was cocking up later installs (I fixed this with an old version of CCleaner). The master.bat file would still not install properly, so I had to do the last bit of the installation manually (thanks to the information of a poster on this forum). I'll repeat it here so it's clear for anyone experiencing the same issue.

    When you've unpacked the batchwork folder (I'm assuming you're using the manual installer and win 98) into your main fallout2 directory you access the same directory via MS DOS prompt. When you've reached the folder you type each line individually making sure you press enter after each line of code. You'll get a blank screen popping up for a split second. When you've done all four the master.bat file should be modified (you can check the file, but you won't get any other type of verification).

    START dat2 d master proto\CRITTERS\00000502.pro proto\CRITTERS\00000503.pro proto\CRITTERS\00000504.pro

    START dat2 a master proto\CRITTERS\00000502.pro proto\CRITTERS\00000503.pro proto\CRITTERS\00000504.pro

    START dat2 d master proto\CRITTERS\00000089.pro proto\CRITTERS\00000079.pro

    START dat2 a master proto\CRITTERS\00000089.pro proto\CRITTERS\00000079.pro

    Hopefully, this post will make it clear to anyone experiencing similar issues and they can avoid a few days of head banging. I'm not sure if this would work if you're trying to use the automatic installation on win 98.

    Thanks to Killap for a great mod!
  3. killap

    killap Bear Dude Moderator Modder

    May 16, 2005

    Glad you got things running eventually.

    I'm curious though, how does the RP 2.2 beta installer behave on Win 98? The master.dat modification step has been improved since the last release from 2 years ago.
  4. Mattij

    Mattij First time out of the vault

    Jul 12, 2013
    Hi Killap.

    The automatic installer ran fine up until the end. It would install all the files on my computer, but would give the warning that I needed to upgrade windows when it got to accessing the master.bat file. The part of the installation modifying the master.bat file is still not working for me. The batchwork folder with the manual installer worked up until the last step (removing temp files, I think it was). When you reached that step a window would come up saying there were files missing (I think it said something about a bad command too).

    Hope that helps.
  5. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    And this was with the RP 2.2 beta installer? Not the 2.1.2b installer?
  6. neovelamir

    neovelamir First time out of the vault

    Jul 15, 2013
    Hi Killap,

    Thanks a ton for this awesome mod. I have a quick problem though.

    I installed the restoration project but the resolution of the mod is still pretty poor. The highest it goes up to is 1024x768

    I intsalled a seperate resolution mod which allows it to be rez'd to my native monitor screen. Will this bug out the game later?

    Thanks for your help
  7. SkynetV4

    SkynetV4 Mildly Dipped

    Jan 25, 2005
    I have a silly question about the restoration beta. Does the Cult of Personality implementation include the infinite party members functionality mentioned in the falloutmods wiki?
  8. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Thread locked for the 2.2 release. Go here.
Thread Status:
Not open for further replies.