Fallout 2 Restoration Project 2.1 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 25, 2010.

Thread Status:
Not open for further replies.
  1. Ghouly89

    Ghouly89 It Wandered In From the Wastes

    Jul 14, 2010
    Killap, will a red-haired female critter be of any use for the RP? You may or may not know that I'm making her right now, and she will definately be up for grabs as an alternate female hero critter. :salute:
  2. Gordulan

    Gordulan First time out of the vault

    Jul 15, 2010
    ghouly, you're my idol as of this moment, you just rock.
  3. Panzerkampfwagen

    Panzerkampfwagen First time out of the vault

    Feb 15, 2010
    I want her too. Killap, please make our dreams come true. :puppy-dog:
  4. ColJack

    ColJack Where'd That 6th Toe Come From?

    May 7, 2003
    Just found my bozar ( eventually, the guards at NCR bazar gun shop no longer have them in inventory, possibly weilding them ? ).

    it has the rifle sound now though, rather than the burst sound.. ?
  5. talk2michael999

    talk2michael999 First time out of the vault

    Jul 10, 2003
    Hiya guys, after installing 2.1.1 over 2.1 and starting a new game I am returning with the issue that I cannot talk to Renesco about the air purifier for the Broken Hills mine. Below is a save game (slot 07) at Renesco, after I've agreed to Zaius's quest (and been given the 'canary' password by not asking for a reward).

    Also, I'm not sure if this is a bug or something that occurred in vanilla F2, but I have another save (slot 06) where I have a crippled leg, but don't get an option to ask the doctor in Broken Hills to heal me because my HP is full. I ended up going to the ants underground, got hit for 1 point then returned and got healed which cured my leg too.

  6. off_jofce

    off_jofce First time out of the vault

    May 10, 2010
    Hello to all, first I would like to say thanks to killap and other community members who did an awesome job with this mod, and made a great game even better :clap: I enjoyed the vanilla F2, and I enjoy the Restored Fallout 2 even more :)

    Secondly, I would like to report a few possible minor bugs

    1. in Klamath, the locked door in Vic's house is locked even after you lockpick it, leave the map and return. If you leave the door in the open position, leave the map and return, you won't be able to close it, it will say the door is locked. Not a serious issue, but annoying if you forget the radio and decide to get back for it later :) I will provide a savegame if need be, but I didn't feel it was necessary.

    2. (NOT A BUG) When you start a new game, if you equip the spear in your active slot, Klint will talk to you as if you have passed the Temple of Trials, if you talk to him without an item in your active slot he will have the right dialogue. Not really a bug but I thought it would be nice to report it.

    3. I also experienced a severe lag when I entered the Den for the first time, but i read the previous threads on this matter, and walked past Petey, initiated conversation and left for the East side, after that the lag wasn't present. I tried to replicate the issue but the lag didn't come up... so I guess it's not a bug :D .

    I have a Windows XP Professional SP3, a clean install of Fallout 2 v1.0 Humongous install, Fallout 2 Restoration Project 2.1.1 (Windows installer)

    Cheers :)
  7. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I tried your save and had no problems with it. You have to be persistent in asking who he is. After all, if you don't know who he is you won't know he's the guy you're looking for.
    Or am I missing something, is the problem something else?
    This is normal "vanilla" behavior for all doctors in the game. I don't know why it's never gotten "fixed". I'll have a look when I have more time.
  8. Thor_Wolf

    Thor_Wolf First time out of the vault

    Jul 16, 2006
    Door Bug

    I found a small glitch today: I knocked open an electronically locked door on the 3th floor of VC's vault with my bare fists . I could not enter the room, however. Not that I wanted to enter this area coz I find it quite silly to open a vault door this way, I was just fooling around due to my lack of lockpick skills. Nothing major though, but I thought I'll report it. Here's a screenshot:

  9. talk2michael999

    talk2michael999 First time out of the vault

    Jul 10, 2003
    Thanks Darek you're right about Renesco, despite clicking through a lot of his options I must have never actually used a no-bullshit response and gotten his name out of him!
  10. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yikes this thread grows while I'm away. Was moving out of my apartment all weekend, so I only now get a chance to catch up on things...

    As I said before, an update (2.1.2) is in the works and will probably be the last update for 2.1. RP 2.2 is in the works and will bring back multilingual support and hopefully some new critters. No plans for any new content, as essentially all pulled content has been restored. Maybe an optional food system someday, but no promises.

    Also, remember that this thread is for bug reports, not content or gameplay discussion. Please post those in the other RP threads.
  11. chenw

    chenw First time out of the vault

    Jan 2, 2008
    oh, I am not sure if this is reported or there has been a way to correct it. But, the combat messages that state how much damage you get hit by, it sometimes just displays a comma or a full stop (period). It can happen to all types of hits, such as 0 damage hit, normal damage hit and critical damage hit. Only attacks done to you suffer from this.
  12. ColJack

    ColJack Where'd That 6th Toe Come From?

    May 7, 2003
    not entirely sure if this is yours or a general engine bug but I tried to get back into the hebologist base after killing AHS9 and the forcefields were up..
    so I detonated a C4 in front of it.
    the first one made the field flicker ( and passable ) but I wanted it gone, so I dropped another C4..
    this onr came up in the screen as "you destroyed the emitter".. but the emitter itself dissapeared entirely, no replacement image?

  13. ColJack

    ColJack Where'd That 6th Toe Come From?

    May 7, 2003
    next bug..

    went to the hubologist secret stash, got the stuff in the safes..

    the "expired G.E.C.K."'s description says the following..

    "This one is well beyond is expiration date. What a waste"

    shouldn't that be "..well beyond IT'S expiration date"?
  14. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I've seen this happen with several bug report saves games posted. Does everyone have this problem? Any pattern to it? Perhaps Timeslip or Haenlomal can shed some light on this...? :)
  15. Skiewolf

    Skiewolf First time out of the vault

    Mar 31, 2010
    Oh I've been waiting for her since I saw she's at the works. Any ETA on her?

    And I do hope she will enter the RP as an hero option.
  16. kungfujoe

    kungfujoe First time out of the vault

    Sep 28, 2008
    No, it should be "its" expiration date. "It's" is "it is."
  17. TailSwallower

    TailSwallower First time out of the vault

    Feb 9, 2010
    I did a clean install of both Fallout 2 and RP, but I continued using the save game from before. Is that going to prove to be an issue? Because I've still had some crashing problems.

    Again, I picked up a Gecko pelt in the primitive village just to try it out, and this time it appeared in my inventory properly, but still crashed the game. I re-loaded and left them on the ground and didn't have any problems until I went to Vault City.

    At Vault City I bought the forged papers, went inside, and got given the job to find the raiders south of the city. Now, as I'm searching around for the Raider camp I keep getting random encounters, and I get crashes every now and then during combat in the encounters.
    The last one was especially frustrating because I had nearly finished clearing out a cave of Lesser Deathclaws - it crashed when I had earned between 6 & 7 thousand XP and only had one Deathclaw left to kill.

    Am I going to have to start a new game, or is there a known issue with the area around Vault City or that part of the quest?
  18. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Is your save game from 2.1? If you are using a save from the Primitive Tribe after you already entered it, then the fix in 2.1.1 won't take affect.

    I'm not sure what to say about these crashes in combat. I've seen several reports but don't see any real pattern. Does this crash happen when a specific gun is being used? I'm curious if the crashes are the result of using the new sounds in the RP (the F1 gun sound, smoking, and maybe one other I'm forgetting). I took the time to make sure the sound lists were correct for the different options one chooses in the installer, but maybe I made a mistake somewhere. Is anyone with crashes in combat willing to test the following?: Reinstall the RP but don't choose the F1 gun or smoking animations. Then see if the crashes still happen.

    EDIT: I see on the RP bug wiki that not installing the F1 gun sounds stops the crashing in combat. If that is indeed the case, then it's final, I'm removing that option from the installer for good. It caused problems in the past, I thought I fixed them, but apparently not. I know some people liked that sound more than the one in F2, but w/e, crashes are worse. Even though I'm sure people will ask where it went once 2.1.1 is released, here's the word: F1 gun sound is no longer supported by the RP.
  19. TailSwallower

    TailSwallower First time out of the vault

    Feb 9, 2010
    The save game was from a version of 2.1 that was installed over 1.2. I reloaded from before I entered the village, but it's probably still a residual effect from the 1.2 files, so my bad. I think I'll go ahead and start a completely new game so I know that any new crashes aren't because of any 1.2 files that were still around when I started the game.

    In regards to the crash the first time it happened just as Vic attacked with the 10mm pistol. I can't remember what was happening on the other crashes, but I don't think it was Vic who was attacking each time.
    I've never been pedantic enough to save during combat, but I might have to start now...
    When I start a new game I'll keep tabs on who is attacking/what is happening just prior to each crash to see if I can give you any more details.
  20. Aphyosis

    Aphyosis Where'd That 6th Toe Come From?

    Nov 4, 2009
    I'd recommend against it. Saving during Combat causes quite a few additional issues.
Thread Status:
Not open for further replies.