Fallout 2 Restoration Project 2.1 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 25, 2010.

Thread Status:
Not open for further replies.
  1. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    High "Science" skill is needed, otherwise you don't gain acces to the Enclave network.

    Hm, i'm installing this part via the robot-control terminal without any problems in RP.
     
  2. Munin

    Munin First time out of the vault

    67
    May 27, 2008
    I 've got a problem with my resolution, I m now playing Fallout 2 with the restoration project on windows 7 and find my intro-movies and in-game view not looking very good (a lot of white/grey dots on parts of my screen, wrong colors, ...).

    Is there a solution for this problem? I ve already tried to change compatibility mode (to xp) and my screen resolution (to 600 x 800): But when I do this I get a popup-error saying that I m already in compatibility mode (disabling the game from starting)
     
  3. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Munin,
    try read from this post, maybe you'll find some useful tip.

     
  4. Munin

    Munin First time out of the vault

    67
    May 27, 2008
    thx for the quick reply, you ve made my day ;-)



    Edit

    I ll post the easy solution for anyone who encounters the same problem again, I didn't found it explained as easy as I found it to solve it. So here we go:


    1) Start the fallout game from your fallout 2 program file or desctop shortcut (so you can go to your in game main menu)
    2) click "options"
    3) click on the "scrn" icon on top of your screen (right next to "game preferences")
    4) then click the "SFALL" tab (just right to the "HIGH RES" tab)
    5) Now you ll see DX-9 mode with the options "off", "full screen" and "windowed mode" => change the setting to "full screen"
    6) tick the box just left of "Restart Game" at the bottom of your screen
    7) click "Done"


    Problem solved
     
  5. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I'm going through the RP bug wiki, so now is the time to report your bugs. If people could also look at the unconfirmed issues list there, it would be most helpful. I'm hoping to get RP 2.1.2 out the door next week.

    EDIT: Went through the whole wiki page. All reports of actual bugs have been fixed. Please look at the unconfirmed reports if you have the time. Also, if there have been reports made in this thread and they are not up on the wiki, I would appreciate it if they could be posted there. I don't really have the time to go through this thread...
     
  6. agris

    agris Still Mildly Glowing

    215
    Jul 8, 2004
    Hey guys, I threw together a few files for people to 'quickly' enable some of the new animations found in the animations thread in this forum.

    This pack will let you use some of the new male + female hero animations found in the NMA thread New Animations 2. It enables the dark brown hero animations for combat leather armor mk2, rather than the default green. It also makes the combat armor mk2 hero animations black, and the brotherhood armor hero animations blue. The inventory images haven't been updated, just the item protos and critter animation list.



    NOTE: This will only work if you use the default male/female hero model, not the long hair dude, medium hair dude or baldie mod. It may work, and just give you the wrong model or it may crash your game.

    This mod contains ZERO content made by me, it just modifies the leather armor mk2, combat armor mk2 and brotherhood armor protos to use the new animations made by Grayswandir and x'il. (thanks guys, these are great)


    Installation:

    I do not include the animation files in this pack, you will have to download them seperately from the New Animations 2 thread. You must download:

    Hero Female Black Combat Armor
    Hero Male/Female Blue Combat Armor
    Hero Male Black Combat Armor (fixed version)
    Hero Female Leather Armor Mk2
    Hero Male Leather Armor Mk2

    Unzip all the files and place the .frms (not including the folder each .zip contains) into ..\fallout 2\data\art\critters

    Then, open up critters.lst, located in the critters folder, with NOTEPAD and paste this into the bottom of the file:

    Code:
    hmlmk2,11,1
    hflmk2,11,1
    hmcmbl,11,1
    hfcabl,11,1
    hmcmbtb,11,1
    hfcmbtb,11,1
    Take care to NOT include any extra spaces or lines in the critter.lst file, i.e. when your cursor is at the end of the file, it should be next to "1" and not under it, or have a space to the left of it.

    Lastly, copy the .PRO files I've included into ..\fallout 2\data\proto\items and make sure they are set to READ ONLY in the file properties. Check item.lst to ensure that

    Code:
    00000239.pro
    00000379.pro
    00000381.pro
    are included in the list. That's it, enjoy!

    Download the new animations enabler here.


    Note: this should work with more just the RP, since I haven't distributed my own critters.list or items.lst. But I also haven't tested it with anything other than my own RP 2.1.1 special brew.
     
  7. NewVic

    NewVic First time out of the vault

    18
    Aug 22, 2010
    Hi! I installed Killap's mod 2 weeks ago. I think its great and far better than the megamod. Its stable and doesn't have any lags. This is what fallout 2 should have looked like at stores 11 years ago.

    ... but I have a problem, for which I am resposible. After installling Killap's newest mod I realy wanted to have a new Vic guy. I downloaded the minimod: Vic Sucks... which changes the fat Vic into the critter with blue jeans and long hair... which makes the gameplay for me fun...

    I had to copy about 7 files from the minimod... the party.txt and a few critter files...
    The problam is that the NEW VIC does not level up at all!!!!

    I am half way through the game and he is still stuck with 70hp - his first level!


    What can I do? Is there anyway I could change it without havin to play everything again? Can I somehow cheat and change his level?
     
  8. Felipefpl

    Felipefpl Look, Ma! Two Heads!

    374
    Jun 17, 2010
    if you installed over a previous mod then copy the savegame to somewhere, reinstall the old mod and be happy. Alas, you should have read the recommendation that says you must install over an untouched fallout 2. ;)
     
  9. Lexx

    Lexx Background Radiant
    Moderator

    Apr 24, 2005
    The "Vic sucks" mod is not compatible with the RP. It was a 5 minutes thing I've made long ago. Some new has to be made, if it shall be RP compatible.
     
  10. NewVic

    NewVic First time out of the vault

    18
    Aug 22, 2010
    I tried to do what you said. The saves did work, but new vic still did not level up :(

    Is there any way I can edit a saved game or change Vic manualy by editing his level in a saved game.
     
  11. UniversalWolf

    UniversalWolf eaten by a grue.

    Aug 28, 2005
    I'm aware of the vanilla bug with this one, but my problem with the RP is different. My followers simply start attacking the brahmin and ignore the wolves entirely. No accidental hits required to start it. I tried it several times because at first I thought it was the AI flaw present in vanilla, but it's not.

    Two more things I noticed (and they're not on the bugwiki): solving the "skimming from the caravans" quest in Modoc made it impossible to talk to Francis, which made the arm-wrestling match inaccessible and made the Zaius note quest impossible to finish.

    Also, I can't seem to get a dialogue option with the holo-scientist in the EPA to say I tested the Solar Scorcher, even though I've used it in combat.

    Sorry for not following bug report protocol on this - kinda pressed for time at the moment. Hopefully next playthrough I can reproduce these and document them properly.
     
  12. Thor_Wolf

    Thor_Wolf First time out of the vault

    28
    Jul 16, 2006
    A quick question:

    I'm having trouble locating the slaver's camp, it's not on the map. I killed Metzger and freed the slaves before I got Sulik to go on his quest. Prior to this I traveled with Vic and completed most of the Northern half of the worldmap, although I haven't been to NCR yet. Can someone give a few spoilers or am I stuck?

    Thanks in advance.

    *Edit* EPA has undergone massive changes. I was wondering if the Doctor is still there because I can't find him anywhere?
     
  13. Radar E 33

    Radar E 33 First time out of the vault

    45
    May 27, 2010
    @Killap: I have uninstalled both the RP and the game countless times, and i cannot correct the issues with content missing. That's why I posted earlier in the thread about getting help with my registry.

    I believe that the FO2 registry data is somehow messed up. As stated on the bug report page, RP 2.0e did not have as many issues as RP 2.1 has with my old computer. As well, i accidentally installed lootable armor mod(the non-RP). I deleted it and installed the RP version. Yet i'm able to get power armor off of the soldiers in the military base. This occurs with my old computer, but not on my windows vista laptop. Perhaps the registry is getting confused...

    In regards to the shi base decomposing body save i posted, i threw the body on the ground on purpose. I tried everything to get the guy to recognize i had the body, but nothing worked.

    @Thor_wolf: Sulik MUST be in your party, or you will lose the chance to find out about Sulik's sister. He MUST. BE. IN. YOUR. PARTY! Not waiting in the same area or city; he must be in your active party. I found this out the hard way.
     
  14. utunnels

    utunnels First time out of the vault

    74
    Aug 2, 2010
    Does anyone know whether this is an vanilla bug or not?

    Sometimes corpse doesn't use its death frame.

    For example, if a bomb happens to explode while a creature is attacking, the creature will play its pain animation, but actually it has already been killed.
    Another example, if a creature falls and hurts itself, the damage may kill it, but sometimes it stands up from its blood and tries to run away. :shock: The animation will then freeze, leaving a standing corpse.
     
  15. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Vanilla bug.
     
  16. Dravean

    Dravean Where'd That 6th Toe Come From?

    477
    Mar 6, 2005
    Nope, the doc got the axe.
     
  17. delamer@mail.ru

    delamer@mail.ru First time out of the vault

    10
    Jan 1, 2009
    Hi, Killap.
    Firstly- thanks for your work, incredible as always.
    I used your restoration project from times of XP x64, now I migrated to Vista x64 and then- to 7 x 64
    All this systems was able to handle fallout 2 only with Mode=4 in ini. Without it- mess with colors and freezings, which required cold restart of the system.
    My video- GF 9800 GT.
    My fallout games was purchased long time ago, they was not patched. Now I will try to install steam versions of the games and will try RP with steamed Fallout 2
     
  18. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    If all goes well, RP 2.1.2 should be released at the end of Tuesday. This is a stability update, with lots of nice fixes for both the RP and the original game (thanks to the sfall team). The only content change (optional change that is) is that Continuum's version of Cassidy's talking head is now used. It looks amazing in game and I think everyone will really like it. Now we just need to voice it. :)

    This will be the last update for a while and my Fallout hiatus will begin shortly after the release. I do still need to get all the .msg files out to the translators, so that they are busy working on the translations for 2.2. Don't expect to see 2.2 until Christmas (or later) though.
     
  19. Felipefpl

    Felipefpl Look, Ma! Two Heads!

    374
    Jun 17, 2010
    killap, did you see that there are a few items with savegames at bug report wiki that you didnt look at? ;) not counting the ones that are in the several pages of this forum. ;)
     
  20. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Those are nearly all encounter/misc issues. They scream faulty installations and/or people saving at wrong times during combat.

    I do see that a few more items have been added as of last night. Hopefully I can quickly get through them early this evening and still release tonight. We'll see.

    I don't really have the time to go through all these pages here, so hopefully they are either dups of the wiki reports or I fixed them on my own bug hunting.
     
Thread Status:
Not open for further replies.