Fallout 2 mod Fallout 2 Restoration Project 2.3.3 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 5, 2014.

  1. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    The Kaga encounter is very similar to the Frog Morton's brothers, which could be avoided completely with decent Outdoorsman skill. Probably you've skipped several encounters labeled "angry bandits".
    Last edited by a moderator: Jan 9, 2016
  2. Phelanpatrick

    Phelanpatrick First time out of the vault

    Jun 3, 2008

    Firstly as usual great job Killap. I really thank you for doing this great mod.

    Secondly, been following the Restoration Project walkthrough and managed to get to the Abbey. Couple of issues I found.
    1. Brother Jason only gives me the quest to format the Abbey computer and not the one to escort him to Gecko. During the dialogue if I suggest that he leave, he would mentions that Gecko is a ghoul town and say no thanks. I tell him they're nice but he replies that they look like brahmin shit. And that's it. I won't get any options when I talk to him again except that I was just saying Hi.
    2. According to the walkthrough Farmer Peterson was supposed to give me lighter which I can use to give to the monk moonshiner. I finished his quest but got nothing. I ended up buying a lighter in vault City.

    I am wondering if I may be missing something.

    Anyway I am still playing and will post anymore issues I may encounter.
    Last edited: Aug 30, 2014
  3. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    You have to talk to Wooz while in Gecko in order to persuade Brother Jason, because Wooz being a Tragic player is the main reason he wants going to Gecko.

    No, it's the old man Tom who should give you the lighter.
  4. LeonaReq

    LeonaReq First time out of the vault

    Aug 21, 2014
    Ahh Ya, that totally makes sense, yes i skip random encounters, i suppose i should start allowing them to happen, it would give me few xp points extra.
    Thank you for the heads up. And as you mentioned it, i had a random encounter that i couldn't cancel, so there he is, Kaga and his freaking 333 HP and i have to run because i've only got 90..well 23 now he shot me. Bloody hell, so much damage! :wtf:
  5. Rafaello

    Rafaello First time out of the vault

    Apr 26, 2010
    It's been a while since I played Restoration Project. I must say I love that it's still being worked on, and I especially love the recently added (last version I played was 2.1.2) the TimeMod on the worldmap, that is being able to travel & have encounters without passage of time.
    However I started playing a few days ago, on 2.1.2. I went to Broken Hills and encountered a weird, already posted bug, that is the deal with Liz not talking to me and Francis saying I'm scum, despite it's my first time in town and my karma is over 400. The fact that bug is posted is true, however I've noticed it's posted as occurring in 2.3.3 also.

    Now, my current problem is very frustrating. I downloaded 2.3.3, installed it, and played. I was in klamath, done some quests, and then I saved the game. Then I exited the game, however to my surprised I got a bluescreen. After restarting everything, I've noticed my primary save file is corrupted, and my secondary (which I also saved at the moment I saved the first) although seemingly viable, it can't be loaded also (FO2 says it can't load it)
    So I restarted the game, and was very cautious around Klamath. Played for a few hours, and then finally grabbed Sulik, took off to Den, ordered him to wait there, saved on all my saving slots, and exited the game. Again, however to the Bluescreen. My all saves are now corrupted, because I saved all 4 of my slots on that same moment. I hope they can be restored, and I beg someone to tell me how, but primarily to tell me what's this bug about. I post my savegame here:

    Awaiting for response. Best regards!
    Last edited: Aug 31, 2014
  6. Phelanpatrick

    Phelanpatrick First time out of the vault

    Jun 3, 2008

    Thanks NovaRain. I'll try those out today.

    Hopefully someone will update the Restoration Project walkthrough with these info someday.
  7. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    Only the "talk to Wooz first" info is not in the walkthrough. The second one is already there, you just need to read more carefully.
  8. Phelanpatrick

    Phelanpatrick First time out of the vault

    Jun 3, 2008
    Another question. According to Per's walkthrough there are supposed to be additional resistances to be gained at the start of every boxing fight in New Reno and they're supposed to be permanent bonuses.

    Am doing the boxing now and I don't see any change during and after every fight. Are they hidden bonuses? Were they removed since some think it's a bug? Tried looking around for the answer and have come up with nothing.

  9. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    It's indeed a bug caused by wield_obj_critter function, and the function is now fixed by sfall. The real bonuses are +5% to Unarmed skill (4% if it's tagged) and DR after you got the Prizefighter reputation title.
    For more details you can check this thread.
  10. Limbabnees

    Limbabnees Still Mildly Glowing

    Jun 17, 2007
    I'm very happy again (and 1001 times again).
    A few days ago i got the ControlPartyMembers working.
    Spendit (no combat skills tagged).

    I'm still testing the abilities before go Ironman :)
    I get crashes when save/reload while in a companion turn.
    You can make Sulik a real mean machine with perks :D

    Companions: When change armor while in inventory, the appearance not change. You need to do it the old way: 'Use Best Armor'
    Ain't good. Marcus can wear also all armors. With Power Armor he's a TANK
    Last edited: Sep 5, 2014
  11. Phelanpatrick

    Phelanpatrick First time out of the vault

    Jun 3, 2008
    Got it. Thanks once more NovaRain
  12. Blue Link

    Blue Link First time out of the vault

    Sep 3, 2014
    Had a strange encounter. I was in the Rat Caves of Klamath, the level with Ke'eng Rat on it. Accidentally saved after dropping Armed Dynamite by one of the weakened support beams, game went without problems. It was when I loaded that things got weird...
    Game loaded, with I am assuming 5-6 seconds left on the Dynamite timer. The explosion animation happened near the ladder up to the Northside, the Dynamite could still be seen at the weakened support beam near the other ladder. I noticed that there was a section of the lower wall missing

    Just below what is Ladder 2 on this map. When I walked there, I discovered I was able to walk into the cavern walls as if they were outside of a building. I would post the save file, but I think I saved over it... Perhaps part of the wall was accidentally programmed to be destructible? On a less exciting note, I was able to pick up the "Set Dynamite" which warned me it was still ticking... Never exploded.
  13. tom gore

    tom gore First time out of the vault

    Nov 20, 2011
    I'm sorry if it's not ok to ask this here, but Im using RP 2.2 and when I leave San Francisco I encounter last Kaga and it crashes when I use action/description cursor on him. Is this a known bug and is it fixed in newer versions of RP?

    Save game: speedyshare . com/unkHF/SLOT01.rar (sorry I couldnt post a direct link so I had to put spaces to it)
    Last edited: Sep 7, 2014
  14. Samson3

    Samson3 First time out of the vault

    Jun 29, 2008
    Hey, I'm hoping someone might be able to help me with an issue I'm facing, now that I'm about to get the latest update to the RP.

    I have the GSP White Label Fallout Collection, and for the longest time, there was something preventing any of Fallout 2's music from playing in-game. Sound effects and such would play, but none of the background music. I put up with it for ages until I became particularly sick of it, and started hunting around for a way to fix it. I believe I ended up having to go into one of the game's files and edit a line of code that hadn't been written, properly. Trouble is, I don't remember the file, nor do I remember the correction I have to type in to get the music playing.

    Before I do a clean re-installation for the RP, is there anyone who knows what I'm talking about that can help me? Playing without the background music really takes a lot out of the experience :(
  15. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    In the main folder, just open and edit the fallout2.cfg file (with notepad). Edit the two music path lines as appropriate.
  16. Samson3

    Samson3 First time out of the vault

    Jun 29, 2008
    Thanks ^_^
    • [Like] [Like] x 1
  17. Arthandas

    Arthandas First time out of the vault

    May 26, 2012
    Is it possible to impose an experience limit of 21 levels like in F1? If so, how?
  18. Blue Link

    Blue Link First time out of the vault

    Sep 3, 2014
    This is more of an annoyance than a bug...

    The quest in Modoc where you help defend the Brahmin from the wild dogs. Sulik and Vic keep randomly attacking the Brahmin, despite them not attacking me first or me attacking them. Is it possible to list the Brahmin as Temporary allies with a green outline, like Lara's Gang in The Den?
  19. Coroner

    Coroner First time out of the vault

    Sep 14, 2014
    Hello guys, I'm wondering if someone can help me with random encounter issue... I'm having random encounters almost every second I'm on the world map, and it's really starting to kill any kind of game immersion. How can I reduce the number of encounters... a lot? I know about outdoorsman skill, but this is too much with or without the skill. Also encounters are all very similar so without proper pacing this is really a huge issue.
  20. I want to ask if the unofficial patch version has the AP ammo problem fixed.