Fallout 2 mod Fallout 2 Restoration Project 2.3.3 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 5, 2014.

  1. Delleropk

    Delleropk First time out of the vault

    10
    Mar 26, 2014
    No Critters

    Hi all, Im new to RP, I've played vanilla F2 a few times and loved it!! i tried using the previous RP and I found I had and error whereby I couldn't see any critters at all!!! in the temple of trials there was no ants at all!! they would engage combat, but i just couldn't see them. I waited for this latested RP but I get the same issue. any clues?

    I've read through the F2RP_Technical_Info web page and I came across something about WINE but I have no idea what this is about.....can anyone help? I'd love to play this game again!!!

    Thanks for reading! :)

    Del
     
  2. Felipefpl

    Felipefpl Look, Ma! Two Heads!

    391
    Jun 17, 2010
    Delleropk - u didnt post your specs (much better if they are on yor signature ;) ) and your distro.
     
  3. Delleropk

    Delleropk First time out of the vault

    10
    Mar 26, 2014
    sorry :)

    Intel Q8300 Quad 2.5GHz
    4GB Ram
    Win 7 Ultimate 64Bit
    Nvidia GTX 650
     
  4. Benf

    Benf First time out of the vault

    5
    Jul 24, 2014
    Hi!

    Killap, first of all, you really did a awesome work !

    I'm playing and I noticed a few things :

    • In modoc, when i finished the quest with the Slags, Jo tells me that i could buy thing at cost price. So i try to trade to see it, and indeed, the price of things are actually lower. But if i quit the dialog, come back, and trade again, the price is anew high. Also, he tells me that i could have some advantage with other peole in Modoc, but i don't know where.
    • For the quest "Defend Grisham Brahmins", it seems it's bugged. For example, when i am teleport, and go back to modoc and talk to Grisham, it tells me all brahmins are dead and ask to cover his losses , giving him 1500$. I answer : "Those brahmin weren't worth more than a $1000." and then he says "Great! Head out to the pastures at night and kill the pack of wild dogs that are attacking my brahmin. Come back here when you finish the job.". And i am teloported to the paturage, with no brahmin left. There are only dogs, so i killed them. It's written i killed of of them, but when i go back to Grishman, i always have the dialog that he lost his brahmin, bis repetita.
    • For this same quest, a friend has an other bug, that i can't reproduce. He lost two brahmins during the fight with dogs, and after the fight, he was teleported outside (i personnaly had toi move to the exit grid). When he goes to talk to Grisham, he has the dialog that he has to cover his losses , giving him 500$ (he has a better speech/charisma) than me. He answers "I've left my money in my room; let me go get it for you." because he did'nt have the money. Then he goes to sell some things to have the account, but he never can pay Grisham for his losses (he doesnt have the same dialog that i, to pay him).
    • Last question : what do have i to modify to translate "You lost/gained karma", i didn't find the file(s).

    Config :
    Intel i5-4570 3.20 GhZ
    8GB Ram
    Win 8.1
    NVIDIA GeForce GTX 770
     
  5. Drobovik

    Drobovik Vault Archivarius Modder

    415
    Jun 20, 2011
    @BenfI can answer the last question for you. The above phrase is in the file called translation.ini. Should be in your main RP folder. Open it with regular text editor.These messages are produced by sfall mod, that's why you can't find them in text folder.
     
    Last edited by a moderator: Jan 9, 2016
  6. Benf

    Benf First time out of the vault

    5
    Jul 24, 2014
    Thanks for the answer.

    I don't find this file. I only see a folder called "translation", with 2 files french.ini and german.ini. Inside them, i have the translated lines for messages "You lost/gained karma" for example. But it seems it is not used, but i don't know why.
     
  7. Delleropk

    Delleropk First time out of the vault

    10
    Mar 26, 2014
    Now Im getting a different error, I've un-installed everything and re installed and now it wont let start playing the game... I am able to load into the game, I click "new game", "create character" watch the elder lady give her speech and then......

    The instruction at 0048d9c4 referenced memory at 00000014
    the memory could not be read from
    click ok to terminate the program

    i hope you can help, I'm desperate to play again :(

    Del
     
    Last edited: Oct 7, 2014
  8. Drobovik

    Drobovik Vault Archivarius Modder

    415
    Jun 20, 2011
    Ok, I see. You're right, translation.ini would be in RP folder only if you install the Russian version through the automatic installer. So, you would need an english version of this ini file. Get it here. Download, find the ini file in "configuration files" folder inside, copy it to RP folder. Then you need to adjust ddraw.ini file from main folder (uncomment the line):

    Code:
    ;Uncomment and point to a file to get alternate translations for some sfall messages
    TranslationsINI=./Translations.ini 
    That's it. Now you can translate translation.ini and it should be used by the game when you load it, provided your language is supported by fallout engine. In my case, russian language requires special fonts to function.

    @Delleropk
    Your installation procedure is f*ed up somewhere. Wine is needed only for macs, I believe. Make sure you NOT installing Fallout into Programs Files folder. Plus you got to make sure that patch000.dat is deleted BEFORE starting the game.
    You should post detailed steps you take when you install the game and RP.
     
    Last edited: Oct 7, 2014
  9. Benf

    Benf First time out of the vault

    5
    Jul 24, 2014
    Thanks, it works. I also could take the french.ini in the Translation folder, rename it in "Translations.ini", and put it in the main folder.
     
  10. Delleropk

    Delleropk First time out of the vault

    10
    Mar 26, 2014
    Thanks Drobovik, I did wonder if it was the installation method. I have never installed to C:\ program files, I've either created c:\games\blackisle...etc or put it on the E:\games\...etc

    Is there a "best" way to un-install or simply follow standard methods? I will then post exact methods used
     
  11. Brunzer

    Brunzer First time out of the vault

    97
    Apr 9, 2010
    I don’t think the RP has a proper uninstaller. By using the uninstaller that comes with Fallout 2 some files will remain. Doesn’t really matter though, simply delete the installation folder and its contents. For the ‘round the world squeaky clean wash’, you could run a registry cleaner. Also, the resolution patch (under windows 7 at least) makes a Fallout 2 folder in C:/Users/%Username%/Appdata/Roaming

    It’s probably, like Drobovik said, your Fallout 2 install. But if you experience random crashes and general instability with other software as well, you’d might want to run a memory test.
     
  12. Delleropk

    Delleropk First time out of the vault

    10
    Mar 26, 2014
    SO I uninstalled F2 and RP (I found an uninstaller for RP) I didnt clear roaming data (as I had already done this before your posted) and reinstalled.

    Here is the method of re-install:

    Stage 1:


    Installed Fallout 2 in compatability mode: win95


    and checked all of the following:
    -run in 256 colors
    -run in 640 x 480 res
    -disable visual themes
    -disable desktop somposition
    -disable display scailing on high DPI settings


    and Ran as Administrator


    installed Humongous install to c:\interplay\blackisle\fallout2


    Stage 2


    Installed RP 2.3.3 using windows installer,
    choosing Full install and using latest High res patch


    Stage 3


    I then edited the ddraw.ini graphics section to "mode=4"
    inline with Killap's post in the tech section


    I then adjusted my screen's resoultion to match my monitor.


    and I think thats it...I still have the error


    I ran the game and posted a video to yourtube showing my error-

    http://youtu.be/5FIXRhOURJY




    This error has now gone with the re-install. thanks though.
     
  13. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Make sure your fallout2.exe file is not running in the compatibility mode too, that's not good for sfall mod.
     
  14. Brunzer

    Brunzer First time out of the vault

    97
    Apr 9, 2010
    Hmm, I have different hardware, but the same OS. Here’s how I install the game:


    • Humongous install in d:\games\fallout2

    • RP installer with all options (except a few things like the dogmeat armor among others)

    • Configure the high res patch (1280*720)

    I don’t set it to compatibility mode, I simply deal with slightly psychedelic graphics during the installation. I don’t run it as admin either, nor do I change the graphic mode (I used to change the mode in earlier iterations of the RP though).

    Never seen that before. Allthough I had the same with a Kaga encounter. Though I think that was intended. I damaged him until he fled, he went invisible, but Sulik was still able to damage him.

    Just a few questions to get a better picture:

    What version of Fallout 2 are you using? (US, German etc.)
    Is there a Patch000.dat file in the root of your install directory?
    You’ve only installed the RP on a clean install right? No other patches, including Killap’s unofficial Fallout patch?
     
  15. Delleropk

    Delleropk First time out of the vault

    10
    Mar 26, 2014
    yeah I made sure that the compatibility is not on for that actual game

    thats interesting, I wonder if I play with different patch options...I'll try a couple.

    yeah its odd that the ants engaged combat but i simply cant see them... :/

    version: unsure, my brother bought it about 10 years ago, I would assume uk, because I know he wanted to but the US version but couldnt get it...or so i remember..how can I check?

    patch file: I can't find any file like that around, I installed it to c:\interplay\blackisle\fallout2, should this file be there too? if so, it is not.

    no other patches have been applied, I installed it exactly as mentioned in my stages.

    Thanks for your effort mate, its great appreciated!!! :D

    Del.
     
  16. Brunzer

    Brunzer First time out of the vault

    97
    Apr 9, 2010
    Somehow I don’t think that the problems stem from the gameplay options. Do you get this error when playing the vanilla game, that is, without the RP?

    Make sure that installing the .frm’s for missing children is checked. Even if you do happen to have the US version, it won’t hurt.

    That is as it should be, patch000.dat should not be in your Fallout2 directory.

    I’m afraid I can’t be of much further help. Like I said, for me installation has always been pretty straightforward. No compatibility mode, no 256 colors or any other special settings. Just the humongous install, the RP and setting up the Hi-res patch. Maybe some of the other members can shed some light on this.
     
  17. Delleropk

    Delleropk First time out of the vault

    10
    Mar 26, 2014

    well thank you for your help, I will double check all your suggestions, hopefully that will work.

    Will post once I've tried these other options

    Del.
     
  18. Delleropk

    Delleropk First time out of the vault

    10
    Mar 26, 2014
    how can I run the game without RP? because when I've tried that the game simply does not load... should I just install 1.2 patch?

    Del.
     
  19. Brunzer

    Brunzer First time out of the vault

    97
    Apr 9, 2010
    You could try the patch. If possible, you should try on a different computer. Maybe your install CD is damaged.
     
  20. Delleropk

    Delleropk First time out of the vault

    10
    Mar 26, 2014
    FIXED!!!!


    Thank you to those who helped me but especially Brunzer!! I fixed my issued by getting a new copy, it appears my install CD is some how corrupted!!

    I look forward to getting back into this epic game!!

    Thanks Killap!