Fallout 2 mod FO2 Engine Tweaks (Sfall)

Discussion in 'Fallout General Modding' started by Dude101, Jul 30, 2007.

  1. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Try setting EnableHeroAppearanceMod=2 in ddraw.ini.
     
  2. fxluk

    fxluk First time out of the vault

    7
    May 8, 2021
    No effect, unfortunately...
     
  3. fxluk

    fxluk First time out of the vault

    7
    May 8, 2021
    Just an update,

    When I strip them from their armor, their look is back to normal.
    When equiping armor, it get back to being broken.

    @Update 2: I am getting somewhere :) After reinstalling pure RP + ECCO 0.63b, now I see the companions correctly, although I am getting the red warning message about RP ddraw.ini being replaced and that I should revert as soon as possible.

    @Update 3: Reinstalled RUP again on top of RP, then ECCO and for it went to normal. I will see how it goes.
     
    Last edited: May 10, 2021
  4. ViperDaimao

    ViperDaimao First time out of the vault

    4
    May 16, 2021
    I'm getting a lot of lag whenever I switch mode to 4 in ddraw.ini, i.e. whenever I'm using DX9.
    I'm on win10, downloaded from steam with RPU v18, and the High Resolution Patch 4.1.8.

    I get lag (moving the mouse, selecting, and the characters moving) whenever I set mode to 4 (also tried 6). It runs fine with mode 0. I've tried it with
    GPUBlt=1,
    Use32BitHeadGraphics=1,
    SingleCore=1,
    OverrideArtCacheSize=1

    Does anyone know what might be the issue?
     
  5. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Those options shouldn't have anything to do with the lag.
    Try setting BackgroundKeyboard and BackgroundMouse options in ddraw.ini, or EXTRA_WIN_MSG_CHECKS in f2_res.ini.
     
  6. ViperDaimao

    ViperDaimao First time out of the vault

    4
    May 16, 2021
    thanks that improves it. It went from skipping frames to now is just moving in slow motion. As soon as I change the mode back to 0 it runs smooth though.
     
  7. ViperDaimao

    ViperDaimao First time out of the vault

    4
    May 16, 2021
    hmm, so I think it might be an issue with the game using my laptops integrated graphics instead of my gpu. When I run the game, the task manager shows the integrated graphics working, and no activity on the geforce gpu. I've added the fallout2.exe and fallout2hd.exe files to the windows graphics performance preferences set to the geforce gpu but still it only appears to use the integrated graphics.

    nvm, it looks like if I put it in mode 4 it uses the nvidia gpu, but still slow and choppy.
     
    Last edited: May 21, 2021
  8. gustarballs1983

    gustarballs1983 Water Chip? Been There, Done That

    857
    Oct 28, 2009
    GPUBlt=1,
    correct

    Use32BitHeadGraphics=1,
    Wrong!!, performance mode is =0
    SingleCore=1,
    Wrong!! If using medicore cpu or a laptop this should be set to =0
    all =1 does is set affinity to core#0 (the first cpu core) this core is usually occupied by other windows tasks as well namely Firewal& Antivirus etc. plus everyother stuff you've got launched in the background. =0 will cause windows to spread/y the load (yea baby cum!) evenly among all cores (as should be).

    OverrideArtCacheSize=1

    Depending on resolution you play, probably WRONG!! =1 replaces value art_cache_size= in fallout2.cfg and sets it to 256 megabytes of fallout2's virtual memory space to be set as graphics cache. For most large maps when playing for example 1920x1080 this is not enaugh!! try setting OverrideArtCache=0 and open fallout2.cfg with notepad and set to at least art_cache_size=261. This is a tricky part as setting it too high will cause proplems with other fallout2 stuff (remember that fallout2 is a 32bit program without large adress awareness. This means fallout2 can still only use 2GB of virtual memory, part of which is the art_cache_size=,and the rest goes to other fallout stuff such as scripts etc. since nowadays Sfall rulez You'll need at least 1,5GB of the 2GB virtual memory adress space reserved for script stuff and sfall) that will leave you with up to 512 MB of graphics cache, however sometimes fallout may refuse to run if you set art_cache_size to such high amount. I'd generally stick to what russian modders settled on the 261 megabytes.

    Too low art_cache_size= will cause slow scrolling speed, and general choppines, although mouse lag is probably due to SingleCore=1 *or* You're using a system with insufficient amount of ram like a x64 bit windows with 4GB or less ram. If so than don't expect Fallout2 with recent sfall build to run smoothly.
     
  9. ViperDaimao

    ViperDaimao First time out of the vault

    4
    May 16, 2021
    thanks. I'm using a laptop with 8gb ram and a geforce gtx 1050 and an i5.
    I tried changing OverrideArtCacheSize to 0 and set the art_cache_size to 261, along with SingleCore=0 and Use32BitHeadGraphics=0 but it's still very choppy and slow.
    I've attached my ddraw.ini and the f2_res.ini from when I click the "Manually Edit Config" button on the Fallout 2 Hi Res Patch Config program.
     

    Attached Files:

  10. gustarballs1983

    gustarballs1983 Water Chip? Been There, Done That

    857
    Oct 28, 2009
    Sorry 4 the delay I was chatting on discord.

    I hope You've changed file extension from .ini to .txt because the forum doesn't accept ini files. I do hope You'll know how to revert it.
    PRO tip:
    don't use in game options to configure f2_res.ini or it may fuck stuff up.

    anyways, I assume You're using integrated soundcard so lowered sound buffers to what it might actually have.
    other stuff:
    cpu handling was totally fucked up in settings. so I've set them to the same what I'm using (and yeah my CPU is a potato compared to yours)
    there were inconsistencies in sfall and HRP resolutions. If You've set them on purpose than I'm sorry I've messed them up. It is generally best to set them in HRP and don't set them in sfall (use both is only for freaks that only *think* they achived an ideal fallout setup).

    Also I hope you haven't messed with commands order, as I don't remember the proper sequencing in RPU. In rest of the mods I tend to use sfall-Extended by Mr.Stalin, it has different sequences of commands.

    anyways Your rig should do just fine. if after applying the changes i provided You still have issues, then look up your power scheme setup in Control Panel. those bitche$ in M$ tend to set power scheme to battery saving castrating laptop's efficiency in favour of battery uptime. and all reasonable players play when thery're pluged in.
    if you don't have 'high performance' power scheme unlocked and enabled, then say so, and I'll wrap up a little tutorial on how to unlock and enable it in win10. most settings there are the same but GPU efficiency is sort of dependant on it too and power saving mode can signifcantly remoove balls from your laptop's calculating power.

    Although be advised that running in high efficiency mode will eat your batery charge in no time, so switch to power saving mode whenever you're not plugeed to a charger

    oops forgot to attach the files:P
     

    Attached Files:

  11. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    From your configs I'd set ProcessorIdle=1 in ddraw.ini or CPU_USAGE_FIX=1 in f2_res.ini (use only one), other than that, your configs seem fine to me. Also in my previous post I mean choosing BackgroundKeyboard/Mouse=1 in ddraw.ini OR EXTRA_WIN_MSG_CHECKS=1 in f2_res.ini.

    I usually run tests on multiple desktops and rack servers, from Pentium II (yes it works) to recent Xeon, but sadly I don't own a laptop. The closest spec I have is a Gen7 i5 with integrated graphics, but it can handle things pretty well with those settings (one of my main test machines).

    Also, a few notes (probably not really helpful, but just in case):
    • SingleCore option was made to prevent some supposed "multihreading bugs" in old times.
    • Originally, art_cache_size was set by Fallout's setup program according to your system memory, but some old re-release on physical CD/DVD and all digital releases (Steam and GOG) use a pre-generated fallout2.cfg in their installation which usually has a low value (it's only an issue if you play mods with custom art assets, like RP), so the option was a convenience for people running RP w/o the need of tweaking that line manually.
    • As for GPUBlt, sfall will automatically switch it off internally if it finds that your graphics couldn't enable it, but it runs fine with the integrated graphics from my Gen7 i5 (Intel's integrated graphics isn't that bad). Enabling Use32BitHeadGraphics doesn't do anything if your game doesn't have the files, the worst thing would happen is keep running a few more useless checks here and there, but if that can hider your game performance for real, your system might have bigger problems than "game plays slowly".
     
    Last edited: May 22, 2021
  12. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    sfall 4.3 and 3.8.30 are released on SourceForge, along with their respective modders packs.
    Note about AIBestWeaponFix option:
    It has been rewritten and is now enabled by default. Now the calculation is:
    Base Priority = (weapon min dmg + weapon max dmg) / 4 (half of the average damage)
    If the weapon has a weapon perk, Base Priority will be multiplied by 2.

    Check my release post of sfall 4.1 in case you're wondering how it worked before or in vanilla.
     
    Last edited: Jun 1, 2021
    • [Rad] [Rad] x 3
  13. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    sfall 4.3.0.1 and 3.8.30.1 are released on SourceForge. They are hotfix releases for the previous version.
    There are some game crashes/hangs reported with RPU v20 due to a few critical bugs in 4.3.

    EDIT: There was an error in the earlier release of 4.3.0.1/3.8.30.1 (dll date June 9). Please re-download the release if you cannot interact with doors or lockers. Sorry for the trouble.
     
    Last edited: Jun 10, 2021
    • [Rad] [Rad] x 1