Fallout 2 mod Megamod version 2.47 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Mar 20, 2017.

  1. HorrendusPT

    HorrendusPT First time out of the vault

    Dec 15, 2014
    Damn! i was about to download this mod but after reading all the bugs it have... Maybe in 10 years when all the bugs are fixed. thank God i haven´t wasted my time with this. RP is the best Mod and this looks like 60% taken from RP. Grats to the effort but i think this Mod is just a huge waste of time.
  2. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    This mod is made by very few people on their free time, gathering assets from different sources, and making them work together, which is not an easy task.

    Beside, even if they don't release a new update every week, they still make updates and provide support.

    Many other mods are just dead, never to be updated ever again. And 99% of the mods never went beyond concept phase.

    Also, in order to be bug free, a mod or a game needs to be tested. And modder cannot afford paid testers. WE ARE the testers.

    And once again, nobody pays them, forces them, rewards them for their work. They do it on their own accord. They don't owe us the thing.
    • [Rad] [Rad] x 5
  3. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    Bullet points for some issues i had recently.

    - There are two versions of the abbey, with different quests. Those mentioned in the Megamod guide are about the location labelled *monastery*. Those quests don't seem to be functionnal. The version labelled *Abbey* is the location we know from the RP.

    - There are two working versions of the primitive tribe (and more that don't work). The smaller version only seems there to move forward with the questline of Carson City. Otherwise, everything else is in the other version. (i don't know if the smaller version can be accessed without cheating).

    - As the Monastery quests were unresponsive, i have to cheat to enable Carson City (two versions. Only one is working). The settlement has a green exit grid that leads to .... bunker 21... Which already is a separate location. I guess it is a glitch. (also, it doesn't seem i am missing any quests. Still have to find Kruget, though)

    - Many unreacheable locations (that i activated through cheats) are either not loading (village near Vault City, Ranger safe house), incomplete (slaver vault), or unlikely to ever be activated (abandoned mine). Might be good to do some clean up to reduce data volume, unless there are plans for those locations.

    - I got most companions together through a perk (some need to clear the party and rehire, but ultimately, it is possible to have them all at the same time). Davin and Miria shouldn't be told to wait while at Modoc. They can become unresponsive. And if told to wait elsewhere, Miria will move toward the exit grid. (but not leave the map. And i can still talk to her and hire her back)

    - If Dobbs is told to wait, he won't accept to be recruited back, saying that the party is full, even if i am alone.

    - Lenny won't join until i get the GECK.

    - This one is bothering me a bit more than the others. Marcus is in my party, but i can't talk to him, meaning that i can't tell him to wait, (dunno what triggered it) and i am prevented to access some locations if he is coming with me. If i can't manage to reset him, i will have to put him down. It will sadden me, but if i must... (i will try what i can to salvage my mutant friend)

    - A lot of floating lines are missing. Didn't list them, though. On the other hand, when i reach a location, i get Skynet floating lines, even if it isn't there. Speaking of Skynet, the sentry bot version doesn't disable security when he enters other floors. (dunno if the robotbrain version still does it)

    - The dwarf at the NCR bazaar entrance is bipolar. Day one, he refuses to let me enter the tent. Day two, i can trade with him. Day three, he outright attack me. (weapon holstered, daytime)

    Edit: Saved Marcus. It looked like i had caused hostility at Broken Hills and Marcus didn't fully acknowledged it. I killed bugged Marcus, Used F2SE to reset Broken Hills, removed Marcus death status and removed Broken Hills enemy status, then went back to Broken Hills to recruit a brand new Marcus. (hopefully didn't remove my quest progression there.)
    Last edited: Sep 22, 2018
  4. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Thanks, @naossano , for the report. I will address these as I fix them.

    I just corrected the Monastery. Turns out an incorrect node was being called in the script when you accept the first mission. I have corrected the bug and the player will now get a holodisk from the head monk in order to do the first mission when the next version is released.

    I have plans for all those maps... someday. I have, however, already corrected the bug that was preventing the player from finding the Ranger Safe Houses. These will be available in the next version.

    I thought I fixed this in the last release (2.47.3). Are you using that latest version? What is time/date on the file gclenny.int in the data/scripts folder?

    I haven't seen this at all. Were the Skynet lines at all locations? If you didn't have Skynet, what party NPCs did you have?

    Oh. And one more thing: don't bother making defenses to anybody about the mod. If someone wants to play it, then fine. If not, that is fine, too. However, I definitely would not have bothered to respond to the post from @HorrendusPT. That's the same person who rated the Megamod in the downloads section, and then clearly says here that s/he never even downloaded it. The person clearly has no idea what s/he's talking about.
  5. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    Lenny file is from september 21th 2014. It is possible that i have an older version. It says 2.47 when i launch the game, but i believe it was 2.47.1, which is kind of weird, as i downloaded the file recently (september 2018) from this thread.

    I will try to see if i can add the monastery holodisk through the F2se and if it works on the Vault City computer.

    About Skynet, it seems it happens at all locations, sometimes above another character's head, sometime on the air. (i've tried the sentry bot version)

    About the ranger safe houses, the dialogs said i already knew the location, while i did not. I made the locations visibles through F2se, and the map weren't working. (black emptyness) (same for the other maps i mentioned as not loading)

    About the dwarf, it seems that the third situation wasn't his fault. When i enter the Bazaar, one of the Vortis men sees me and trigger hostility. I might take care of him later on.

    The second Marcus also became unresponsive. I guess i will make a third and final Marcus when i'll go to Mariposa.

    The defense was about mods in general. Not all mods are great. But there are other ways to adress it.
  6. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    The latest version of Lenny should be from March 2018. I just tested it last night, and it is working properly.

    And, if you add the Abbey Holodisk to your inventory, the quests will still not work. I went through the head monk's script last night. There were various nodes that were numbered incorrectly, not just one.

    And here is 2.47.3. The link was several pages back.

    http://www.mediafire.com/file/glh196ftmsofedy/Megamod update 2.47.3.zip
    Last edited: Sep 23, 2018
  7. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    I checked my downloaded files, and i confirm that i used 2.47.1. Now updating to 2.47.3.

    The readme files seems to also indicate fixes for bugs that i've noticed, but forgot about.

    Also had an issue with the EPA. When i ask to retrieve one of the npc (i guess the RP companions), nothing happens. No message error. No resurrection either. I will check again with the patch.

    Thanks for the update.

    Edit: The link in the first page is still 2.47.1, which explains why i've downloaded this one. Also, the third Marcus works fine.
    Last edited: Sep 24, 2018
  8. Yaruj

    Yaruj First time out of the vault

    May 24, 2018
    MIB88, can you update the first page with 2.47.3 version please? I guess it could solve many problems with people downloading the wrong patch and then having issues which were fixed long ago.
  9. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    I finally caught what triggered the issue with Marcus. He becomes unresponsive as soon as we finish the conversation about him no longer being sterile. (When you pay him a prostitute at cat's paw, he says he hopes the girl doesn't get pregnant. You have the option to ask him about that. Turn out i didn't ask him about it on his third incarnation.)

    Noticed a couple of issues at Vault 14.

    - The music randomly glitch. Sometime we have one music, sometimes another, sometime the wind soundtrack (the one from the demo. or the one when loading a map), sometimes no soundtrack at all.
    - The light is also variable. Sometimes it gets very very dark.
    - Can't get Meris, as at some point in the conversation after i ask if i can take the Wanamingo, there is no more lines, but the dialogs stays open. (i can't leave it with enter, spacebar, escape, 0 or 1). I am stuck there unless i force to crash to desktop. (which effectively prevent me to get that party member)

    Doesn't happen all the time, but it seems that, if i drive a car, reach a green circle (a city on worldmap), then move again within that same green circle, i lose the car...
  10. VonZorch

    VonZorch First time out of the vault

    Jan 1, 2012
    You might want to add to the install instructions that, if running under WINE, you need to extract to a different directory, I use Extract in my development area, then use a bulk renamer such, as Thunar, to make sure all directory and file names have the same case, in both directories. Then copy and paste to the MegaMod folder If not you may have things like a data folder and a Data folder, or 00000012.PRO and 00000012.pro, in which case things do not work right.
  11. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    Trying to make 3rd Marcus (with new armor) leave my party (through dialogs or by killing him) screwed my whole game.

    I had to reinstall the game for my savegames to work again. (although, i avoided any savegame related to Marcus)

    Dunno if the major crash happened because of being a third Marcus, because of the armor, because of Marcus being bugged in the first place, because i updated during the playthrough or if it is some *read only* tag issue.
  12. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    Hi MIB88
    Can i ask how thinks going on you side? I have feelings that release of update is near, so i wish to know.

    And something come to my mind. About healing. Is it possible to skill healing remade that it will always succeed restore few HP, but the cost will be the time spend on it. If is low and normally it shall fail it will cost more time. (currently always 30 min) On Other side if is high enough it can be done faster and whit more hp restored.

    Secondary the Medic kit, doctor bag, military (something), is just like normal healing and can be consumed. And the consume rate is pretty high and can fail. So how about remove the consume ability from them or pick it to be fine low and make it function as increase of skill for first aid and doctor. (same as tools for other skills, as pick lock, and repair)
  13. Sekos

    Sekos First time out of the vault

    Oct 30, 2018
    Hi! I just subscribed to give you a big THANK YOU for making my prefered game of all times more alive than ever, all these mods are so well made, with such a respect with the basic spirit (and grampy bone, neva forget grampy bone...) of the game, damn I still have so much fun after more than 20 games... I love to rediscover it, everytime I find new features, SUPER BIG THANK YOU FOR THAT.
    Well now I'm here, I can report things I have issues with (I just discovered 2.47.3, was one hour ago on 2.47.1, but still):
    - The security bot version of Skynet can't be given orders anymore: I first hired it, then dropped it to my base, until there no problem, dialogues and stuff, but now I re-hired it the only dialogue line available is "Not much of a conversationalist, eh?", so I can't ask it to leave the party or change distances or what, forced to kill it to hire other people (3CHR)
    - There's no way to get inside the Brotherhood Bunker, there's a lack of conversation with the main gate character
    I'll test the rest right now, I can't wait to finally save Sulik's sis!

    Just an idea: maybe you could make a topic about GVARS files, if that doesn't take you too much time (I don't know how you work who knows? Maybe it could be quickly done) to help fans to manage to temper with issues they meet, not a precise thing jut a few enlightments on the limits of the thing (highest values, knows issues...)

    Damn we're far from finishing with this game, thank you again!
    • [Rad] [Rad] x 2
  14. _Pyran_

    _Pyran_ It Wandered In From the Wastes

    Jan 31, 2017
    Megamod with fix

    MIB Megamod 2.47.3:
    - Megamod 2.47.1 with update 2.47.3
    - Minifix 0.2 by Darek (3 fixed scripts).
    - Patch000.dat with critters-proto, instead of packing procedure with batch & processdat2.exe.
    - use the default critical with bug fixes (value=2).
    - deleted old unused files (acm converter, temp files, old frm, old HRP).

    - add: sFall by NovaRain\Phobos 3.8.11.
    - add: sFall Configurator net 3.5.
    - add: Hi-Res 4.1.8.
    - add: New menu background.

    - enable: The sFall function is used - additional patches.
    - enable: Appearance mod (Mash & Co).
    - Fixed: NPC levelUp resetting. ;(

    - unpack this archive
    - copy files to the game folder
    - run mm_start.bat
    - play the game
    Last edited: Dec 11, 2018
    • [Rad] [Rad] x 2
  15. Yaruj

    Yaruj First time out of the vault

    May 24, 2018
    Hello again.
    In the Russian Megamod guide (https://falloutmods.fandom.com/wiki/Russian_Megamod_Guide) it is said that there're some extra quests in Redding for Kokoweef or for Morning star mines after bringing chip to one of them with posibility to tarnish Doc. Johnson.
    I did not have this quests in my game and there is no description of these quests in English and Czech versions of this guide.
    Were they cut out from the mod or are they going to be implemented in next version?
  16. Hubal

    Hubal It Wandered In From the Wastes

    Sep 11, 2014
    Thanks Pyran!
    • [Rad] [Rad] x 2
  17. bugtrack

    bugtrack First time out of the vault

    Jan 3, 2015
    one day ill get all the updates on megamod i need and play it again. one day.
  18. Muttie

    Muttie It Wandered In From the Wastes

    Oct 9, 2017
    I think the patron of the Hole (Den) is bugged. He goes home during the morning hours (about 4.00 to 8.00 o'clock) and returns in the morning (8.00 o'clock). This leaving and coming bugs out. And he starts to stand at the edge of the map incapable of coming or going (basically frozen in place, which does not seem to clear up again). The only thing that works is to push him back into the bar manually (lol), but he starts to walk into walls after that (double lol).
    I believe vanilla had the same issue.
    However, RP Mod fixed it. And when you replace the dcbilly.int with the one from RP Mod the patron starts to come and go with only minor hiccups (needs sometimes a few seconds to start moving).
    I don't know if there are any other strings attached, though, i.e. if replacing the MM script for billy will cause other issues. But, so far, the RP Mod script works fine.

    Anyway, you should check if the bug can be reproduced in case it's just my version that is faulty.
  19. Homer

    Homer First time out of the vault

    Dec 7, 2018
    First of all I would like to thank the creators and the people behind this mod.

    Right now I'm going through a couple of bugs that are annoying.

    - Can't read the raider's map, so I can't get the locations of their base
    - I can't got up ladders, the char just stays put when I click on them
    - Holodisks don't work, when I click on them (tried a few) it just says (that does nothing)
  20. obimark

    obimark First time out of the vault

    Aug 1, 2012
    Hi all,
    MIB88, thank you for all your hard work. I recently started another run, all was going well. There's minor issue with Primitive tribe, I didn't get the quest to deliver 10 knives and spears, Kron skipped me right through to trader encounter. Maybe cause I played with female, but not quite important. Sulik's sister was displayed as ghost as well, but was functional otherwise and did not impact any quest.
    I got a huge problem with Miria though. She levels up correctly, however as soon as I load/enter another screen she reverts from fearsome warrior to wife. Have no idea how that happened. Klint, Sulik and Vic level up normally and retain their levels.
    I didn't get much farther than Redding, New Reno I barely scratched, so I didn't get very far. Still, if game could be salvaged...
    Attached is the savegame, just before I and Miria level up.
    Have installed on clean installation of Fallout 2, first Megamod 2.47.1 then 2.47.3 patch with hotfix from few posts above.
    EDIT: on second look, just Vic retains his levels, neither Sulik nor Kllint Level up normally

    Attached Files:

    Last edited: Dec 9, 2018